About

Certified software package for calculating properties of water/steam, gases and gases mixtures
"WaterSteamPro"TM

Web-site: http://www.wsp.ru

Authors:

  • Konstantin A. Orlov, PhD, Associate Professor of TWT department of MPEI, e-mail: orlov@twt.mpei.ac.ru
  • Alexey A. Alexandrov, prof. of the MPEI, honorary member of the IAPWS
  • Alexey V. Ochkov, engineer in the MPEI
  • Valery F. Ochkov, prof. of the MPEI

Copyright © 1999-2010, Konstantin Orlov.

Copyright © 1999-2010, authors.

Copyright © 1999-2010, Moscow Power Engineering Institute (TU).

(Version 6.5 English)

- Moscow 1999-2010 -


Annotation

"WaterSteamPro" is the calculation tool for thermophysical properties of water and water steam in a wide range of input data.

It also provides calculations of ideal gases and its mixtures.

"WaterSteamPro" defines more than 300 functions to calculate water and steam properties by equations, offered by the International Association for the Properties of Water and Steam. The thermodynamic properties are evaluated according to Formulation 1997 for industrial use, and others by appropriate Formulations.

GOSSTANDART OF RUSSIA (http://www.gost.ru) sertificate that the software program "WaterSteamPro" reproduce data appropriated by State Service for Standart Reference Data (GSSSD R-776-98) and the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam. The registration number is "AK-35/4".

"WaterSteamPro" is registered by "Russian Agency for Patents and Trademarks (Rospatent)" (http://www.rupto.ru). The patent number is "2000610803".

The software package "WaterSteamPro" is recommended by Department of General Inspection for Exploitation of Electrical Power Stations and Networks of Russian Joint Stock Company Unified Energy System of Russia (RAO "UES of Russia" - http://www.rao-ees.ru/en/) to use in power engineering (information letter # IP-14-27-2001 of 03.08.2001).

This version contains examples of "WaterSteamPro" operation in the following program environments:

  • Mathcad Professional of the MathSoft, Inc. corporation;
  • Microsoft Excel, the Microsoft Office component of the Microsoft, Inc. corporation;
  • Microsoft Visual Basic 6.0, the Microsoft Visual Studio 6.0 component of the Microsoft, Inc. corporation;
  • Windows Scripting Host (examples in JScript and VBScript languages are given);
  • Borland Delphi;
  • HTML Example - using WaterSteamPro in Internet and Intranet.


What's new

What's new in WaterSteamPro 6.5

  1. Increased area of functions for calculating properties of water/steam up to 50 MPa for temperatures from 800°C to 2000°C (early up to 10 MPa). This changes based on new equations from IAPWS - http://www.iapws.org.
  2. Viscosity and based on viscosity properties are calculated with new equation from IAPWS (IAPWS - http://www.iapws.org).
  3. There is a set of files for using WaterSteamPro in Matlab. This files are not included in WaterSteamPro installation packages and available for downloading from Internet-site of WaterSteamPro: http://www.wsp.ru/en.
  4. Added functions for calculating density of water/steam based on IF-97.
  5. Added functions for calculating static dielectric constant of water/steam.
  6. Added functions for calculating ionization constant of water.
  7. Added functions for calculating refractive index of water.
  8. Added functions for calculating (d density / d pressure)enthalpy=const of water/steam in single phase and double phase areas.
  9. Added functions for calculating (d density / d enthalpy)pressure=const of water/steam in single phase and double phase areas.
  10. Added function for calculating properties set (including derivatives) in meta-stable region.
  11. In installation package added Microsoft Excel worksheet "WaterSteamPro Excel Calculator". This worksheet allow to easy and powerfull calculations of properties of water/steam in Excel.
  12. Now in Microsoft Excel are working functions, which return a set of values. A set of values are return as array. Additional information given in documentation. Sample of usage see in new worksheet for Excel - "WSP Excel Calculator".
  13. Changed a problem for function documentation in "Insert Function" dialog in Mathcad from version 12 and above.
  14. Changes in Active-X object. Now settings are different for different Active-X objects.
  15. Previous change allow to create Internet-resource http://www.wsp.ru/en/test, which allow to test WaterSteamPro functions online.
  16. Changes in function for determining the IF-97 region for water/steam: now calculation goes down to melting line (early calculations go down to 273.15 K).
  17. In "Insert Function" dialog in Mathcad added information of usage of unit-based WaterSteamPro functions.
  18. Added unit "kPa" to program "WSP Calculator".
  19. Changes for working with WaterSteamPro Calculator in Microsoft Windows Vista.
  20. Solved the bug in Setup Wizard which allow to not right selection of path for WaterSteamPro documents for Mathcad in case of target path is not exist.
  21. Changes in Setup Wizard.
  22. Changes in documentation.
  23. Changes in license files.


System requirements

In order to install and run WaterSteamPro, the following are recommended or required:

  • Windows 95/95/ME or higher or Windows NT 4.0 with SP3/2000/XP/2003 or higher.
  • DCOM support (Win 95/98). Free upgrade of DCOM for Windows 95/98 is available at http://www.microsoft.com/com/resources/downloads.asp.
  • Approximately 6 MB of free hard disk space depending on your software installed.
  • Microsoft Internet Explorer 5.0 or higher.
  • Microsoft Office 97 or higher.
  • Mathsoft Mathcad 8 Professional or higher.
  • For reading documentation upgrade Html Help is recommended. Free upgrade of Html Help is available at http://msdn.microsoft.com/library/tools/htmlhelp.
  • Programs, and WaterSteamPro examples which are available with the basic WaterSteamPro files (examples in Mathcad, Excel, Visual Basic, etc.), have the appropriate system requirements.


Official certification of the WaterSteamPro

State certification of the WaterSteamPro

1. GOSSTANDART OF RUSSIA (http://www.gost.ru) granded the software program "WaterSteamPro" the certificate that WaterSteamPro functions reproduce the values from the standart reference data (GSSSD R-776-98) and the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The registration number is "AK-35/4" of April 16, 2001 . The electronic copy of certificate is presented at the WaterSteamPro web site: http://www.wsp.ru/eng/certif.htm.

2. The software program "WaterSteamPro" was registered by "Russian Agency for Patents and Trademarks (Rospatent)" (http://www.rupto.ru/MAIN_E.HTM). The registration number is "2000610803" of August 25, 2000. The electronic copy of certificate is presented at the WaterSteamPro web site: http://www.wsp.ru/eng/certif.htm.

3. The software program "WaterSteamPro" was recommended by Department of General Inspection for Exploitation of Electrical Power Stations and Networks of Russian Joint Stock Company Unified Energy System of Russia (RAO "UES of Russia" - http://www.rao-ees.ru/en/) for using in power engineering (information letter # IP-14-27-2001 of 03.08.2001).

The electronic version of information letter is available at the WaterSteamPro web site : http://www.wsp.ru/eng/certif.htm.


WaterSteamPro Distribution Package

The following components are available:

  • The library "OKAWSP6.DLL" that is the main library containing definitions of functions for calculation of water and water steam properties.
  • The program "WaterSteamPro Calculator" for calculation of water and water steam properties without using of other program environments (Excel, Mathcad, etc). The program is written in Microsoft Visual C++ 6.0 (SP3). Sources of a similar program written in Visual Basic 6.0 are also available.
  • The set of files for WaterSteamPro operating in Mathcad
  • The Microsoft Excel 97 document "WSP_EXCEL.XLS" containing the example of using the library in Microsoft Excel.
  • The add-in file OKAWSP6.XLA for easier application of all functions of WaterSteamPro package in Microsoft Excel.
  • Two files for WSH (Windows Scripting Host) written in languages VBScript and Jscript containing the example of using ActiveX-object, WSP.WSPCalculator, designed for calculation of water and water steam properties.
  • Samples and system file for using WaterSteamPro in Borland Delphi.
  • HTML files, illustrating examples of WaterSteamPro operation in Excel and Mathcad.
  • Documentation.


License agreement for the "WaterSteamPro"

  1. All rights to "WaterSteamPro" are reserved by the author - Konstantin A. Orlov.
  2. The author reserves the right to modify subsequently the license agreement.
  3. The WaterSteamPro trial version may be freely distributed and copied only as it supplied (installation archive). No person or company may charged a fee for the distribution of WaterSteamPro without written permission from the author. The trial version may be used in the period of one month. After that you must to buy the license or break to use the WaterSteamPro.
  4. The author grants you this license to use WaterSteamPro on a single computer. You may not transfer the licensed program to any natural or juridical person.
  5. To use WaterSteamPro for commercial purposes you must conclude special license agreement. To adjust the agreement you need to contact with author - Konstantin Orlov.
  6. You may copy or use in your design the source (uncompiled) code of the programs included in WaterSteamPro.
  7. You may use under this license any part of WaterSteamPro for individual, non-commercial purposes. For all over purposes you must to purchase special licenses.
  8. It is forbidden to develop, share, distribute and so on the programs based on WaterSteamPro which can be the competitor for WaterSteamPro. It's mean that the programs based on any part of WaterSteamPro must not to reproduce the functionality of the WaterSteamPro.
  9. Using any program from WaterSteamPro package, it is necessary to give the reference that you use WaterSteamPro (for example, in About box or in bibliography) and point out the authors, copyright owner and web site of the program.
  10. You may not use copy, emulate, rent, lease, sell, decompile, disassemble, study the program code by other means, transfer the licensed program, or any subset of the licensed program, except as provided for in this agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal or civil prosecution.
  11. WaterSteamPro is distributed "AS IS". No warranty of any kind is expressed or implied. You use it on your own risk. The author will not be liable for data loss, damages, loss of profits or any other kind of loss while using or misusing this software.
  12. Installing and using WaterSteamPro signifies acceptance of these terms and conditions of the license. If you do not agree with the terms of this license you must remove WaterSteamPro files from your storage devices and cease to use the program.
  13. All rights not expressly granted here are reserved by the program author - Konstantin Orlov.

Yours faithfully,
Konstantin Orlov


Registration

To purchase and register you must complete the registration form noted the necessary type of license and send it to Konstantin Orlov.

There are the following license types:

1. "Personal" license give you a license to use WaterSteamPro in individual non-commercial purposes for one personal computer for as long as you own the product.

2. "Enterprise" license to use WaterSteamPro on several computers in one organization (for juridical persons). You may not create commercial programs based on WaterSteamPro. The registration fee depends on the number of PC. The license includes also WaterSteamPro SDK: the tools and documentation to create non-commercial programs based upon WaterSteamPro in different programs and programming languages.

3. "Developer" license give you a license to create commercial programs based upon WaterSteamPro. The license includes also WaterSteamPro SDK (see #2) and your own "local registration data" - the data for special mechanism, which works with registration process in WaterSteamPro.

Contact address:

  • E-mail: orlov@twt.mpei.ac.ru
  • Konstantin A. Orlov


Registration form

Note: all this data will be used only for contacting with you.

First Name:
________________________________________________________________

Second Name:
________________________________________________________________

Patronymic name (optional):
________________________________________________________________

Place of employment/study (optional):
________________________________________________________________

Address (optional):
________________________________________________________________

City (optional):
________________________________________________________________

Country:
________________________________________________________________

Phone (optional):
________________________________________________________________

E-mail/www-home page address:
________________________________________________________________

Where are you find the first information about the WaterSteamPro (optional):
________________________________________________________________

What purposes is the "WaterSteamPro" package supposed to be used for (optional):
________________________________________________________________
________________________________________________________________
________________________________________________________________
________________________________________________________________


Possible ways of the WaterSteamPro usage

The "WaterSteamPro" package for calculation of water and water steam properties is possible to be operated in the following ways:

  • Customary use - by means of "WaterSteamPro Calculator";
  • Operation in the Mathcad physical and mathematical package (see "Operation of WaterSteamPro in "Mathcad Professional");
  • The OKAWSP6.DLL library permits more specific problems to be solved for it allows export of all the required functions. Examples are - the program "WaterSteamPro Calculator", the add-in Microsoft Excel file "WSPMCAD.XLL";
  • Operation of the program through an ActiveX object with PROGID "WSP.WSPCalculator" and CLASSID "5BE869D4-B28C-11D3-95EF-83B4A7A61825". Examples are - Microsoft Excel and WSH;
  • Operation of "WaterSteamPro" in other program environments is possible by means of a stub-library which applies to "OKAWSP6.DLL". Example is - the "WSPMCAD.DLL" library. This library is the "intermediary" between Mathcad and "OKAWSP6.DLL".


Using the OKAWSP6.DLL library

The OKAWSP6.DLL library contains the source code calculating water and water steam properties. The OKAWSP6.DLL library is a Windows dynamic link library (DLL) and it is applicable for programs which use DLL in their operations.

The library is stored in the "System" folder of the Windows catalog. For Windows 9x/Me the folder is commonly "C:\WINDOWS\SYSTEM"; for Windows NT/2000/XP that is "C:\WINNT\SYSTEM32".

The section "List of the WaterSteamPro functions" lists the exported functions therefore we consider only library features.

All exported functions take arguments and return values in the SI system. To operate with other dimensions recalculation is needed. WaterSteamPro Calculator contains an example of using various dimensions. WaterSteamPro Calculator is described above and available with initial code.

WaterSteamPro Calculator also contains an example of OKAWSP6.DLL library operation in Visual Basic. You can use the library in other languages too.


Using the OKAWSP5.DLL library

The library OKAWSP5.DLL is not supplied from the version 6.0 of WaterSteamPro. Use the OKAWSP6.DLL instead.

If you need OKAWSP5.DLL please use WaterSteamPro version 5.6.


WaterSteamPro Calculator

The Program WaterSteamPro Calculator

The program is designed for calculation of water and water steam properties without recourse to supplementary software.

The program is available with the initial code of an analogous program, written in the Visual Basic language of Microsoft Visual Studio 6.0 Professional Edition (Service Pack 3).

Figure 1 presents the main window of the program "WaterSteamPro Calculator".

Fig. 1. The main window of the program "WaterSteamPro Calculator"

There are several modes in program, which is depends on arguments of the functions of the package WaterSteamPro.

The adjustment of WaterSteamPro Calculator given in Adjustment of the WaterSteamPro Calculator".


Calculation modes in the WaterSteamPro Calculator

  • F(P, T) - "Common properties" - water/steam properties are calculated with pressure and temperature data. Water condition region therewith is determined. If a point being calculated appears to lie on the saturation line, steam parameters are returned.

    Fig. 1. Calculations by the common functions

  • F(P, H) - properties are calculated with pressure and specific enthalpy. Water condition region is automatically determined.
  • F(P, S) - properties are calculated with pressure and specific entropy. Water condition region is automatically determined.
  • F(H, S) - properties are calculated with specific enthalpy and specific entropy. Water condition region is automatically determined.
  • F(Psat) - "Saturation line - pressure dependence" - presents properties of water/steam on the saturation line depending on pressure value.
  • F(Tsat) - "Saturation line - temperature dependence" - presents water/steam properties in the saturation line depending on temperature value (analogously to the previous mode);
  • F(P, X), F(T, X) - "Common properties including the double-phase area" - presents water/steam properties depending on pressure, temperature and vapor fraction. In so doing, the given mode appears analogous to the mode "Common properties" if a computed point lies not in the saturation line. Otherwise, water/water steam properties are calculated for the double-phase area depending on vapor fraction and temperature.
  • Meta-Stable - properties are calculated with pressure and temperature using Meta-Stable functions of the WaterSteamPro.


Adjustment WaterSteamPro Calculator

The program "WaterSteamPro Calculator" allow to set-up the output of the values of properties for different units. For each of calculated properties exist some available units. This unit may be selected from the list (in right from value). The program with one of the version of units showed in picture 1.

Pic. 1. Main window of the program WaterSteamPro Calculator

Also in WaterSteamPro Calculator may be setting-up next features:

  • Displayed digits count. Adjustment available through menu "Settings\Displayed digits count". The range - from 1 to 15.
  • Internal tolerance in WaterSteamPro functions. Adjustment available through menu "Settings\Internal tolerance".
  • Mode of the check of the range of arguments. Available through menu "Settings\Check input range mode".
  • Mode of the made result more precision. Available through menu "Settings\Make result more precision".
  • Show calculation low window. Available through menu "Settings\Show log window".
  • Enable calculation logging. Available through menu "Settings\Enable logging".

Also you can see the units in WaterSteamPro calculator through menu "Settings\View units information".


Program WaterSteamPro Calculator (Visual Basic)

Installation package of the WaterSteamPro be contained with the source code of program, similar as WaterSteamPro Calculator. This source code for Microsoft Visual Basic 6.0 (Professional Edition). So this program named WaterSteamPro Calculator (Visual Basic), unlike WaterSteamPro Calculator, which written in Visual C++.

For using WaterSteamPro Calculator (Visual Basic) it is necessary to compile project "watersteampro.vbp" with using Microsoft Visual Basic 6.0.

The adjustment of WaterSteamPro Calculator (Visual Basic) described in "Adjustment WaterSteamPro Calculator (Visual Basic)".


Adjustment of the WaterSteamPro Calculator (Visual Basic)

The program "WaterSteamPro Calculator" allows setting output values of water and water steam properties for various physical units and formats. The file "WATERSTEAMPRO.INI" serves for that purpose which is stored in the program directory containing the program "WaterSteamPro Calculator". The given file is a standard file of Windows settings containing sections, keys and corresponding values. Description of the file format is given below.

Section [Format]

The given section allows setting output format of water and water steam properties. Formatting parameters are activated by a call of the built-in function "FORMAT" present in the programming language Visual Basic, therefore the user may find their description in any edition illustrating Visual Basic operations.

Possible keys available in the given section:

  • "SaturationPressure" - output format of the saturation pressure value;
  • "SaturationTemperature" - the saturation temperature format;
  • "EsteamationHeat" - format of a specific heat of evaporation;
  • "Volume" - format of a specific volume;
  • "InternalEnergy" - format of a specific internal energy;
  • "Entropy" - format of a specific entropy;
  • "Entalphy" - format of a specific enthalpy;
  • "HeatCapacityAtConstantPressure" - format of a specific heat capacity at constant pressure;
  • "HeatCapacityAtConstantVolume" - format of a specific heat capacity at constant volume;
  • "SoundVelocity" - format of a sound velocity;
  • "ThermoConductivity" - format of a thermal conductivity;
  • "DynamicViscosity" - format of a dynamic viscosity;
  • "KinematicViscosity" - format of a kinematic viscosity;
  • "Prandtle" - format of the Prandtl number;
  • "IsoEntropyCoefficient" - format of an isentropic curve;
  • "SurfaceTension" - format of a surface tension;

Setup of units

All functions of the OKAWSP6.DLL library take arguments as initial values and return values in the format of International System of Units (SI system). The program "WaterSteamPro Calculator" allows recalculation of output data into different units and supports setting new units. For this purpose the "WATERSTEAMPRO.INI" file contains a number of sections enabling setting correspondence between user units and standard SI units. Section structure provides two keys for any unit ¾ the first one is a unit "name", and the second one - is a "conversion factor" for a new dimension and a standard one. Key names for dimension setting are composed respecting the following rule: a string "Name_" and "¹", where "¹" - is a sequence number of a current dimension in the given section. Key names for the dimension "conversion factor" - is a string "Value_" and "¹". Numeration starts with unity and should not contain misses. Example of creation of a pressure dimension set is given in what follows. The corresponding section is named "Pressure". Therefore the file "WATERSTEAMPRO.INI" may include the following lines:

[Pressure]
[Pressure]
Name_1=bar
Value_1=100000
Name_2=MPa
Value_2=1000000
Name_3=Psi
Value_3=6894.75729316836
Name_4=atm
Value_4=101325
Name_5=in hg
Value_5=3376.86427794708
Name_6=torr
Value_6=133.322312022206
Name_7=mm hg
Value_7=133.322312022206

The example under examination defines seven additional dimensions with the following names: "bar", "MPa", "Psi", "atm", "in hg", "torr", "mm hg". Each dimension has its own conversion factor. The base pressure SI unit is Pascal. One bar contains 100 000 Pa, therefore the conversion factor for dimension "bar" - is 100 000. The remaining conversion factors are estimated in a similar manner. Possible number of dimensions is limited only by system resources.

Sections of the setting file allowing preset of dimensions are given below:

  • [Pressure] - dimensions of pressure. Dimensions of the section serve for output of "saturation line pressure" values and for input of "pressure" values. The base dimension - is Pa.
  • [DegreeOfDryness] - dimensions of degree of dryness. Dimensions of the section serve for output of "degree of dryness" values. The base dimension - is non-dimensional value (fractions).
  • [Volume] - dimensions of specific volume. Dimensions of the section serve for output of "specific volume" values. The base dimension - is m3/kg.
  • [Energy] - dimensions of energy. Dimensions of the section serve for output of values of "specific enthalpy", "specific internal energy" and "heat of vaporization". The base dimension - is J/kg.
  • [Entropy] - dimensions of entropy. Dimensions of the section serve for output of values of "specific entropy", "specific heat capacity at constant pressure" and "specific heat capacity at constant volume". The base dimension - is J/(kg·K).
  • [Velocity] - dimensions of speed. Dimensions of the section serve for output of "sound velocity" values. The base dimension - is m/sec.
  • [ThermCond] - dimensions of thermal conductivity. Dimensions of the section serve for output of "thermal conductivity" values. The base dimension - is W/(m·K).
  • [DynVis] - dimensions of dynamic viscosity. Dimensions of the section serve for output of "dynamic viscosity" values. The base dimension - is Pa·señ.
  • [KinVis] - dimensions of kinematic viscosity. Dimensions of the section serve for output of "kinematic viscosity" values. The base dimension - is m2/sec.
  • [SurfaceTension] - dimensions of surface tension. Dimensions of the section serve for output of "surface tension" values. The base dimension - is N/m.


Using ActiveX-objects of WSP.WSPCalculator

The OKAWSP6A.DLL library is a server for ActiveX-objects with ProgID "WSP.WSPCalculator". This object exports functions similar to functions of OKAWSP6.DLL library. In principle, it simply readdresses function call to OKAWSP6.DLL library, therefore using of OKAWSP6.DLL library directly differ from that of ActiveX objects of "WSP.WSPCalculator" in a mode of function calling.

To run ActiveX objects of "WSP.WSPCalculator" it is necessary to register it in the Windows registry. In case of error run the following program to register the object in the system:

Regsvr32.exe okawsp6a.dll

The program "Regsvr32.exe" is available in Windows 98 and stores in the folder "SYSTEM" (in WinNT it located in SYSTEM32 folder).

The examples of using "WSP.WSPCalculator" ActiveX objects contains in Microsoft Excel file "WSP.EXCEL.XLS" and in two Windows Scripting Host files named "WSP.JS" and "WSP.VBS". Descriptions of the examples are given in the corresponding sections.

Names of functions of "WSP.WSPCalculator" ActiveX objects coincide with names of functions exported by "OKAWSP6.DLL" library; therefore the list of functions is not given here, but is presented at the item "Description of functions of WaterSteamPro package".


Using ActiveX-objects of "WSP.WSPCalculator" in Microsoft Excel

The "WSP_EXCEL.XLS" file presents an example of operation of WaterSteamPro package in Microsoft Excel. It requires Microsoft Excel 8.0 (Microsoft Excel 97) and higher.

The given example uses ActiveX-objects of "WSP.WSPCalculator" in order to gain access to the functions of WaterSteamPro package. For that, a new module in the Visual Basic for Applications (VBA) editor is generated containing codes of created stub-functions. To jump to the Visual Basic editor you may press the key combination Alt-F11, or select the item "Visual Basic Editor" from the "Tools/Macro" menu.

Furthermore, a "WSP.WSPCalculator" object is accessible in two ways. The first one - is to create an application object by means of the function "CreateObject (class, [servername])", which creates an ActiveX-object with a name "class" and a server with a name "servername". Function code in this case, for example, at calculation of saturation depending on temperature, is presented below:

Function PST(t as double) as double
Dim wsp as object
Set wsp = CreateObject("WSP.WSPCalculator")
PST = wsp.wspPST(t)
End function

Let us examine this example. We define the function "PST" ("double" type), which returns saturation pressure depending on temperature "t" ("double" type). Then we define the variable named "wsp" of "object" type. In the next line, the "wsp" variable takes a result returned by the function "CreateObject" obtained with a parameter "WSP.WSPCalculator". Thereafter a value returned by the "wspPST" function of created "WSP.WSPCalculator" application object, named "wsp", is used as the result of the "PST" function.

The disadvantage of this technique is that every call of the function results in creation of a new "WSP.WSPCalculator" application object.

Another way to gain an access to a "WSP.WSPCalculator" object - is to connect all ActiveX objects from the OKAWSP6A.DLL library to an Excel document. To do this select the item "References" from the "Tools" menu. Tick the "WaterSteamPro" element in the displayed list (see Fig. 4) and push OK.

Fig. 4. Insertion of reference to the library

The given technique allows all ActiveX objects from a connected library to become accessible. The following code allowing access to WaterSteamPro functions is enabled now (we define an alternative function for calculation of saturation depending on temperature):

Public wsp2 As New Wsp.WSPCalculator
Function PST2(t as double) as double
PST2 = wsp2.wspPST(t)
End function

Let us examine this example. The variable "wsp2" of "Wsp.WSPCalculator" type is defined in the module (not in the function). And stub-functions refer to methods of this variable.

The second method has the advantage of using the Microsoft IntelliSence technology for creation of functions allowing display of all accessible functions. This is also possible by using Object Browser (F2 key). The second advantage of this method - lies in speed of function operation - an ActiveX-object is created only once, rather than at each function call.

In a similar manner, the "WaterSteamPro" package can be used in any program environment "acquainted with" Visual Basic. In principle, it was possible to organize an analogous access to functions in the program "WaterSteamPro Calculator" (the Microsoft Visual Basic version), but a direct DLL call is executed faster than a call through ActiveX objects.


Usage of the WaterSteamPro in Microsoft Excel

Programming in the Microsoft Excel environment is executed by means of the language Visual Basic for Applications (VBA). The VBA language allows both reference to ActiveX-objects and direct reference to Windows system libraries. Thus there are two ways of "WaterSteamPro" package operation in the Excel environment. The first one - is operation through references to ActiveX-objects of "WSP.WSPCalculator". And the second one - is a direct operation of the "OKAWSP6.DLL" library.

The "WaterSteamPro" package delivery set contains the "WSP_EXCEL.XLS" file with an example of package operation in Microsoft Excel. The given file demonstrates ways of "WaterSteamPro" function access by various programs. The "WSP_EXCEL.XLS" file investigates not all functions but presents examples of water/water steam properties calculation using these functions.

In order to operate with functions for calculation of water and water steam properties directly in Microsoft Excel the user should apply the "OKAWSP6.XLA" add-in. The given add-in is also available in the "WaterSteamPro" package delivery set. Operation technique of the "OKAWSP6.XLA" add-in is presented in the section "The add-in operation in Microsoft Excel".


Using the Microsoft Excel add-in

The Microsoft Excel allows so-called "add-ins". They represent programs that add to Excel various operations, calculations that are not possible with standard Excel means.

The file "wspexcel.xll" contains a module, which allows import of functions from the main library "OKAWSP6.DLL". Functions become accessible to Microsoft Excel (for operation in an Excel worksheet or in Visual Basic) at opening "wspexcel.xll". The list of functions therewith appears in the dialog-box "Master of Functions" (see Fig. 5).

Fig. 5. The Microsoft Excel "Master of Functions" dialog

Operation of the "wspexcel.xll" add-in requires the file to be stored in the catalog of Microsoft Excel user add-ins. By default it's installing to folder "[MICROSOFT OFFICE]\OFFICE\Library". This folder name is prompted in Install Wizard of the WaterSteamPro. However, the add-in file may be stored at another place. To do this the user should specify an access path of the "wspexcel.xll" file in the dialog-box "Add-ins" (add-in enable).

To enable operation of the add-in file in Microsoft Excel it is necessary to select the item "Add-ins" at the "Tools" menu. This displays the dialog-box with the list of available extensions (see Fig. 6). If the "wspexcel.xll" file is present in the catalog of Microsoft Excel settings, the "WaterSteamPro" item automatically appears in the dialog-box. Otherwise, the user should push the button "Browse." and specify location of the "wspexcel.xll" file. Then select the item "WaterSteamPro" to enable the given setting and push "OK".

Fig. 6, a. Dialog-box "Add-ins" in Microsoft Excel

This operation makes all functions of WaterSteamPro accessible not only during a current Microsoft Excel session but also at subsequent startups of the program. To disable autoload of the "wspexcel.xll" add-in remove the item "WaterSteamPro" from the above-mentioned dialog-box "Add-ins".

Starting from Microsoft Office 2007 the way to enable WaterSteamPro XLL add-in is changed. You should use the steps showed on figures 6,b-6,c.

Fig. 6, b. Go to "Parameters" dialog in Microsoft Excel

Fig. 6, c. Go to "Add-ins" dialog in Microsoft Excel

Fig. 6, a. "Add-ins" dialog in Microsoft Excel


Using WaterSteamPro in WSH (Windows Scripting Host)

Windows Scripting Host is the technique of program creation in Windows using the script languages. This technique has replaced bat files of MS-DOS. Standard Windows 98 delivery package presents two script languages: JScript (analog of JavaScript) and VBScript (Visual Basic Scripting Edition). A program for WSH represents a text file with a program written in a language supported by WSH.

In what follows there are illustrated two files designed for WSH and written in JScript and in VBScript. The files enable calculation of specific volume, specific enthalpy and specific entropy in a point defined by preset values of pressure and temperature, which are program arguments and are defined at a program-file call. In the absence of arguments the program calculates default parameters. Otherwise, the first argument - is pressure (Pa), and the second one - temperature (K).

The file "WaterSteamPro.js", programming language - is JScript:

var wsp = WScript.CreateObject("WSP.WSPCalculator");
var wshshell = WScript.CreateObject("WScript.Shell")
if (! wsp)
{
   wshshell.Popup('Error with creating ActiveX object!',0,'',0)
   WScript.Quit();
}else
{
   var arg = WScript.Arguments;
   var p = 1000000;
   var t = 400;
   if (arg.length > 1)
   {
      p = arg.Item(0);
      t = arg.Item(1);
   }else
   {
      wshshell.Popup('Arguments absent. Loaded default values!',0,'',0);
   };
   var v = wsp.wspVPT(p, t);
   var s = wsp.wspSPT(p, t);
   var h = wsp.wspHPT(p, t);
   wshshell.Popup('P='+p+'Pa;T='+t+'K;V='+v+'m3/kg;S='+s+'J/kg*K;H='+h+'J/kg',0,'',0);
}

The given example applies the technique described above in the section "Operation of WaterSteamPro in Microsoft Excel" with reference to the function "CreateObject", that is why it is not thoroughly described here and only the most common features are stated here

First lines provide creation of two objects: the first object allows access to functions for calculation of properties of water and water steam, and the second one - serves to display messages. Then the program verifies whether a "WSP.WSPCalculator" object was created and, if not, displays a warning message and terminates operation. If an application object was created successfully the following variables are defined: the variable "arg" keeping set of arguments (which are specified in the command line) required at a file call, and two variables keeping default design values of parameters (the design value of pressure "p" - is 1000000, and the design value of temperature "t" - is 400). After that the program checks number of arguments and if their quantity exceeds unit (two or more), the variables "p" and "t" take respectively the value of the first and the second argument (argument numbers are - zero and unit). Otherwise, the message on the absence of arguments is displayed and the program operates with default values. The next stage comprises reference to methods of created "wsp" object (of "WSP.WSPCalculator" type) which return values of specific volume, entropy and enthalpy. A message presenting obtained calculation results is displayed on completion of program operation.

Let us investigate the file "WaterSteamPro.vbs", the programming language - is VBScript. The program algorithm is identical to the one described above, and all the differences are related to a specific character of the programming language:

Set wsp = WScript.CreateObject("WSP.WSPCalculator")
Set wshshell = WScript.CreateObject("WScript.Shell")
if Not IsObject(wsp) Then
   wshshell.Popup "Error with creating ActiveX object!",0,"",0
   WScript.Quit
Else
   Set arg = WScript.Arguments
   Dim p
   p = 1000000
   Dim t
   t = 400
   if arg.length > 1 Then
      p = arg.Item(0)
      t = arg.Item(1)
   else
      wshshell.Popup "Arguments absent. Loaded default values!",0,"",0
   End if
   dim v
   v = wsp.wspVPT(p, t)
   dim s
   s = wsp.wspSPT(p, t)
   dim h
   h = wsp.wspHPT(p, t)
   wshshell.Popup "P=" & p & ";T=" & t & ";V=" & v & ";S=" & s & ";H=" & h & "",0,"",0
end if


Using WaterSteamPro in Mathcad

For Mathcad 12 users

Mathcad Professional - is a mathematical package designed by MathSoft, Inc. The first versions of WaterSteamPro package were designed in Mathcad and worked only in that environment. However, starting with the 5-th version all functions were converted to C++ language, which enable use of WaterSteamPro package in other environments.

To use functions for water and steam in Mathcad in the previous versions you should import a Mathcad worksheet containing function definitions into a new one. For that, the Reference mechanism was used. To access the functions from the OKAWSP6.DLL library now stub-library WSPMCAD.DLL was written readdressing the calls from Mathcad to OKAWSP6.DLL. The library WSPMCAD.DLL is written using the USEREFI technique attaching the functions written in Mathcad C. Unfortunately, it is the MathSoft policy that you can access the user functions only in Mathcad Professional versions. That resulted in the following requirements to Mathcad:

  • Mathcad Professional
  • Mathcad 8.0 and higher. In principle, Mathcad 7 Professional environment will work, but definitions of WaterSteamPro functions in the "Insert Function" dialog box and built-in Mathcad facility of operation with dimensions are inaccessible.
  • Operation in Mathcad demo-version (Mathcad Explorer) is also possible, but the tested version Mathcad 8 Explorer (SP2) displayed a number of strange bugs, though functions themselves operated correctly.

As already mentioned, the WSPMCAD.DLL library allows new capabilities of new WaterSteamPro version in Mathcad Professional. The library should be kept in the USEREFI folder of the Mathcad catalog.

Note: the unified function names of the 5-th version are incompatible with the previous versions. Therefore it is necessary to change function names in Mathcad worksheets using earlier versions. A number of functions for calculation of water/water steam properties in the saturation line are not defined also in the 5-th version (though, these functions are used rarely). Worksheets operating with these functions should use previous versions of the program. Another way - is to apply both the new and the previous version of WaterSteamPro at the same time (that has been successfully tested).

A new capability of the program version is that you can insert functions into a worksheet in the standard dialog box "Insert Function", which is enabled by means of either the toolbar, or the item "Insert Function." in the menu "Insert". To display a list of functions in the "Insert Function." dialog box the file WSPMCAD.XML keeping definitions of WaterSteamPro functions should be in folder DOC\FUNCDOC of the Mathcad catalog. Since you can not use the file WSPMCAD.XML in Mathcad 7 Professional, the given Mathcad version does not allow function definitions in the "Insert Function" dialog box.

To install the functions for calculation of properties of water and water steam click the function name in the "Insert Function" dialog box shown below. If the function list is absent reinstall the program or register files manually as described above.

All functions of WaterSteamPro package are displayed in the "Insert Function" dialog box in sections starting with the line "WaterSteamPro" (see Fig. 7).

Fig. 7. Dialog box "Insert Function" with "WaterSteamPro" functions

Attention: It is strongly recommended that you use dimensions in WaterSteamPro functions in Mathcad. For that, insert a reference to file "WaterSteamPro.mcd" in an active Mathcad worksheet. How to do that is described in Mathcad user's guide. The description of using dimension functions is given in "Two ways of using WaterSteamPro functions in Mathcad"

For Mathcad 12 users

In Mathcad 12 namespace operator was introduced. With this future the WaterSteamPro functions with dimensions will not work.

How to manually solve the problem is described in F.A.Q.

Due to namespace operator in Mathcad 12 the files "watersteampro.mcd" for Mathcad version below 12 and from 12 and upper are different. So for differ versions of Mathcad the differ file "watersteampro.mcd" is reqiured.

There are different files "watersteampro.mcd" in release version of WaterSteamPro 6.0 to support both Mathcad 12 (or later) and older versions.

To solve the problem of using dimension WaterSteamPro functions in release version of WaterSteamPro 6.0 used next algorithm:

  • At installation the WaterSteamPro installer check for Mathcad version. If version less than 12 the file "watersteampro.mcd" for Mathcad 8 and above is used. If version greater or equal to 12 than the file "watersteampro.mcd" for Mathcad 12 is used. The selected file is installed to specified documents folder.
  • In addition, file "watersteampro.mcd" for Mathcad versions less than 12 installed to folder "[WATERSTEAMPRO_INSTALL_PATH]\Samples\Mathcad\MC8" and "[MATHCAD_DOCS]\WaterSteamPro\MC8" regardless of Mathcad version. "[WATERSTEAMPRO_INSTALL_PATH]" is the folder where the WaterSteamPro is installed and "[MATHCAD_DOCS]" - it's a folder where Mathcad documents are installed.
  • Similarly file "watersteampro.mcd" for Mathcad versions equal or greater than 12 installed to folder "[WATERSTEAMPRO_INSTALL_PATH]\Samples\Mathcad\MC12" and "[MATHCAD_DOCS]\WaterSteamPro\MC12" regardless of Mathcad version.

This allow to use the file "watersteampro.mcd" for installed version of Mathcad. In case of upgrading to another version of Mathcad it is require to use needed file from "MC8" or "MC12" folder.

In case of simultaneously installed two or more versions of Mathcad (as example Mathcad 11 and Mathcad 12) it is required to make the reference to needed file "watersteampro.mcd" in "MC8" or "MC12" folder. In this case to work with the same Mathcad document in differ versions of Mathcad is difficult.


Two modes of using WaterSteamPro functions in Mathcad

In Mathcad, a complete set of units is available as built-in variables. This allows you to treat dimensional quantities more powerful.

The following conditions of using WaterSteamPro package in Mathcad are possible:

  • Dimensionless. All function arguments should have dimensions in the SI system. The results are also returned in the SI unit system.
  • Dimensional. Mathcad checks units for dimensional consistency and recalculates a result.

The first mode is enabled at a Mathcad startup (the library WSPMCAD.DLL should be kept in the folder USEREFI and it should be already loaded). In this case, the user have to see so that dimensions of all the arguments of WaterSteamPro are in the SI system.

To operate the program in the second mode (dimensional mode) the file named "WATERSTEAMPRO.MCD" should be inserted into a worksheet through the item "Reference." of the "Insert" menu. This file redefines functions permitting them to operate with dimensions.

Fig. 8 illustrates the difference between the foregoing modes.

Fig. 8. WaterSteamPro modes in Mathcad

The second mode is recommended. All Mathcad examples of the "WaterSteamPro" delivery set operate with dimensions.

Attention: it is not recommended to insert more than one (Reference) file "watersteampro.mcd" into a worksheet. Otherwise, dimension problems will occur - the program will operate with dimensions to the power equal to a number of insertions.


Description of functions for calculation of properties of water and steam in WaterSteamPro

All WaterSteamPro functions uses base units from the SI unit system: pascal, kelvin, joule, kilogramm, meter, second. Additional capabilities of using units has program Mathcad of the MathSoft Engineering & Education, Inc.

Most of the functions (except for some system functions) have double type of arguments and results (a real number with double precision).

In case of error, all functions return the value -1 (minus one). The function "wspGETLASTERROR()" allows to analyze a code of an error. An error code is saved until another function is called, except for the system functions.

The function names in WaterSteamPro are unified (they have identical names in different programs) and are generated according the following rules:

  • A name begins with the prefix "wsp" (small letters);
  • After that a descriptor of the sought quantity is situated. For example, specific enthalpy is "H" (capital letters);
  • The next component is a descriptor of region and condition of water/water steam. For example, water in the saturation line is denoted as "SW" ("Saturated Water"). Names of generalized functions (for example, specific volume as a function of pressure and temperature) have not such a component.
  • The end of a name is the argument descriptors. Thus, specific volume is function of pressure, temperature and degree of dryness and it is denoted as "PTX" - where "P" - pressure; "T" - temperature; "X" - degree of dryness.

String descriptors of quantities and dimensions in the SI unit system are listed below:

  • Pressure: "Pressure" - "P", [Pa];
  • Temperature: "Temperature" - "T", [K];
  • Specific volume: "specific Volume" - "V", [m3/kg];
  • Specific internal energy: "specific internal energy (U) " - "U", [J/kg];
  • Specific entropy: "specific entropy (S) " - "S", [J/(kg·K)];
  • Specific enthalpy: " specific enthalpy (H) " - "H", [J/kg];
  • Specific heat capacity at constant pressure: "specific heat Capacity at constant Pressure" - "CP", [J/(kg·K)];
  • Specific heat capacity at constant volume: "specific heat Capacity at constant Volume" - "CV", [J/(kg·K)];
  • Sound velocity: "sound velocity (W) " - "W", [m/s];
  • Density: "density (R)" - "R", [kg/m3];
  • Specific evaporation heat: "specific evaporation heat (R) " - "R", [J/kg];
  • Thermal conductivity: "THERMal CONDuctivity" - "THERMCOND", [W/(m·K)];
  • Dynamic viscosity: "DYNamic VIScosity" - "DYNVIS", [Pa·sec] = [kg/(m·sec)];
  • Kinematic viscosity: "KINematic VIScosity" - "KINVIS", [m2/sec];
  • Coefficient of surface tension: "SURFace TENsion" - "SURFTEN", [N/m];
  • Prandtl number "PRANDTL's number" - "PRANDTLE", [-];
  • Isoentropic exponent: "isoentropic exponent (K) " - "K", [-];
  • Joule-Thomson coefficient: "JOULE-THOMSON coefficient " - "JOULETHOMPSON", [K/Pa];

Descriptors of regions and condition of water:

  • Generalized functions (total range of definition) - without descriptors;
  • Functions of water properties at the saturation line: "Saturation Water " - "SW";
  • Functions of steam properties at the saturation line: "Saturation Steam " - "SS";
  • Functions of the double-phase area: - "S";
  • Functions of meta-stable properties: "MetaStable" - "MS";


Input equations of WaterSteamPro

Source formulation of the WaterSteamPro

Input equations for the thermodynamic properties are the basic equations of International Equation System of 1997 for the thermodynamic properties of water and steam for industrial use proposed by International Association for Properties of Water and Steam (www.iapws.org), reffered to as Formulation IAPWS-IF97. Outlines of that are given in next sections.


Main constants

Specific gas constant of water: R = 0,461526 kJ/(kg·K).

Parameters of water in critical point:

  • absolute temperature Tcr = 647,096 K in International temperature scale 1990 y. (ITS-90);
  • pressure Pcr = 22,064 MPa;
  • density ρcr = 322 kg/m3.


Structure of the Formulation IF–97

The Formulation consists of equation sets for various regions within such parameters as:

273.15 ≤ T ≤ 1073.15 at p ≤ 100 MPa

1073.15 ≤ T ≤ 2273.15 at p ≤ 50 MPa

Figure 1 shows location of these regions in p-T diagram. Regions 1, 2, 5 are based on fundamental Gibbs energy equation g(p, T), region 3 on fundamental HelmHoltz energy equation f(ρ, T), and the saturation line is described by equation Ps(Ts) and Ts(Ps). These five equations are the main in the Formulation IF-97. Besides, some additional equations are used that allow to avoid iterative procedures. Description of that is given in [3].

Pic. 1. Regions of application the Formulation IF-97

The borders of regions are clear from fig. 1, except for that between regions 2 and 3 which is close to the isentropic curve and is represented by equations:

P = n1 + n2·T + n3·T2 (1)

or

T = n4 + ((P - n5)/n3)(1/2) (2)

Equations (1) and (2) are valid from temperature 623,15 K and pressure 16,5292 MPa to temperature 863,15 K and pressure 100 MPa.


Agreement between the values of thermodynamic properties at the borders of IF-97 regions

Table 1 shows discrepancy of the values of thermodynamic properties calculated on the basic equations for bordering one-phase regions. Table 2 shows discrepancy of pressure, temperature and Gibbs energy at saturation line with separated point at T = 623,15 K where equations for three regions are agreed.

Table # 1. Discrepancy of the values of thermodynamic properties at the borders of IF-97 regions

Quantity, x | Border of regions # 1, 3 |  | Border of regions # 2, 3 |  | Border of regions # 2, 5
 | |Δx|max | σ*1 | |Δx|max | σ | |Δx|max | σ
υ, % | 0,004 | 0,002 | 0,018 | 0,007 | 0,002 | 0,001
h, kJ/kg | 0,031 | 0,014 | 0,134 | 0,073 | 0,020 | 0,012
ÑÐ, % | 0,195 | 0,058 | 0,353 | 0,169 | 0,081 | 0,048
s, J/(kg·K) | 0,042 | 0,022 | 0,177 | 0,094 | 0,042 | 0,025
g, kJ/kg | 0,005 | 0,005 | 0,005 | 0,003 | 0,026 | 0,021
w, % | 0,299 | 0,087 | 0,403 | 0,073 | 0,021 | 0,009

Table # 2. Discrepancy of the values of thermodynamic properties at the saturation line

Quantity, x | T1 ≤ T ≤ 623.15 K |  | 623.15 K ≤ T ≤ Tcritical |  | T = 623,15 K
 | |Δx|max | σ*2 | |Δx|max | σ
PS, % | 0,0069 | 0,0033 | 0,0026 | 0,0015 | 0,0041
TS, % | 0,0006 | 0,0003 | 0,0003 | 0,0002 | 0,0006
g, kJ/kg | 0,012 | 0,006 | 0,002 | 0,001 | 0,005

*1 Mean square deviation σ is calculated for 3000 points allocated uniformly along two parts of saturation line

*2 Mean square deviation σ is calculated for 3000 points allocated uniformly along two parts of saturation line


Error estimating

Error estimation

Figures 2, 3, 4, 5 show error estimations for specific volume, isobaric heat capacity, saturation pressure and sound velocity calculated on equations of Formulation IF–97 . That are the tolerances for the values considered and have no static sense. The message «tolerace cannnot be determined» is connected with the region where extrapolated values from [1] are used as initial data for the equation.

Error for dynamic viscosity for liquid: at pressure up to 100 MPa and temperature up to 250 °C is 1%, up to 300 °C – 2%, at 350 °C and above – 3%. For steam at pressure up to 50 MPa and temperature up to 475 °C that amount to 2%, and at higher pressure and temperature – 3%.

Error for thermal conductivity for liquid: at temperature range 25 – 200 °C and pressure up to 5 MPa is 1.5%, and at higher pressure and temperature up to 300 °C – 2%. For steam at temperature up to 550 °C and pressure up to 0.1 MPa is 1.5%, and at pressure up to 40 MPa – 3%. The equation for thermal conductivity gives a finite value in critical point, while it must be infinite according to the theory. Correspondingly, the error for thermal conductivity cannot be estimated close to critical point.

Fig. 2. Relative error for specific volume
For critical region (hatched triangle), bordered by isohoric lines 0,0019 and 0,0069 m3/kg and isobar 30 MPa. Relative error for pressure is marked.

Fig. 3. Relative error for specific isobaric heat capacity
Borders of critical region (hatched triangle) – see. fig. 2

Fig. 4. Relative error for sound velocity
Borders of critical region (hatched triangle) – see. fig. 2

Fig. 5. Relative error for saturation pressure


General characteristic and range of validity of functions

General characteristic and range of definition of functions

WaterSteamPro has a function set for calculation of thermodynamic properties, coefficient of surface tension, kinematic and dynamic viscosities, thermal conductivity, Prandtl number, isentropic exponent, Joule-Thomson coefficient for water and steam at saturation line, one-phase and double-phase areas, etc.

All the thermodynamic properties are calculated by Formulation IF-97 [2]. At that, all the values of thermodynamic properties of water and steam at saturation line at temperatures above 350 °C (pressure above 16,5 MPa) are calculated by implicit equation for IF-97 region 3 with values of temperature and pressure, defined by the equation for saturation line (IF-97 region 4). All the thermodynamic functions include temperature range from 0.01 to 2000°C at pressure up to 10 MPa and from 0.01 to 800°C at pressure up to 100 MPa.

Dynamic viscosity of water and steam at saturation line is calculated by equation IAPWS-85 [5], corrected for temperature scale ITS-90. The range of validity (according to IAPWS) is for pressure up to 500 MPa temperature is from 0 to 150°C, for pressure up to 350 MPa temperature is from 150 to 600°C, for pressure up to 300 MPa temperature is from 600 to 900°C. Density values which are the arguments of the equation are defined by Formulation IF-97 for given temperature and pressure.

The values of kinematic viscosity are calculated by the equation:

ν = μ / ρ

where: μ - dynamic viscosity which is defined by equation described above, ρ - density which is the value inverse to specific volume calculated by Formulation IF-97.

Thermal conductivity of water and steam at saturation line is calculated by equation IAPWS-85, recommended for industrial use [6], and corrected for temperature scale ITS-90. At that, the density values, which are the arguments of the equation as for dynamic viscosity, are calculated by Formulation IF-97. The range of validity corresponds with recommendations of IAPWS: at temperature from 0.01 to 800°C and pressure up to 40 MPa, at temperature from 0.01 to 650°C and pressure from 40 to 70 MPa, at temperature from 0.01 to 500°C and pressure from 70 to 100 MPa.

The Prandtl number is calculated as:

Pr = (μ·Cp) / λ

where: μ - dynamic viscosity; Cp - specific isobaric heat capacity defined by Formulation IF-97; λ - thermal conductivity defined by IAPWS formulation from 1985. The range of definition corresponds with range of definition of equation for thermal conductivity.

Isoentropic exponent is calculated as:

K = w * w / (p * v)

where: w - sound velocity; p - pressure; v - specific volume. The range of parameters corresponds with IF-97.

Joule-Thomson coefficient (JT = (dt/dp)h) is calculated by equation which is specific for each region of the IF-97.


Remarks about the function set ("non-physical" functions)

There are some functions in WaterSteamPro, named "non-physical", which calculate properties of water and steam but have no physical meaning. For example, function wspCPSTX(t, x), calculates specific isobaric heat capacity (Cp) in double-phase area depending on temperature t and dryness factor x. In reality, that equals to infinity in double-phase area. However, the function returns the value defined from:

Cpsw(t)·(1 - x) + Cpss(t)·x,

where Cpsw(t) - is the function of specific isobaric heat capacity of water at saturation line; Cpss(t) - is the function of specific isobaric heat capacity of steam at saturation line.

All similar functions are marked by sign [image] in list of WaterSteamPro functions. All these functions are defined when it is necessary to make optimization or find a root and therefore to calculate a value of a property. That may occurs automatically, for example, when Newton method is used. The second example: such up-to-date mathematical packages as Mathcad have built-in functions that find roots, minimums, maximums and so on. At that, if a function has a discontinuity the root may be not found even if it is situated in the tolerance range.

To solve this problem, for universality, the additional functions were defined in WaterSteamPro that return "non-real (physical)" values.

For the same purpose, WaterSteamPro has the ability to disable checking arguments for tolerance range. By default, when calling a function the argument range is checked before calculation. If an argument is out of range the error is occurred with code 2 (WSP_OUT_OF_RANGE).

To disable checking arguments function wspSETCHECKRANGEMODE(mode) is defined. Calling this function with argument equals to zero (0) disable checking the arguments for tolerance range which defined by the region of allowable parameters of the input equations. That allows calculating beyond the original regions with the values of the properties, which are not corresponding with real.

Warning!

From the WaterSteamPro 6.5, all "non-physical" functions when checking arguments mode is on (by default) are generated error with code 2 (WSP_OUT_OF_RANGE).

All functions, based on "non-physical" functions, at specified arguments sets can also generate the same error.

As example, function wspCPSTX(t, x) generate the error at any arguments sets (when checking arguments is on - see below). And function wspCPPH(p, h), which is internally can call wspCPSTX(t, x) - can generate the error only when parameters set (pressure p and specific enthalpy h) is correspondent to double-phase area.

So, by default "non-physical" functions will not work (only return error value "-1.0").

To "turn on" "non-physical" functions you need to disable the checking arguments mode. It can be done by preliminary call to function wspSETCHECKRANGEMODE(mode) with parameter mode = 0.


Properties of metastable supercooled steam

To calculate some thermal processes, mainly the processes of steam expansion in turbines, it is important to know properties of metastable supercooled steam in the region adjoining the region 2 of formulation on the side of right boundary curve. As there is no experimental data of thermodynamic properties of supercooled water steam, its calculation can only be made by extrapolation of equation of state formed for a stable superheated steam to that region. An analysis of several equations such as the main equation for region 2 of the formulation, equation of a superheated steam from formulation IFC-67 and International equation of state for general and scientific application IAPWS-95, shows that results of its extrapolation are considerably different. Such situation is typical for complicated equations containing a lot of constants. Therefore, as initial datum for equation of state of a metastable supercooled steam were taken that obtained from simpler equation that was formulated as auxiliary for International equation of state IAPWS-95 [1].

To calculate metastable region of supercooled steam the equation given in [3] is used. List of functions for property calculation of supercooled metastable steam is given here.

The equation is applicable for the metastable steam region from the upper boundary curve to a line of 5% humidity of steam in equilibrium h, s - chart at pressure up to 10 MPa. The following datum define adjustment of calculated values on the saturation line with the main equation for region 2:

|Δv|max = 0.014 % | |Δs|max = 0.082 J/(kg·K)
|Δh|max = 0.043 kJ/kg | |Δg|max = 0.023 kJ/kg
|Δcp|max = 0.78 % | |Δw|max = 0.05 %

The equation for metastable steam region converts to the equation for region 2 in discrete steps along the 10 MPa isobar in the field of metastable steam, but that is not of essential practical importance.

The monitoring values of thermodynamic properties of metastable supercooled steam are given in tab. 1.

Table 1. Thermodynamic properties of a metastable supercooled steam
Property | t = 450 K, P = 1 MPa | t = 440 K, P = 1 MPa | t = 450 K, P = 1.5 MPa
v, m3/kg | 0.192516540 | 0.186212297 | 0.121685206
h, kJ/kg | 0.276881115·104 | 0.274015123·104 | 0.272134539·104
u, kJ/kg | 0.257629461·104 | 0.255393894·104 | 0.253881785·104
s, kJ/(kg·K) | 0.656660377·101 | 0.650218759·101 | 0.629170440·101
cp, kJ/(kg·K) | 0.276349265·101 | 0.298166443·101 | 0.362795578·101
w, m/sec | 0.498408101·103 | 0.489363295·103 | 0.481941819·103


Codes of errors in the WaterSteamPro's calculations

The function "wspGETLASTERROR()" returns code of the error occured in the last call of the WaterSteamPro function.

Possible values:

  • "0" - "No error occurs" - there was no error;
  • "1" - "Incorrect parameters: error in calculations with floating point";
  • "2" - "Arguments are outside of applicable domain";
  • "3" - "Limit of iterations is exceeded" – it is impossible to find value of density in the third region of IF-97. That error occurs if the given number of iterations (the function "wspGETMAXITERATION()") does not attain the required accuracy (function "wspGETDELTAPRESSURE()");
  • "4" - "Can't understand water state region" – unknown region of water state;
  • "5" - "Beta testing is over. Please get new version" – beta release program testing time is over (does not exist in the complete program version);
  • "6" - "Registration error. Please reinstall WaterSteamPro" – safeguard error (occurs in unregistered version).
  • "7" - "This function is available only in registered version of the WaterSteamPro" – from version 5.2 all new functions work only in registered versions. It is not affect the functions getting from the earlier versions.
  • "8" - "This function is not implemented in current version of WaterSteamPro . Try newer version" - function is only declared in current version of the WaterSteamPro and can be implemented in next version of the program.
  • "9" - " Low memory"
  • "10" - "Registered status expired" - registration expired. Use next version of registration data.
  • "11" - "Syntax error." - there is syntax error in gas specification string.


Calculating thermodynamic properties of gases and gases mixtures

Common description

List of built-in gases

Ways of functions using for calculating properties of gases

Functions based on gas identifiers

Functions based on gas specifications

Format of gas specification string

For users of beta versions of WaterSteamPro 6.0

Starting from version 6.0 WaterSteamPro provides functions for calculation properties of the gases. These functions compute thermodynamic properties of eleven gases (components of combustion products and air) and their mixtures in ideal state at temperatures varying from 200 to 2500K. The mixtures considered as ideal. For description of the formulas and numerical coefficient refer to [57, 74].

WaterSteamPro functions for gases have the prefix "wspg".

These functions applies to calculations of thermodynamic properties of air, combustion products, and some gases under moderate pressures (because the gases are considered to be ideal) at temperature range from 200K to 2500K.

The need for these functions has arisen because the present methods calculate the thermodynamic properties of air and combustion products (for boilers, gas turbines etc) with assumptions in which, for example, processes of expansion and compression are computed by adiabatic exponent, while using of specific enthalpy and entropy is simpler and more evident. Besides, the concept of "separate" expansion of air and combustion products in gas turbine when they expand to the equal pressure having different output temperatures is artificial. It is simpler to make calculation of that kind by the equations for gaseous mixtures considering the mixture as one gas and compute by the values of specific enthalpy and entropy.

The aim of creation the functions was also to provide simple, convenient and fast calculation of thermodynamic properties of gases and their mixtures in various applications.

List of built-in gases

This list contains the most common gases in heat-and-power engineering calculations:

  • nitrogen N2;
  • oxygen O2;
  • carbon monoxide CO;
  • carbon dioxide CO2;
  • water vapor H2O;
  • sulfur dioxide SO2;
  • air;
  • air nitrogen;
  • nitrogen monoxide NO;
  • nitrogen dioxide NO2;
  • argon Ar;
  • neon Ne;
  • hydrogen H2.

In addition to source gases air and atmospheric nitrogen are also built-in defined as gaseous mixture of the accepted composition.

Composition of dry air (volume fractions), the same as in [12], accepted as follows:

  • nitrogen - 78,03%;
  • oxygen - 20,99%;
  • argon - 0,94%;
  • hydrogen - 0,01%;
  • carbon dioxide - 0,03%.

Composition of dry air nitrogen (volume fractions), the same as in [12], accepted as follows:

  • nitrogen - 98,76%;
  • argon - 1,19%;
  • hydrogen - 0,01%;
  • carbon dioxide - 0,04%.

Used constants and parameters:

  • absolute gas constant: R = 8.31451 J/(mole·K);
  • molar mass of gases given in table 1;
  • standard pressure P0 = 105 Pa = 1 bar = 0.1 MPa = 14.5037737730209 psi.

In table 1 given the list of built-in (available at any time) gases, their names and identifiers. More information about names and identifiers given in next chapters.

Table 1. List of built-in gases.

Gas title | Gas name | Molar mass, kg/mole | Unique gas identificator
Nitrogen | N2 | 0.0280134 [14] | 0
Oxygen | O2 | 0.0319988 [14] | 1
Carbon monoxide | CO | 0.0280104 [14] | 2
Carbon dioxide | CO2 | 0.0440098 [14] | 3
Water vapor | H2O | 0.0180152 [14] | 4
Sulfur dioxide | SO2 | 0.064059 [14] | 5
Air (as single gas)* | Air | 0.02896431986** | 6
Air nitrogen (as single gas)* | N2Air | 0.02815922054** | 7
Nitrogen monoxide | NO | 0.0300061 [14] | 8
Nitrogen dioxide | NO2 | 0.0460055 [14] | 9
Argon | Ar | 0.039948 [14] | 10
Neon | Ne | 0.020179 [14] | 11
Hydrogen | H2 | 0.0020158 [14] | 12
Air as gases mixture | AirMix | 0.02896431986** | 13
Air nitrogen as gases mixture | N2AirMix | 0.02815922054** | 14

* The term "as single gas" means that the program considers it as the gas which properties are equivalent to that of mixture of composing gases. That allows us to compute properties of the mixtures without taking the dissociation into account.

** Calculated for accepted components fractions [12].

Ways of using functions for calculating properties of gases

There are two ways of using and two sets of functions for working with gases and mixtures on their base:

  1. Using gas identificators.
  2. Using gas specifications.

These methods have their own advantages and limitations. Your choice will depend on used applications and your requirements. The description of these methods is given below.

Functions based on gas identifiers

In this method all the gases, built-in and user-defined, are represented as the "gas identifiers" (id) which are the numbers (of the long type). The functions for gas calculation search out the data by the passed identifier and compute the required value.

Table 1 shows identifiers for the built-in gases.

This method enables us to work in most of applications and gives fast access to data.

The limitations of this method are: it needs hard order of function calls which some applications, for example Excel, cannot always provide, and necessity to free memory occupied by user gases (mixtures).

Names functions defined for computing of the gas properties by the identifier contain string "ID" (they listed in the section "Finctions list"):

  • wspgCPIDT(id, t) - returns specific isobaric heat capacity of the gas with the identifier id at temperature t;
  • wspgHIDT(id, t) - returns specific enthalpy of the gas with the identifier id at temperature t;
  • wspgSIDT(id, t) - returns specific entropy of the gas with the identifier id at temperature t and pressure P0 = 1 bar;
  • wspgSIDPT(id, p, t) - returns specific entropy of the gas with the identifier id at temperature t and pressure p;
  • wspgTIDPS(id, p, s) - returns the temperature of the gas with the identifier id at pressure p and specific entropy s;
  • ...
  • wspgIDNAME(gas_name) - the identifier of the defined (or built-in) gas named gas_name;
  • wspgNEWID() - the identifier of the new (user) gas;
  • wspgNEWIDNAME(gas_name) - the identifier of the new (user) gas which have the new unique name gas_name;
  • wspgNEWIDGS(gas_specification) - the identifier of the new (user) gas which composition corresponds with given specification gas_specification (detailed information about the gas specifications in the following);
  • wspgADDGASM(id_target, id_source, mass) - addition of the gas having mass "mass" and the identifier id_source into the gas composition defined by the identifier id_target;
  • wspgADDGASV(id_target, id_source, volume) - addition of the gas having the volume "volume" and the identifier id_source into the gas composition defined by the identifier id_target;
  • wspgMFIDID(gas_id_looked, gas_id_looked_for) - mass fraction of the gas with the identifier gas_id_looked_for in the gas with the identifier gas_id_looked;
  • wspgVFIDID(gas_id_looked, gas_id_looked_for) - volume fraction of the gas with the identifier gas_id_looked_for in the gas with the identifier gas_id_looked;
  • wspgDELETEGASID(id) - deletes created user gas with the identifier gas_id;
  • wspgDELETEGASES() - deletes all the gases created by a user.
  • wspgGASESCOUNT() - number of the gases, user and built-in.

To use the functions listed above:

  1. For computing properties of the built-in gases (see table 1) it is necessary to transfer required gas identifiers (table 1) to the correspondent functions.
  2. For creating a new (user) gas that will represent a mixture consisted from other gases call one of the functions wspgNEWID(), wspgNEWIDNAME(gas_name), or wspgNEWIDGS(gas_specification). Each of them returns the unique number, identifying a new gas unambiguously.
  3. After getting the identifier of a new gas, enter its composition by functions wspgADDGASM(id_target, id_source, mass) or wspgADDGASV(id_target, id_source, volume). Use first of them if the composition by mass is known and the second in case of composition by volume. Indicate the identifier of a new gas obtained by previous step as id_target and the identifier of the gas obtained before (built-in or user) as id_source.
  4. After indicating the gas composition you can call required functions for computing the gas properties, as in step 1, that is the mixture of others gases. At that, it is necessary to use the identifier obtained in step 2.
  5. To determine mass or volume fractions of the gas use functions wspgMFIDID(gas_id_looked, gas_id_looked_for) or wspgVFIDID(gas_id_looked, gas_id_looked_for).
  6. Finishing a work with a user gas you should free the memory occupied by this gas using function wspgDELETEGASID(id). After that any call to the user gas will display an error message. To delete the functions defined by a user (i.e. all except for the built-in) call function wspgDELETEGASES(). After that, each call to the user gases will also display an error message.

To determine the number of all the gases (user and built-in) call function wspgGASESCOUNT().

You can enter the gas composition (step 3) when you create the gas (step 2) by function wspgNEWIDGS(gas_specification) indicating the gas specification. See the detailed description of the gas specifications in the next section. At that, it is not necessarily using functions wspgADDGASM(id_target, id_source, mass) and wspgADDGASV(id_target, id_source, volume).

You can create mixtures of the gaseous mixtures based on the method described above. For that enter the identifiers of user gases (mixtures) created before as id_source in functions wspgADDGASM(id_target, id_source, mass) and wspgADDGASV(id_target, id_source, volume).

Look at an example of computing properties of the moist air in a hypothetic application. The composition of the dry air equals to that defined in WaterSteamPro and mass of the water vapour is 0.007 kg/kg (i.e. 0.007 kg of water vapour/ kg of dry air).

id_dry_air = wspgNEWID() // Get the identifier of the new gas - dry air.
wspgADDGASV(id_dry_air, 0, 78.03) // Addition of 78.03 volume units of the gas with identifier 0 (nitrogen) to composition of dry air (see table 1).
wspgADDGASV(id_dry_air, 1, 20.99) // Addition of 20.99 volume units of the gas with identifier 1 (oxygen)to composition of dry air (see table 1).
wspgADDGASV(id_dry_air, 10, 0.94) // Addition of 0.94 volume units of the gas with identifier 10 (argon) to composition of dry air (see table 1).
wspgADDGASV(id_dry_air, 12, 0.01) // Addition of 0.01 volume units of the gas with identifier 12 (hydrogen) to composition of dry air (see table 1).
wspgADDGASV(id_dry_air, 3, 0.03) // Addition of 0.03 volume units of the gas with identifier 3 (carbon dioxide) to composition of dry air (see table 1).
id_moist_air = wspgNEWID() // Get the identifier of the new gas - moist air.
wspgADDGASM(id_moist_air, id_dry_air, 1) // Addition of 1 mass unit of the gas (dry air) to composition of moist air.
wspgADDGASM(id_moist_air, 4, 0.007) // Addition of 0.007 mass units of the gas with identifier 4 (water steam) to composition of moist air (see table 1).
h_moist = wspgHIDT(id_moist_air, 500) // Enthalpy of the moist air at temperature 500K.
s_moist = wspgSIDPT(id_moist_air, 300000.0, 500) // Entropy of the moist air at temperature 500K and pressure 300 kPa.
wspgDELETEGASID(id_moist_air) // Frees memory occupied by dry air.
wspgDELETEGASID(id_dry_air) // Frees memory occupied by moist air.

You should always use the gas identifiers in Mathcad 8 because it does not work with the functions containing string variables. Although, the next Mathcad versions allow us to work with strings and, thus, you can use the functions with gas specifications.

Functions based on gas specifications

In this method all the functions, built-in and users, are represented by "gas specification".

The specification in WaterSteamPro is a string containing description of a gas (composition of the gaseous mixture). Format of the string is described below.

The advantages of this method are: clear description of gas composition; you need not free memory; the hard order of function calls is not required.

The limitation is: time consumption for access to gases data and for analysis of specification string is higher than for identifiers ones. Although caching the gas data make up for this limitation. As a result, analysis of the specification string and creating a gas based on it is executed only in the first call to gas property with such specification.

The functions for computing gas properties using specifications contain string "GS" in their names (see the list of functions in section "Functions"):

  • wspgCPGST(gas_specification, t) - returns specific isobaric heat capacity for the gas with specification gas_specification at temperature t;
  • wspgHGST(gas_specification, t) - returns specific enthalpy for the gas with specification gas_specification at temperature t;
  • wspgSGST(gas_specification, t) - returns specific entropy for the gas with specification gas_specification at temperature t and pressure P0 = 1 bar;
  • wspgSGSPT(gas_specification, p, t) - returns specific entropy for the gas with specification gas_specification at temperature t and pressure p;
  • wspgTGSPS(gas_specification, p, s) - returns temperature for the gas with specification gas_specification at pressure p and specific entropy s;
  • ...
  • wspgNEWIDGS(gas_specification) - the identifier of a new (user) gas which composition corresponds with that defined by specification gas_specification (after calling the function and working with identifier obtained it is necessary to free memory by function wspgDELETEGASID(id));
  • wspgMFGSGS(gas_spec_looked, gas_spec_looked_for) - mass fraction of the gas with specification gas_spec_looked_for in the gas with that gas_spec_looked;
  • wspgVFGSGS(gas_spec_looked, gas_spec_looked_for) - volume fraction of the gas with specification gas_spec_looked_for in the gas with that gas_spec_looked;

To compute properties of the gases defined by specifications it is necessary to transfer required strings into the correspondent functions. It is not required to free memory for gases.

Look at an example of computing properties of the moist air in a hypothetic application. The composition of the dry air equals to that defined in WaterSteamPro and mass of the water vapour is 0.007 kg/kg (i.e. 0.007 kg of water vapour/kg of dry air).

moist_air_spec = "{N2:78.03;O2:20.99;Ar:0.94;H2:0.01;CO2:0.03}:1M;H2O:0.007M" // specification of the gas - moist air
h_moist = wspgHGST(moist_air_spec, 500) // Enthalpy of moist air at temperature 500K.
s_moist = wspgSGSPT(moist_air_spec, 300000.0, 500) // Entropy of moist air at temperature 500K.

Specifications are used in Excel where setting the hard order of recalculating formulae in cells is impossible.

Gas identifiers are used the in Mathcad 8 because it does not work with the functions containing string variables. Although, the next Mathcad versions allow us to work with strings and, thus, you can use the functions with gas specifications.

Format of gas specification string

Gas1Name[:Gas1Part][;Gas2Name[:Gas2Part]][;Gas3Name[:Gas3Part]]...

where:

Gas1Name - name of first gas component or mixture specification.

Gas1Part - amount of first gas component.

Gas2Name - name of second gas component or mixture specification.

Gas2Part - amount of second gas component.

Gas3Name - name of third gas component or mixture specification.

Gas3Part - amount of third gas component.

etc.

As example of gas specification string

O2;CO2;H2O;SO2

It is a mixture of gases "O2", "CO2", "H2O", "SO2" having the composition by volume 1:1:1:1 (i.e. a mixture consisting of one volume part of "O2", one volume part of "CO2", one volume part of "H2O", and one volume part of"SO2").

Gas specification

O2:1;CO2:3;H2O:5

describes the gas consisting of one volume part of O2, three volume parts of CO2, and five volume parts of H2O.

By default 1 mole (1 volume part) is used as GasPart. Enter suffix "M" to use fractions by mass. Thus, specification

O2:1M;CO2:2M

describes the mixture consisting of one mass part of O2 and two mass parts of CO2.

In addition, there are several suffixes to indicate the amount of the component:

  • "V" - use of volume parts. That is the same as the suffix absence.
  • "%" - use of one hundredth of a volume part. The notation "N2:78.03%" means the same as "N2:0.7803".
  • "M" - use of mass parts.
  • "KG" - use of mass parts. That is the same as the suffix "M".
  • "G" - use of one thousand of a mass part.

The name of a gas may be:

  • Name of a built-in gas (for example, "O2", "H2O" etc.);
  • Name of a user gas created by a function wspgNEWIDNAME(gas_name);
  • Mixtures, the separate specification of the gas.

Last string means that it is possible to compute mixture of gaseous mixture. Thus, the specification

{O2;CO2:2};{H2O;CO2:2}:3

describes a mixture consisting of one volume part of the mixture which, in turn, consists of one volume part of O2 and two volume parts of CO2, and three volume parts of another mixture consisting of one volume part of H2O and two volume parts of CO2.

For users of beta versions of WaterSteamPro 6.0

Beta versions of WaterSteamPro (up to beta 8) used functions based that segregate terms of gas and mixture. In release version these terms are united. Besides, referred beta versions have not the mechanism of work with gas specifications that makes use of functions in Microsoft Excel practically impossible.

As a result of such modifications some functions available in beta-versions were removed and others were changed. Table 2 lists functions available in the beta versions and their analogues in release release WaterSteamPro 6.0.

Table. 2. Functions for calculations of the gas properties in beta-versions and in final release

Function name in beta versions | Function name of analogue in release version | Comment
wspgCPIDT | wspgCPIDT |
wspgHIDT | wspgHIDT |
wspgS0IDT | wspgSIDT | The name was modified for unification.
wspgMMID | wspgMMID |
wspgSIDPT | wspgSIDPT |
wspgNEWMIX | - no function - | There is not term "mixture" in the release version. The general term "gas" is used instead of it.
wspgADDGASM2MIX | wspgADDGASM | There is not term "mixture" in the release version. For this reason its name was changed although it works in the same way.
wspgADDGASMO2MIX | wspgADDGASV | There is not term "mixture" in the release version. For this reason its name was changed although it works in the same way.
wspgNEWGASFROMMIX | - no function - | This function is needless in the release version because there is no term "mixture" and gas properties are calculated at any moment.
wspgDELETEGAS | wspgDELETEGASID | Function name was modified to describe its argument but it works in the same way.
wspgDELETEMIX | - no function - | This function is needless in the release version because there is no term "mixture".
wspgDELETEALLGASES | wspgDELETEGASES | Function name was modified for short.
wspgDELETEALLMIX | - no function - | This function is needless in the release version because there is no term "mixture".
wspgGETGASESCOUNT | wspgGASESCOUNT | Function name was modified for short.
wspgGETMIXCOUNT | - no function - |
wspgCVIDT | wspgCVIDT |
wspgUIDT | wspgUIDT |
wspgCPINTIDTT | - no function - | To compute integral mean of heat capacity at temperature range from t1 to t2 use the formula: cp_int = (wspgHIDT(id, t2) - wspgHIDT(id, t1)) / (t2 - t1).
wspgTIDH | wspgTIDH |
wspgTIDS0 | wspgTIDS | Function name was modified for unification.
wspgTIDPS | wspgTIDPS |
wspgGASWFINMIX | wspgMFIDID | There is not term "mixture" in the release version. For this reason its name was changed although it works in the same way.
wspgGASMFINMIX | wspgVFIDID | There is not term "mixture" in the release version. For this reason its name was changed although it works in the same way.
wspgVIDT | wspgVIDT |
wspgVIDPT | wspgVIDPT |
wspgGCID | wspgGCID |
wspgCPIDPT | - no function - | Specific isobaric heat capacity does not depend of pressure because gases are considered to be ideal.
wspgHIDPT | - no function - | Specific entropy does not depend of pressure because gases are considered to be ideal.
wspgPIDTS | wspgPIDTS |


WaterSteamPro functions list

  • General: recommended to use functions.
  • Saturation Line: functions for calculation properties at saturation line for water and vapor.
  • Double-phase area: functions for calculation properties in double-phase area: water-vapor.
  • Sublimation and Melting Lines: functions for calculation properties at sublimation and melting lines.
  • MetaStable: functions for calculation properties of meta-stable supercooled steam
  • Source: functions from IAPWS IF-97 and other formulations.
  • Gases: functions for calculation properties of gases and gases mixtures.
  • System: system functions.

    Category: General

    Recommended to use functions.

  1. Specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspCPEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  2. Specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspCPEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  3. Specific isobaric heat capacity [J/(kg·K)] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspCPHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  4. Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspCPPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspCPxPT or wspCPSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  5. Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspCPPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspCPxPT or wspCPSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  6. Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCPPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspCPxPT) is used.

  7. Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspCPPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspCPxPT or wspCPSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  8. Specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspCVEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  9. Specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspCVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  10. Specific isochoric heat capacity [J/(kg·K)] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspCVHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  11. Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspCVPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspCVxPT or wspCVSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  12. Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspCVPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspCVxPT or wspCVSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  13. Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCVPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspCVxPT) is used.

  14. Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspCVPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspCVxPT or wspCVSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  15. Static dielectric constant of ordinary water substance [-] as function of pressure p [Pa], temperature t [K]:

    wspDCPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – static dielectric constant of ordinary water substance [-], type: double.

    Function is based upon the function wspDCRT(r, t). The latest in it's turn is based upon the "Release on the Static Dielectric Constant of Ordinary Water Substance for Temperatures from 238K to 873K and Pressures up to 1000 MPa", 1997 from IAPWS. The range of validity is from 238 to 273K in the metastable liquid at atmospheric pressure (0.101325 MPa); from 273 to 323 K at pressures up to the lower of the ice IV melting pressure or 1000 MPa; above 323 K at pressures up to 600 MPa. The formulation also extrapolates smoothly up to at least 1200 K and 1200 MPa.

  16. Derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspDDDHPPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  17. Derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5] as function of pressure p [Pa], temperature t [K]:

    wspDDDHPPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspDDDHPxPT) is used.

  18. Derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspDDDHPPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspDDDHPxPT or wspDDDHPSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  19. Derivate of density on pressure with constant enthalpy of water/steam [sec2/m2] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspDDDPHPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – derivate of density on pressure with constant enthalpy of water/steam [sec2/m2], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  20. Derivate of density on pressure with constant enthalpy of water/steam [sec2/m2] as function of pressure p [Pa], temperature t [K]:

    wspDDDPHPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – derivate of density on pressure with constant enthalpy of water/steam [sec2/m2], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspDDDPHxPT) is used.

  21. Derivate of density on pressure with constant enthalpy of water/steam [sec2/m2] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspDDDPHPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – derivate of density on pressure with constant enthalpy of water/steam [sec2/m2], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspDDDPHxPT or wspDDDPHSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  22. Density [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspDPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – density [kg/m3], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspDxPT) is used.

  23. Density [kg/m3] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspDPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – density [kg/m3], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspDxPT or wspDSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  24. Dynamic viscosity at the end of expansion/compression process [Pa·sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspDYNVISEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – dynamic viscosity at the end of expansion/compression process [Pa·sec], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  25. Dynamic viscosity at the end of expansion/compression process [Pa·sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspDYNVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – dynamic viscosity at the end of expansion/compression process [Pa·sec], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  26. Dynamic viscosity [Pa·sec] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspDYNVISHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – dynamic viscosity [Pa·sec], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  27. Dynamic viscosity [Pa·sec] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspDYNVISPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – dynamic viscosity [Pa·sec], type: double.

    The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspDYNVISPT or wspDYNVISSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  28. Dynamic viscosity [Pa·sec] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspDYNVISPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – dynamic viscosity [Pa·sec], type: double.

    The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspDYNVISPT or wspDYNVISSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  29. Dynamic viscosity [Pa·sec] as function of pressure p [Pa], temperature t [K]:

    wspDYNVISPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – dynamic viscosity [Pa·sec], type: double.

    The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspDYNVISRT is used for calculation the argument of which is density defined by reverse value of the function wspVPT.

  30. Dynamic viscosity [Pa·sec] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspDYNVISPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – dynamic viscosity [Pa·sec], type: double.

    The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspDYNVISPT or wspDYNVISSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  31. Specific enthalpy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspHEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific enthalpy at the end of expansion/compression process [J/kg], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  32. Specific enthalpy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspHEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific enthalpy at the end of expansion/compression process [J/kg], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  33. Specific enthalpy [J/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspHPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific enthalpy [J/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspHxPT or wspHSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  34. Specific enthalpy [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspHPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific enthalpy [J/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspHxPT) is used.

  35. Specific enthalpy [J/kg] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspHPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific enthalpy [J/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspHxPT or wspHSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  36. Joule-Thomson coefficient at the end of expansion/compression process [K/Pa] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspJOULETHOMPSONEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – Joule-Thomson coefficient at the end of expansion/compression process [K/Pa], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  37. Joule-Thomson coefficient at the end of expansion/compression process [K/Pa] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspJOULETHOMPSONEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – Joule-Thomson coefficient at the end of expansion/compression process [K/Pa], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  38. Joule-Thomson coefficient [K/Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspJOULETHOMPSONHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – Joule-Thomson coefficient [K/Pa], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  39. Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspJOULETHOMPSONPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – Joule-Thomson coefficient [K/Pa], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspJOULETHOMPSONPT or wspJOULETHOMPSONSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  40. Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspJOULETHOMPSONPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – Joule-Thomson coefficient [K/Pa], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspJOULETHOMPSONPT or wspJOULETHOMPSONSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  41. Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSONPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – Joule-Thomson coefficient [K/Pa], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspJOULETHOMPSONxPT) is used.

  42. Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspJOULETHOMPSONPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – Joule-Thomson coefficient [K/Pa], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspJOULETHOMPSONPT or wspJOULETHOMPSONSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  43. Isoentropic exponent at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspKEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – isoentropic exponent at the end of expansion/compression process [-], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  44. Isoentropic exponent [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspKEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – isoentropic exponent [-], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  45. Isoentropic exponent [-] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspKHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – isoentropic exponent [-], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  46. Kinematic viscosity at the end of expansion/compression process [m2/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspKINVISEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – kinematic viscosity at the end of expansion/compression process [m2/sec], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  47. Kinematic viscosity at the end of expansion/compression process [m2/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspKINVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – kinematic viscosity at the end of expansion/compression process [m2/sec], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  48. Kinematic viscosity [m2/sec] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspKINVISHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – kinematic viscosity [m2/sec], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  49. Kinematic viscosity [m2/sec] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspKINVISPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – kinematic viscosity [m2/sec], type: double.

    The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspKINVISPT or wspKINVISSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  50. Kinematic viscosity [m2/sec] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspKINVISPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – kinematic viscosity [m2/sec], type: double.

    The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspKINVISPT or wspKINVISSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  51. Kinematic viscosity [m2/sec] as function of pressure p [Pa], temperature t [K]:

    wspKINVISPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – kinematic viscosity [m2/sec], type: double.

    The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The equation is: KINVIS = DYNVIS · V is used for calculation, where DYNVIS defined by the function wspDYNVISPT and V - by wspVPT.

  52. Kinematic viscosity [m2/sec] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspKINVISPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – kinematic viscosity [m2/sec], type: double.

    The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspKINVISPT or wspKINVISSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  53. Isoentropic exponent [-] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspKPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – isoentropic exponent [-], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspKPT or wspKSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  54. Isoentropic exponent [-] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspKPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – isoentropic exponent [-], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspKPT or wspKSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  55. Isoentropic exponent [-] as function of pressure p [Pa], temperature t [K]:

    wspKPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – isoentropic exponent [-], type: double.

    The range of the validity is within that described in IF-97. Used equation is: K = W · W / (P · V) is used for calculation, where W (sound velocity) is defined by the function wspWPT, P - pressure and V (specific volume) - by wspVPT.

  56. Isoentropic exponent [-] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspKPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – isoentropic exponent [-], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspKPT or wspKSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  57. Pressure [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – pressure [Pa], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  58. Negative logarithm (base 10) of the ionization constant of water [-] as function of pressure p [Pa], temperature t [K]:

    wspPKWPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – negative logarithm (base 10) of the ionization constant of water [-], type: double.

    Function is based upon the function wspPKWRT(r, t). The latest in it's turn based upon the "Release on the Ionization Constant of H2O, August 2007" from IAPWS.

  59. Prandtl number at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspPRANDTLEEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – Prandtl number at the end of expansion/compression process [-], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  60. Prandtl number at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspPRANDTLEEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – Prandtl number at the end of expansion/compression process [-], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  61. Prandtl number [-] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPRANDTLEHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – Prandtl number [-], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  62. Prandtl number [-] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspPRANDTLEPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – Prandtl number [-], type: double.

    The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspPRANDTLEPT or wspPRANDTLESTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  63. Prandtl number [-] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspPRANDTLEPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – Prandtl number [-], type: double.

    The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspPRANDTLEPT or wspPRANDLTESTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  64. Prandtl number [-] as function of pressure p [Pa], temperature t [K]:

    wspPRANDTLEPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – Prandtl number [-], type: double.

    The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity. The equation is: Pr = DYNVIS · CP / THERMCOND is used for calculation, where DYNVIS is calculated by the function wspDYNVISPT, CP - by wspCPPT and THERMCOND - by wspTHERMCONDPT.

  65. Prandtl number [-] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspPRANDTLEPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – Prandtl number [-], type: double.

    The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspPRANDTLEPPT or wspPRANDTLEPSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  66. Properties calculation result as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPTHS(h, s, *p, *t)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • p – pressure [Pa], type: double. Warning! It's output parameter;
    • t – temperature [K], type: double. Warning! It's output parameter;
    • Return value – properties calculation result, type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantities are calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  67. Refractive index [-] as function of pressure p [Pa], temperature t [K], wave length wavelength [m]:

    wspRIPTL(p, t, wavelength)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • wavelength – wave length [m], type: double;
    • Return value – refractive index [-], type: double.

    Function is based upon the function wspRIRTL(r, t, wavelength). The latest in it's turn is based upon the "Release on the Refractive Index of Ordinary Water Substance as a Function of Wavelength, Temperature and Pressure", 1997 from IAPWS. The range of validity is: temperatures from -12 to 500°C, densities up to 1060 kg/m3, wavelengths from 0.2 mkm to 1.1 mkm. The formulation also extrapolates smoothly up to 1.9 mkm in water.

  68. Specific entropy at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspSEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific entropy at the end of expansion/compression process [J/(kg·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  69. Specific entropy at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspSEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific entropy at the end of expansion/compression process [J/(kg·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  70. Specific entropy [J/(kg·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspSPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – specific entropy [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspSPTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  71. Specific entropy [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific entropy [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspSxPT) is used.

  72. Specific entropy [J/(kg·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspSPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific entropy [J/(kg·K)], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspSxPT or wspSSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  73. Surface tension [N/m] as function of temperature t [K]:

    wspSURFTENT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – surface tension [N/m], type: double.

    The function is based on the IAPWS Release on The Surface Tension of Ordinary Water Substance 1995. The range of validity is from triple point (273.16K or 0.01°C) to 647.096 K.

  74. Temperature at the end of expansion/compression process [K] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspTEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – temperature at the end of expansion/compression process [K], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  75. Temperature at the end of expansion/compression process [K] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspTEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – temperature at the end of expansion/compression process [K], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  76. Thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspTHERMCONDEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  77. Thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspTHERMCONDEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  78. Thermal conductivity coefficient [W/(m·K)] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTHERMCONDHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

    It is a function. The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  79. Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspTHERMCONDPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

    The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspTHERMCONDPT or wspTHERMCONDSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  80. Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspTHERMCONDPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

    The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspTHERMCONDPT or wspTHERMCONDSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  81. Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], temperature t [K]:

    wspTHERMCONDPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

    The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). The function wspTHERMCONDRT is used for calculation the argument of which is density defined by the reverse value of function wspVPT.

  82. Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspTHERMCONDPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

    The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspTHERMCONDPT or wspTHERMCONDSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  83. Temperature [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature [K], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  84. Temperature [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspTPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature [K], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  85. Temperature [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspTPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature [K], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  86. Specific internal energy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspUEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific internal energy at the end of expansion/compression process [J/kg], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  87. Specific internal energy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspUEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific internal energy at the end of expansion/compression process [J/kg], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), w- specific enthalpy in initial point, h1 - specific enthalpy in final point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in final point with isoentropic expansion (s = Const). For the calculating the process of compression you must to use instead the efficiency eff the inverse number (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  88. Specific internal energy [J/kg] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspUHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific internal energy [J/kg], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  89. Specific internal energy [J/kg] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspUPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – specific internal energy [J/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspUxPT or wspUSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  90. Specific internal energy [J/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspUPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific internal energy [J/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspUxPT or wspUSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  91. Specific internal energy [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspUPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific internal energy [J/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspUxPT) is used.

  92. Specific internal energy [J/kg] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspUPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific internal energy [J/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspUxPT or wspUSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  93. Specific volume at the end of expansion/compression process [m3/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspVEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific volume at the end of expansion/compression process [m3/kg], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  94. Specific volume at the end of expansion/compression process [m3/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – specific volume at the end of expansion/compression process [m3/kg], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  95. Specific volume [m3/kg] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspVHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific volume [m3/kg], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  96. Specific volume [m3/kg] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspVPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – specific volume [m3/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspVPTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  97. Specific volume [m3/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspVPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific volume [m3/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspVxPT or wspVPTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  98. Specific volume [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspVPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific volume [m3/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspVxPT) is used.

  99. Specific volume [m3/kg] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspVPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific volume [m3/kg], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspVxPT or wspVSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  100. Properties calculation result as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPTPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
    • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
    • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
    • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
    • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
    • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
    • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
    • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
    • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
    • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • Return value – properties calculation result, type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspVUSHDERPTxPT) is used to return the set of properties and so speed up calculation of several values in one point.

    Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  101. Sound velocity at the end of expansion/compression process [m/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspWEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – sound velocity at the end of expansion/compression process [m/sec], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  102. Sound velocity at the end of expansion/compression process [m/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspWEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – sound velocity at the end of expansion/compression process [m/sec], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  103. Speed of sound [m/sec] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspWHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – speed of sound [m/sec], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  104. Speed of sound [m/sec] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspWPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – speed of sound [m/sec], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspWxPT or wspWSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  105. Speed of sound [m/sec] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspWPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – speed of sound [m/sec], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspWxPT or wspWSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  106. Speed of sound [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspWPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – speed of sound [m/sec], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspWxPT) is used.

  107. Speed of sound [m/sec] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspWPTX(p, t, x)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – speed of sound [m/sec], type: double.

    The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspWxPT or wspWSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.

  108. Vapor fraction at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspXEXPANSIONPTPEFF(p0, t0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – vapor fraction at the end of expansion/compression process [-], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  109. Vapor fraction at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspXEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    where:

    • p0 – pressure at initial point [Pa], type: double;
    • t0 – temperature at initial point [K], type: double;
    • x0 – vapor fraction at initial point [-], type: double;
    • p1 – pressure at final point [Pa], type: double;
    • eff – internal efficiency of process [-], type: double;
    • Return value – vapor fraction at the end of expansion/compression process [-], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  110. Vapor fraction [-] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspXHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – vapor fraction [-], type: double.

    It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  111. Vapor fraction [-] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspXPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – vapor fraction [-], type: double.

    It is a function. The range of the validity is within that described in IF-97. The IF-97 region is determined for given p and h (by function wspWATERSTATEAREAPH). If the region is double-phase the sought parameter is calculated. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  112. Vapor fraction [-] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspXPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – vapor fraction [-], type: double.

    It is a function. The range of the validity is within that described in IF-97. The IF-97 region is determined for given p and s (by function wspWATERSTATEAREAPS). If the region is double-phase the sought parameter is calculated. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    113. Category: Saturation Line

    Functions for calculation properties at saturation line for water and vapor.

  113. Specific isobaric heat capacity of steam at saturation line [J/(kg·K)] as function of temperature t [K]:

    wspCPSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity of steam at saturation line [J/(kg·K)], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  114. Specific isobaric heat capacity of water at saturation line [J/(kg·K)] as function of temperature t [K]:

    wspCPSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity of water at saturation line [J/(kg·K)], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  115. Specific isochoric heat capacity of steam at saturation line from the double-phase region [J/(kg·K)] as function of temperature t [K]:

    wspCVDPSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity of steam at saturation line from the double-phase region [J/(kg·K)], type: double.

    Function returns the sum of specific isochoric heat capacity of steam from one-phase region (function wspCVSST) and additional increment calculated by corresponding thermodynamic formulas. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  116. Specific isochoric heat capacity of water at saturation line from the double-phase region [J/(kg·K)] as function of temperature t [K]:

    wspCVDPSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity of water at saturation line from the double-phase region [J/(kg·K)], type: double.

    Function returns the sum of specific isochoric heat capacity of water from one-phase region (function wspCVSWT) and additional increment calculated by corresponding thermodynamic formulas. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  117. Specific isochoric heat capacity of steam at saturation line from the one-phase region [J/(kg·K)] as function of temperature t [K]:

    wspCVSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity of steam at saturation line from the one-phase region [J/(kg·K)], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  118. Specific isochoric heat capacity of water at saturation line from the one-phase region [J/(kg·K)] as function of temperature t [K]:

    wspCVSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity of water at saturation line from the one-phase region [J/(kg·K)], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  119. Derivate of density on enthalpy with constant pressure of steam at saturation line [kg·sec2/m5] as function of temperature t [K]:

    wspDDDHPSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – derivate of density on enthalpy with constant pressure of steam at saturation line [kg·sec2/m5], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  120. Derivate of density on enthalpy with constant pressure of water at saturation line [kg·sec2/m5] as function of temperature t [K]:

    wspDDDHPSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – derivate of density on enthalpy with constant pressure of water at saturation line [kg·sec2/m5], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  121. Derivate of density on pressure with constant enthalpy of steam at saturation line [sec2/m2] as function of temperature t [K]:

    wspDDDPHSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – derivate of density on pressure with constant enthalpy of steam at saturation line [sec2/m2], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  122. Derivate of density on pressure with constant enthalpy of water at saturation line [sec2/m2] as function of temperature t [K]:

    wspDDDPHSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – derivate of density on pressure with constant enthalpy of water at saturation line [sec2/m2], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  123. Derivative of saturation pressure on saturation temperature [Pa/K] as function of temperature t [K]:

    wspDPDTST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – derivative of saturation pressure on saturation temperature [Pa/K], type: double.

    Function is based upon "Supplementary Release on Saturation Properties of Ordinary Water Substance" from International Association for the Properties of Water and Steam. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  124. Density of steam at saturation line [kg/m3] as function of temperature t [K]:

    wspDSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – density of steam at saturation line [kg/m3], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  125. Density of water at saturation line [kg/m3] as function of temperature t [K]:

    wspDSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – density of water at saturation line [kg/m3], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  126. Dynamic viscosity of steam at saturation line [Pa·sec] as function of temperature t [K]:

    wspDYNVISSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – dynamic viscosity of steam at saturation line [Pa·sec], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  127. Dynamic viscosity of water at saturation line [Pa·sec] as function of temperature t [K]:

    wspDYNVISSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – dynamic viscosity of water at saturation line [Pa·sec], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  128. Specific enthalpy of steam at saturation line [J/kg] as function of temperature t [K]:

    wspHSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific enthalpy of steam at saturation line [J/kg], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  129. Specific enthalpy of water at saturation line [J/kg] as function of temperature t [K]:

    wspHSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific enthalpy of water at saturation line [J/kg], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  130. Joule-Thomson coefficient of steam at saturation line [K/Pa] as function of temperature t [K]:

    wspJOULETHOMPSONSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – Joule-Thomson coefficient of steam at saturation line [K/Pa], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  131. Joule-Thomson coefficient of water at saturation line [K/Pa] as function of temperature t [K]:

    wspJOULETHOMPSONSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – Joule-Thomson coefficient of water at saturation line [K/Pa], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  132. Kinematic viscosity of steam at saturation line [m2/sec] as function of temperature t [K]:

    wspKINVISSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – kinematic viscosity of steam at saturation line [m2/sec], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  133. Kinematic viscosity of water at saturation line [m2/sec] as function of temperature t [K]:

    wspKINVISSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – kinematic viscosity of water at saturation line [m2/sec], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  134. Isoentropic exponent of steam at saturation line [-] as function of temperature t [K]:

    wspKSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – isoentropic exponent of steam at saturation line [-], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  135. Isoentropic exponent of water at saturation line [-] as function of temperature t [K]:

    wspKSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – isoentropic exponent of water at saturation line [-], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  136. Prandtl number of steam at saturation line [-] as function of temperature t [K]:

    wspPRANDTLESST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – Prandtl number of steam at saturation line [-], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  137. Prandtl number of water at saturation line [-] as function of temperature t [K]:

    wspPRANDTLESWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – Prandtl number of water at saturation line [-], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  138. Pressure at saturation line [Pa] as function of temperature t [K]:

    wspPST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – pressure at saturation line [Pa], type: double.

    Function is based upon the Supplementary Release on Saturation Properties of Ordinary Water Substance from IAPWS. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  139. Specific enthalpy of steam at saturation line [J/kg] as function of specific entropy s [J/(kg·K)]:

    wspROUGHHSSS(s)

    where:

    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific enthalpy of steam at saturation line [J/kg], type: double.

    Function uses the special equation from Supplementory Release for IF-97 Formulation. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  140. Specific enthalpy of water at saturation line [J/kg] as function of specific entropy s [J/(kg·K)]:

    wspROUGHHSWS(s)

    where:

    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific enthalpy of water at saturation line [J/kg], type: double.

    Function uses the special equation from Supplementory Release for IF-97 Formulation. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  141. Rough value of density of steam at saturation line [kg/m3] as function of temperature t [K]:

    wspROUGHRSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – rough value of density of steam at saturation line [kg/m3], type: double.

    This function allows to calculate quickly rough value of steam density at saturation line. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  142. Rough value of density of water at saturation line [kg/m3] as function of temperature t [K]:

    wspROUGHRSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – rough value of density of water at saturation line [kg/m3], type: double.

    This function allows to calculate quickly rough value of steam density at saturation line. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  143. Specific evaporation heat [J/kg] as function of temperature t [K]:

    wspRST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific evaporation heat [J/kg], type: double.

    The result of function is calculated by formula r = (hs - hw), where hs - specific enthalpy of steam at saturation line, hw - specific enthalpy of water at saturation line. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  144. Specific entropy of steam at saturation line [J/(kg·K)] as function of temperature t [K]:

    wspSSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific entropy of steam at saturation line [J/(kg·K)], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  145. Specific entropy of water at saturation line [J/(kg·K)] as function of temperature t [K]:

    wspSSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific entropy of water at saturation line [J/(kg·K)], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  146. Thermal conductivity coefficient of steam at saturation line [W/(m·K)] as function of temperature t [K]:

    wspTHERMCONDSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – thermal conductivity coefficient of steam at saturation line [W/(m·K)], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  147. Thermal conductivity coefficient of water at saturation line [W/(m·K)] as function of temperature t [K]:

    wspTHERMCONDSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – thermal conductivity coefficient of water at saturation line [W/(m·K)], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  148. Temperature at saturation line [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTSHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature at saturation line [K], type: double.

    Function calculates saturation temperature on a base of thermodunamic formulas. Newton method is used to determine the root. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  149. Temperature at saturation line [K] as function of pressure p [Pa]:

    wspTSP(p)

    where:

    • p – pressure [Pa], type: double;
    • Return value – temperature at saturation line [K], type: double.

    Function is based upon the Supplementary Release on Saturation Properties of Ordinary Water Substance from IAPWS. The range of validity is from triple point of water (0.01°C or 611.657 Pa) to critical point (647.096K or 373.946°C or 22.064 MPa).

  150. Specific internal energy of steam at saturation line [J/kg] as function of temperature t [K]:

    wspUSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific internal energy of steam at saturation line [J/kg], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  151. Specific internal energy of water at saturation line [J/kg] as function of temperature t [K]:

    wspUSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific internal energy of water at saturation line [J/kg], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  152. Specific volume of steam at saturation line [m3/kg] as function of temperature t [K]:

    wspVSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific volume of steam at saturation line [m3/kg], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  153. Specific volume of water at saturation line [m3/kg] as function of temperature t [K]:

    wspVSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – specific volume of water at saturation line [m3/kg], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  154. Properties calculation result for steam at saturation line as function of temperature t [K]:

    wspVUSHCVWDERPTSST(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    where:

    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
    • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
    • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
    • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
    • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
    • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
    • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
    • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
    • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
    • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • Return value – properties calculation result for steam at saturation line, type: double.

    The function is based upon IF-97 formulation. It returns the property set that speed up calculation considerably. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

    Note: In Mathcad the function have only parameters (t) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  155. Properties calculation result for water at saturation line as function of temperature t [K]:

    wspVUSHCVWDERPTSWT(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    where:

    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
    • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
    • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
    • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
    • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
    • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
    • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
    • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
    • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
    • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • Return value – properties calculation result for water at saturation line, type: double.

    The function is based upon IF-97 formulation. It returns the property set that speed up calculation considerably. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

    Note: In Mathcad the function have only parameters (t) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  156. Sound velocity in steam at saturation line [m/sec] as function of temperature t [K]:

    wspWSST(t)

    where:

    • t – temperature [K], type: double;
    • Return value – sound velocity in steam at saturation line [m/sec], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

  157. Sound velocity in water at saturation line [m/sec] as function of temperature t [K]:

    wspWSWT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – sound velocity in water at saturation line [m/sec], type: double.

    The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

    158. Category: Double-phase area

    Functions for calculation properties in double-phase area: water-vapor.

  158. Specific isobaric heat capacity in double-phase area [J/(kg·K)] as function of temperature t [K], vapor fraction x [-]:

    wspCPSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific isobaric heat capacity in double-phase area [J/(kg·K)], type: double.

    Function uses functions wspCPSST and wspCPSWT which return specific heat capacities at constant pressure (Cp) of steam and water at saturation line. The function uses following formula: CPx = (1 - X)·CPw + X·CPs, where CPs = wspCPSST, CPw = wspCPSWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.

  159. Specific isochoric heat capacity in double-phase area [J/(kg·K)] as function of temperature t [K], vapor fraction x [-]:

    wspCVSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific isochoric heat capacity in double-phase area [J/(kg·K)], type: double.

    Function uses functions wspCVDPSST and wspCVDPSWT which return specific heat capacities at constant volume (Cv) of steam and water at saturation line in the double-phase region area. The function uses following formula: CVx = (1 - X)·CVDPw + X·CVDPs, where CVDPs = wspCVDPSST, CVDPw = wspCVDPSWT and X - vapor fraction. This function used functions wspCVSST and wspCVSWT until version 5.6 which is not conform to thermodynamic, because it neglects the jump of properties at saturation line. The range of validity is double-phase (water-vapor) area.

  160. Density in double-phase area [kg/m3] as function of temperature t [K], vapor fraction x [-]:

    wspDSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – density in double-phase area [kg/m3], type: double.

    Function uses the function named wspVSTX which return specific volume in double-phase area. The function uses following formula: Dx = 1 / Vx, where Vx = wspVSTX(t, x). The range of validity is double-phase (water-vapor) area.

  161. Dynamic viscosity in double-phase area [Pa·sec] as function of temperature t [K], vapor fraction x [-]:

    wspDYNVISSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – dynamic viscosity in double-phase area [Pa·sec], type: double.

    Function uses functions wspDYNVISSST and wspDYNVISSWT which return dynamic viscosity of steam and water at saturation line. The function uses following formula: DYNVISx = (1 - X)·DYNVISw + X·DYNVISs, where DYNVISs = wspDYNVISSST, DYNVISw = wspDYNVISSWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.

  162. Specific enthalpy in double-phase area [J/kg] as function of temperature t [K], vapor fraction x [-]:

    wspHSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific enthalpy in double-phase area [J/kg], type: double.

    Function uses functions wspHSST and wspHSWT which return specific enthalpies of steam and water at saturation line. The function uses following formula: Hx = (1 - X)·Hw + X·Hs, where Hs = wspHSST, Hw = wspHSWT and X - vapor fraction. The range of validity is double-phase (water-vapor) area.

  163. Joule-Thomson coefficient in double-phase area [K/Pa] as function of temperature t [K], vapor fraction x [-]:

    wspJOULETHOMPSONSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – Joule-Thomson coefficient in double-phase area [K/Pa], type: double.

    Function calculate the Joule-Thomson coefficient in double-phase area by equation at saturation line: JT = (dT/dP)h. Until version 5.6 the function used wspJOULETHOMPSONSST and wspJOULETHOMPSONSWT and returned value from following formula: JTx = (1 - X)·JOULETHOMPSONw + X·JOULETHOMPSONs, where JOULETHOMPSONs = wspJOULETHOMPSONSST, JOULETHOMPSONw = wspJOULETHOMPSONSWT and X - vapor vapor fraction that did not conform to definition of Joule-Thomson coefficient. Now it calculates correctly. The range of validity is double-phase (water-vapor) area.

  164. Kinematic viscosity in double-phase area [m2/sec] as function of temperature t [K], vapor fraction x [-]:

    wspKINVISSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – kinematic viscosity in double-phase area [m2/sec], type: double.

    Function uses functions wspKINVISSST and wspKINVISSWT which return kinematic viscosities of steam and water at saturation line. The function uses next formula: KINVISx = (1 - X)·KINVISw + X·KINVISs, where KINVISs = wspKINVISSST, KINVISw = wspKINVISSWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.

  165. Isoentropic exponent in double-phase area [-] as function of temperature t [K], vapor fraction x [-]:

    wspKSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – isoentropic exponent in double-phase area [-], type: double.

    Function calculate isoentropic exponent in double-phase area considering property jump at saturation line. Until version 5.6 this function uses following formula: Kx = (1 - X)·Kw + X·Ks, where Ks = wspKSST, Kw = wspKSWT and X - vapor fraction. But that is not agree with thermodynamic. Now it is calculated properly. The range of validity is double-phase (water-vapor) area.

  166. Prandtl number in double-phase area [-] as function of temperature t [K], vapor fraction x [-]:

    wspPRANDTLESTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – Prandtl number in double-phase area [-], type: double.

    Function uses functions wspPRANDTLESST and wspPRANDTLESWT which returns Prandtl numbers of steam and water at saturation line. The function uses following formula: PRANDTLEx = (1 - X)·PRANDTLEw + X·PRANDTLEs, where PRANDTLEs = wspPRANDTLESST, PRANDTLEw = wspPRANDTLESWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.

  167. Specific entropy in double-phase area [J/(kg·K)] as function of temperature t [K], vapor fraction x [-]:

    wspSSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific entropy in double-phase area [J/(kg·K)], type: double.

    Function uses functions wspSSST and wspSSWT which return specific entropies of steam and water at saturation line. The function uses following formula: Sx = (1 - X)·Sw + X·Ss, where Ss = wspSSST, Sw = wspSSWT and X - vapor fraction. The range of validity is double-phase (water-vapor) area.

  168. Thermal conductivity coefficient in double-phase area [W/(m·K)] as function of temperature t [K], vapor fraction x [-]:

    wspTHERMCONDSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – thermal conductivity coefficient in double-phase area [W/(m·K)], type: double.

    Function uses functions wspTHERMCONDSST and wspTHERMCONDSWT which return thermal conductivity of steam and water at saturation line. The function uses following formula: THERMCONDx = (1 - X)·THERMCONDw + X·THERMCONDs, where THERMCONDs = wspTHERMCONDSST, THERMCONDw = wspTHERMCONDSWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.

  169. Properties calculation result in double-phase area as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTXSHS(h, s, *t, *x)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • t – saturation temperature [K], type: double. Warning! It's output parameter;
    • x – vapor fraction [-], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in double-phase area, type: double.

    Function calculates saturation temperature and vapor fraction on the base of thermodunamic formulas. Newton method is used to determine the root. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE). The range of validity is double-phase (water-vapor) area.

    Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  170. Specific internal energy in double-phase area [J/kg] as function of temperature t [K], vapor fraction x [-]:

    wspUSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific internal energy in double-phase area [J/kg], type: double.

    Function uses functions wspUSST and wspUSWT which return specific internal energies of steam and water at saturation line. The function uses following formula: Ux = (1 - X)·Uw + X·Us, where Us = wspUSST, Uw = wspUSWT and X - vapor fraction. The range of validity is double-phase (water-vapor) area.

  171. Specific volume in double-phase area [m3/kg] as function of temperature t [K], vapor fraction x [-]:

    wspVSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – specific volume in double-phase area [m3/kg], type: double.

    Function uses the functions wspVSST and wspVSWT which return specific volumes of steam and water at saturation line. The function uses following formula: Vx = (1 - X)·Vw + X·Vs, where Vs = wspVSST, Vw = wspVSWT and X - vapor fraction. The range of validity is double-phase (water-vapor) area.

  172. Sound velocity in double-phase area [m/sec] as function of temperature t [K], vapor fraction x [-]:

    wspWSTX(t, x)

    where:

    • t – temperature [K], type: double;
    • x – vapor fraction [-], type: double;
    • Return value – sound velocity in double-phase area [m/sec], type: double.

    Function uses function wspKSTX to calculate sound velocity in double-phase area conforming with thermodynamic. The function neglects the flow structure. Until version 5.6 this function used following formula: Wx = (1 - X)·Ww + X·Ws, where Ws = wspWSST, Ww = wspWSWT and X - vapor fraction, which disagrees with thermodynamic because it neglects the property jump at saturation line. The range of validity is double-phase (water-vapor) area.

  173. Vapor fraction [-] as function of temperature t [K], specific isobaric heat capacity Cp [J/(kg·K)]:

    wspXSTCP(t, Cp)

    where:

    • t – temperature [K], type: double;
    • Cp – specific isobaric heat capacity [J/(kg·K)], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (CP - CPw)/(CPs - CPw), where CPw = wspCPSWT, CPs = wspCPSST. The range of calculation is double-phase (water-vapor) area.

  174. Vapor fraction [-] as function of temperature t [K], specific isochoric heat capacity Cv [J/(kg·K)]:

    wspXSTCV(t, Cv)

    where:

    • t – temperature [K], type: double;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (CV - CVDPw)/(CVDPs - CVDPw), where CVDPw = wspCVDPSWT, CVDPs = wspCVDPSST. The range of validity is double-phase (water-vapor) area.

  175. Vapor fraction [-] as function of temperature t [K], density r [kg/m3]:

    wspXSTD(t, r)

    where:

    • t – temperature [K], type: double;
    • r – density [kg/m3], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = rs * (rw - r) / (r * (rw - rs)), where rw = wspDSWT, rs = wspDSST. The range of validity is double-phase (water-vapor) area.

  176. Vapor fraction [-] as function of temperature t [K], dynamic viscosity dv [Pa·sec]:

    wspXSTDYNVIS(t, dv)

    where:

    • t – temperature [K], type: double;
    • dv – dynamic viscosity [Pa·sec], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (DV - DVw)/(DVs - DVw), where DVw = wspDYNVISSWT, DVs = wspDYNVISSST. The range of calculation is double-phase (water-vapor) area.

  177. Vapor fraction [-] as function of temperature t [K], specific enthalpy h [J/kg]:

    wspXSTH(t, h)

    where:

    • t – temperature [K], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (H - Hw)/(Hs - Hw), where Hw = wspHSWT, Hs = wspHSST. The range of validity is double-phase (water-vapor) area.

  178. Vapor fraction [-] as function of temperature t [K], Joule-Thomson coefficient jt [K/Pa]:

    wspXSTJOULETHOMPSON(t, jt)

    where:

    • t – temperature [K], type: double;
    • jt – Joule-Thomson coefficient [K/Pa], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (JOULETHOMPSON - JOULETHOMPSONw)/(JOULETHOMPSONs - JOULETHOMPSONw), where JOULETHOMPSONw = wspJOULETHOMPSONSWT, JOULETHOMPSONs = wspJOULETHOMPSONSST. The range of validity is double-phase (water-vapor) area.

  179. Vapor fraction [-] as function of temperature t [K], isoentropic exponent k [-]:

    wspXSTK(t, k)

    where:

    • t – temperature [K], type: double;
    • k – isoentropic exponent [-], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (K - Kw)/(Ks - Kw), where Kw = wspKSWT, Ks = wspKSST. The range of validity is double-phase (water-vapor) area.

  180. Vapor fraction [-] as function of temperature t [K], kinematic viscosity kv [m2/sec]:

    wspXSTKINVIS(t, kv)

    where:

    • t – temperature [K], type: double;
    • kv – kinematic viscosity [m2/sec], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (KV - KVw)/(KVs - KVw), where KVw = wspKINVISSWT, KVs = wspKINVISSST. The range of calculation is double-phase (water-vapor) area.

  181. Vapor fraction [-] as function of temperature t [K], Prandtl number pr [-]:

    wspXSTPRANDTLE(t, pr)

    where:

    • t – temperature [K], type: double;
    • pr – Prandtl number [-], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (PR - PRw)/(PRs - PRw), where PRw = wspPRANDTLESWT, PRs = wspPRANDTLESST. The range of calculation is double-phase (water-vapor) area.

  182. Vapor fraction [-] as function of temperature t [K], specific entropy s [J/(kg·K)]:

    wspXSTS(t, s)

    where:

    • t – temperature [K], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (S - Sw)/(Ss - Sw), where Sw = wspSSWT, Ss = wspSSST. The range of validity is double-phase (water-vapor) area.

  183. Vapor fraction [-] as function of temperature t [K], thermal conductivity coefficient tc [W/(m·K)]:

    wspXSTTHERMCOND(t, tc)

    where:

    • t – temperature [K], type: double;
    • tc – thermal conductivity coefficient [W/(m·K)], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (TC - TCw)/(TCs - TCw), where TCw = wspTHERMCONDSWT, TCs = wspTHERMCONDSST. The range of calculation is double-phase (water-vapor) area.

  184. Vapor fraction [-] as function of temperature t [K], specific internal energy u [J/kg]:

    wspXSTU(t, u)

    where:

    • t – temperature [K], type: double;
    • u – specific internal energy [J/kg], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (U - Uw)/(Us - Uw), where Uw = wspUSWT, Us = wspUSST. The range of validity is double-phase (water-vapor) area.

  185. Vapor fraction [-] as function of temperature t [K], specific volume v [m3/kg]:

    wspXSTV(t, v)

    where:

    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double;
    • Return value – vapor fraction [-], type: double.

    This function uses formula: X = (V - Vw)/(Vs - Vw), where Vw = wspVSWT, Vs = wspVSST. The range of validity is double-phase (water-vapor) area.

  186. Vapor fraction [-] as function of temperature t [K], speed of sound w [m/sec]:

    wspXSTW(t, w)

    where:

    • t – temperature [K], type: double;
    • w – speed of sound [m/sec], type: double;
    • Return value – vapor fraction [-], type: double.

    From version 5.6 this function calculates value of sound velocity in double-phase region from isoentropic exponent that is conform to thermodynamic. Until version 5.6 this function used formula: X = (W - Ww)/(Ws - Ww), where Ww = wspWSWT, Ws = wspWSST which was not right. Now it is calculated correctly. The range of validity is double-phase (water-vapor) area.

    187. Category: Sublimation and Melting Lines

    Functions for calculation properties at sublimation and melting lines.

  187. Pressure at melting line of ice I [Pa] as function of temperature t [K]:

    wspPMELTIT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – pressure at melting line of ice I [Pa], type: double.

    Function is based on "Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance" IAPWS (Milan, Italy, September 1993).

  188. Pressure at sublimation line [Pa] as function of temperature t [K]:

    wspPSUBT(t)

    where:

    • t – temperature [K], type: double;
    • Return value – pressure at sublimation line [Pa], type: double.

    Function is based on "Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance" IAPWS (Milan, Italy, September 1993).

    189. Category: MetaStable

    Functions for calculation properties of meta-stable supercooled steam

  189. Specific isobaric heat capacity of meta-stable supercooled steam [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCPMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity of meta-stable supercooled steam [J/(kg·K)], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  190. Specific isochoric heat capacity of meta-stable supercooled steam [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCVMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity of meta-stable supercooled steam [J/(kg·K)], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  191. Dynamic viscosity of meta-stable supercooled steam [Pa·sec] as function of pressure p [Pa], temperature t [K]:

    wspDYNVISMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – dynamic viscosity of meta-stable supercooled steam [Pa·sec], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  192. Specific enthalpy of meta-stable supercooled steam [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspHMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific enthalpy of meta-stable supercooled steam [J/kg], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  193. Joule-Thomson coefficient of meta-stable supercooled steam [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSONMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – Joule-Thomson coefficient of meta-stable supercooled steam [K/Pa], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  194. Kinematic viscosity of meta-stable supercooled steam [m2/sec] as function of pressure p [Pa], temperature t [K]:

    wspKINVISMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – kinematic viscosity of meta-stable supercooled steam [m2/sec], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  195. Isoentropic exponent of meta-stable supercooled steam [-] as function of pressure p [Pa], temperature t [K]:

    wspKMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – isoentropic exponent of meta-stable supercooled steam [-], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  196. Prandtl number of meta-stable supercooled steam [-] as function of pressure p [Pa], temperature t [K]:

    wspPRANDTLEMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – Prandtl number of meta-stable supercooled steam [-], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  197. Specific entropy of meta-stable supercooled steam [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspSMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific entropy of meta-stable supercooled steam [J/(kg·K)], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  198. Thermal conductivity coefficient of meta-stable supercooled steam [W/(m·K)] as function of pressure p [Pa], temperature t [K]:

    wspTHERMCONDMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – thermal conductivity coefficient of meta-stable supercooled steam [W/(m·K)], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  199. Specific internal energy of meta-stable supercooled steam [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspUMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific internal energy of meta-stable supercooled steam [J/kg], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  200. Specific volume of meta-stable supercooled steam [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspVMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific volume of meta-stable supercooled steam [m3/kg], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

  201. Properties calculation result of super-cooled steam (meta-stable region) as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPTMSPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
    • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
    • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
    • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
    • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
    • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
    • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
    • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
    • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
    • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • Return value – properties calculation result of super-cooled steam (meta-stable region), type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

    Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  202. Sound velocity of meta-stable supercooled steam [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspWMSPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – sound velocity of meta-stable supercooled steam [m/sec], type: double.

    This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

    203. Category: Source

    Functions from IAPWS IF-97 and other formulations.

  203. Specific isobaric heat capacity in IF-97 region 1 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCP1PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity in IF-97 region 1 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  204. Specific isobaric heat capacity in IF-97 region 2 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCP2PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity in IF-97 region 2 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  205. Specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCP3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)], type: double.

    Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  206. Specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)] as function of density r [kg/m3], temperature t [K]:

    wspCP3RT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  207. Specific isobaric heat capacity in IF-97 region 5 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCP5PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity in IF-97 region 5 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  208. Specific isochoric heat capacity in IF-97 region 1 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCV1PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity in IF-97 region 1 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  209. Specific isochoric heat capacity in IF-97 region 2 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCV2PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity in IF-97 region 2 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  210. Specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCV3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)], type: double.

    Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  211. Specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)] as function of density r [kg/m3], temperature t [K]:

    wspCV3RT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  212. Specific isochoric heat capacity in IF-97 region 5 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCV5PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity in IF-97 region 5 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  213. Density in IF-97 region 1 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspD1PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – density in IF-97 region 1 [kg/m3], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  214. Density in IF-97 region 2 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspD2PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – density in IF-97 region 2 [kg/m3], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  215. Density in IF-97 region 3 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspD3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – density in IF-97 region 3 [kg/m3], type: double.

    Function calculates the density in region 3 by calling the function wspR3PTR0 with the corresponding initial estimate for density. Used for unification of the functions in all IF-97 regions. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  216. Density in IF-97 region 5 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspD5PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – density in IF-97 region 5 [kg/m3], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  217. Static dielectric constant of ordinary water substance [-] as function of density r [kg/m3], temperature t [K]:

    wspDCRT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – static dielectric constant of ordinary water substance [-], type: double.

    Function is based upon the "Release on the Static Dielectric Constant of Ordinary Water Substance for Temperatures from 238K to 873K and Pressures up to 1000 MPa", 1997 from IAPWS. The range of validity is from 238 to 273K in the metastable liquid at atmospheric pressure (0.101325 MPa); from 273 to 323 K at pressures up to the lower of the ice IV melting pressure or 1000 MPa; above 323 K at pressures up to 600 MPa. The formulation also extrapolates smoothly up to at least 1200 K and 1200 MPa.

  218. Dynamic viscosity [Pa·sec] as function of density r [kg/m3], temperature t [K]:

    wspDYNVISRT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – dynamic viscosity [Pa·sec], type: double.

    Function is based upon the Revised Release on the IAPS Formulation 1985 for the Viscosity of Ordinary Water Substance with correction for ITS-90 (International Temperature Scale). The range of validity is for pressure up to 500 MPa temperature is from 0 to 150°C, for pressure up to 350 MPa temperature is from 150 to 600°C, for pressure up to 300 MPa temperature is from 600 to 900°C.

  219. Specific enthalpy in IF-97 region 1 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspH1PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific enthalpy in IF-97 region 1 [J/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  220. Specific enthalpy at line between areas 2b and 2c [J/kg] as function of pressure p [Pa]:

    wspH2B2CP(p)

    where:

    • p – pressure [Pa], type: double;
    • Return value – specific enthalpy at line between areas 2b and 2c [J/kg], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  221. Specific enthalpy in IF-97 region 2 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspH2PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific enthalpy in IF-97 region 2 [J/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  222. Specific enthalpy in IF-97 region 3 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspH3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific enthalpy in IF-97 region 3 [J/kg], type: double.

    Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  223. Specific enthalpy in IF-97 region 3 [J/kg] as function of density r [kg/m3], temperature t [K]:

    wspH3RT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – specific enthalpy in IF-97 region 3 [J/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  224. Specific enthalpy in IF-97 region 5 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspH5PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific enthalpy in IF-97 region 5 [J/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  225. Specific enthalpy at boundary line between areas 1 and 3 [J/kg] as function of specific entropy s [J/(kg·K)]:

    wspHB13S(s)

    where:

    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific enthalpy at boundary line between areas 1 and 3 [J/kg], type: double.

    Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004).

  226. Joule-Thomson coefficient in IF-97 region 1 [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSON1PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – Joule-Thomson coefficient in IF-97 region 1 [K/Pa], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The equation: JT = (T*dV/dT - V)/Cp is used, where T - temperature, dV/dT - differential quotient (dV/dT)p, V - volume, Cp - isobaric heat capacity (Cp).

  227. Joule-Thomson coefficient in IF-97 region 2 [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSON2PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – Joule-Thomson coefficient in IF-97 region 2 [K/Pa], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The equation: JT = (T*dV/dT - V)/Cp is used, where T - temperature, dV/dT - differential quotient (dV/dT)p, V - volume, Cp - isobaric heat capacity (Cp).

  228. Joule-Thomson coefficient in IF-97 region 3 [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSON3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – Joule-Thomson coefficient in IF-97 region 3 [K/Pa], type: double.

    Function calculates Joule-Thomson coefficient for region 3 of IF-97 Formulation. This function uses function wspR3PT(p, t) to calculate density and then returns the value from the function wspJOULETHOMPSON3RT(r, t). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  229. Joule-Thomson coefficient in IF-97 region 3 [K/Pa] as function of density r [kg/m3], temperature t [K]:

    wspJOULETHOMPSON3RT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – Joule-Thomson coefficient in IF-97 region 3 [K/Pa], type: double.

    Function calculates the Joule-Thomson coefficient for region 3 of IF-97 Formulation.

  230. Joule-Thomson coefficient in IF-97 region 5 [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSON5PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – Joule-Thomson coefficient in IF-97 region 5 [K/Pa], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The equation: JT = (T*dV/dT - V)/Cp is used, where T - temperature, dV/dT - differential quotient (dV/dT)p, V - volume, Cp - isobaric heat capacity (Cp).

  231. Pressure in IF-97 region 1 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspP1HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – pressure in IF-97 region 1 [Pa], type: double.

    Function is based upon "Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2001). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  232. Pressure at line between areas 2 and 3 [Pa] as function of temperature t [K]:

    wspP23T(t)

    where:

    • t – temperature [K], type: double;
    • Return value – pressure at line between areas 2 and 3 [Pa], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam. Used in function wspWATERSTATEAREA when region of IF-97 is determined.

  233. Pressure at line between areas 2b and 2c [Pa] as function of specific enthalpy h [J/kg]:

    wspP2B2CH(h)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • Return value – pressure at line between areas 2b and 2c [Pa], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  234. Pressure in IF-97 region 2 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspP2HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – pressure in IF-97 region 2 [Pa], type: double.

    Function is based upon "Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2001) and used the functions: wspP2AHS(h, s), wspP2BHS(h, s) and wspP2CHS(h, s). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  235. Pressure in IF-97 region 3 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspP3HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – pressure in IF-97 region 3 [Pa], type: double.

    Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  236. Pressure in IF-97 region 3 [Pa] as function of density r [kg/m3], temperature t [K]:

    wspP3RT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – pressure in IF-97 region 3 [Pa], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  237. Pressure in IF-97 region 5 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspP5HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – pressure in IF-97 region 5 [Pa], type: double.

    Function is used to find the pressure in region 5 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  238. Pressure at boundary line between areas 2 and 3 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPB23HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – pressure at boundary line between areas 2 and 3 [Pa], type: double.

    Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004).

  239. Area of phase state as function of pressure p [Pa], temperature t [K]:

    wspPHASESTATEPT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – area of phase state, type: long.

    Function returns code of phase state in point with given p, t. If pressure p or temperature t are above critical (Prk or Tkr), the result is "3" (phase state - supercritical). If the point is situated above the saturation line (in P-T diagramm) the result is "1" (phase state - liquid). If the point is situated below the saturation line (in P-T diagram) the result is "2" (phase state - steam). If point is situated below triple point, the return is error value ("-1").

  240. Negative logarithm (10 base) of the ionization constant of water [-] as function of density r [kg/m3], temperature t [K]:

    wspPKWRT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – negative logarithm (10 base) of the ionization constant of water [-], type: double.

    Function is based upon the "Release on the Ionization Constant of H2O, August 2007" from IAPWS.

  241. Properties calculation result in IF-97 region 1 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPT1HS(h, s, *p, *t)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • p – pressure [Pa], type: double. Warning! It's output parameter;
    • t – temperature [K], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 1, type: double.

    Function is used to find parameters in region 1 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  242. Properties calculation result in IF-97 region 1 as function of density r [kg/m3], specific enthalpy h [J/kg]:

    wspPT1RH(r, h, *p, *t)

    where:

    • r – density [kg/m3], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • p – pressure [Pa], type: double. Warning! It's output parameter;
    • t – temperature [K], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 1, type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (r, h) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (r, h) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  243. Properties calculation result in IF-97 region 2 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPT2HS(h, s, *p, *t)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • p – pressure [Pa], type: double. Warning! It's output parameter;
    • t – temperature [K], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 2, type: double.

    Function is used to find parameters in region 2 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  244. Properties calculation result in IF-97 region 2 as function of density r [kg/m3], specific enthalpy h [J/kg]:

    wspPT2RH(r, h, *p, *t)

    where:

    • r – density [kg/m3], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • p – pressure [Pa], type: double. Warning! It's output parameter;
    • t – temperature [K], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 2, type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (r, h) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (r, h) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  245. Properties calculation result in IF-97 region 3 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPT3HS(h, s, *p, *t)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • p – pressure [Pa], type: double. Warning! It's output parameter;
    • t – temperature [K], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 3, type: double.

    Function is based on function wspRT3HS. After calling wspRT3HS the standard equations are used to determine the pressure. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  246. Properties calculation result in IF-97 region 5 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPT5HS(h, s, *p, *t)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • p – pressure [Pa], type: double. Warning! It's output parameter;
    • t – temperature [K], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 5, type: double.

    Function is used to find parameters in region 5 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  247. Properties calculation result in IF-97 region 5 as function of density r [kg/m3], specific enthalpy h [J/kg]:

    wspPT5RH(r, h, *p, *t)

    where:

    • r – density [kg/m3], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • p – pressure [Pa], type: double. Warning! It's output parameter;
    • t – temperature [K], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 5, type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (r, h) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (r, h) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  248. Density in IF-97 region 3 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspR3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – density in IF-97 region 3 [kg/m3], type: double.

    Function calculates the density in region 3 by calling the function wspR3PTR0 with the corresponding initial estimate for density. Used for unification of the functions in all IF-97 regions. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  249. Density in IF-97 region 3 [kg/m3] as function of pressure p [Pa], temperature t [K], initial density r0 [kg/m3]:

    wspR3PTR0(p, t, r0)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • r0 – initial density [kg/m3], type: double;
    • Return value – density in IF-97 region 3 [kg/m3], type: double.

    Function used the Newton method with initial estimate for density to calculate the density. Used for unification of the functions in all IF-97 regions. Since at some stages the function use iterations, to speed up calculations you may vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  250. Refractive index [-] as function of density r [kg/m3], temperature t [K], wave length wavelength [m]:

    wspRIRTL(r, t, wavelength)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • wavelength – wave length [m], type: double;
    • Return value – refractive index [-], type: double.

    Function is based upon the "Release on the Refractive Index of Ordinary Water Substance as a Function of Wavelength, Temperature and Pressure", 1997 from IAPWS. The range of validity is: temperatures from -12 to 500°C, densities up to 1060 kg/m3, wavelengths from 0.2 mkm to 1.1 mkm. The formulation also extrapolates smoothly up to 1.9 mkm in water.

  251. Properties calculation result in IF-97 region 3 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspRT3HS(h, s, *r, *t)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • r – density [kg/m3], type: double. Warning! It's output parameter;
    • t – temperature [K], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 3, type: double.

    Function is used to find parameters in region 3 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  252. Specific entropy in IF-97 region 1 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspS1PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific entropy in IF-97 region 1 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  253. Specific entropy in IF-97 region 2 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspS2PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific entropy in IF-97 region 2 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  254. Specific entropy in IF-97 region 3 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspS3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific entropy in IF-97 region 3 [J/(kg·K)], type: double.

    Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  255. Specific entropy in IF-97 region 3 [J/(kg·K)] as function of density r [kg/m3], temperature t [K]:

    wspS3RT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – specific entropy in IF-97 region 3 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  256. Specific entropy in IF-97 region 5 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspS5PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific entropy in IF-97 region 5 [J/(kg·K)], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  257. Temperature in IF-97 region 1 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspT1HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 1 [K], type: double.

    Function is based upon "Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2001). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  258. Temperature in IF-97 region 1 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT1PH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature in IF-97 region 1 [K], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  259. Temperature in IF-97 region 1 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT1PS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 1 [K], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  260. Temperature at line between areas 2 and 3 [K] as function of pressure p [Pa]:

    wspT23P(p)

    where:

    • p – pressure [Pa], type: double;
    • Return value – temperature at line between areas 2 and 3 [K], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam. Used in function wspWATERSTATEAREA when region of IF-97 is determined.

  261. Temperature in IF-97 region 2a [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT2APH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature in IF-97 region 2a [K], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  262. Temperature in IF-97 region 2a [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT2APS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 2a [K], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  263. Temperature in IF-97 region 2b [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT2BPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature in IF-97 region 2b [K], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  264. Temperature in IF-97 region 2b [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT2BPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 2b [K], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  265. Temperature in IF-97 region 2c [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT2CPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature in IF-97 region 2c [K], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  266. Temperature in IF-97 region 2c [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT2CPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 2c [K], type: double.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  267. Temperature in IF-97 region 2 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspT2HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 2 [K], type: double.

    Function is based upon the "Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2001). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  268. Temperature in IF-97 region 2 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT2PH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature in IF-97 region 2 [K], type: double.

    Function is based upon functions wspT2APH, wspT2BPH and wspT2CPH. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  269. Temperature in IF-97 region 2 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT2PS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 2 [K], type: double.

    Function is based upon functions wspT2APS, wspT2BPS and wspT2CPS. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  270. Temperature in IF-97 region 3 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspT3HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 3 [K], type: double.

    Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  271. Temperature in IF-97 region 3 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT3PH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature in IF-97 region 3 [K], type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  272. Temperature in IF-97 region 3 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT3PS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 3 [K], type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  273. Temperature in IF-97 region 3 [K] as function of density r [kg/m3], specific enthalpy h [J/kg]:

    wspT3RH(r, h)

    where:

    • r – density [kg/m3], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature in IF-97 region 3 [K], type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  274. Temperature in IF-97 region 5 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspT5HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 5 [K], type: double.

    Function is used to find the temperature in region 5 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  275. Temperature in IF-97 region 5 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT5PH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature in IF-97 region 5 [K], type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  276. Temperature in IF-97 region 5 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT5PS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature in IF-97 region 5 [K], type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. It uses the Newton method to determine the roots of the function with two arguments. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  277. Temperature at boundary line between areas 2 and 3 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTB23HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature at boundary line between areas 2 and 3 [K], type: double.

    Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004).

  278. Thermal conductivity coefficient [W/(m·K)] as function of density r [kg/m3], temperature t [K]:

    wspTHERMCONDRT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

    Function is based upon the Revised Release on the IAPS Formulation 1985 for the Thermal Conductivity of Ordinary Water Substance with correction for ITS-90 (International Temperature Scale). The range of validity is: temperature from 0.01 to 800°C for pressure up to 40 MPa, from 0.01 to 650°C for pressure from 40 to 70 MPa, from 0.01 to 500 °C for pressure from 70 to 100 MPa.

  279. Specific internal energy in IF-97 region 1 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspU1PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific internal energy in IF-97 region 1 [J/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  280. Specific internal energy in IF-97 region 2 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspU2PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific internal energy in IF-97 region 2 [J/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  281. Specific internal energy in IF-97 region 3 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspU3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific internal energy in IF-97 region 3 [J/kg], type: double.

    Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  282. Specific internal energy in IF-97 region 3 [J/kg] as function of density r [kg/m3], temperature t [K]:

    wspU3RT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – specific internal energy in IF-97 region 3 [J/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  283. Specific internal energy in IF-97 region 5 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspU5PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific internal energy in IF-97 region 5 [J/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  284. Specific volume in IF-97 region 1 [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspV1PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific volume in IF-97 region 1 [m3/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  285. Specific volume in IF-97 region 2 [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspV2PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific volume in IF-97 region 2 [m3/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  286. Specific volume in IF-97 region 3 [m3/kg] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspV3HS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific volume in IF-97 region 3 [m3/kg], type: double.

    Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  287. Specific volume in IF-97 region 3 [m3/kg] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspV3PH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – specific volume in IF-97 region 3 [m3/kg], type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  288. Specific volume in IF-97 region 3 [m3/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspV3PS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – specific volume in IF-97 region 3 [m3/kg], type: double.

    Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  289. Specific volume in IF-97 region 3 [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspV3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific volume in IF-97 region 3 [m3/kg], type: double.

    Function is based upon function wspR3PT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  290. Specific volume in IF-97 region 5 [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspV5PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific volume in IF-97 region 5 [m3/kg], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  291. Properties calculation result in IF-97 region 1 as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPT1PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
    • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
    • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
    • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
    • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
    • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
    • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
    • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
    • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
    • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 1, type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably.

    Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  292. Properties calculation result in IF-97 region 2 as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPT2PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
    • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
    • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
    • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
    • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
    • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
    • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
    • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
    • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
    • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 2, type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably.

    Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  293. Properties calculation result in IF-97 region 3 as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPT3PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
    • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
    • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
    • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
    • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
    • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
    • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
    • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
    • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
    • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 3, type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

    Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  294. Properties calculation result in IF-97 region 3 as function of density r [kg/m3], temperature t [K]:

    wspVUSHCVWDERPT3RT(r, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
    • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
    • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
    • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
    • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
    • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
    • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
    • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
    • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
    • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 3, type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably.

    Note: In Mathcad the function have only parameters (r, t) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (r, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  295. Properties calculation result in IF-97 region 5 as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPT5PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
    • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
    • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
    • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
    • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
    • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
    • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
    • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
    • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
    • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
    • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
    • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
    • Return value – properties calculation result in IF-97 region 5, type: double.

    The function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably.

    Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

    Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.

  296. Sound velocity in IF-97 region 1 [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspW1PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – sound velocity in IF-97 region 1 [m/sec], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  297. Sound velocity in IF-97 region 2 [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspW2PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – sound velocity in IF-97 region 2 [m/sec], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  298. Sound velocity in IF-97 region 3 [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspW3PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – sound velocity in IF-97 region 3 [m/sec], type: double.

    Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

  299. Sound velocity in IF-97 region 3 [m/sec] as function of density r [kg/m3], temperature t [K]:

    wspW3RT(r, t)

    where:

    • r – density [kg/m3], type: double;
    • t – temperature [K], type: double;
    • Return value – sound velocity in IF-97 region 3 [m/sec], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  300. Sound velocity in IF-97 region 5 [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspW5PT(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – sound velocity in IF-97 region 5 [m/sec], type: double.

    Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.

  301. IF-97 region as function of pressure p [Pa], temperature t [K]:

    wspWATERSTATEAREA(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – IF-97 region, type: long.

    Function is based upon the regions allocation in the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam and used in functions.

  302. IF-97 region (version 2) as function of pressure p [Pa], temperature t [K]:

    wspWATERSTATEAREA2(p, t)

    where:

    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – IF-97 region (version 2), type: long.

    Function is based upon the regions allocation in the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam (version 2 - without region 4 - saturation line) and used in functions.

  303. IF-97 region as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspWATERSTATEAREAHS(h, s)

    where:

    • h – specific enthalpy [J/kg], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – IF-97 region, type: long.

    Function is based upon allocation of additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and used in functions to determine the IF-97 region.

  304. IF-97 region as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspWATERSTATEAREAPH(p, h)

    where:

    • p – pressure [Pa], type: double;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – IF-97 region, type: long.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and used in functions to determine the IF-97 region.

  305. IF-97 region as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspWATERSTATEAREAPS(p, s)

    where:

    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – IF-97 region, type: long.

    Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and used in functions to determine the IF-97 region.

    306. Category: Gases

    Functions for calculation properties of gases and gases mixtures.

  306. Addition of one gas to another as function of identificator of target gas id_target, identificator of added gas id_source, added gas mass mass:

    wspgADDGASM(id_target, id_source, mass)

    where:

    • id_target – identificator of target gas, type: long;
    • id_source – identificator of added gas, type: long;
    • mass – added gas mass, type: double;
    • Return value – addition of one gas to another, type: long.

    Function adds the specified mass of one gas (given by it's identificator id_source) to another gases compound (given by gas identificator id_target).

  307. Addition of one gas to another as function of identificator of target gas id_target, identificator of added gas id_source, added gas volume volume:

    wspgADDGASV(id_target, id_source, volume)

    where:

    • id_target – identificator of target gas, type: long;
    • id_source – identificator of added gas, type: long;
    • volume – added gas volume, type: double;
    • Return value – addition of one gas to another, type: long.

    Function adds the specified volume (or moles count) of one gas (given by it's identificator id_source) to another gases compound (given by gas identificator id_target).

  308. Specific isobaric heat capacity [J/(kg·K)] as function of gas specification gas_specification, temperature t [K]:

    wspgCPGST(gas_specification, t)

    where:

    • gas_specification – gas specification, type: string;
    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

    Function calculates specific isobaric heat capacity for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.

  309. Specific isobaric heat capacity [J/(kg·K)] as function of gas identificator id, temperature t [K]:

    wspgCPIDT(id, t)

    where:

    • id – gas identificator, type: long;
    • t – temperature [K], type: double;
    • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

    Function calculates specific isobaric heat capacity for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.

  310. Specific isochoric heat capacity [J/(kg·K)] as function of gas specification gas_specification, temperature t [K]:

    wspgCVGST(gas_specification, t)

    where:

    • gas_specification – gas specification, type: string;
    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

    Function calculates specific isochoric heat capacity for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.

  311. Specific isochoric heat capacity [J/(kg·K)] as function of gas identificator id, temperature t [K]:

    wspgCVIDT(id, t)

    where:

    • id – gas identificator, type: long;
    • t – temperature [K], type: double;
    • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

    Function calculates specific isochoric heat capacity for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.

  312. Deleting of all user-defined gases:

    wspgDELETEGASES()

    where:

    • Return value – deleting of all user-defined gases, type: long.

    Function removes all user-defined gases. Also the memory for these gases is freed. After call to this function only built-in gases are available.

    Note: In Mathcad function have one parameter which value is not used.

  313. Deleting of early created gas as function of gas identificator id:

    wspgDELETEGASID(id)

    where:

    • id – gas identificator, type: long;
    • Return value – deleting of early created gas, type: long.

    Function removes gas with given identificator. Also the memory for this gas is freed.

  314. Available gases count:

    wspgGASESCOUNT()

    where:

    • Return value – available gases count, type: long.

    Function return count of all gases: built-in and user-defined.

    Note: In Mathcad function have one parameter which value is not used.

  315. Specific gas constant [J/(kg·K)] as function of gas specification gas_specification:

    wspgGCGS(gas_specification)

    where:

    • gas_specification – gas specification, type: string;
    • Return value – specific gas constant [J/(kg·K)], type: double.

  316. Specific gas constant [J/(kg·K)] as function of gas identificator id:

    wspgGCID(id)

    where:

    • id – gas identificator, type: long;
    • Return value – specific gas constant [J/(kg·K)], type: double.

  317. Specific enthalpy [J/kg] as function of gas specification gas_specification, temperature t [K]:

    wspgHGST(gas_specification, t)

    where:

    • gas_specification – gas specification, type: string;
    • t – temperature [K], type: double;
    • Return value – specific enthalpy [J/kg], type: double.

    Function calculates specific enthalpy for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.

  318. Specific enthalpy [J/kg] as function of gas identificator id, temperature t [K]:

    wspgHIDT(id, t)

    where:

    • id – gas identificator, type: long;
    • t – temperature [K], type: double;
    • Return value – specific enthalpy [J/kg], type: double.

    Function calculates specific enthalpy for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.

  319. Gas identificator as function of existing gas name name:

    wspgIDNAME(name)

    where:

    • name – existing gas name, type: string;
    • Return value – gas identificator, type: long.

    Function return the identificator of early defined gas (or built-in). If there is no gas with this name the error (with code WSP_E_BAD_PARAMS) is generated.

  320. Mass fraction (MF) of gas as function of primary gas specification gas_spec_looked, gas specification looked for gas_spec_looked_for:

    wspgMFGSGS(gas_spec_looked, gas_spec_looked_for)

    where:

    • gas_spec_looked – primary gas specification, type: string;
    • gas_spec_looked_for – gas specification looked for, type: string;
    • Return value – mass fraction (MF) of gas, type: double.

    Function calculates specific mass fraction of gas (given by gas specification in gas_spec_looked_for) in gas (given by gas specification in gas_spec_looked).

  321. Mass fraction (MF) of gas as function of primary gas identificator id_looked, gas identificator looked for id_looked_for:

    wspgMFIDID(id_looked, id_looked_for)

    where:

    • id_looked – primary gas identificator, type: long;
    • id_looked_for – gas identificator looked for, type: long;
    • Return value – mass fraction (MF) of gas, type: double.

    Function calculates specific mass fraction of gas (given by gas identificator in id_looked_for) in gas (given by gas identificator in id_looked).

  322. Molar mass [kg/mole] as function of gas specification gas_specification:

    wspgMMGS(gas_specification)

    where:

    • gas_specification – gas specification, type: string;
    • Return value – molar mass [kg/mole], type: double.

  323. Molar mass [kg/mole] as function of gas identificator id:

    wspgMMID(id)

    where:

    • id – gas identificator, type: long;
    • Return value – molar mass [kg/mole], type: double.

  324. New gas identificator:

    wspgNEWID()

    where:

    • Return value – new gas identificator, type: long.

    Function define new gas and return of identificator of new gas. The memory for this gas must be freed when work with this gas is finished by calling the function wspgDELETEGASID or wspgDELETEGASES. Otherwise the memory will be freed only when calling program is finished.

    Note: In Mathcad function have one parameter which value is not used.

  325. New gas identificator as function of gas specification gas_specification:

    wspgNEWIDGS(gas_specification)

    where:

    • gas_specification – gas specification, type: string;
    • Return value – new gas identificator, type: long.

    Function define new gas and return of identificator of new gas which is fit with given specification. The memory for this gas must be freed when work with this gas is finished by calling the function wspgDELETEGASID or wspgDELETEGASES. Otherwise the memory will be freed only when calling program is finished.

  326. Gas identificator as function of new gas name name:

    wspgNEWIDNAME(name)

    where:

    • name – new gas name, type: string;
    • Return value – gas identificator, type: long.

    Function define new gas and return identificator of this gas. If there is gas with this same name the error (with code WSP_E_BAD_PARAMS) is generated. The memory for this gas must be freed when work with this gas is finished by calling the function wspgDELETEGASID or wspgDELETEGASES. Otherwise the memory will be freed only when calling program is finished.

  327. Pressure [Pa] as function of gas specification gas_specification, temperature t [K], specific entropy s [J/(kg·K)]:

    wspgPGSTS(gas_specification, t, s)

    where:

    • gas_specification – gas specification, type: string;
    • t – temperature [K], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – pressure [Pa], type: double.

    Function calculates pressure for the gas specification in ideal state at given specific entropy and temperature. The range of validity is temperatures from 200K to 2500K.

  328. Pressure [Pa] as function of gas identificator id, temperature t [K], specific entropy s [J/(kg·K)]:

    wspgPIDTS(id, t, s)

    where:

    • id – gas identificator, type: long;
    • t – temperature [K], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – pressure [Pa], type: double.

    Function calculates pressure for the gas in ideal state at given specific entropy and temperature. The range of validity is temperatures from 200K to 2500K.

  329. Specific entropy [J/(kg·K)] as function of gas specification gas_specification, pressure p [Pa], temperature t [K]:

    wspgSGSPT(gas_specification, p, t)

    where:

    • gas_specification – gas specification, type: string;
    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific entropy [J/(kg·K)], type: double.

    Function calculates specific entropy for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.

  330. Specific entropy at pressure p0 = 100 kPa [J/(kg·K)] as function of gas specification gas_specification, temperature t [K]:

    wspgSGST(gas_specification, t)

    where:

    • gas_specification – gas specification, type: string;
    • t – temperature [K], type: double;
    • Return value – specific entropy at pressure p0 = 100 kPa [J/(kg·K)], type: double.

    Function calculates specific entropy for the given gas specification in ideal state at pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.

  331. Specific entropy [J/(kg·K)] as function of gas identificator id, pressure p [Pa], temperature t [K]:

    wspgSIDPT(id, p, t)

    where:

    • id – gas identificator, type: long;
    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific entropy [J/(kg·K)], type: double.

    Function calculates specific entropy for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.

  332. Specific entropy at pressure p0 = 100 kPa [J/(kg·K)] as function of gas identificator id, temperature t [K]:

    wspgSIDT(id, t)

    where:

    • id – gas identificator, type: long;
    • t – temperature [K], type: double;
    • Return value – specific entropy at pressure p0 = 100 kPa [J/(kg·K)], type: double.

    Function calculates specific entropy for the gas in ideal state at pressure 100 kPa. The range of validity is temperatures from 200K to 2500K.

  333. Temperature [K] as function of gas specification gas_specification, specific enthalpy h [J/kg]:

    wspgTGSH(gas_specification, h)

    where:

    • gas_specification – gas specification, type: string;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature [K], type: double.

    Function calculates temperature for the gas specification in ideal state at given specific enthalpy. The range of validity is temperatures from 200K to 2500K.

  334. Temperature [K] as function of gas specification gas_specification, pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspgTGSPS(gas_specification, p, s)

    where:

    • gas_specification – gas specification, type: string;
    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature [K], type: double.

    Function calculates temperature for the gas specification in ideal state at given specific entropy and pressure. The range of validity is temperatures from 200K to 2500K.

  335. Temperature at pressure p0 = 100 kPa [K] as function of gas specification gas_specification, specific entropy s [J/(kg·K)]:

    wspgTGSS(gas_specification, s)

    where:

    • gas_specification – gas specification, type: string;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature at pressure p0 = 100 kPa [K], type: double.

    Function calculates temperature for the gas specification in ideal state at given specific entropy and pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.

  336. Temperature [K] as function of gas identificator id, specific enthalpy h [J/kg]:

    wspgTIDH(id, h)

    where:

    • id – gas identificator, type: long;
    • h – specific enthalpy [J/kg], type: double;
    • Return value – temperature [K], type: double.

    Function calculates temperature for the gas in ideal state at given specific enthalpy. The range of validity is temperatures from 200K to 2500K.

  337. Temperature [K] as function of gas identificator id, pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspgTIDPS(id, p, s)

    where:

    • id – gas identificator, type: long;
    • p – pressure [Pa], type: double;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature [K], type: double.

    Function calculates temperature for the gas in ideal state at given specific entropy and pressure. The range of validity is temperatures from 200K to 2500K.

  338. Temperature at pressure p0 = 100 kPa [K] as function of gas identificator id, specific entropy s [J/(kg·K)]:

    wspgTIDS(id, s)

    where:

    • id – gas identificator, type: long;
    • s – specific entropy [J/(kg·K)], type: double;
    • Return value – temperature at pressure p0 = 100 kPa [K], type: double.

    Function calculates temperature for the gas in ideal state at given specific entropy and pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.

  339. Specific internal energy [J/kg] as function of gas specification gas_specification, temperature t [K]:

    wspgUGST(gas_specification, t)

    where:

    • gas_specification – gas specification, type: string;
    • t – temperature [K], type: double;
    • Return value – specific internal energy [J/kg], type: double.

    Function calculates specific internal energy for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.

  340. Specific internal energy [J/kg] as function of gas identificator id, temperature t [K]:

    wspgUIDT(id, t)

    where:

    • id – gas identificator, type: long;
    • t – temperature [K], type: double;
    • Return value – specific internal energy [J/kg], type: double.

    Function calculates specific internal energy for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.

  341. Volume fraction (VF) of gas as function of primary gas specification gas_spec_looked, gas specification looked for gas_spec_looked_for:

    wspgVFGSGS(gas_spec_looked, gas_spec_looked_for)

    where:

    • gas_spec_looked – primary gas specification, type: string;
    • gas_spec_looked_for – gas specification looked for, type: string;
    • Return value – volume fraction (VF) of gas, type: double.

    Function calculates specific volume fraction of gas (given by gas specification in gas_spec_looked_for) in gas (given by gas specification in gas_spec_looked).

  342. Volume fraction (VF) of gas as function of primary gas identificator id_looked, gas identificator looked for id_looked_for:

    wspgVFIDID(id_looked, id_looked_for)

    where:

    • id_looked – primary gas identificator, type: long;
    • id_looked_for – gas identificator looked for, type: long;
    • Return value – volume fraction (VF) of gas, type: double.

    Function calculates specific volume fraction of gas (given by gas identificator in id_looked_for) in gas (given by gas identificator in id_looked).

  343. Specific volume [m3/kg] as function of gas specification gas_specification, pressure p [Pa], temperature t [K]:

    wspgVGSPT(gas_specification, p, t)

    where:

    • gas_specification – gas specification, type: string;
    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific volume [m3/kg], type: double.

    Function calculates specific volume for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.

  344. Specific volume at pressure p0 = 100 kPa [m3/kg] as function of gas specification gas_specification, temperature t [K]:

    wspgVGST(gas_specification, t)

    where:

    • gas_specification – gas specification, type: string;
    • t – temperature [K], type: double;
    • Return value – specific volume at pressure p0 = 100 kPa [m3/kg], type: double.

    Function calculates specific volume for the given gas specification in ideal state at pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.

  345. Specific volume [m3/kg] as function of gas identificator id, pressure p [Pa], temperature t [K]:

    wspgVIDPT(id, p, t)

    where:

    • id – gas identificator, type: long;
    • p – pressure [Pa], type: double;
    • t – temperature [K], type: double;
    • Return value – specific volume [m3/kg], type: double.

    Function calculates specific volume for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.

  346. Specific volume at pressure p0 = 100 kPa [m3/kg] as function of gas identificator id, temperature t [K]:

    wspgVIDT(id, t)

    where:

    • id – gas identificator, type: long;
    • t – temperature [K], type: double;
    • Return value – specific volume at pressure p0 = 100 kPa [m3/kg], type: double.

    Function calculates specific volume for the gas in ideal state at pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.

    347. Category: System

    System functions.

  347. Absolute gas constant [J/(mole·K)]:

    wspGETABSOLUTEGASCONSTANT()

    where:

    • Return value – absolute gas constant [J/(mole·K)], type: double.

    Function returns value of absolute gas constant used in gases equations of WaterSteamPro.

    Note: In Mathcad function have one parameter which value is not used.

  348. Mode of checking the range of functions arguments:

    wspGETCHECKRANGEMODE()

    where:

    • Return value – mode of checking the range of functions arguments, type: long.

    Function returns zero if the checking is disabled.

    Note: In Mathcad function have one parameter which value is not used.

  349. Maximum difference between pressure values at estimation of the area 3 parameters [Pa]:

    wspGETDELTAPRESSURE()

    where:

    • Return value – maximum difference between pressure values at estimation of the area 3 parameters [Pa], type: double.

    Function is obsolete. From version 6.0 it is not used!

    Note: In Mathcad function have one parameter which value is not used.

    Note: This function is obsolete and it is recommended don't use it.

  350. Maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K]:

    wspGETDELTATS()

    where:

    • Return value – maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K], type: double.

    Function is obsolete and not used from version 6.0!

    Note: In Mathcad function have one parameter which value is not used.

    Note: This function is obsolete and it is recommended don't use it.

  351. Initial value for density of steam in IF-97 region 3 [kg/m3]:

    wspGETINITSTEAMDENSITY()

    where:

    • Return value – initial value for density of steam in IF-97 region 3 [kg/m3], type: double.

    Function is obsolete. From version 6.0 it is not used!

    Note: In Mathcad function have one parameter which value is not used.

    Note: This function is obsolete and it is recommended don't use it.

  352. Initial value for density of water in IF-97 region 3 [kg/m3]:

    wspGETINITWATERDENSITY()

    where:

    • Return value – initial value for density of water in IF-97 region 3 [kg/m3], type: double.

    Function is obsolete. From version 6.0 it is not used!

    Note: In Mathcad function have one parameter which value is not used.

    Note: This function is obsolete and it is recommended don't use it.

  353. Last error code:

    wspGETLASTERROR()

    where:

    • Return value – last error code, type: long.

    Function returns last error occurred in any functions except the system functions. Any function call (except those systems) set the error code to zero (no error).

    Note: In Mathcad function have one parameter which value is not used.

  354. Last error description:

    wspGETLASTERRORDESCRIPTION()

    where:

    • Return value – last error description, type: string.

    Function returns last error description occurred in the function except those systems. The result of function is defined in library OKAWSP6.DLL as LPCSTR (ANSI-symbols), but in ActiveX-object WSP.WSPCalculator - as BSTR (Unicode). You must use the ActiveX-version of function in Visual Basic. If you use non Active-X component you do not have to care about freeing memory because this function uses the static buffer to return values.

    Note: In Mathcad function have one parameter which value is not used.

  355. Last error description:

    wspGETLASTERRORDESCRIPTIONW()

    where:

    • Return value – last error description, type: unicodestring.

    Function returns last error description occurred in any function call except those systems.

    Note: In Mathcad function have one parameter which value is not used.

  356. Maximum iterations count for Newton method:

    wspGETMAXITERATION()

    where:

    • Return value – maximum iterations count for Newton method, type: long.

    This number is used for the Newton method. If number of iterations is more than that value the error WSP_CANT_FIND_ROOT (3) occurs.

    Note: In Mathcad function have one parameter which value is not used.

  357. Relative precision in the WaterSteamPro functions [-]:

    wspGETTOLERANCE()

    where:

    • Return value – relative precision in the WaterSteamPro functions [-], type: double.

    Return the current value of tolerance. It is used in functions which require the relative precision.

    Note: In Mathcad function have one parameter which value is not used.

  358. Mode of management of make function results more precise:

    wspGETTOLERANCEMODE()

    where:

    • Return value – mode of management of make function results more precise, type: long.

    Function return the current mode of functions result improvement. It is used when result of a function can be improved (function with arguments p, h and p, s). If result equals to zero improvement is disabled. Otherwise enabled. See also function wspSETTOLERANCEMODE.

    Note: In Mathcad function have one parameter which value is not used.

  359. Internal version of the WaterSteamPro:

    wspGETWSPVERSION()

    where:

    • Return value – internal version of the WaterSteamPro, type: double.

    The format of version is x.yzzz where x - major version, y - minor version, zzz - revision.

    Note: In Mathcad function have one parameter which value is not used.

  360. Mode of calculating dissociation while calculate gases mixtures:

    wspgGETCALCDISSMODE()

    where:

    • Return value – mode of calculating dissociation while calculate gases mixtures, type: long.

    Function is used in functions for gas mixture properties. If mode equals to 0 dissociation is not calculated. If mode equals to 1 dissociation is calculated always. If mode equals to 2 dissociation is calculated only for temperatures above 1200 K.

    Note: In Mathcad function have one parameter which value is not used.

  361. Set and return a mode of calculating dissociation while calculate gases mixtures as function of mode mode:

    wspgSETCALCDISSMODE(mode)

    where:

    • mode – mode, type: long;
    • Return value – set and return a mode of calculating dissociation while calculate gases mixtures, type: long.

    Function is used in functions for gas mixture properties. If mode equals to 0 dissociation is not calculated. If mode equals to 1 dissociation is calculated always. If mode equals to 2 dissociation is calculated only for temperatures above 1200 K.

  362. Process registration of the WaterSteamPro as function of registration name name, registration key key:

    wspLOCALREGISTRATION(name, key)

    where:

    • name – registration name, type: string;
    • key – registration key, type: string;
    • Return value – process registration of the WaterSteamPro, type: void.

    Function was used in "Developer" license of WaterSteamPro. This function is obsolete.

    Note: This function is obsolete and it is recommended don't use it.

  363. Process registration of the WaterSteamPro as function of registration name name, registration data data:

    wspLOCALREGISTRATIONEXA(name, data)

    where:

    • name – registration name, type: string;
    • data – registration data, type: long;
    • Return value – process registration of the WaterSteamPro, type: double.

    Function is used in "Developer" license of WaterSteamPro. For more information see WaterSteamPro SDK.

  364. Process registration of the WaterSteamPro as function of registration name name, registration data data:

    wspLOCALREGISTRATIONEXW(name, data)

    where:

    • name – registration name, type: unicodestring;
    • data – registration data, type: long;
    • Return value – process registration of the WaterSteamPro, type: double.

    Function is used in "Developer" license of WaterSteamPro. For more information see WaterSteamPro SDK.

  365. Set and return a mode of checking the range of functions arguments as function of mode mode:

    wspSETCHECKRANGEMODE(mode)

    where:

    • mode – mode, type: long;
    • Return value – set and return a mode of checking the range of functions arguments, type: long.

    Function adjust the mode of checking for input parameters range. It is used in functions before calculating. If argument mode equals to zero the checking is disabled and the calculation speeds up but errors may occur.

  366. Set and return maximum difference between pressure values at estimation of the area 3 parameters [Pa] as function of delta pressure delta [Pa]:

    wspSETDELTAPRESSURE(delta)

    where:

    • delta – delta pressure [Pa], type: double;
    • Return value – set and return maximum difference between pressure values at estimation of the area 3 parameters [Pa], type: double.

    Function is obsolete. From version 6.0 it is not used!

    Note: This function is obsolete and it is recommended don't use it.

  367. Set and return maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K] as function of temperature delta delta [K]:

    wspSETDELTATS(delta)

    where:

    • delta – temperature delta [K], type: double;
    • Return value – set and return maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K], type: double.

    Function is obsolete and is not used from version 6.0!

    Note: This function is obsolete and it is recommended don't use it.

  368. Set and return the initial value for density of steam in IF-97 region 3 [kg/m3] as function of density r [kg/m3]:

    wspSETINITSTEAMDENSITY(r)

    where:

    • r – density [kg/m3], type: double;
    • Return value – set and return the initial value for density of steam in IF-97 region 3 [kg/m3], type: double.

    Function is obsolete. From version 6.0 it is not used!

    Note: This function is obsolete and it is recommended don't use it.

  369. Set and return initial value for density of water in IF-97 region 3 [kg/m3] as function of density r [kg/m3]:

    wspSETINITWATERDENSITY(r)

    where:

    • r – density [kg/m3], type: double;
    • Return value – set and return initial value for density of water in IF-97 region 3 [kg/m3], type: double.

    Function is obsolete. From version 6.0 it is not used!

    Note: This function is obsolete and it is recommended don't use it.

  370. Set and return a last error code as function of error code ErrCode:

    wspSETLASTERROR(ErrCode)

    where:

    • ErrCode – error code, type: long;
    • Return value – set and return a last error code, type: long.

    This function can be used to estimate error number: all error codes are enumerated starting from zero (no error) and increase subsequently with step 1. If a parameter overruns the function returns (and sets) zero - that means no error.

  371. Set and return maximum iterations count for Newton method as function of maximum iteration maxiteration:

    wspSETMAXITERATION(maxiteration)

    where:

    • maxiteration – maximum iteration, type: long;
    • Return value – set and return maximum iterations count for Newton method, type: long.

    If a function uses the Newton method this number is needed. If number of iterations more than this value the error WSP_CANT_FIND_ROOT (3) occurs.

  372. Set and return relative precision in the WaterSteamPro functions [-] as function of tolerance tolerance [-]:

    wspSETTOLERANCE(tolerance)

    where:

    • tolerance – tolerance [-], type: double;
    • Return value – set and return relative precision in the WaterSteamPro functions [-], type: double.

    The value of tolerance is used in functions which require the relative precision (usually when the iterations used).

  373. Set and return a mode of management of make function results more precise as function of mode mode:

    wspSETTOLERANCEMODE(mode)

    where:

    • mode – mode, type: long;
    • Return value – set and return a mode of management of make function results more precise, type: long.

    Function adjust the mode of functions result improvement. It is used when result of a function can be improved (functions with arguments (p, h), (p, s) and so on). Usually iterations used to do it. If an argument equals to zero improvement is disabled and calculation speeds up while the tolerance decreases.


WaterSteamPro functions history list

  • Version 6.5
  • Version 6.0
  • Version 5.6
  • Version 5.5
  • Version 5.4
  • Version 5.3
  • Version 5.2
  • Version 5.1
  • Version 5.0

Version 6.5

  1. Density [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspDPT(p, t)

  2. Derivate of density on pressure with constant enthalpy of water/steam [sec2/m2] as function of pressure p [Pa], temperature t [K]:

    wspDDDPHPT(p, t)

  3. Derivate of density on pressure with constant enthalpy of water/steam [sec2/m2] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspDDDPHPTX(p, t, x)

  4. Derivate of density on pressure with constant enthalpy of water/steam [sec2/m2] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspDDDPHPH(p, h)

  5. Derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5] as function of pressure p [Pa], temperature t [K]:

    wspDDDHPPT(p, t)

  6. Derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspDDDHPPTX(p, t, x)

  7. Derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspDDDHPPH(p, h)

  8. Density [kg/m3] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspDPTX(p, t, x)

  9. Negative logarithm (base 10) of the ionization constant of water [-] as function of pressure p [Pa], temperature t [K]:

    wspPKWPT(p, t)

  10. Static dielectric constant of ordinary water substance [-] as function of pressure p [Pa], temperature t [K]:

    wspDCPT(p, t)

  11. Refractive index [-] as function of pressure p [Pa], temperature t [K], wave length wavelength [m]:

    wspRIPTL(p, t, wavelength)

  12. Density of steam at saturation line [kg/m3] as function of temperature t [K]:

    wspDSST(t)

  13. Derivate of density on pressure with constant enthalpy of steam at saturation line [sec2/m2] as function of temperature t [K]:

    wspDDDPHSST(t)

  14. Derivate of density on pressure with constant enthalpy of water at saturation line [sec2/m2] as function of temperature t [K]:

    wspDDDPHSWT(t)

  15. Derivate of density on enthalpy with constant pressure of steam at saturation line [kg·sec2/m5] as function of temperature t [K]:

    wspDDDHPSST(t)

  16. Derivate of density on enthalpy with constant pressure of water at saturation line [kg·sec2/m5] as function of temperature t [K]:

    wspDDDHPSWT(t)

  17. Density of water at saturation line [kg/m3] as function of temperature t [K]:

    wspDSWT(t)

  18. Density in double-phase area [kg/m3] as function of temperature t [K], vapor fraction x [-]:

    wspDSTX(t, x)

  19. Vapor fraction [-] as function of temperature t [K], density r [kg/m3]:

    wspXSTD(t, r)

  20. Properties calculation result of super-cooled steam (meta-stable region) as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPTMSPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  21. Density in IF-97 region 1 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspD1PT(p, t)

  22. Density in IF-97 region 2 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspD2PT(p, t)

  23. Density in IF-97 region 3 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspD3PT(p, t)

  24. Density in IF-97 region 5 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspD5PT(p, t)

  25. Negative logarithm (10 base) of the ionization constant of water [-] as function of density r [kg/m3], temperature t [K]:

    wspPKWRT(r, t)

  26. Static dielectric constant of ordinary water substance [-] as function of density r [kg/m3], temperature t [K]:

    wspDCRT(r, t)

  27. Refractive index [-] as function of density r [kg/m3], temperature t [K], wave length wavelength [m]:

    wspRIRTL(r, t, wavelength)

Version 6.0

  1. Pressure [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPHS(h, s)

  2. Temperature [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTHS(h, s)

  3. Properties calculation result as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPTHS(h, s, *p, *t)

  4. Specific volume [m3/kg] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspVHS(h, s)

  5. Specific internal energy [J/kg] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspUHS(h, s)

  6. Specific isobaric heat capacity [J/(kg·K)] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspCPHS(h, s)

  7. Specific isochoric heat capacity [J/(kg·K)] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspCVHS(h, s)

  8. Speed of sound [m/sec] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspWHS(h, s)

  9. Joule-Thomson coefficient [K/Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspJOULETHOMPSONHS(h, s)

  10. Thermal conductivity coefficient [W/(m·K)] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTHERMCONDHS(h, s)

  11. Dynamic viscosity [Pa·sec] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspDYNVISHS(h, s)

  12. Prandtl number [-] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPRANDTLEHS(h, s)

  13. Kinematic viscosity [m2/sec] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspKINVISHS(h, s)

  14. Isoentropic exponent [-] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspKHS(h, s)

  15. Vapor fraction [-] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspXHS(h, s)

  16. Vapor fraction [-] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspXPH(p, h)

  17. Vapor fraction [-] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspXPS(p, s)

  18. Rough value of density of steam at saturation line [kg/m3] as function of temperature t [K]:

    wspROUGHRSST(t)

  19. Rough value of density of water at saturation line [kg/m3] as function of temperature t [K]:

    wspROUGHRSWT(t)

  20. Specific enthalpy of steam at saturation line [J/kg] as function of specific entropy s [J/(kg·K)]:

    wspROUGHHSSS(s)

  21. Specific enthalpy of water at saturation line [J/kg] as function of specific entropy s [J/(kg·K)]:

    wspROUGHHSWS(s)

  22. Temperature at saturation line [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTSHS(h, s)

  23. Properties calculation result in double-phase area as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTXSHS(h, s, *t, *x)

  24. Pressure at sublimation line [Pa] as function of temperature t [K]:

    wspPSUBT(t)

  25. Pressure at melting line of ice I [Pa] as function of temperature t [K]:

    wspPMELTIT(t)

  26. Pressure in IF-97 region 1 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspP1HS(h, s)

  27. Temperature in IF-97 region 1 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspT1HS(h, s)

  28. Properties calculation result in IF-97 region 1 as function of density r [kg/m3], specific enthalpy h [J/kg]:

    wspPT1RH(r, h, *p, *t)

  29. Pressure in IF-97 region 2 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspP2HS(h, s)

  30. Temperature in IF-97 region 2 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspT2HS(h, s)

  31. Properties calculation result in IF-97 region 2 as function of density r [kg/m3], specific enthalpy h [J/kg]:

    wspPT2RH(r, h, *p, *t)

  32. Pressure in IF-97 region 3 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspP3HS(h, s)

  33. Temperature in IF-97 region 3 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspT3HS(h, s)

  34. Specific volume in IF-97 region 3 [m3/kg] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspV3HS(h, s)

  35. Specific volume in IF-97 region 3 [m3/kg] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspV3PH(p, h)

  36. Specific volume in IF-97 region 3 [m3/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspV3PS(p, s)

  37. Temperature in IF-97 region 3 [K] as function of density r [kg/m3], specific enthalpy h [J/kg]:

    wspT3RH(r, h)

  38. Properties calculation result in IF-97 region 5 as function of density r [kg/m3], specific enthalpy h [J/kg]:

    wspPT5RH(r, h, *p, *t)

  39. Area of phase state as function of pressure p [Pa], temperature t [K]:

    wspPHASESTATEPT(p, t)

  40. IF-97 region as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspWATERSTATEAREAHS(h, s)

  41. Temperature at boundary line between areas 2 and 3 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspTB23HS(h, s)

  42. Pressure at boundary line between areas 2 and 3 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPB23HS(h, s)

  43. Specific enthalpy at boundary line between areas 1 and 3 [J/kg] as function of specific entropy s [J/(kg·K)]:

    wspHB13S(s)

  44. Pressure in IF-97 region 5 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspP5HS(h, s)

  45. Temperature in IF-97 region 5 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspT5HS(h, s)

  46. Properties calculation result in IF-97 region 1 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPT1HS(h, s, *p, *t)

  47. Properties calculation result in IF-97 region 2 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPT2HS(h, s, *p, *t)

  48. Properties calculation result in IF-97 region 3 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspRT3HS(h, s, *r, *t)

  49. Properties calculation result in IF-97 region 3 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPT3HS(h, s, *p, *t)

  50. Properties calculation result in IF-97 region 5 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

    wspPT5HS(h, s, *p, *t)

  51. Specific isobaric heat capacity [J/(kg·K)] as function of gas identificator id, temperature t [K]:

    wspgCPIDT(id, t)

  52. Specific isobaric heat capacity [J/(kg·K)] as function of gas specification gas_specification, temperature t [K]:

    wspgCPGST(gas_specification, t)

  53. Specific enthalpy [J/kg] as function of gas identificator id, temperature t [K]:

    wspgHIDT(id, t)

  54. Specific enthalpy [J/kg] as function of gas specification gas_specification, temperature t [K]:

    wspgHGST(gas_specification, t)

  55. Specific entropy at pressure p0 = 100 kPa [J/(kg·K)] as function of gas identificator id, temperature t [K]:

    wspgSIDT(id, t)

  56. Specific entropy at pressure p0 = 100 kPa [J/(kg·K)] as function of gas specification gas_specification, temperature t [K]:

    wspgSGST(gas_specification, t)

  57. Specific entropy [J/(kg·K)] as function of gas identificator id, pressure p [Pa], temperature t [K]:

    wspgSIDPT(id, p, t)

  58. Specific entropy [J/(kg·K)] as function of gas specification gas_specification, pressure p [Pa], temperature t [K]:

    wspgSGSPT(gas_specification, p, t)

  59. Specific isochoric heat capacity [J/(kg·K)] as function of gas identificator id, temperature t [K]:

    wspgCVIDT(id, t)

  60. Specific isochoric heat capacity [J/(kg·K)] as function of gas specification gas_specification, temperature t [K]:

    wspgCVGST(gas_specification, t)

  61. Specific internal energy [J/kg] as function of gas identificator id, temperature t [K]:

    wspgUIDT(id, t)

  62. Specific internal energy [J/kg] as function of gas specification gas_specification, temperature t [K]:

    wspgUGST(gas_specification, t)

  63. Molar mass [kg/mole] as function of gas identificator id:

    wspgMMID(id)

  64. Molar mass [kg/mole] as function of gas specification gas_specification:

    wspgMMGS(gas_specification)

  65. Specific gas constant [J/(kg·K)] as function of gas identificator id:

    wspgGCID(id)

  66. Specific gas constant [J/(kg·K)] as function of gas specification gas_specification:

    wspgGCGS(gas_specification)

  67. Specific volume at pressure p0 = 100 kPa [m3/kg] as function of gas identificator id, temperature t [K]:

    wspgVIDT(id, t)

  68. Specific volume at pressure p0 = 100 kPa [m3/kg] as function of gas specification gas_specification, temperature t [K]:

    wspgVGST(gas_specification, t)

  69. Specific volume [m3/kg] as function of gas identificator id, pressure p [Pa], temperature t [K]:

    wspgVIDPT(id, p, t)

  70. Specific volume [m3/kg] as function of gas specification gas_specification, pressure p [Pa], temperature t [K]:

    wspgVGSPT(gas_specification, p, t)

  71. Temperature [K] as function of gas identificator id, specific enthalpy h [J/kg]:

    wspgTIDH(id, h)

  72. Temperature [K] as function of gas specification gas_specification, specific enthalpy h [J/kg]:

    wspgTGSH(gas_specification, h)

  73. Temperature at pressure p0 = 100 kPa [K] as function of gas identificator id, specific entropy s [J/(kg·K)]:

    wspgTIDS(id, s)

  74. Temperature at pressure p0 = 100 kPa [K] as function of gas specification gas_specification, specific entropy s [J/(kg·K)]:

    wspgTGSS(gas_specification, s)

  75. Temperature [K] as function of gas identificator id, pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspgTIDPS(id, p, s)

  76. Temperature [K] as function of gas specification gas_specification, pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspgTGSPS(gas_specification, p, s)

  77. Pressure [Pa] as function of gas identificator id, temperature t [K], specific entropy s [J/(kg·K)]:

    wspgPIDTS(id, t, s)

  78. Pressure [Pa] as function of gas specification gas_specification, temperature t [K], specific entropy s [J/(kg·K)]:

    wspgPGSTS(gas_specification, t, s)

  79. Volume fraction (VF) of gas as function of primary gas specification gas_spec_looked, gas specification looked for gas_spec_looked_for:

    wspgVFGSGS(gas_spec_looked, gas_spec_looked_for)

  80. Mass fraction (MF) of gas as function of primary gas specification gas_spec_looked, gas specification looked for gas_spec_looked_for:

    wspgMFGSGS(gas_spec_looked, gas_spec_looked_for)

  81. Volume fraction (VF) of gas as function of primary gas identificator id_looked, gas identificator looked for id_looked_for:

    wspgVFIDID(id_looked, id_looked_for)

  82. Mass fraction (MF) of gas as function of primary gas identificator id_looked, gas identificator looked for id_looked_for:

    wspgMFIDID(id_looked, id_looked_for)

  83. Gas identificator as function of existing gas name name:

    wspgIDNAME(name)

  84. New gas identificator:

    wspgNEWID()

  85. Gas identificator as function of new gas name name:

    wspgNEWIDNAME(name)

  86. New gas identificator as function of gas specification gas_specification:

    wspgNEWIDGS(gas_specification)

  87. Deleting of early created gas as function of gas identificator id:

    wspgDELETEGASID(id)

  88. Deleting of all user-defined gases:

    wspgDELETEGASES()

  89. Available gases count:

    wspgGASESCOUNT()

  90. Addition of one gas to another as function of identificator of target gas id_target, identificator of added gas id_source, added gas mass mass:

    wspgADDGASM(id_target, id_source, mass)

  91. Addition of one gas to another as function of identificator of target gas id_target, identificator of added gas id_source, added gas volume volume:

    wspgADDGASV(id_target, id_source, volume)

  92. Set and return a mode of calculating dissociation while calculate gases mixtures as function of mode mode:

    wspgSETCALCDISSMODE(mode)

  93. Mode of calculating dissociation while calculate gases mixtures:

    wspgGETCALCDISSMODE()

  94. Last error description:

    wspGETLASTERRORDESCRIPTIONW()

  95. Process registration of the WaterSteamPro as function of registration name name, registration data data:

    wspLOCALREGISTRATIONEXA(name, data)

  96. Process registration of the WaterSteamPro as function of registration name name, registration data data:

    wspLOCALREGISTRATIONEXW(name, data)

  97. Absolute gas constant [J/(mole·K)]:

    wspGETABSOLUTEGASCONSTANT()

Version 5.6

  1. Properties calculation result as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPTPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  2. Derivative of saturation pressure on saturation temperature [Pa/K] as function of temperature t [K]:

    wspDPDTST(t)

  3. Specific isochoric heat capacity of steam at saturation line from the double-phase region [J/(kg·K)] as function of temperature t [K]:

    wspCVDPSST(t)

  4. Specific isochoric heat capacity of water at saturation line from the double-phase region [J/(kg·K)] as function of temperature t [K]:

    wspCVDPSWT(t)

  5. Properties calculation result for water at saturation line as function of temperature t [K]:

    wspVUSHCVWDERPTSWT(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  6. Properties calculation result for steam at saturation line as function of temperature t [K]:

    wspVUSHCVWDERPTSST(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  7. Properties calculation result in IF-97 region 1 as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPT1PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  8. Properties calculation result in IF-97 region 2 as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPT2PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  9. Properties calculation result in IF-97 region 3 as function of density r [kg/m3], temperature t [K]:

    wspVUSHCVWDERPT3RT(r, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  10. Properties calculation result in IF-97 region 3 as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPT3PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  11. Properties calculation result in IF-97 region 5 as function of pressure p [Pa], temperature t [K]:

    wspVUSHCVWDERPT5PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

Version 5.5

  1. Specific volume of meta-stable supercooled steam [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspVMSPT(p, t)

  2. Specific internal energy of meta-stable supercooled steam [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspUMSPT(p, t)

  3. Specific entropy of meta-stable supercooled steam [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspSMSPT(p, t)

  4. Specific enthalpy of meta-stable supercooled steam [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspHMSPT(p, t)

  5. Specific isobaric heat capacity of meta-stable supercooled steam [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCPMSPT(p, t)

  6. Specific isochoric heat capacity of meta-stable supercooled steam [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCVMSPT(p, t)

  7. Sound velocity of meta-stable supercooled steam [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspWMSPT(p, t)

  8. Thermal conductivity coefficient of meta-stable supercooled steam [W/(m·K)] as function of pressure p [Pa], temperature t [K]:

    wspTHERMCONDMSPT(p, t)

  9. Dynamic viscosity of meta-stable supercooled steam [Pa·sec] as function of pressure p [Pa], temperature t [K]:

    wspDYNVISMSPT(p, t)

  10. Prandtl number of meta-stable supercooled steam [-] as function of pressure p [Pa], temperature t [K]:

    wspPRANDTLEMSPT(p, t)

  11. Kinematic viscosity of meta-stable supercooled steam [m2/sec] as function of pressure p [Pa], temperature t [K]:

    wspKINVISMSPT(p, t)

  12. Isoentropic exponent of meta-stable supercooled steam [-] as function of pressure p [Pa], temperature t [K]:

    wspKMSPT(p, t)

  13. Joule-Thomson coefficient of meta-stable supercooled steam [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSONMSPT(p, t)

Version 5.4

  1. Temperature at the end of expansion/compression process [K] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspTEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  2. Specific volume at the end of expansion/compression process [m3/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  3. Specific internal energy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspUEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  4. Specific enthalpy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspHEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  5. Specific entropy at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspSEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  6. Specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspCPEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  7. Specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspCVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  8. Sound velocity at the end of expansion/compression process [m/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspWEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  9. Thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspTHERMCONDEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  10. Kinematic viscosity at the end of expansion/compression process [m2/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspKINVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  11. Dynamic viscosity at the end of expansion/compression process [Pa·sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspDYNVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  12. Prandtl number at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspPRANDTLEEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  13. Isoentropic exponent [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspKEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  14. Joule-Thomson coefficient at the end of expansion/compression process [K/Pa] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspJOULETHOMPSONEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  15. Vapor fraction at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspXEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  16. Vapor fraction at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspXEXPANSIONPTPEFF(p0, t0, p1, eff)

Version 5.3

  1. Temperature at the end of expansion/compression process [K] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspTEXPANSIONPTPEFF(p0, t0, p1, eff)

  2. Specific volume at the end of expansion/compression process [m3/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspVEXPANSIONPTPEFF(p0, t0, p1, eff)

  3. Specific internal energy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspUEXPANSIONPTPEFF(p0, t0, p1, eff)

  4. Specific enthalpy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspHEXPANSIONPTPEFF(p0, t0, p1, eff)

  5. Specific entropy at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspSEXPANSIONPTPEFF(p0, t0, p1, eff)

  6. Specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspCPEXPANSIONPTPEFF(p0, t0, p1, eff)

  7. Specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspCVEXPANSIONPTPEFF(p0, t0, p1, eff)

  8. Sound velocity at the end of expansion/compression process [m/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspWEXPANSIONPTPEFF(p0, t0, p1, eff)

  9. Thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspTHERMCONDEXPANSIONPTPEFF(p0, t0, p1, eff)

  10. Kinematic viscosity at the end of expansion/compression process [m2/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspKINVISEXPANSIONPTPEFF(p0, t0, p1, eff)

  11. Dynamic viscosity at the end of expansion/compression process [Pa·sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspDYNVISEXPANSIONPTPEFF(p0, t0, p1, eff)

  12. Prandtl number at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspPRANDTLEEXPANSIONPTPEFF(p0, t0, p1, eff)

  13. Isoentropic exponent at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspKEXPANSIONPTPEFF(p0, t0, p1, eff)

  14. Joule-Thomson coefficient at the end of expansion/compression process [K/Pa] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

    wspJOULETHOMPSONEXPANSIONPTPEFF(p0, t0, p1, eff)

Version 5.2

  1. Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSONPT(p, t)

  2. Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspJOULETHOMPSONPTX(p, t, x)

  3. Temperature [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspTPH(p, h)

  4. Temperature [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspTPS(p, s)

  5. Specific internal energy [J/kg] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspUPH(p, h)

  6. Specific volume [m3/kg] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspVPH(p, h)

  7. Specific entropy [J/(kg·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspSPH(p, h)

  8. Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspCPPH(p, h)

  9. Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspCVPH(p, h)

  10. Speed of sound [m/sec] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspWPH(p, h)

  11. Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspJOULETHOMPSONPH(p, h)

  12. Dynamic viscosity [Pa·sec] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspDYNVISPH(p, h)

  13. Kinematic viscosity [m2/sec] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspKINVISPH(p, h)

  14. Prandtl number [-] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspPRANDTLEPH(p, h)

  15. Isoentropic exponent [-] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspKPH(p, h)

  16. Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspTHERMCONDPH(p, h)

  17. Specific internal energy [J/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspUPS(p, s)

  18. Specific volume [m3/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspVPS(p, s)

  19. Specific enthalpy [J/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspHPS(p, s)

  20. Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspCPPS(p, s)

  21. Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspCVPS(p, s)

  22. Speed of sound [m/sec] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspWPS(p, s)

  23. Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspJOULETHOMPSONPS(p, s)

  24. Dynamic viscosity [Pa·sec] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspDYNVISPS(p, s)

  25. Kinematic viscosity [m2/sec] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspKINVISPS(p, s)

  26. Prandtl number [-] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspPRANDTLEPS(p, s)

  27. Isoentropic exponent [-] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspKPS(p, s)

  28. Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspTHERMCONDPS(p, s)

  29. Joule-Thomson coefficient of steam at saturation line [K/Pa] as function of temperature t [K]:

    wspJOULETHOMPSONSST(t)

  30. Joule-Thomson coefficient of water at saturation line [K/Pa] as function of temperature t [K]:

    wspJOULETHOMPSONSWT(t)

  31. Joule-Thomson coefficient in double-phase area [K/Pa] as function of temperature t [K], vapor fraction x [-]:

    wspJOULETHOMPSONSTX(t, x)

  32. Vapor fraction [-] as function of temperature t [K], Joule-Thomson coefficient jt [K/Pa]:

    wspXSTJOULETHOMPSON(t, jt)

  33. Joule-Thomson coefficient in IF-97 region 1 [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSON1PT(p, t)

  34. Joule-Thomson coefficient in IF-97 region 2 [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSON2PT(p, t)

  35. Joule-Thomson coefficient in IF-97 region 3 [K/Pa] as function of density r [kg/m3], temperature t [K]:

    wspJOULETHOMPSON3RT(r, t)

  36. Joule-Thomson coefficient in IF-97 region 3 [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSON3PT(p, t)

  37. Joule-Thomson coefficient in IF-97 region 5 [K/Pa] as function of pressure p [Pa], temperature t [K]:

    wspJOULETHOMPSON5PT(p, t)

  38. Temperature in IF-97 region 1 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT1PH(p, h)

  39. Temperature in IF-97 region 1 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT1PS(p, s)

  40. Temperature in IF-97 region 2a [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT2APH(p, h)

  41. Temperature in IF-97 region 2a [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT2APS(p, s)

  42. Temperature in IF-97 region 2b [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT2BPH(p, h)

  43. Temperature in IF-97 region 2b [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT2BPS(p, s)

  44. Temperature in IF-97 region 2c [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT2CPH(p, h)

  45. Temperature in IF-97 region 2c [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT2CPS(p, s)

  46. Temperature in IF-97 region 2 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT2PH(p, h)

  47. Temperature in IF-97 region 2 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT2PS(p, s)

  48. Temperature in IF-97 region 3 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT3PH(p, h)

  49. Temperature in IF-97 region 3 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT3PS(p, s)

  50. Temperature in IF-97 region 5 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspT5PH(p, h)

  51. Temperature in IF-97 region 5 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspT5PS(p, s)

  52. Pressure at line between areas 2b and 2c [Pa] as function of specific enthalpy h [J/kg]:

    wspP2B2CH(h)

  53. Specific enthalpy at line between areas 2b and 2c [J/kg] as function of pressure p [Pa]:

    wspH2B2CP(p)

  54. IF-97 region as function of pressure p [Pa], specific enthalpy h [J/kg]:

    wspWATERSTATEAREAPH(p, h)

  55. IF-97 region as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

    wspWATERSTATEAREAPS(p, s)

  56. Set and return relative precision in the WaterSteamPro functions [-] as function of tolerance tolerance [-]:

    wspSETTOLERANCE(tolerance)

  57. Relative precision in the WaterSteamPro functions [-]:

    wspGETTOLERANCE()

  58. Set and return a mode of management of make function results more precise as function of mode mode:

    wspSETTOLERANCEMODE(mode)

  59. Mode of management of make function results more precise:

    wspGETTOLERANCEMODE()

  60. Internal version of the WaterSteamPro:

    wspGETWSPVERSION()

Version 5.1

  1. Last error description:

    wspGETLASTERRORDESCRIPTION()

  2. Process registration of the WaterSteamPro as function of registration name name, registration key key:

    wspLOCALREGISTRATION(name, key)

Version 5.0

  1. Surface tension [N/m] as function of temperature t [K]:

    wspSURFTENT(t)

  2. Specific volume [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspVPT(p, t)

  3. Specific internal energy [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspUPT(p, t)

  4. Specific entropy [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspSPT(p, t)

  5. Specific enthalpy [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspHPT(p, t)

  6. Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCPPT(p, t)

  7. Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCVPT(p, t)

  8. Speed of sound [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspWPT(p, t)

  9. Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], temperature t [K]:

    wspTHERMCONDPT(p, t)

  10. Dynamic viscosity [Pa·sec] as function of pressure p [Pa], temperature t [K]:

    wspDYNVISPT(p, t)

  11. Prandtl number [-] as function of pressure p [Pa], temperature t [K]:

    wspPRANDTLEPT(p, t)

  12. Kinematic viscosity [m2/sec] as function of pressure p [Pa], temperature t [K]:

    wspKINVISPT(p, t)

  13. Isoentropic exponent [-] as function of pressure p [Pa], temperature t [K]:

    wspKPT(p, t)

  14. Specific volume [m3/kg] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspVPTX(p, t, x)

  15. Specific internal energy [J/kg] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspUPTX(p, t, x)

  16. Specific entropy [J/(kg·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspSPTX(p, t, x)

  17. Specific enthalpy [J/kg] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspHPTX(p, t, x)

  18. Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspCPPTX(p, t, x)

  19. Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspCVPTX(p, t, x)

  20. Speed of sound [m/sec] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspWPTX(p, t, x)

  21. Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspTHERMCONDPTX(p, t, x)

  22. Dynamic viscosity [Pa·sec] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspDYNVISPTX(p, t, x)

  23. Prandtl number [-] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspPRANDTLEPTX(p, t, x)

  24. Kinematic viscosity [m2/sec] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspKINVISPTX(p, t, x)

  25. Isoentropic exponent [-] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

    wspKPTX(p, t, x)

  26. Pressure at saturation line [Pa] as function of temperature t [K]:

    wspPST(t)

  27. Temperature at saturation line [K] as function of pressure p [Pa]:

    wspTSP(p)

  28. Specific volume of steam at saturation line [m3/kg] as function of temperature t [K]:

    wspVSST(t)

  29. Specific volume of water at saturation line [m3/kg] as function of temperature t [K]:

    wspVSWT(t)

  30. Specific internal energy of steam at saturation line [J/kg] as function of temperature t [K]:

    wspUSST(t)

  31. Specific internal energy of water at saturation line [J/kg] as function of temperature t [K]:

    wspUSWT(t)

  32. Specific entropy of steam at saturation line [J/(kg·K)] as function of temperature t [K]:

    wspSSST(t)

  33. Specific entropy of water at saturation line [J/(kg·K)] as function of temperature t [K]:

    wspSSWT(t)

  34. Specific enthalpy of steam at saturation line [J/kg] as function of temperature t [K]:

    wspHSST(t)

  35. Specific enthalpy of water at saturation line [J/kg] as function of temperature t [K]:

    wspHSWT(t)

  36. Specific isobaric heat capacity of steam at saturation line [J/(kg·K)] as function of temperature t [K]:

    wspCPSST(t)

  37. Specific isobaric heat capacity of water at saturation line [J/(kg·K)] as function of temperature t [K]:

    wspCPSWT(t)

  38. Specific isochoric heat capacity of steam at saturation line from the one-phase region [J/(kg·K)] as function of temperature t [K]:

    wspCVSST(t)

  39. Specific isochoric heat capacity of water at saturation line from the one-phase region [J/(kg·K)] as function of temperature t [K]:

    wspCVSWT(t)

  40. Sound velocity in steam at saturation line [m/sec] as function of temperature t [K]:

    wspWSST(t)

  41. Sound velocity in water at saturation line [m/sec] as function of temperature t [K]:

    wspWSWT(t)

  42. Thermal conductivity coefficient of steam at saturation line [W/(m·K)] as function of temperature t [K]:

    wspTHERMCONDSST(t)

  43. Thermal conductivity coefficient of water at saturation line [W/(m·K)] as function of temperature t [K]:

    wspTHERMCONDSWT(t)

  44. Dynamic viscosity of steam at saturation line [Pa·sec] as function of temperature t [K]:

    wspDYNVISSST(t)

  45. Dynamic viscosity of water at saturation line [Pa·sec] as function of temperature t [K]:

    wspDYNVISSWT(t)

  46. Prandtl number of steam at saturation line [-] as function of temperature t [K]:

    wspPRANDTLESST(t)

  47. Prandtl number of water at saturation line [-] as function of temperature t [K]:

    wspPRANDTLESWT(t)

  48. Kinematic viscosity of steam at saturation line [m2/sec] as function of temperature t [K]:

    wspKINVISSST(t)

  49. Kinematic viscosity of water at saturation line [m2/sec] as function of temperature t [K]:

    wspKINVISSWT(t)

  50. Isoentropic exponent of steam at saturation line [-] as function of temperature t [K]:

    wspKSST(t)

  51. Isoentropic exponent of water at saturation line [-] as function of temperature t [K]:

    wspKSWT(t)

  52. Specific evaporation heat [J/kg] as function of temperature t [K]:

    wspRST(t)

  53. Specific volume in double-phase area [m3/kg] as function of temperature t [K], vapor fraction x [-]:

    wspVSTX(t, x)

  54. Specific internal energy in double-phase area [J/kg] as function of temperature t [K], vapor fraction x [-]:

    wspUSTX(t, x)

  55. Specific entropy in double-phase area [J/(kg·K)] as function of temperature t [K], vapor fraction x [-]:

    wspSSTX(t, x)

  56. Specific enthalpy in double-phase area [J/kg] as function of temperature t [K], vapor fraction x [-]:

    wspHSTX(t, x)

  57. Specific isobaric heat capacity in double-phase area [J/(kg·K)] as function of temperature t [K], vapor fraction x [-]:

    wspCPSTX(t, x)

  58. Specific isochoric heat capacity in double-phase area [J/(kg·K)] as function of temperature t [K], vapor fraction x [-]:

    wspCVSTX(t, x)

  59. Sound velocity in double-phase area [m/sec] as function of temperature t [K], vapor fraction x [-]:

    wspWSTX(t, x)

  60. Thermal conductivity coefficient in double-phase area [W/(m·K)] as function of temperature t [K], vapor fraction x [-]:

    wspTHERMCONDSTX(t, x)

  61. Dynamic viscosity in double-phase area [Pa·sec] as function of temperature t [K], vapor fraction x [-]:

    wspDYNVISSTX(t, x)

  62. Prandtl number in double-phase area [-] as function of temperature t [K], vapor fraction x [-]:

    wspPRANDTLESTX(t, x)

  63. Kinematic viscosity in double-phase area [m2/sec] as function of temperature t [K], vapor fraction x [-]:

    wspKINVISSTX(t, x)

  64. Isoentropic exponent in double-phase area [-] as function of temperature t [K], vapor fraction x [-]:

    wspKSTX(t, x)

  65. Vapor fraction [-] as function of temperature t [K], specific volume v [m3/kg]:

    wspXSTV(t, v)

  66. Vapor fraction [-] as function of temperature t [K], specific internal energy u [J/kg]:

    wspXSTU(t, u)

  67. Vapor fraction [-] as function of temperature t [K], specific entropy s [J/(kg·K)]:

    wspXSTS(t, s)

  68. Vapor fraction [-] as function of temperature t [K], specific enthalpy h [J/kg]:

    wspXSTH(t, h)

  69. Vapor fraction [-] as function of temperature t [K], specific isobaric heat capacity Cp [J/(kg·K)]:

    wspXSTCP(t, Cp)

  70. Vapor fraction [-] as function of temperature t [K], specific isochoric heat capacity Cv [J/(kg·K)]:

    wspXSTCV(t, Cv)

  71. Vapor fraction [-] as function of temperature t [K], speed of sound w [m/sec]:

    wspXSTW(t, w)

  72. Vapor fraction [-] as function of temperature t [K], thermal conductivity coefficient tc [W/(m·K)]:

    wspXSTTHERMCOND(t, tc)

  73. Vapor fraction [-] as function of temperature t [K], dynamic viscosity dv [Pa·sec]:

    wspXSTDYNVIS(t, dv)

  74. Vapor fraction [-] as function of temperature t [K], kinematic viscosity kv [m2/sec]:

    wspXSTKINVIS(t, kv)

  75. Vapor fraction [-] as function of temperature t [K], Prandtl number pr [-]:

    wspXSTPRANDTLE(t, pr)

  76. Vapor fraction [-] as function of temperature t [K], isoentropic exponent k [-]:

    wspXSTK(t, k)

  77. Pressure at line between areas 2 and 3 [Pa] as function of temperature t [K]:

    wspP23T(t)

  78. Temperature at line between areas 2 and 3 [K] as function of pressure p [Pa]:

    wspT23P(p)

  79. IF-97 region as function of pressure p [Pa], temperature t [K]:

    wspWATERSTATEAREA(p, t)

  80. IF-97 region (version 2) as function of pressure p [Pa], temperature t [K]:

    wspWATERSTATEAREA2(p, t)

  81. Thermal conductivity coefficient [W/(m·K)] as function of density r [kg/m3], temperature t [K]:

    wspTHERMCONDRT(r, t)

  82. Dynamic viscosity [Pa·sec] as function of density r [kg/m3], temperature t [K]:

    wspDYNVISRT(r, t)

  83. Specific volume in IF-97 region 1 [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspV1PT(p, t)

  84. Specific internal energy in IF-97 region 1 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspU1PT(p, t)

  85. Specific entropy in IF-97 region 1 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspS1PT(p, t)

  86. Specific enthalpy in IF-97 region 1 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspH1PT(p, t)

  87. Specific isobaric heat capacity in IF-97 region 1 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCP1PT(p, t)

  88. Specific isochoric heat capacity in IF-97 region 1 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCV1PT(p, t)

  89. Sound velocity in IF-97 region 1 [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspW1PT(p, t)

  90. Specific volume in IF-97 region 2 [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspV2PT(p, t)

  91. Specific internal energy in IF-97 region 2 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspU2PT(p, t)

  92. Specific entropy in IF-97 region 2 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspS2PT(p, t)

  93. Specific enthalpy in IF-97 region 2 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspH2PT(p, t)

  94. Specific isobaric heat capacity in IF-97 region 2 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCP2PT(p, t)

  95. Specific isochoric heat capacity in IF-97 region 2 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCV2PT(p, t)

  96. Sound velocity in IF-97 region 2 [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspW2PT(p, t)

  97. Pressure in IF-97 region 3 [Pa] as function of density r [kg/m3], temperature t [K]:

    wspP3RT(r, t)

  98. Density in IF-97 region 3 [kg/m3] as function of pressure p [Pa], temperature t [K], initial density r0 [kg/m3]:

    wspR3PTR0(p, t, r0)

  99. Density in IF-97 region 3 [kg/m3] as function of pressure p [Pa], temperature t [K]:

    wspR3PT(p, t)

  100. Specific internal energy in IF-97 region 3 [J/kg] as function of density r [kg/m3], temperature t [K]:

    wspU3RT(r, t)

  101. Specific entropy in IF-97 region 3 [J/(kg·K)] as function of density r [kg/m3], temperature t [K]:

    wspS3RT(r, t)

  102. Specific enthalpy in IF-97 region 3 [J/kg] as function of density r [kg/m3], temperature t [K]:

    wspH3RT(r, t)

  103. Specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)] as function of density r [kg/m3], temperature t [K]:

    wspCP3RT(r, t)

  104. Specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)] as function of density r [kg/m3], temperature t [K]:

    wspCV3RT(r, t)

  105. Sound velocity in IF-97 region 3 [m/sec] as function of density r [kg/m3], temperature t [K]:

    wspW3RT(r, t)

  106. Specific volume in IF-97 region 3 [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspV3PT(p, t)

  107. Specific internal energy in IF-97 region 3 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspU3PT(p, t)

  108. Specific entropy in IF-97 region 3 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspS3PT(p, t)

  109. Specific enthalpy in IF-97 region 3 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspH3PT(p, t)

  110. Specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCP3PT(p, t)

  111. Specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCV3PT(p, t)

  112. Sound velocity in IF-97 region 3 [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspW3PT(p, t)

  113. Specific volume in IF-97 region 5 [m3/kg] as function of pressure p [Pa], temperature t [K]:

    wspV5PT(p, t)

  114. Specific internal energy in IF-97 region 5 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspU5PT(p, t)

  115. Specific entropy in IF-97 region 5 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspS5PT(p, t)

  116. Specific enthalpy in IF-97 region 5 [J/kg] as function of pressure p [Pa], temperature t [K]:

    wspH5PT(p, t)

  117. Specific isobaric heat capacity in IF-97 region 5 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCP5PT(p, t)

  118. Specific isochoric heat capacity in IF-97 region 5 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

    wspCV5PT(p, t)

  119. Sound velocity in IF-97 region 5 [m/sec] as function of pressure p [Pa], temperature t [K]:

    wspW5PT(p, t)

  120. Set and return a mode of checking the range of functions arguments as function of mode mode:

    wspSETCHECKRANGEMODE(mode)

  121. Mode of checking the range of functions arguments:

    wspGETCHECKRANGEMODE()

  122. Set and return a last error code as function of error code ErrCode:

    wspSETLASTERROR(ErrCode)

  123. Last error code:

    wspGETLASTERROR()

  124. Set and return maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K] as function of temperature delta delta [K]:

    wspSETDELTATS(delta)

  125. Maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K]:

    wspGETDELTATS()

  126. Set and return maximum iterations count for Newton method as function of maximum iteration maxiteration:

    wspSETMAXITERATION(maxiteration)

  127. Maximum iterations count for Newton method:

    wspGETMAXITERATION()

  128. Set and return maximum difference between pressure values at estimation of the area 3 parameters [Pa] as function of delta pressure delta [Pa]:

    wspSETDELTAPRESSURE(delta)

  129. Maximum difference between pressure values at estimation of the area 3 parameters [Pa]:

    wspGETDELTAPRESSURE()

  130. Set and return initial value for density of water in IF-97 region 3 [kg/m3] as function of density r [kg/m3]:

    wspSETINITWATERDENSITY(r)

  131. Initial value for density of water in IF-97 region 3 [kg/m3]:

    wspGETINITWATERDENSITY()

  132. Set and return the initial value for density of steam in IF-97 region 3 [kg/m3] as function of density r [kg/m3]:

    wspSETINITSTEAMDENSITY(r)

  133. Initial value for density of steam in IF-97 region 3 [kg/m3]:

    wspGETINITSTEAMDENSITY()


WaterSteamPro obsolete functions list

  1. Maximum difference between pressure values at estimation of the area 3 parameters [Pa]:

    wspGETDELTAPRESSURE()

  2. Maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K]:

    wspGETDELTATS()

  3. Initial value for density of steam in IF-97 region 3 [kg/m3]:

    wspGETINITSTEAMDENSITY()

  4. Initial value for density of water in IF-97 region 3 [kg/m3]:

    wspGETINITWATERDENSITY()

  5. Process registration of the WaterSteamPro as function of registration name name, registration key key:

    wspLOCALREGISTRATION(name, key)

  6. Set and return maximum difference between pressure values at estimation of the area 3 parameters [Pa] as function of delta pressure delta [Pa]:

    wspSETDELTAPRESSURE(delta)

  7. Set and return maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K] as function of temperature delta delta [K]:

    wspSETDELTATS(delta)

  8. Set and return the initial value for density of steam in IF-97 region 3 [kg/m3] as function of density r [kg/m3]:

    wspSETINITSTEAMDENSITY(r)

  9. Set and return initial value for density of water in IF-97 region 3 [kg/m3] as function of density r [kg/m3]:


WaterSteamPro history

What's new in WaterSteamPro 6.5

  1. Increased area of functions for calculating properties of water/steam up to 50 MPa for temperatures from 800°C to 2000°C (early up to 10 MPa). This changes based on new equations from IAPWS - http://www.iapws.org.
  2. Added functions for calculating (d density / d pressure)enthalpy=const of water/steam in single phase and double phase areas.
  3. Added functions for calculating (d density / d enthalpy)pressure=const of water/steam in single phase and double phase areas.
  4. Added functions for calculating density of water/steam based on IF-97.
  5. Added functions for calculating static dielectric constant of water/steam.
  6. Added functions for calculating ionization constant of water.
  7. Added functions for calculating refractive index of water.
  8. Added function for calculating properties set (including derivatives) in meta-stable region.
  9. Viscosity and based on viscosity properties are calculated with new equation from IAPWS (IAPWS - http://www.iapws.org).
  10. Changed the work of "non-physical" functions (as example wspCPSTX(t, x) - specific heat capacity at constant pressure). Now these functions and functions which depends on thems (as example, wspCPPH(p, h) - specific heat capacity at constant pressure as function of pressure and specific enthalpy) works only when checking for input parameters range is disabled (see functions wspSETCHECKRANGEMODE(mode) and wspGETCHECKRANGEMODE()).
  11. Big changes to module with input parameters range checking. Now there are more matches between different input parameters sets: (p, h), (p, t), (p, s), (h, s).
  12. Changes in some components of WaterSteamPro to allow to proper work in Microsoft Windows Vista/7.
  13. Now WaterSteamPro fully support 32-bit and 64-bit versions of Microsoft Windows (from Windows 98 to Windows 7 and above).
  14. Add-in for Microsoft Excel now works in 32-bit and 64-bit versions of Microsoft Excel (from Microsoft Office 97 to Microsoft Office 2010 and above).
  15. Now available a set of files for using WaterSteamPro in MATLAB (32-bit and 64-bit versions). This files are not included in WaterSteamPro installation packages and available for downloading from Internet-site of WaterSteamPro: http://www.wsp.ru/en.
  16. Now available a set of files for using WaterSteamPro in Scilab (32-bit and 64-bit versions). This files are not included in WaterSteamPro installation packages and available for downloading from Internet-site of WaterSteamPro: http://www.wsp.ru/en.
  17. In installation package added Microsoft Excel worksheet "WaterSteamPro Excel Calculator". This worksheet allow to easy and powerfull calculations of properties of water/steam in Excel.
  18. Now in Microsoft Excel are working functions, which return a set of values. A set of values are return as array. Additional information given in documentation. Sample of usage see in new worksheet for Excel - "WSP Excel Calculator".
  19. Changed a problem for function documentation in "Insert Function" dialog in Mathcad from version 12 and above.
  20. Changes in Active-X object. Now settings are different for different Active-X objects.
  21. Added support for 64-bit Active-X object.
  22. Previous change allow to create Internet-resource http://www.wsp.ru/en/test, which allow to test WaterSteamPro functions online.
  23. Changes in function for determining the IF-97 region for water/steam: now calculation goes down to melting line (early calculations go down to 273.15 K).
  24. In "Insert Function" dialog in Mathcad added information of usage of unit-based WaterSteamPro functions.
  25. Added unit "kPa" to program "WSP Calculator".
  26. Solved the bug in Setup Wizard which allow to not right selection of path for WaterSteamPro documents for Mathcad in case of target path is not exist.
  27. Changes in Setup Wizard.
  28. Changes in documentation.
  29. Changes in license files.
  30. This is the latest version of the WaterSteamPro which works in Windows 9x/Me. Next versions of the WaterSteamPro will support only Windows XP and above.

What's new in version 6.0

  1. New functions for calculation properties depending on parameters (h, s) for all regions of IF-97.
  2. New functions to speed up property calculations in region 3 of IF-97 depending on parameters (p, h), (p, s).
  3. New functions for calculation rough values of density on saturation line for water and steam (wspROUSGHRSWT(t), wspROUGHRSST(t)).
  4. New functions for calculation rough values of specific enthalpy on saturation line for water and steam (wspROUGHHSWS(s), wspROUGHHSSS(s)) depending on parameter (s).
  5. New functions for calculation of initial value for density in region 3 of IF-97 depending on pressure and temperature. That speed up considerably calculation of r(p, t) in region 3 (in my opinion 3 - 5 times faster).
  6. New functions for calculation source properties in regions ## 1, 2, 3, 5 of IF-97 depending on parameters (r, h).
  7. New functions for calculation pressure at sublimation and melting lines.
  8. Changed the algorithm for working with calculation tolerance and regions bounds. Due to this change some functions are absolete and don't used.
  9. New functions for calculation thermodynamic properties of 11 gases (included to air and combustion products) and mixtures on their base in temperature range from 200 to 2500K. Gases and mixtures are processed as ideal gases and ideal mixtures.
  10. Added samples of using gases functions in Excel and Mathcad.
  11. Added sample of using WaterSteamPro functions in Maple.
  12. Added integration module for Maple.
  13. Program WaterSteamPro Calculator is rewritten and new functions have been added in it.
  14. Fully rewritten integration module for Excel (with xll technology).
  15. Solved the problem with displaying WaterSteamPro function help in Excel.
  16. Added program "WaterSteamPro Updater" - now you can quickly check for new WaterSteamPro releases.
  17. Solved the problem for using WaterSteamPro functions in Mathcad 12. Additional information given in documentation.
  18. Bug fixes in functions wspJOULETHOMPSON2PT(p, t), wspCPMSPT(p, t), wspJOULETHOMPSON5PT(p, t), wspVUSHCVWDERPT5PT(p, t), wspPT5RH(r, h), wspPT5HS(h, s).
  19. Extended bounds checking for double-phase area.
  20. New installer is written using the new program. The previous program (IS 5.1) "crashed" making the installer.
  21. Internal calculation of functions is written anew. In this connection and others, the main library of WaterSteamPro is named OKAWSP6.DLL.
  22. Changes in documentation.
  23. Registration mechanism is changed.

What's new in version 5.6

  1. The software package "WaterSteamPro" is recommended by Department of General Inspection for Exploitation of Electrical Power Stations and Networks of Russian Joint Stock Company Unified Energy System of Russia (RAO "UES of Russia" - http://www.rao-ees.ru/en/) for using in power engineering (information letter # IP-14-27-2001 from 03.08.2001).
  2. Calculations are speeded up noticeably. The result you can see here
  3. Eight new functions for combined calculation which allow faster calculation of several properties in one point. Besides, new functions allow calculating derivates of basic properties depending on pressure and temperature. List of new functions is given here.
  4. New function wspDPDTST for calculation derivative of saturation pressure on saturation temperature.
  5. Calculation of properties in double-phase region is changed.
  6. Two functions for calculation isochoric heat capacity (Cv) at saturation line from the double-phase region area. These functions allow properly calculation (that agree with thermodynamic) of the next properties in double-phase area: isochoric heat capacity, isoentropic exponent, sound velocity. List of new functions is given here.
  7. Function wspCVSTX now uses functions mentioned above which consider isochoric heat capacity jump at saturation line. That allow the function to be removed from "non thermodynamic" category.
  8. Function wspKSTX now uses functions mentioned above which consider isochoric heat capacity jump at saturation line. That allow the function to be removed from "non thermodynamic" category.
  9. Function wspWSTX now uses functions mentioned above which consider isochoric heat capacity jump at saturation line. That allow the function to be removed from "non thermodynamic" category.
  10. Function for calculation Joule-Thompson coefficient in double-phase area (wspJOULETHOMPSONSTX) now calculates the value agreed with thermodynamic: JT = (dt/dp)h=const, not as in previous versions by dryness factor. That allow the function to be removed from "non thermodynamic" category.
  11. Added search capability in documentation.

What's new in version 5.5

  1. "WaterSteamPro" received the official certificate from GOSSTANDART OF RUSSIA (http://www.gost.ru) that WaterSteamPro functions reproduce the values from the standard reference data (GSSSD R-776-98) and the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam. The registration number is "AK-35/4" of April 16 2001. You can find the electronic copy of certificate at web site of WaterSteamPro: http://www.wsp.ru/eng/certif.htm.
  2. Thirteen functions for calculation meta-stable area of steam. Here is the list of new functions.
  3. New functions are supported in the program WSP Calculator.
  4. Some improvements in internal code of functions that speed up calculations.
  5. Mathcad Samples were changed greatly.
  6. All new samples for Mathcad are renamed 8.3 formats and installed to subfolder "WaterSteamPro" of your "My Documents" folder.
  7. Code for registration is changed. That does not apply to users registered earlier. No registered users need to change their registration code.
  8. Mathcad file "units.mcd" with additional dimensions for WaterSteamPro is renamed "wspunits.mcd" for unification with Russian version of WaterSteamPro and for compatibility with other user's files. Old file "units.mcd" is included only for compatibility.
  9. Documentation is changed.

What's new in version 5.4

  1. WaterSteamPro received the official certificate from GOSSTANDART OF RUSSIA (http://www.gost.ru) that WaterSteamPro functions reproduce the values from the standard reference data (GSSSD R-776-98) and the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam. The registration number is "AK-35/4" of April 16 2001. You can find the electronic copy of certificate at web site of WaterSteamPro: http://www.wsp.ru/eng/certif.htm. Added 16 new functions for calculating processed of expansion/compression. List of the new functions given here.
  2. Sixteen functions are added for calculation compression/expansion properties in double phase area. Here is the list of new functions.
  3. WaterSteamPro has full support for calculation processes of expansion and compression in double phase area.
  4. There are three new samples of using WaterSteamPro functions for expansion/compression in Mathcad. Search these files in your "My Documents" folder.
  5. Program WSP Calculator was improved.
  6. Registration was improved.

What's new in version 5.3

  1. 1. There are 14 new functions for calculation values in expansion/compression processes. List of the new functions is given here
  2. 2. The registration rules are changed, the details see in section F.A.Q..
  3. 3. File "watersteampro.mcd" for work with beta-version of Mathcad 2001 is changed.

What's new in version 5.2

  1. Fifty nine new functions including thermophysical properties with arguments pressure and entropy listed in new file of documentation function history Description of all functions is renewed.
  2. Functions for Joule-Thompson coefficient calculation.
  3. Function for checking internal version of WaterSteamPro: "wspGETWSPVERSION".
  4. Program "WaterSteamPro Calculator" with new improvements.
  5. Examples of new functions of WaterSteamPro Mathcad files (see graphics). Bugs in sample file of WaterSteamPro for Mathcad is fixed.
  6. WaterSteamPro Add-in for Microsoft Excel has been rewritten. Now "Insert function" Wizard displays the quick reference for selected WaterSteamPro function.
  7. Example of the using WaterSteamPro in Borland Delphi.
  8. New section (several files) for developer.
  9. Some noncritical bug fixes in Excel examples.
  10. Some noncritical bug fixes in installation program.
  11. Documentation have been changed.
  12. New section in "FAQ"
  13. Bug fixes in WSP Calculator connected with dimension of the surface tension.
  14. Bug fixes in library OKAWSP5.DLL. Function wspGETLASTERROR may have returned value 0 (no error) when some floating-point error occurred in a function (the functions always return value "-1" - indicator of error) or checking the argument range was disabled by function wspSETCHECKRANGEMODE.
  15. New section "Special thanks" have been appeared in documentation.

What's new in version 5.1

  1. Function wspGETLASTERRORDESCRIPTION() which returns description of an error.
  2. Program "WaterSteamPro Calculator" is rewritten.
  3. Bug fixes in function wspXSTH(t, h) This function has worked only when range checking was disabled.
  4. Changes in Microsoft Excel add-in OKAWSP5.XLA installation folder, which now installs to Excel folder.
  5. Installation program has been rewritten.
  6. Documentation has been changed.

What's new in version 5.0

  1. All functions have been transferred into C++ and composed into a dynamic-link library (DLL).
  2. Calculation speed in the Mathcad environment have been increased by 8 - 14 times comparing with the earlier versions.
  3. WaterSteamPro package is executable in other program environments now.
  4. WaterSteamPro Calculator is available now with the sources in the Microsoft Windows environment that allows calculation of water and water steam properties.
  5. Examples of WaterSteamPro operation in Microsoft Visual Basic, Microsoft Excel, and even Windows Scripting Host are also available.
  6. New functions for calculation of water and water steam properties (see "List of functions for calculation of water and water steam properties").
  7. All functions have new names for unification (the version is not compatible with WaterSteamPro versions lower than 5.0).
  8. The installer is available now.


F.A.Q.

F.A.Q. (Frequently Asked Questions)

Q: What is the difference of the WaterSteamPro from the other programs?

Q: What's mean "to register a program"?

Q: What's the period for the registration?

Q: How I can increase the speed of the calculations in the WaterSteamPro functions?

Q: The functions of the WaterSteamPro appeared to operate in only SI units. Is there a set of functions which allow passing and returning values in non-SI units?

Q: How to add the WaterSteamPro functions descriptions in 'Insert function' dialog of Mathcad 11?

Q: How to solve the problem with WaterSteamPro functions with dimensions in Mathcad 12?

Answers

top

Q: What is the difference of the WaterSteamPro from the other programs?

A: As source formulas in the WaterSteamPro used the "Industrial" Formulation-97 of the International Association for the Properties of Water and Steam (http://www.iapws.org). This formulation is intended for replacement more old formulation from 1967 year (IF-67). Many programs based upon old formulation. The new formulation more quick and precise than older. In the WaterSteamPro added some functions for more powerfull and easy calculation of the properties of water and steam. In source Formulation IF-97 not calculated the values for Joule-Thompson coefficient, Isoentropic coefficient. But these values may be calculated in the WaterSteamPro. In the WaterSteamPro also added the functions with the arguments (p - pressure, h - specific enthalpy) and (p - pressure, s - specific entropy) for all areas of the IF-97 Formulation.

Next feature of the WaterSteamPro is that you may call it's functions from different programs (as example Mathcad, C/C++, Delphi, Basic, JavaScript/VBScript, HTML-pages). The names of functions, arguments and results will be the same.

top

Q: What's mean "to register a program"?

A: With registration of the WaterSteamPro you will receive your own "registration key". Under WaterSteamPro License only you may use it. Additional information about registration given here.

top

Q: What's the period for the registration?

A: Registration will be continued only for current version of the WaterSteamPro. For all people who's registered WaterSteamPro earlier than 22 January 2001 all future versions will be free. But in current time the registration key for all versions of the WaterSteamPro is the same, so the future versions of the WaterSteamPro may be used with the current registration key. The registration key will be changed in 6 version of the WaterSteamPro. But for registered users the payment for next versions will be with discount.

top

Q: How I can increase the speed of the calculations in the WaterSteamPro functions?

A: For the first you may to uncheck the mode of the checking parameters range. For this you must to call the function wspSETCHECKRANGEMODE(mode) with parameter mode equal to zero.

For the second if you use the functions with arguments (p, h) and (p, s) you may to uncheck the mode of the made answer more precision. For this you must to call the function wspSETTOLERANCEMODE(mode) with parameter mode equal to zero. After that the result of function will be lost the precision. Note that this is only for areas 1 and 2 from the IAPWS IF-97 where the Additional Formulation is exist. In area 3 and 5 used the Newton method for determining the temperature. But in area 1 and 2 for the first calculated the rough value which is after adjusted with Newton method.

If you not want to use the function wspSETTOLERANCEMODE(mode) (see above) you may to less the precision with increasing the speed. As I tell above the Newton method used for adjusting the functions results. This method stopped if difference is less than internal precision. You may to increase the value of the precision and the needed count of the iteration will be decreased. It's will be affect to the speed of the calculations. Note that it's mainly effect to calculation in areas 3 and 5 where only the Newton method used. In other areas (1 and 2) the count of the iteration is small.

top

Q: The functions of the WaterSteamPro appeared to operate in only SI units. Is there a set of functions which allow passing and returning values in non-SI units?

A: The WaterSteamPro is developed to be the world-wide program for calculating properties of water and steam. So for this the all native functions of the WaterSteamPro works with SI units. But you may to overload functions or transform your native units to SI. The program WaterSteamPro Calculator is partially used the well-known relations between units. These relations can be founded in the program Mathcad from MathSoft, Inc.

If you want to see how to manually translate units you may to load example of the usage of the WaterSteamPro in HTML pages (see the WaterSteamPro Program Group/Examples). After the file is loaded to Internet Explorer please select "View Source" from the mouse right-button menu.

The program Mathcad allow to work with units in a high-level. Mathcad will automatically translate to units in needed one. As example please see in documentation the section "Two ways of usage of the WaterSteamPro's functions in Mathcad" or see the file "Two modes of the usage the WaterSteamPro.mcd" in your "My Documents" folder after installing the WaterSteamPro.

top

Q: How to add the WaterSteamPro functions descriptions in 'Insert function' dialog of Mathcad 11?

A: To do it you must do next step:

In Mathcad 11 installation folder (usually it is "C:\Program Files\MathSoft\Mathcad 11") you will find the subfolder named "DOC". In this subfolder you will find the subfolder named "Funcdoc". In last subfolder you will find the file "wspmcad.xml". And this file you must to rename it into "wspsmcad_EN.xml".

Thanks for this advice to rjw57.

top

Q: How to solve the problem with WaterSteamPro functions with dimensions in Mathcad 12?

MathSoft introduced in Mathcad 12 the functions namespaces (see it in MC12 documentation). With this future the WaterSteamPro functions with dimensions will not work.

In file "watersteampro.mcd" WaterSteamPro functions redefined to support the Mathcad units. You can open this document and see it' body.

Also you can manually change this file to support the MC12. To do it you must follow next steps:

1. File "watersteampro.mcd" have the full list of WaterSteamPro functions with next view (as example):

wspPST(t) := wspPST(t / K + 1 - 1) * Pa

2. For each WaterSteamPro functions you must to change the line as follows:

wspPST(t) := wspPST[user](t / K + 1 - 1) * Pa

where [user] - it's MC12 namespace operator. To input it you must to press keystroke: [Ctrl][Shift]N.

3. Save the file "watersteampro.mcd".

When you done this for all the WaterSteamPro functions then they will work in MC12.

This error solved in release version of WaterSteamPro 6.0. For previous versions please use the above mentioned steps to solve it.


Sample of water and steam property calculation using WaterSteamPro

Please input values for arguments:

Pressure:

Temperature:

P = 100000 Pa; T = 373.15 K

Calculated properties:

Specific volume: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. m3/kg

Specific internal energy: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. kJ/kg

Specific enthalpy: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. kJ/kg

Specific entropy: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. J/(kg·K)

Specific heat capacity at constant pressure: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. J/(kg·K)

Specific heat capacity at constant volume: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. J/(kg·K)

Sound velocity: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. m/sec


Literature

1. Release on The IAPWS Formulation-1995 for the Thermodynamic Properties of Ordinary Water Substance for General and Scientific Use. International Association for the Properties of Water and Steam / Executive Secretary R.B. Dooley. Electric Power Research Institute. Palo Alto. CA 94304, USA.

2. IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam. International Association for the Properties of Water and Steam / Executive Secretary R.B. Dooley. Electric Power Research Institute. Palo Alto. CA 94304, USA.

3. A.A. Alexandrov - Formulation IAPWS-IF97 for calculation thermodynamic properties of water and steam for industrial use. 2. Additional formulation / Thermal Energy journal. 1998. # 10. p. 64 – 72.

4. Supplementary Release on Saturation Properties of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A143-149.

5. Release on The IAPS Formulation 1985 for the Viscosity of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A33-48.

6. Release on The IAPWS Formulation 1985 for the Thermal Conductivity of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A49-70.

7. Release on The Surface Tension of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A143-149.

8. A.A.Alexandrov, B.A. Grigoriev – Tables of thermo-phisycs properties of water and steam. Reference book. MPEI, 1999. ISBN 5-7046-0397-1

9. Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam (September 2004).

10. Supplementary Release on Backward Equations for the Functions T(p,h), v(p,h) and T(p,s), v(p,s) for the Critical and Supercritical Regions to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam (August 2003).

11. Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam (September 2001).

12. Rivkin S.L. Thermodynamic properties of gases. Spravochnik. - 4 isd., pererab. M.: Energoatomisdat, 1987. p. 288: il.

13. Комплекс прикладных и учебных интерактивных программ для вычисления термодинамических свойств рабочих тел и теплоносителей / В.В. Сычев, А.А. Александров, А.В. Матвеев, И.В. Царев, З.А. Ершова //Известия вузов. Энергетика, 1990, № 9, 126 - 128.

14. Термодинамические свойства индивидуальных веществ. Справочное издание: в 4-х т./Л.В. Гурвич, И.В. Вейц, В.А. Медведев и др. 3-е изд., перераб. и расширен. Т.1. Кн. 2 М.: Наука, 1978. 328 с.

15. Release on the IAPWS Formulation-1995 for the Thermodynamic Properties of Ordinary Water Substance for General and Scientific Use. International Association for the Properties of Water and Steam / Executive Secretary R.B. Dooley. Electric Power Research Institute. Palo Alto. CA 94304, USA.

16. Cooper, J.R. Representation of the Ideal-Gas Thermodynamic Properties of Water. Int. J. Thermophys. 1982. V. 3. P.35 - 43.

17. Friedman A.S., Haar L. High Speed Machine Computing of Ideal Gas Thermodynamic Functions - I. Isotopic Water Molecules. J. Chem. Phys. 1954. V. 22. P. 2051 - 2058.

18. Vidler M., Tennyson J. Accurate partition function and thermodynamic data for water. Journal of Chemical Physics. Volume 113, Number 21. 1 December 2000.

19. Woolley, H.W., 1980, Thermodynamic Properties for H2O in the Ideal Gas State. Water and Steam: Their Properties and Current Industrial Application, Proceedings of the 9th International Conference on the Properties of Water and Steam, J. Straub and K. Scheffler, eds., Pergamon Press, New York, pp. 166 - 175.

20. Woolley, H.W., 1987, Ideal Gas Thermodynamic Functions for Water. J. Res. Natl. Bur. Stand., 92, pp.35 - 51.

21. Bucker, D., Span, R., Wagner, W. Thermodynamic Property Models for Moist Air and Combustion Gases. ASME Journal of Engineering for Gas Turbines and Power. Vol. 125 January 2003, pp. 374-384.

22. Woolley, H.W., 1954, Thermodynamic Functions for Carbon Dioxide in the Ideal Gas State, Journal of Research of the National Bureau of Standards, 52(6):289.

23. Диоксид углерода жидкий и газообразный. Плотность, фактор сжимаемости, энтальпия, энтропия, изобарная теплоемкость, скорость звука и коэффициент объемного расширения при температурах 220...1300 К и давлениях 0.1...100 МПа. Таблицы стандартных справочных данных. Изд-во стандартов, 1986 г.

24. Термодинамические свойства кислорода: ГСССД. Серия монографии / В.В. Сычев, А.А. Вассерман, А.Д. Козлов, Г.А. Спиридонов, В.А. Цымарный. М.: Изд-во стандартов, 1981., - 340 с., ил.

25. Термодинамические свойства азота. Сычев В.В. и др. М., Изд-во стандартов, 1977. с. 352.

26. Термодинамические свойства воздуха. / Сычев В.В., Вассерман А.А., Козлов А.Д., Спиридонов Г.А., Цымарный В.А. - ГСССД. Серия монографии. М.: Издательство стандартов, 1978. с. 276.

27. Набор программ для расчета теплофизических свойств воды и водяного пара ("WaterSteamPro"). РОСПАТЕНТ, Свидетельство № 2000610803 от 25 августа 2000 г.

28. IVTANTHERMO for Windows. Database on thermodynamic properties of individual substances and thermodynamic modeling software. V.S. Yungman at al. Version 3.0. Glushko Thermocenter of RAS. 1992-2003.

29. McBride, B.J., Gordon, S., 1996, Computer Program for Calculation of Complex Chemical Equilibrium Composition and Applications. NASA RP-1311, National Aeronautics and Space Administration, Washington, DC.

30. McBride, B.J., Gordon, S., 2003, Computer Program for Calculation of Complex Chemical Equilibrium Composition and Applications Version 2 (CEA2). NASA RP-1311, National Aeronautics and Space Administration, Washington, DC.

31. Guideline on the Use of Fundamental Physical Constants and Basic Constants of Water. The International Association for the Properties of Water and Steam (September 2001).

32. Guideline: Tabular Taylor Series Expansion (TTSE) Method for Calculation of Thermodynamic Properties of Water and Steam Applied to IAPWS-95 as an Example. International Association for the Properties of Water and Steam (August 2003).

33. IAPS Supplementary Release: Saturation Properties of Ordinary Water Substance. (September 1992).

34. IAPWS Release on the Values of Temperature, Pressure and Density of Ordinary and Heavy Water Substances at their Respective Critical Points (September 1992).

35. Jacobsen, R.T., Penoncello, S.G., Beyerlein, S.W., Clarke, W.P. and Lemmon, E.W. A Thermodynamic Property Formulation for Air. Fluid Phase Equilibria, 79:113-124, 1992.

36. Jacobsen, R.T., Stewart, R.B., and Jahangiri, M. Thermodynamic Properties of Nitrogen from the Freezing Line to 2000 K at Pressures to 1000 MPa. J. Phys. Chem. Ref. Data, 15(2):735-909, 1986.

37. Katti, R.S., Jacobsen, R.T., Stewart, R.B., and Jahangiri, M. Thermodynamic Properties for Neon for Temperatures from the Triple Point to 700 K at Pressures to 700 MPa. Adv. Cryo. Eng., 31: 1189-1197, 1986.

38. Kretzsehmar, H-J., St?cker, I., Willkommen, T., Tr?benback, J., Dittmann, A. Supplementary equations v(p, t) for the critical region to the new industrial formulation IAPWS-IF97 for water and steam. Steam, water and hydrothermal systems: Physics and chemistry Meeting the Needs of Industry. Proc. of the 13th International Conference on Properties of Water and Steam. NRC Research Press. Ottawa, 2000. p. 225 - 264.

39. McCarty, R.D. and Arp, V.D. A New Wide Range Equation of State for Helium. Adv. Cryo. Eng., 35:1465-1475, 1990.

40. McCarty, R.D. Hydrogen, Technological Survey - Thermophysical Properties. NASA SP-3089, National Aeronautics and Space Administration, 1975.

41. Periodic Table of the Elements at Los Alamos National Laboratory. http://periodic.lanl.gov/default.htm.

42. Release on the IAPWS Formulation-1995 for the Thermodynamic Properties of Ordinary Water Substance for General and Scientific Use. International Association for the Properties of Water and Steam / Executive Secretary R.B. Dooley. Electric Power Research Institute. Palo Alto. CA 94304, USA.

43. Release on the ion product of water substance. International Association for the Properties of Steam (May 1980).

44. Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance". The International Association for the Properties of Water and Steam (September 1993).

45. Revised Release on the IAPS Formulation 1985 for the Viscosity of Ordinary Water Substance. (August 2003).

46. Schmidt, R. and Wagner, W. A New Form of Equation of State for Pure Substances and Its Application to Oxygen. Fluid Phase Equilib., 19:175-200, 1985.

47. Setzmann, U. and Wagner, W. A New Equation of State and Tables of Thermodynamic Properties for Methane Covering the Range from the Melting Line to 625 K at Pressures up to 1000 MPa. J. Phys. Chem. Ref. Data, 20(6):1061-1151, 1991.

48. Span, R. and Wagner, W. A New Equation of State for Carbon Dioxide Covering the Fluid Region from the Triple-Point Temperature to 1100 K at Pressures up to 800 MPa. J. Phys. Chem. Ref. Data, 25(6):1509-1596, 1996.

49. Span, R., Lemmon, E.W., Jacobsen, R.T., Wagner, W., and Yokozeki, A., 2000, "A Reference Equation of State for the Thermodynamic Properties of Nitrogen for Temperature from 63.151 to 1000 K and Pressures up to 2200 MPa." J. Phys. Chem. Ref. Data, accepted for publication 29, pp. 1361 - 1433.

50. Stewart, R.B. and Jacobsen, R.T. Thermodynamic Properties of Argon from the Triple Point to 1200 K at Pressures to 1000 MPa. J. Phys. Chem. Ref. Data, 18(2):639-798, 1989.

51. Supplementary Release on Saturation Properties of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A143-149.

52. Thermodynamic derivatives for water and steam. Solomon L. Rivkin, Aleksey A. Alexandrov, Elena A. Kremenevskaya. Washington, D.C., V.H. Winston & Sons, 1978. - 264 pp., ill.

53. Thermophysical Properties of Humid Air and Combustion-Gas Mixtures. The International Association for the Properties of Water and Steam (July 2002).

54. Александров А.А. Международное уравнение состояния воды и водяного пара / Теплоэнергетика. 1997. № 10. С. 68 - 72.

55. Александров А.А. Система уравнений IAPWS-IF97 для вычисления термодинамических свойств воды и водяного пара в промышленных расчетах. Ч. 1. Основные уравнения / Теплоэнергетика. 1998. № 9. С. 69 - 77.

56. Александров А.А. Система уравнений IAPWS-IF97 для вычисления термодинамических свойств воды и водяного пара в промышленных расчетах. Ч. 2. Дополнительные уравнения / Теплоэнергетика. 1998. № 10. С. 64 - 72.

57. Alexandrov, A.A., Orlov, K.A., Ochkov V.F., Formulations and program for calculating properties of gases and combustion gases / Thermal engineering, in print.

58. Александров А.А., Орлов К.А., Очков В.Ф. Открытые расчеты в энергетике на базе Mathcad Application Server. В печати.

59. Воронец Д., Козич Д. Влажный воздух: термодинамические свойства и применение. Пер. с сербохорв. М.: Энергоатомиздат, 1984. с. 136.

60. Диоксид углерода жидкий и газообразный. Плотность, фактор сжимаемости, энтальпия, энтропия, изобарная теплоемкость, скорость звука и коэффициент объемного расширения при температурах 220:1300 К и давлениях 0.1:100 МПа. Таблицы стандартных справочных данных. Изд-во стандартов, 1986 г.

61. Комплекс прикладных и учебных интерактивных программ для вычисления термодинамических свойств рабочих тел и теплоносителей / В.В. Сычев, А.А. Александров, А.В. Матвеев, И.В. Царев, З.А. Ершова //Известия вузов. Энергетика, 1990, № 9, 126 - 128.

62. Метан жидкий и газообразный, термодинамические свойства, коэффициенты динамической вязкости и теплопроводности при температурах 91...700 К и давлениях 0.1...100 МПа. ГСССД / Козлов А.Д., Мамонов Ю.В., Роговин М.Д., Рыбаков С.И., Степанов С.А., Сычев В.В. М. 2000. 43 c.

63. Набор программ для расчета теплофизических свойств воды и водяного пара ("WaterSteamPro"). РОСПАТЕНТ, Свидетельство № 2000610803 от 25 августа 2000 г.

64. Орлов К.А., Александров А.А., Очков В.Ф., Кондакова Г.Ю., Очков А.В. Разработка современных программных средств для расчета термодинамических свойств воды и свойств водных растворов на основе системы уравнений ISF-95 // VIII Междунар. науч.-техн. конф. студентов и аспирантов: тез. докл. М.: Изд-во МЭИ, 2002. Т. 3. с. 183 - 185.

65. Орлов К.А., Александров А.А., Очков В.Ф., Очков А.В. Программный комплекс "WaterSteamPro" для расчета теплофизических свойств воды и водяного пара // Х Российская Конференция по Теплофизическим Свойствам Веществ: тезисы докладов. Казань: изд-во "Бутлеровские сообщения", 2002. С. 187 - 188.

66. Орлов К.А. Программа "WaterSteamPro" // Компьютерная математика, КомпьютерПресс, № 4'2001.

67. Орлов К.А. Теплофизические свойства воды и водяного пара в Mathcad Professional // Компьютерная математика, КомпьютерПресс, № 12'1999.

68. Очков В.Ф., Утенков В.Ф., Орлов К.А. Теплотехнические расчеты в среде Mathcad. //Теплоэнергетика, 2000. с. 73 - 78.

69. Очков В.Ф. Раздел 5.5.2. "Решение инженерно-технических задач в среде Mathcad" справочника "Теплоэнергетика и теплотехника" Кн.1. М.: Издательство МЭИ, 1999 - 522 с.: ил.

70. Сычев В.В. Новое уравнение для показателя адиабаты влажного пара. // Теплоэнергетика №3 , 1961. с. 67 - 70.

71. Теоретические основы теплотехники. Теплотехнический эксперимент: Справочник / Под общ. ред. чл.-корр. РАН А.В. Клименко и проф. В.М. Зорина. - 3-е изд., перераб. и доп. - М.: Изд-во МЭИ, 2001. - 564 с., ил. - (Теплоэнергетика и теплотехника; Кн. 2).

72. Теплофизические свойства технических важных газов при высоких температурах и давлениях. Справочник / В.Н. Зубарев, А.Д. Козлов, В.М. Кузнецов и др. М.: Энергоатомиздат, 1989. с. 232: ил.

73. Термодинамика парогазовых смесей: Учебное пособие / Г.А. Мухачев. Изд-во Казан. Гос. техн. ун-та. Казань, 1995. 67 с.

74. Orlov K.A. Investigation of combined gas-steam cycles with steam injection on base of developed application programs on properties of working fluids // Doctoral thesis. Moscow Power Engineering Institute, Moscow, 2004.


WaterSteamPro Thanks

  • To begin with I want to thank all who buy and register the program and help me to create new versions of WaterSteamPro. At first I created the program only for internal use (for me) and after a time it was turned into that what you see now.
  • For the second, I thank David E. Baugh from the Benham Electrosynthesis Company who is still hoping to correct my terrible English.
  • My special thanks to other authors of WaterSteamPro. I could not release even the first version of WaterSteamPro without their help.
  • Thanks to Juli Chudova. She help me to translate the documentation.


Copyrights & Trademarks

WaterSteamPro - is registered program and trademark of Moscow Power Engineering Institute (Technical University).

Mathcad - is registered trademark of MathSoft, Inc.

Microsoft, Microsoft Windows, Microsoft Visual Basic, Microsoft Visual Studio, Microsoft Visual C++, Microsoft Office, Visual Basic for Applications (VBA), Microsoft Excel - are registered trademarks of Microsoft Corp. Windows NT - is a trademark of Microsoft Corp.

Delphi - is registered trademark of Borland, Inc.

Other brand and product names are trademarks or registered trademarks of their respective owners.

Section "Structure and Regions of IAPWS-IF97" based upon book: A.A. Alexandrov, B.A. Grigoriev - Tables for thermalphysics properties of water and steam. Reference book. - Moscow.: MPEI, 1999. - 168 pages.


Obsolete WaterSteamPro functions

Version 6.0 of WaterSteamPro and next contain functions which are not used any more. They remain for compatibility but their calling generate the error with number 8 (see error codes).

All these function marked as [image] in the list of WaterSteamPro functions.

List of these functions given here.


Computational speedup in version 5.6

In version 5.6 the mechanism of functions calculation is improved noticeably. The base functions with relative time for its calculation are listed below.

First is the name of function, the next is relative time for calculation of a control point in old version of WaterSteamPro (version 5.5) and then - relative time for calculation of the same point in the new version (5.6) of WaterSteamPro.

The functions, which are not included, based on the listed functions and calculated quicker too.

wspV1PT

Old time: 7.170

New time: 3.314

wspU1PT

Old time: 14.330

New time: 3.575

wspS1PT

Old time: 7.531

New time: 3.665

wspH1PT

Old time: 7.561

New time: 3.274

wspCP1PT

Old time: 6.829

New time: 3.324

wspCV1PT

Old time: 19.828

New time: 4.076

wspW1PT

Old time: 21.270

New time: 3.915

wspT1PH

Old time: 3.715

New time: 2.373

wspT1PS

Old time: 3.725

New time: 2.383

wspJOULETHOMPSON1PT

Old time: 13.419

New time: 3.825

wspDYNVISRT

Old time: 4.477

New time: 2.944

wspV2PT

Old time: 8.852

New time: 4.176

wspU2PT

Old time: 18.216

New time: 4.997

wspS2PT

Old time: 14.981

New time: 4.596

wspH2PT

Old time: 9.774

New time: 4.556

wspCP2PT

Old time: 10.214

New time: 4.616

wspCV2PT

Old time: 26.888

New time: 4.947

wspW2PT

Old time: 25.576

New time: 4.977

wspT2APH

Old time: 7.090

New time: 3.425

wspT2BPH

Old time: 7.771

New time: 3.715

wspT2CPH

Old time: 4.546

New time: 2.473

wspT2APS

Old time: 8.963

New time: 6.529

wspT2BPS

Old time: 7.651

New time: 3.355

wspT2CPS

Old time: 5.488

New time: 2.523

wspJOULETHOMPSON2PT

Old time: 17.365

New time: 4.486

wspP3RT

Old time: 7.611

New time: 3.595

wspU3RT

Old time: 7.741

New time: 3.545

wspS3RT

Old time: 15.502

New time: 3.835

wspH3RT

Old time: 15.091

New time: 3.635

wspCP3RT

Old time: 22.372

New time: 4.046

wspCV3RT

Old time: 7.42

New time: 3.625

wspW3RT

Old time: 23.624

New time: 4.076

wspJOULETHOMPSON3RT

Old time: 22.993

New time: 4.066

wspT3PH

Old time: 7.000

New time: 0.881

wspT3PS

Old time: 19.778

New time: 2.473

wspV5PT

Old time: 9.654

New time: 12.177

wspU5PT

Old time: 8.181

New time: 4.797

wspS5PT

Old time: 8.543

New time: 4.867

wspH5PT

Old time: 5.177

New time: 4.646

wspCP5PT

Old time: 5.317

New time: 4.786

wspCV5PT

Old time: 10.885

New time: 5.237

wspW5PT

Old time: 10.996

New time: 5.337

wspT5PH

Old time: 4.706

New time: 2.443

wspT5PS

Old time: 4.767

New time: 2.533

wspJOULETHOMPSON5PT

Old time: 8.031

New time: 4.877

wspVMSPT

Old time: 12.468

New time: 11.386

wspUMSPT

Old time: 15.232

New time: 12.227

wspSMSPT

Old time: 15.001

New time: 12.187

wspHMSPT

Old time: 12.878

New time: 12.087

wspCPMSPT

Old time: 12.848

New time: 12.157

wspCVMSPT

Old time: 17.305

New time: 12.327

wspWMSPT

Old time: 17.365

New time: 12.387

wspJOULETHOMPSONMSPT

Old time: 15.071

New time: 12.147


wspCP1PT

Specific isobaric heat capacity in IF-97 region 1 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCP1PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity in IF-97 region 1 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspCP2PT

Specific isobaric heat capacity in IF-97 region 2 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCP2PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity in IF-97 region 2 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspCP3PT

Specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCP3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)], type: double.

Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCP3RT

Specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)] as function of density r [kg/m3], temperature t [K]:

wspCP3RT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity in IF-97 region 3 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspCP5PT

Specific isobaric heat capacity in IF-97 region 5 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCP5PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity in IF-97 region 5 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspCPEXPANSIONPTPEFF

Specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspCPEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCPEXPANSIONPTXPEFF

Specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspCPEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific isobaric heat capacity at the end of expansion/compression process [J/(kg·K)], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCPHS

Specific isobaric heat capacity [J/(kg·K)] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspCPHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCPMSPT

Specific isobaric heat capacity of meta-stable supercooled steam [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCPMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity of meta-stable supercooled steam [J/(kg·K)], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspCPPH

Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspCPPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspCPxPT or wspCPSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCPPS

Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspCPPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspCPxPT or wspCPSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCPPT

Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCPPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspCPxPT) is used.


wspCPPTX

Specific isobaric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspCPPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspCPxPT or wspCPSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspCPSST

Specific isobaric heat capacity of steam at saturation line [J/(kg·K)] as function of temperature t [K]:

wspCPSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity of steam at saturation line [J/(kg·K)], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspCPSTX

Specific isobaric heat capacity in double-phase area [J/(kg·K)] as function of temperature t [K], vapor fraction x [-]:

wspCPSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific isobaric heat capacity in double-phase area [J/(kg·K)], type: double.

Function uses functions wspCPSST and wspCPSWT which return specific heat capacities at constant pressure (Cp) of steam and water at saturation line. The function uses following formula: CPx = (1 - X)·CPw + X·CPs, where CPs = wspCPSST, CPw = wspCPSWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.


wspCPSWT

Specific isobaric heat capacity of water at saturation line [J/(kg·K)] as function of temperature t [K]:

wspCPSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity of water at saturation line [J/(kg·K)], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspCV1PT

Specific isochoric heat capacity in IF-97 region 1 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCV1PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity in IF-97 region 1 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspCV2PT

Specific isochoric heat capacity in IF-97 region 2 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCV2PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity in IF-97 region 2 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspCV3PT

Specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCV3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)], type: double.

Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCV3RT

Specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)] as function of density r [kg/m3], temperature t [K]:

wspCV3RT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity in IF-97 region 3 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspCV5PT

Specific isochoric heat capacity in IF-97 region 5 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCV5PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity in IF-97 region 5 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspCVDPSST

Specific isochoric heat capacity of steam at saturation line from the double-phase region [J/(kg·K)] as function of temperature t [K]:

wspCVDPSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity of steam at saturation line from the double-phase region [J/(kg·K)], type: double.

Function returns the sum of specific isochoric heat capacity of steam from one-phase region (function wspCVSST) and additional increment calculated by corresponding thermodynamic formulas. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspCVDPSWT

Specific isochoric heat capacity of water at saturation line from the double-phase region [J/(kg·K)] as function of temperature t [K]:

wspCVDPSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity of water at saturation line from the double-phase region [J/(kg·K)], type: double.

Function returns the sum of specific isochoric heat capacity of water from one-phase region (function wspCVSWT) and additional increment calculated by corresponding thermodynamic formulas. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspCVEXPANSIONPTPEFF

Specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspCVEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCVEXPANSIONPTXPEFF

Specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspCVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific isochoric heat capacity at the end of expansion/compression process [J/(kg·K)], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCVHS

Specific isochoric heat capacity [J/(kg·K)] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspCVHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCVMSPT

Specific isochoric heat capacity of meta-stable supercooled steam [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCVMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity of meta-stable supercooled steam [J/(kg·K)], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspCVPH

Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspCVPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspCVxPT or wspCVSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCVPS

Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspCVPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspCVxPT or wspCVSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspCVPT

Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspCVPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspCVxPT) is used.


wspCVPTX

Specific isochoric heat capacity [J/(kg·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspCVPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspCVxPT or wspCVSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspCVSST

Specific isochoric heat capacity of steam at saturation line from the one-phase region [J/(kg·K)] as function of temperature t [K]:

wspCVSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity of steam at saturation line from the one-phase region [J/(kg·K)], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspCVSTX

Specific isochoric heat capacity in double-phase area [J/(kg·K)] as function of temperature t [K], vapor fraction x [-]:

wspCVSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific isochoric heat capacity in double-phase area [J/(kg·K)], type: double.

Function uses functions wspCVDPSST and wspCVDPSWT which return specific heat capacities at constant volume (Cv) of steam and water at saturation line in the double-phase region area. The function uses following formula: CVx = (1 - X)·CVDPw + X·CVDPs, where CVDPs = wspCVDPSST, CVDPw = wspCVDPSWT and X - vapor fraction. This function used functions wspCVSST and wspCVSWT until version 5.6 which is not conform to thermodynamic, because it neglects the jump of properties at saturation line. The range of validity is double-phase (water-vapor) area.


wspCVSWT

Specific isochoric heat capacity of water at saturation line from the one-phase region [J/(kg·K)] as function of temperature t [K]:

wspCVSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity of water at saturation line from the one-phase region [J/(kg·K)], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspD1PT

Density in IF-97 region 1 [kg/m3] as function of pressure p [Pa], temperature t [K]:

wspD1PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – density in IF-97 region 1 [kg/m3], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspD2PT

Density in IF-97 region 2 [kg/m3] as function of pressure p [Pa], temperature t [K]:

wspD2PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – density in IF-97 region 2 [kg/m3], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspD3PT

Density in IF-97 region 3 [kg/m3] as function of pressure p [Pa], temperature t [K]:

wspD3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – density in IF-97 region 3 [kg/m3], type: double.

Function calculates the density in region 3 by calling the function wspR3PTR0 with the corresponding initial estimate for density. Used for unification of the functions in all IF-97 regions. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspD5PT

Density in IF-97 region 5 [kg/m3] as function of pressure p [Pa], temperature t [K]:

wspD5PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – density in IF-97 region 5 [kg/m3], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspDCPT

Static dielectric constant of ordinary water substance [-] as function of pressure p [Pa], temperature t [K]:

wspDCPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – static dielectric constant of ordinary water substance [-], type: double.

Function is based upon the function wspDCRT(r, t). The latest in it's turn is based upon the "Release on the Static Dielectric Constant of Ordinary Water Substance for Temperatures from 238K to 873K and Pressures up to 1000 MPa", 1997 from IAPWS. The range of validity is from 238 to 273K in the metastable liquid at atmospheric pressure (0.101325 MPa); from 273 to 323 K at pressures up to the lower of the ice IV melting pressure or 1000 MPa; above 323 K at pressures up to 600 MPa. The formulation also extrapolates smoothly up to at least 1200 K and 1200 MPa.


wspDCRT

Static dielectric constant of ordinary water substance [-] as function of density r [kg/m3], temperature t [K]:

wspDCRT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – static dielectric constant of ordinary water substance [-], type: double.

Function is based upon the "Release on the Static Dielectric Constant of Ordinary Water Substance for Temperatures from 238K to 873K and Pressures up to 1000 MPa", 1997 from IAPWS. The range of validity is from 238 to 273K in the metastable liquid at atmospheric pressure (0.101325 MPa); from 273 to 323 K at pressures up to the lower of the ice IV melting pressure or 1000 MPa; above 323 K at pressures up to 600 MPa. The formulation also extrapolates smoothly up to at least 1200 K and 1200 MPa.


wspDDDHPPH

Derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspDDDHPPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspDDDHPPT

Derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5] as function of pressure p [Pa], temperature t [K]:

wspDDDHPPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspDDDHPxPT) is used.


wspDDDHPPTX

Derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspDDDHPPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – derivate of density on enthalpy with constant pressure of water/steam [kg·sec2/m5], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspDDDHPxPT or wspDDDHPSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspDDDHPSST

Derivate of density on enthalpy with constant pressure of steam at saturation line [kg·sec2/m5] as function of temperature t [K]:

wspDDDHPSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – derivate of density on enthalpy with constant pressure of steam at saturation line [kg·sec2/m5], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspDDDHPSWT

Derivate of density on enthalpy with constant pressure of water at saturation line [kg·sec2/m5] as function of temperature t [K]:

wspDDDHPSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – derivate of density on enthalpy with constant pressure of water at saturation line [kg·sec2/m5], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspDDDPHPH

Derivate of density on pressure with constant enthalpy of water/steam [sec2/m2] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspDDDPHPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – derivate of density on pressure with constant enthalpy of water/steam [sec2/m2], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspDDDPHPT

Derivate of density on pressure with constant enthalpy of water/steam [sec2/m2] as function of pressure p [Pa], temperature t [K]:

wspDDDPHPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – derivate of density on pressure with constant enthalpy of water/steam [sec2/m2], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspDDDPHxPT) is used.


wspDDDPHPTX

Derivate of density on pressure with constant enthalpy of water/steam [sec2/m2] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspDDDPHPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – derivate of density on pressure with constant enthalpy of water/steam [sec2/m2], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspDDDPHxPT or wspDDDPHSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspDDDPHSST

Derivate of density on pressure with constant enthalpy of steam at saturation line [sec2/m2] as function of temperature t [K]:

wspDDDPHSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – derivate of density on pressure with constant enthalpy of steam at saturation line [sec2/m2], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspDDDPHSWT

Derivate of density on pressure with constant enthalpy of water at saturation line [sec2/m2] as function of temperature t [K]:

wspDDDPHSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – derivate of density on pressure with constant enthalpy of water at saturation line [sec2/m2], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspDPDTST

Derivative of saturation pressure on saturation temperature [Pa/K] as function of temperature t [K]:

wspDPDTST(t)

where:

  • t – temperature [K], type: double;
  • Return value – derivative of saturation pressure on saturation temperature [Pa/K], type: double.

Function is based upon "Supplementary Release on Saturation Properties of Ordinary Water Substance" from International Association for the Properties of Water and Steam. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspDPT

Density [kg/m3] as function of pressure p [Pa], temperature t [K]:

wspDPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – density [kg/m3], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspDxPT) is used.


wspDPTX

Density [kg/m3] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspDPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – density [kg/m3], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspDxPT or wspDSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspDSST

Density of steam at saturation line [kg/m3] as function of temperature t [K]:

wspDSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – density of steam at saturation line [kg/m3], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspDSTX

Density in double-phase area [kg/m3] as function of temperature t [K], vapor fraction x [-]:

wspDSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – density in double-phase area [kg/m3], type: double.

Function uses the function named wspVSTX which return specific volume in double-phase area. The function uses following formula: Dx = 1 / Vx, where Vx = wspVSTX(t, x). The range of validity is double-phase (water-vapor) area.


wspDSWT

Density of water at saturation line [kg/m3] as function of temperature t [K]:

wspDSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – density of water at saturation line [kg/m3], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspDYNVISEXPANSIONPTPEFF

Dynamic viscosity at the end of expansion/compression process [Pa·sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspDYNVISEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – dynamic viscosity at the end of expansion/compression process [Pa·sec], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspDYNVISEXPANSIONPTXPEFF

Dynamic viscosity at the end of expansion/compression process [Pa·sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspDYNVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – dynamic viscosity at the end of expansion/compression process [Pa·sec], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspDYNVISHS

Dynamic viscosity [Pa·sec] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspDYNVISHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – dynamic viscosity [Pa·sec], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspDYNVISMSPT

Dynamic viscosity of meta-stable supercooled steam [Pa·sec] as function of pressure p [Pa], temperature t [K]:

wspDYNVISMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – dynamic viscosity of meta-stable supercooled steam [Pa·sec], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspDYNVISPH

Dynamic viscosity [Pa·sec] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspDYNVISPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – dynamic viscosity [Pa·sec], type: double.

The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspDYNVISPT or wspDYNVISSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspDYNVISPS

Dynamic viscosity [Pa·sec] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspDYNVISPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – dynamic viscosity [Pa·sec], type: double.

The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspDYNVISPT or wspDYNVISSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspDYNVISPT

Dynamic viscosity [Pa·sec] as function of pressure p [Pa], temperature t [K]:

wspDYNVISPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – dynamic viscosity [Pa·sec], type: double.

The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspDYNVISRT is used for calculation the argument of which is density defined by reverse value of the function wspVPT.


wspDYNVISPTX

Dynamic viscosity [Pa·sec] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspDYNVISPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – dynamic viscosity [Pa·sec], type: double.

The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspDYNVISPT or wspDYNVISSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspDYNVISRT

Dynamic viscosity [Pa·sec] as function of density r [kg/m3], temperature t [K]:

wspDYNVISRT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – dynamic viscosity [Pa·sec], type: double.

Function is based upon the Revised Release on the IAPS Formulation 1985 for the Viscosity of Ordinary Water Substance with correction for ITS-90 (International Temperature Scale). The range of validity is for pressure up to 500 MPa temperature is from 0 to 150°C, for pressure up to 350 MPa temperature is from 150 to 600°C, for pressure up to 300 MPa temperature is from 600 to 900°C.


wspDYNVISSST

Dynamic viscosity of steam at saturation line [Pa·sec] as function of temperature t [K]:

wspDYNVISSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – dynamic viscosity of steam at saturation line [Pa·sec], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspDYNVISSTX

Dynamic viscosity in double-phase area [Pa·sec] as function of temperature t [K], vapor fraction x [-]:

wspDYNVISSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – dynamic viscosity in double-phase area [Pa·sec], type: double.

Function uses functions wspDYNVISSST and wspDYNVISSWT which return dynamic viscosity of steam and water at saturation line. The function uses following formula: DYNVISx = (1 - X)·DYNVISw + X·DYNVISs, where DYNVISs = wspDYNVISSST, DYNVISw = wspDYNVISSWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.


wspDYNVISSWT

Dynamic viscosity of water at saturation line [Pa·sec] as function of temperature t [K]:

wspDYNVISSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – dynamic viscosity of water at saturation line [Pa·sec], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspgADDGASM

Addition of one gas to another as function of identificator of target gas id_target, identificator of added gas id_source, added gas mass mass:

wspgADDGASM(id_target, id_source, mass)

where:

  • id_target – identificator of target gas, type: long;
  • id_source – identificator of added gas, type: long;
  • mass – added gas mass, type: double;
  • Return value – addition of one gas to another, type: long.

Function adds the specified mass of one gas (given by it's identificator id_source) to another gases compound (given by gas identificator id_target).


wspgADDGASV

Addition of one gas to another as function of identificator of target gas id_target, identificator of added gas id_source, added gas volume volume:

wspgADDGASV(id_target, id_source, volume)

where:

  • id_target – identificator of target gas, type: long;
  • id_source – identificator of added gas, type: long;
  • volume – added gas volume, type: double;
  • Return value – addition of one gas to another, type: long.

Function adds the specified volume (or moles count) of one gas (given by it's identificator id_source) to another gases compound (given by gas identificator id_target).


wspgCPGST

Specific isobaric heat capacity [J/(kg·K)] as function of gas specification gas_specification, temperature t [K]:

wspgCPGST(gas_specification, t)

where:

  • gas_specification – gas specification, type: string;
  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

Function calculates specific isobaric heat capacity for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgCPIDT

Specific isobaric heat capacity [J/(kg·K)] as function of gas identificator id, temperature t [K]:

wspgCPIDT(id, t)

where:

  • id – gas identificator, type: long;
  • t – temperature [K], type: double;
  • Return value – specific isobaric heat capacity [J/(kg·K)], type: double.

Function calculates specific isobaric heat capacity for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgCVGST

Specific isochoric heat capacity [J/(kg·K)] as function of gas specification gas_specification, temperature t [K]:

wspgCVGST(gas_specification, t)

where:

  • gas_specification – gas specification, type: string;
  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

Function calculates specific isochoric heat capacity for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgCVIDT

Specific isochoric heat capacity [J/(kg·K)] as function of gas identificator id, temperature t [K]:

wspgCVIDT(id, t)

where:

  • id – gas identificator, type: long;
  • t – temperature [K], type: double;
  • Return value – specific isochoric heat capacity [J/(kg·K)], type: double.

Function calculates specific isochoric heat capacity for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgDELETEGASES

Deleting of all user-defined gases:

wspgDELETEGASES()

where:

  • Return value – deleting of all user-defined gases, type: long.

Function removes all user-defined gases. Also the memory for these gases is freed. After call to this function only built-in gases are available.

Note: In Mathcad function have one parameter which value is not used.


wspgDELETEGASID

Deleting of early created gas as function of gas identificator id:

wspgDELETEGASID(id)

where:

  • id – gas identificator, type: long;
  • Return value – deleting of early created gas, type: long.

Function removes gas with given identificator. Also the memory for this gas is freed.


wspGETABSOLUTEGASCONSTANT

Absolute gas constant [J/(mole·K)]:

wspGETABSOLUTEGASCONSTANT()

where:

  • Return value – absolute gas constant [J/(mole·K)], type: double.

Function returns value of absolute gas constant used in gases equations of WaterSteamPro.

Note: In Mathcad function have one parameter which value is not used.


wspGETCHECKRANGEMODE

Mode of checking the range of functions arguments:

wspGETCHECKRANGEMODE()

where:

  • Return value – mode of checking the range of functions arguments, type: long.

Function returns zero if the checking is disabled.

Note: In Mathcad function have one parameter which value is not used.


wspGETDELTAPRESSURE

Maximum difference between pressure values at estimation of the area 3 parameters [Pa]:

wspGETDELTAPRESSURE()

where:

  • Return value – maximum difference between pressure values at estimation of the area 3 parameters [Pa], type: double.

Function is obsolete. From version 6.0 it is not used!

Note: In Mathcad function have one parameter which value is not used.

Note: This function is obsolete and it is recommended don't use it.


wspGETDELTATS

Maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K]:

wspGETDELTATS()

where:

  • Return value – maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K], type: double.

Function is obsolete and not used from version 6.0!

Note: In Mathcad function have one parameter which value is not used.

Note: This function is obsolete and it is recommended don't use it.


wspGETINITSTEAMDENSITY

Initial value for density of steam in IF-97 region 3 [kg/m3]:

wspGETINITSTEAMDENSITY()

where:

  • Return value – initial value for density of steam in IF-97 region 3 [kg/m3], type: double.

Function is obsolete. From version 6.0 it is not used!

Note: In Mathcad function have one parameter which value is not used.

Note: This function is obsolete and it is recommended don't use it.


wspGETINITWATERDENSITY

Initial value for density of water in IF-97 region 3 [kg/m3]:

wspGETINITWATERDENSITY()

where:

  • Return value – initial value for density of water in IF-97 region 3 [kg/m3], type: double.

Function is obsolete. From version 6.0 it is not used!

Note: In Mathcad function have one parameter which value is not used.

Note: This function is obsolete and it is recommended don't use it.


wspGETLASTERROR

Last error code:

wspGETLASTERROR()

where:

  • Return value – last error code, type: long.

Function returns last error occurred in any functions except the system functions. Any function call (except those systems) set the error code to zero (no error).

Note: In Mathcad function have one parameter which value is not used.


wspGETLASTERRORDESCRIPTION

Last error description:

wspGETLASTERRORDESCRIPTION()

where:

  • Return value – last error description, type: string.

Function returns last error description occurred in the function except those systems. The result of function is defined in library OKAWSP6.DLL as LPCSTR (ANSI-symbols), but in ActiveX-object WSP.WSPCalculator - as BSTR (Unicode). You must use the ActiveX-version of function in Visual Basic. If you use non Active-X component you do not have to care about freeing memory because this function uses the static buffer to return values.

Note: In Mathcad function have one parameter which value is not used.


wspGETLASTERRORDESCRIPTIONW

Last error description:

wspGETLASTERRORDESCRIPTIONW()

where:

  • Return value – last error description, type: unicodestring.

Function returns last error description occurred in any function call except those systems.

Note: In Mathcad function have one parameter which value is not used.


wspGETMAXITERATION

Maximum iterations count for Newton method:

wspGETMAXITERATION()

where:

  • Return value – maximum iterations count for Newton method, type: long.

This number is used for the Newton method. If number of iterations is more than that value the error WSP_CANT_FIND_ROOT (3) occurs.

Note: In Mathcad function have one parameter which value is not used.


wspGETTOLERANCE

Relative precision in the WaterSteamPro functions [-]:

wspGETTOLERANCE()

where:

  • Return value – relative precision in the WaterSteamPro functions [-], type: double.

Return the current value of tolerance. It is used in functions which require the relative precision.

Note: In Mathcad function have one parameter which value is not used.


wspGETTOLERANCEMODE

Mode of management of make function results more precise:

wspGETTOLERANCEMODE()

where:

  • Return value – mode of management of make function results more precise, type: long.

Function return the current mode of functions result improvement. It is used when result of a function can be improved (function with arguments p, h and p, s). If result equals to zero improvement is disabled. Otherwise enabled. See also function wspSETTOLERANCEMODE.

Note: In Mathcad function have one parameter which value is not used.


wspGETWSPVERSION

Internal version of the WaterSteamPro:

wspGETWSPVERSION()

where:

  • Return value – internal version of the WaterSteamPro, type: double.

The format of version is x.yzzz where x - major version, y - minor version, zzz - revision.

Note: In Mathcad function have one parameter which value is not used.


wspgGASESCOUNT

Available gases count:

wspgGASESCOUNT()

where:

  • Return value – available gases count, type: long.

Function return count of all gases: built-in and user-defined.

Note: In Mathcad function have one parameter which value is not used.


wspgGCGS

Specific gas constant [J/(kg·K)] as function of gas specification gas_specification:

wspgGCGS(gas_specification)

where:

  • gas_specification – gas specification, type: string;
  • Return value – specific gas constant [J/(kg·K)], type: double.


wspgGCID

Specific gas constant [J/(kg·K)] as function of gas identificator id:

wspgGCID(id)

where:

  • id – gas identificator, type: long;
  • Return value – specific gas constant [J/(kg·K)], type: double.


wspgGETCALCDISSMODE

Mode of calculating dissociation while calculate gases mixtures:

wspgGETCALCDISSMODE()

where:

  • Return value – mode of calculating dissociation while calculate gases mixtures, type: long.

Function is used in functions for gas mixture properties. If mode equals to 0 dissociation is not calculated. If mode equals to 1 dissociation is calculated always. If mode equals to 2 dissociation is calculated only for temperatures above 1200 K.

Note: In Mathcad function have one parameter which value is not used.


wspgHGST

Specific enthalpy [J/kg] as function of gas specification gas_specification, temperature t [K]:

wspgHGST(gas_specification, t)

where:

  • gas_specification – gas specification, type: string;
  • t – temperature [K], type: double;
  • Return value – specific enthalpy [J/kg], type: double.

Function calculates specific enthalpy for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgHIDT

Specific enthalpy [J/kg] as function of gas identificator id, temperature t [K]:

wspgHIDT(id, t)

where:

  • id – gas identificator, type: long;
  • t – temperature [K], type: double;
  • Return value – specific enthalpy [J/kg], type: double.

Function calculates specific enthalpy for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgIDNAME

Gas identificator as function of existing gas name name:

wspgIDNAME(name)

where:

  • name – existing gas name, type: string;
  • Return value – gas identificator, type: long.

Function return the identificator of early defined gas (or built-in). If there is no gas with this name the error (with code WSP_E_BAD_PARAMS) is generated.


wspgMFGSGS

Mass fraction (MF) of gas as function of primary gas specification gas_spec_looked, gas specification looked for gas_spec_looked_for:

wspgMFGSGS(gas_spec_looked, gas_spec_looked_for)

where:

  • gas_spec_looked – primary gas specification, type: string;
  • gas_spec_looked_for – gas specification looked for, type: string;
  • Return value – mass fraction (MF) of gas, type: double.

Function calculates specific mass fraction of gas (given by gas specification in gas_spec_looked_for) in gas (given by gas specification in gas_spec_looked).


wspgMFIDID

Mass fraction (MF) of gas as function of primary gas identificator id_looked, gas identificator looked for id_looked_for:

wspgMFIDID(id_looked, id_looked_for)

where:

  • id_looked – primary gas identificator, type: long;
  • id_looked_for – gas identificator looked for, type: long;
  • Return value – mass fraction (MF) of gas, type: double.

Function calculates specific mass fraction of gas (given by gas identificator in id_looked_for) in gas (given by gas identificator in id_looked).


wspgMMGS

Molar mass [kg/mole] as function of gas specification gas_specification:

wspgMMGS(gas_specification)

where:

  • gas_specification – gas specification, type: string;
  • Return value – molar mass [kg/mole], type: double.


wspgMMID

Molar mass [kg/mole] as function of gas identificator id:

wspgMMID(id)

where:

  • id – gas identificator, type: long;
  • Return value – molar mass [kg/mole], type: double.


wspgNEWID

New gas identificator:

wspgNEWID()

where:

  • Return value – new gas identificator, type: long.

Function define new gas and return of identificator of new gas. The memory for this gas must be freed when work with this gas is finished by calling the function wspgDELETEGASID or wspgDELETEGASES. Otherwise the memory will be freed only when calling program is finished.

Note: In Mathcad function have one parameter which value is not used.


wspgNEWIDGS

New gas identificator as function of gas specification gas_specification:

wspgNEWIDGS(gas_specification)

where:

  • gas_specification – gas specification, type: string;
  • Return value – new gas identificator, type: long.

Function define new gas and return of identificator of new gas which is fit with given specification. The memory for this gas must be freed when work with this gas is finished by calling the function wspgDELETEGASID or wspgDELETEGASES. Otherwise the memory will be freed only when calling program is finished.


wspgNEWIDNAME

Gas identificator as function of new gas name name:

wspgNEWIDNAME(name)

where:

  • name – new gas name, type: string;
  • Return value – gas identificator, type: long.

Function define new gas and return identificator of this gas. If there is gas with this same name the error (with code WSP_E_BAD_PARAMS) is generated. The memory for this gas must be freed when work with this gas is finished by calling the function wspgDELETEGASID or wspgDELETEGASES. Otherwise the memory will be freed only when calling program is finished.


wspgPGSTS

Pressure [Pa] as function of gas specification gas_specification, temperature t [K], specific entropy s [J/(kg·K)]:

wspgPGSTS(gas_specification, t, s)

where:

  • gas_specification – gas specification, type: string;
  • t – temperature [K], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – pressure [Pa], type: double.

Function calculates pressure for the gas specification in ideal state at given specific entropy and temperature. The range of validity is temperatures from 200K to 2500K.


wspgPIDTS

Pressure [Pa] as function of gas identificator id, temperature t [K], specific entropy s [J/(kg·K)]:

wspgPIDTS(id, t, s)

where:

  • id – gas identificator, type: long;
  • t – temperature [K], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – pressure [Pa], type: double.

Function calculates pressure for the gas in ideal state at given specific entropy and temperature. The range of validity is temperatures from 200K to 2500K.


wspgSETCALCDISSMODE

Set and return a mode of calculating dissociation while calculate gases mixtures as function of mode mode:

wspgSETCALCDISSMODE(mode)

where:

  • mode – mode, type: long;
  • Return value – set and return a mode of calculating dissociation while calculate gases mixtures, type: long.

Function is used in functions for gas mixture properties. If mode equals to 0 dissociation is not calculated. If mode equals to 1 dissociation is calculated always. If mode equals to 2 dissociation is calculated only for temperatures above 1200 K.


wspgSGSPT

Specific entropy [J/(kg·K)] as function of gas specification gas_specification, pressure p [Pa], temperature t [K]:

wspgSGSPT(gas_specification, p, t)

where:

  • gas_specification – gas specification, type: string;
  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific entropy [J/(kg·K)], type: double.

Function calculates specific entropy for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgSGST

Specific entropy at pressure p0 = 100 kPa [J/(kg·K)] as function of gas specification gas_specification, temperature t [K]:

wspgSGST(gas_specification, t)

where:

  • gas_specification – gas specification, type: string;
  • t – temperature [K], type: double;
  • Return value – specific entropy at pressure p0 = 100 kPa [J/(kg·K)], type: double.

Function calculates specific entropy for the given gas specification in ideal state at pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.


wspgSIDPT

Specific entropy [J/(kg·K)] as function of gas identificator id, pressure p [Pa], temperature t [K]:

wspgSIDPT(id, p, t)

where:

  • id – gas identificator, type: long;
  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific entropy [J/(kg·K)], type: double.

Function calculates specific entropy for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgSIDT

Specific entropy at pressure p0 = 100 kPa [J/(kg·K)] as function of gas identificator id, temperature t [K]:

wspgSIDT(id, t)

where:

  • id – gas identificator, type: long;
  • t – temperature [K], type: double;
  • Return value – specific entropy at pressure p0 = 100 kPa [J/(kg·K)], type: double.

Function calculates specific entropy for the gas in ideal state at pressure 100 kPa. The range of validity is temperatures from 200K to 2500K.


wspgTGSH

Temperature [K] as function of gas specification gas_specification, specific enthalpy h [J/kg]:

wspgTGSH(gas_specification, h)

where:

  • gas_specification – gas specification, type: string;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature [K], type: double.

Function calculates temperature for the gas specification in ideal state at given specific enthalpy. The range of validity is temperatures from 200K to 2500K.


wspgTGSPS

Temperature [K] as function of gas specification gas_specification, pressure p [Pa], specific entropy s [J/(kg·K)]:

wspgTGSPS(gas_specification, p, s)

where:

  • gas_specification – gas specification, type: string;
  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature [K], type: double.

Function calculates temperature for the gas specification in ideal state at given specific entropy and pressure. The range of validity is temperatures from 200K to 2500K.


wspgTGSS

Temperature at pressure p0 = 100 kPa [K] as function of gas specification gas_specification, specific entropy s [J/(kg·K)]:

wspgTGSS(gas_specification, s)

where:

  • gas_specification – gas specification, type: string;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature at pressure p0 = 100 kPa [K], type: double.

Function calculates temperature for the gas specification in ideal state at given specific entropy and pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.


wspgTIDH

Temperature [K] as function of gas identificator id, specific enthalpy h [J/kg]:

wspgTIDH(id, h)

where:

  • id – gas identificator, type: long;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature [K], type: double.

Function calculates temperature for the gas in ideal state at given specific enthalpy. The range of validity is temperatures from 200K to 2500K.


wspgTIDPS

Temperature [K] as function of gas identificator id, pressure p [Pa], specific entropy s [J/(kg·K)]:

wspgTIDPS(id, p, s)

where:

  • id – gas identificator, type: long;
  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature [K], type: double.

Function calculates temperature for the gas in ideal state at given specific entropy and pressure. The range of validity is temperatures from 200K to 2500K.


wspgTIDS

Temperature at pressure p0 = 100 kPa [K] as function of gas identificator id, specific entropy s [J/(kg·K)]:

wspgTIDS(id, s)

where:

  • id – gas identificator, type: long;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature at pressure p0 = 100 kPa [K], type: double.

Function calculates temperature for the gas in ideal state at given specific entropy and pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.


wspgUGST

Specific internal energy [J/kg] as function of gas specification gas_specification, temperature t [K]:

wspgUGST(gas_specification, t)

where:

  • gas_specification – gas specification, type: string;
  • t – temperature [K], type: double;
  • Return value – specific internal energy [J/kg], type: double.

Function calculates specific internal energy for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgUIDT

Specific internal energy [J/kg] as function of gas identificator id, temperature t [K]:

wspgUIDT(id, t)

where:

  • id – gas identificator, type: long;
  • t – temperature [K], type: double;
  • Return value – specific internal energy [J/kg], type: double.

Function calculates specific internal energy for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgVFGSGS

Volume fraction (VF) of gas as function of primary gas specification gas_spec_looked, gas specification looked for gas_spec_looked_for:

wspgVFGSGS(gas_spec_looked, gas_spec_looked_for)

where:

  • gas_spec_looked – primary gas specification, type: string;
  • gas_spec_looked_for – gas specification looked for, type: string;
  • Return value – volume fraction (VF) of gas, type: double.

Function calculates specific volume fraction of gas (given by gas specification in gas_spec_looked_for) in gas (given by gas specification in gas_spec_looked).


wspgVFIDID

Volume fraction (VF) of gas as function of primary gas identificator id_looked, gas identificator looked for id_looked_for:

wspgVFIDID(id_looked, id_looked_for)

where:

  • id_looked – primary gas identificator, type: long;
  • id_looked_for – gas identificator looked for, type: long;
  • Return value – volume fraction (VF) of gas, type: double.

Function calculates specific volume fraction of gas (given by gas identificator in id_looked_for) in gas (given by gas identificator in id_looked).


wspgVGSPT

Specific volume [m3/kg] as function of gas specification gas_specification, pressure p [Pa], temperature t [K]:

wspgVGSPT(gas_specification, p, t)

where:

  • gas_specification – gas specification, type: string;
  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific volume [m3/kg], type: double.

Function calculates specific volume for the given gas specification in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgVGST

Specific volume at pressure p0 = 100 kPa [m3/kg] as function of gas specification gas_specification, temperature t [K]:

wspgVGST(gas_specification, t)

where:

  • gas_specification – gas specification, type: string;
  • t – temperature [K], type: double;
  • Return value – specific volume at pressure p0 = 100 kPa [m3/kg], type: double.

Function calculates specific volume for the given gas specification in ideal state at pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.


wspgVIDPT

Specific volume [m3/kg] as function of gas identificator id, pressure p [Pa], temperature t [K]:

wspgVIDPT(id, p, t)

where:

  • id – gas identificator, type: long;
  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific volume [m3/kg], type: double.

Function calculates specific volume for the gas in ideal state. The range of validity is temperatures from 200K to 2500K.


wspgVIDT

Specific volume at pressure p0 = 100 kPa [m3/kg] as function of gas identificator id, temperature t [K]:

wspgVIDT(id, t)

where:

  • id – gas identificator, type: long;
  • t – temperature [K], type: double;
  • Return value – specific volume at pressure p0 = 100 kPa [m3/kg], type: double.

Function calculates specific volume for the gas in ideal state at pressure p0 = 100 kPa. The range of validity is temperatures from 200K to 2500K.


wspH1PT

Specific enthalpy in IF-97 region 1 [J/kg] as function of pressure p [Pa], temperature t [K]:

wspH1PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific enthalpy in IF-97 region 1 [J/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspH2B2CP

Specific enthalpy at line between areas 2b and 2c [J/kg] as function of pressure p [Pa]:

wspH2B2CP(p)

where:

  • p – pressure [Pa], type: double;
  • Return value – specific enthalpy at line between areas 2b and 2c [J/kg], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspH2PT

Specific enthalpy in IF-97 region 2 [J/kg] as function of pressure p [Pa], temperature t [K]:

wspH2PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific enthalpy in IF-97 region 2 [J/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspH3PT

Specific enthalpy in IF-97 region 3 [J/kg] as function of pressure p [Pa], temperature t [K]:

wspH3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific enthalpy in IF-97 region 3 [J/kg], type: double.

Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspH3RT

Specific enthalpy in IF-97 region 3 [J/kg] as function of density r [kg/m3], temperature t [K]:

wspH3RT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – specific enthalpy in IF-97 region 3 [J/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspH5PT

Specific enthalpy in IF-97 region 5 [J/kg] as function of pressure p [Pa], temperature t [K]:

wspH5PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific enthalpy in IF-97 region 5 [J/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspHB13S

Specific enthalpy at boundary line between areas 1 and 3 [J/kg] as function of specific entropy s [J/(kg·K)]:

wspHB13S(s)

where:

  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific enthalpy at boundary line between areas 1 and 3 [J/kg], type: double.

Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004).


wspHEXPANSIONPTPEFF

Specific enthalpy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspHEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific enthalpy at the end of expansion/compression process [J/kg], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspHEXPANSIONPTXPEFF

Specific enthalpy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspHEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific enthalpy at the end of expansion/compression process [J/kg], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspHMSPT

Specific enthalpy of meta-stable supercooled steam [J/kg] as function of pressure p [Pa], temperature t [K]:

wspHMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific enthalpy of meta-stable supercooled steam [J/kg], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspHPS

Specific enthalpy [J/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspHPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific enthalpy [J/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspHxPT or wspHSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspHPT

Specific enthalpy [J/kg] as function of pressure p [Pa], temperature t [K]:

wspHPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific enthalpy [J/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspHxPT) is used.


wspHPTX

Specific enthalpy [J/kg] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspHPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific enthalpy [J/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspHxPT or wspHSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspHSST

Specific enthalpy of steam at saturation line [J/kg] as function of temperature t [K]:

wspHSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific enthalpy of steam at saturation line [J/kg], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspHSTX

Specific enthalpy in double-phase area [J/kg] as function of temperature t [K], vapor fraction x [-]:

wspHSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific enthalpy in double-phase area [J/kg], type: double.

Function uses functions wspHSST and wspHSWT which return specific enthalpies of steam and water at saturation line. The function uses following formula: Hx = (1 - X)·Hw + X·Hs, where Hs = wspHSST, Hw = wspHSWT and X - vapor fraction. The range of validity is double-phase (water-vapor) area.


wspHSWT

Specific enthalpy of water at saturation line [J/kg] as function of temperature t [K]:

wspHSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific enthalpy of water at saturation line [J/kg], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspJOULETHOMPSON1PT

Joule-Thomson coefficient in IF-97 region 1 [K/Pa] as function of pressure p [Pa], temperature t [K]:

wspJOULETHOMPSON1PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – Joule-Thomson coefficient in IF-97 region 1 [K/Pa], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The equation: JT = (T*dV/dT - V)/Cp is used, where T - temperature, dV/dT - differential quotient (dV/dT)p, V - volume, Cp - isobaric heat capacity (Cp).


wspJOULETHOMPSON2PT

Joule-Thomson coefficient in IF-97 region 2 [K/Pa] as function of pressure p [Pa], temperature t [K]:

wspJOULETHOMPSON2PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – Joule-Thomson coefficient in IF-97 region 2 [K/Pa], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The equation: JT = (T*dV/dT - V)/Cp is used, where T - temperature, dV/dT - differential quotient (dV/dT)p, V - volume, Cp - isobaric heat capacity (Cp).


wspJOULETHOMPSON3PT

Joule-Thomson coefficient in IF-97 region 3 [K/Pa] as function of pressure p [Pa], temperature t [K]:

wspJOULETHOMPSON3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – Joule-Thomson coefficient in IF-97 region 3 [K/Pa], type: double.

Function calculates Joule-Thomson coefficient for region 3 of IF-97 Formulation. This function uses function wspR3PT(p, t) to calculate density and then returns the value from the function wspJOULETHOMPSON3RT(r, t). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspJOULETHOMPSON3RT

Joule-Thomson coefficient in IF-97 region 3 [K/Pa] as function of density r [kg/m3], temperature t [K]:

wspJOULETHOMPSON3RT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – Joule-Thomson coefficient in IF-97 region 3 [K/Pa], type: double.

Function calculates the Joule-Thomson coefficient for region 3 of IF-97 Formulation.


wspJOULETHOMPSON5PT

Joule-Thomson coefficient in IF-97 region 5 [K/Pa] as function of pressure p [Pa], temperature t [K]:

wspJOULETHOMPSON5PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – Joule-Thomson coefficient in IF-97 region 5 [K/Pa], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The equation: JT = (T*dV/dT - V)/Cp is used, where T - temperature, dV/dT - differential quotient (dV/dT)p, V - volume, Cp - isobaric heat capacity (Cp).


wspJOULETHOMPSONEXPANSIONPTPEFF

Joule-Thomson coefficient at the end of expansion/compression process [K/Pa] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspJOULETHOMPSONEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – Joule-Thomson coefficient at the end of expansion/compression process [K/Pa], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspJOULETHOMPSONEXPANSIONPTXPEFF

Joule-Thomson coefficient at the end of expansion/compression process [K/Pa] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspJOULETHOMPSONEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – Joule-Thomson coefficient at the end of expansion/compression process [K/Pa], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspJOULETHOMPSONHS

Joule-Thomson coefficient [K/Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspJOULETHOMPSONHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – Joule-Thomson coefficient [K/Pa], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspJOULETHOMPSONMSPT

Joule-Thomson coefficient of meta-stable supercooled steam [K/Pa] as function of pressure p [Pa], temperature t [K]:

wspJOULETHOMPSONMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – Joule-Thomson coefficient of meta-stable supercooled steam [K/Pa], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspJOULETHOMPSONPH

Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspJOULETHOMPSONPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – Joule-Thomson coefficient [K/Pa], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspJOULETHOMPSONPT or wspJOULETHOMPSONSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspJOULETHOMPSONPS

Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspJOULETHOMPSONPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – Joule-Thomson coefficient [K/Pa], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspJOULETHOMPSONPT or wspJOULETHOMPSONSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspJOULETHOMPSONPT

Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], temperature t [K]:

wspJOULETHOMPSONPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – Joule-Thomson coefficient [K/Pa], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspJOULETHOMPSONxPT) is used.


wspJOULETHOMPSONPTX

Joule-Thomson coefficient [K/Pa] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspJOULETHOMPSONPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – Joule-Thomson coefficient [K/Pa], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspJOULETHOMPSONPT or wspJOULETHOMPSONSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspJOULETHOMPSONSST

Joule-Thomson coefficient of steam at saturation line [K/Pa] as function of temperature t [K]:

wspJOULETHOMPSONSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – Joule-Thomson coefficient of steam at saturation line [K/Pa], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspJOULETHOMPSONSTX

Joule-Thomson coefficient in double-phase area [K/Pa] as function of temperature t [K], vapor fraction x [-]:

wspJOULETHOMPSONSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – Joule-Thomson coefficient in double-phase area [K/Pa], type: double.

Function calculate the Joule-Thomson coefficient in double-phase area by equation at saturation line: JT = (dT/dP)h. Until version 5.6 the function used wspJOULETHOMPSONSST and wspJOULETHOMPSONSWT and returned value from following formula: JTx = (1 - X)·JOULETHOMPSONw + X·JOULETHOMPSONs, where JOULETHOMPSONs = wspJOULETHOMPSONSST, JOULETHOMPSONw = wspJOULETHOMPSONSWT and X - vapor vapor fraction that did not conform to definition of Joule-Thomson coefficient. Now it calculates correctly. The range of validity is double-phase (water-vapor) area.


wspJOULETHOMPSONSWT

Joule-Thomson coefficient of water at saturation line [K/Pa] as function of temperature t [K]:

wspJOULETHOMPSONSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – Joule-Thomson coefficient of water at saturation line [K/Pa], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspKEXPANSIONPTPEFF

Isoentropic exponent at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspKEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – isoentropic exponent at the end of expansion/compression process [-], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKEXPANSIONPTXPEFF

Isoentropic exponent [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspKEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – isoentropic exponent [-], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKHS

Isoentropic exponent [-] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspKHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – isoentropic exponent [-], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKINVISEXPANSIONPTPEFF

Kinematic viscosity at the end of expansion/compression process [m2/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspKINVISEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – kinematic viscosity at the end of expansion/compression process [m2/sec], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKINVISEXPANSIONPTXPEFF

Kinematic viscosity at the end of expansion/compression process [m2/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspKINVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – kinematic viscosity at the end of expansion/compression process [m2/sec], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKINVISHS

Kinematic viscosity [m2/sec] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspKINVISHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – kinematic viscosity [m2/sec], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKINVISMSPT

Kinematic viscosity of meta-stable supercooled steam [m2/sec] as function of pressure p [Pa], temperature t [K]:

wspKINVISMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – kinematic viscosity of meta-stable supercooled steam [m2/sec], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspKINVISPH

Kinematic viscosity [m2/sec] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspKINVISPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – kinematic viscosity [m2/sec], type: double.

The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspKINVISPT or wspKINVISSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKINVISPS

Kinematic viscosity [m2/sec] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspKINVISPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – kinematic viscosity [m2/sec], type: double.

The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspKINVISPT or wspKINVISSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKINVISPT

Kinematic viscosity [m2/sec] as function of pressure p [Pa], temperature t [K]:

wspKINVISPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – kinematic viscosity [m2/sec], type: double.

The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The equation is: KINVIS = DYNVIS · V is used for calculation, where DYNVIS defined by the function wspDYNVISPT and V - by wspVPT.


wspKINVISPTX

Kinematic viscosity [m2/sec] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspKINVISPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – kinematic viscosity [m2/sec], type: double.

The range of the validity is within that described in IF-97 and in formulation for dynamic viscosity (see function wspDYNVISRT). The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspKINVISPT or wspKINVISSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspKINVISSST

Kinematic viscosity of steam at saturation line [m2/sec] as function of temperature t [K]:

wspKINVISSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – kinematic viscosity of steam at saturation line [m2/sec], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspKINVISSTX

Kinematic viscosity in double-phase area [m2/sec] as function of temperature t [K], vapor fraction x [-]:

wspKINVISSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – kinematic viscosity in double-phase area [m2/sec], type: double.

Function uses functions wspKINVISSST and wspKINVISSWT which return kinematic viscosities of steam and water at saturation line. The function uses next formula: KINVISx = (1 - X)·KINVISw + X·KINVISs, where KINVISs = wspKINVISSST, KINVISw = wspKINVISSWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.


wspKINVISSWT

Kinematic viscosity of water at saturation line [m2/sec] as function of temperature t [K]:

wspKINVISSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – kinematic viscosity of water at saturation line [m2/sec], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspKMSPT

Isoentropic exponent of meta-stable supercooled steam [-] as function of pressure p [Pa], temperature t [K]:

wspKMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – isoentropic exponent of meta-stable supercooled steam [-], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspKPH

Isoentropic exponent [-] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspKPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – isoentropic exponent [-], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspKPT or wspKSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKPS

Isoentropic exponent [-] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspKPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – isoentropic exponent [-], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspKPT or wspKSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspKPT

Isoentropic exponent [-] as function of pressure p [Pa], temperature t [K]:

wspKPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – isoentropic exponent [-], type: double.

The range of the validity is within that described in IF-97. Used equation is: K = W · W / (P · V) is used for calculation, where W (sound velocity) is defined by the function wspWPT, P - pressure and V (specific volume) - by wspVPT.


wspKPTX

Isoentropic exponent [-] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspKPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – isoentropic exponent [-], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspKPT or wspKSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspKSST

Isoentropic exponent of steam at saturation line [-] as function of temperature t [K]:

wspKSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – isoentropic exponent of steam at saturation line [-], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspKSTX

Isoentropic exponent in double-phase area [-] as function of temperature t [K], vapor fraction x [-]:

wspKSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – isoentropic exponent in double-phase area [-], type: double.

Function calculate isoentropic exponent in double-phase area considering property jump at saturation line. Until version 5.6 this function uses following formula: Kx = (1 - X)·Kw + X·Ks, where Ks = wspKSST, Kw = wspKSWT and X - vapor fraction. But that is not agree with thermodynamic. Now it is calculated properly. The range of validity is double-phase (water-vapor) area.


wspKSWT

Isoentropic exponent of water at saturation line [-] as function of temperature t [K]:

wspKSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – isoentropic exponent of water at saturation line [-], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspLOCALREGISTRATION

Process registration of the WaterSteamPro as function of registration name name, registration key key:

wspLOCALREGISTRATION(name, key)

where:

  • name – registration name, type: string;
  • key – registration key, type: string;
  • Return value – process registration of the WaterSteamPro, type: void.

Function was used in "Developer" license of WaterSteamPro. This function is obsolete.

Note: This function is obsolete and it is recommended don't use it.


wspLOCALREGISTRATIONEXA

Process registration of the WaterSteamPro as function of registration name name, registration data data:

wspLOCALREGISTRATIONEXA(name, data)

where:

  • name – registration name, type: string;
  • data – registration data, type: long;
  • Return value – process registration of the WaterSteamPro, type: double.

Function is used in "Developer" license of WaterSteamPro. For more information see WaterSteamPro SDK.


wspLOCALREGISTRATIONEXW

Process registration of the WaterSteamPro as function of registration name name, registration data data:

wspLOCALREGISTRATIONEXW(name, data)

where:

  • name – registration name, type: unicodestring;
  • data – registration data, type: long;
  • Return value – process registration of the WaterSteamPro, type: double.

Function is used in "Developer" license of WaterSteamPro. For more information see WaterSteamPro SDK.


wspP1HS

Pressure in IF-97 region 1 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspP1HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – pressure in IF-97 region 1 [Pa], type: double.

Function is based upon "Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2001). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspP2B2CH

Pressure at line between areas 2b and 2c [Pa] as function of specific enthalpy h [J/kg]:

wspP2B2CH(h)

where:

  • h – specific enthalpy [J/kg], type: double;
  • Return value – pressure at line between areas 2b and 2c [Pa], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspP2HS

Pressure in IF-97 region 2 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspP2HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – pressure in IF-97 region 2 [Pa], type: double.

Function is based upon "Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2001) and used the functions: wspP2AHS(h, s), wspP2BHS(h, s) and wspP2CHS(h, s). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspP3HS

Pressure in IF-97 region 3 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspP3HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – pressure in IF-97 region 3 [Pa], type: double.

Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspP3RT

Pressure in IF-97 region 3 [Pa] as function of density r [kg/m3], temperature t [K]:

wspP3RT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – pressure in IF-97 region 3 [Pa], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspP5HS

Pressure in IF-97 region 5 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspP5HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – pressure in IF-97 region 5 [Pa], type: double.

Function is used to find the pressure in region 5 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspP23T

Pressure at line between areas 2 and 3 [Pa] as function of temperature t [K]:

wspP23T(t)

where:

  • t – temperature [K], type: double;
  • Return value – pressure at line between areas 2 and 3 [Pa], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam. Used in function wspWATERSTATEAREA when region of IF-97 is determined.


wspPB23HS

Pressure at boundary line between areas 2 and 3 [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspPB23HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – pressure at boundary line between areas 2 and 3 [Pa], type: double.

Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004).


wspPHASESTATEPT

Area of phase state as function of pressure p [Pa], temperature t [K]:

wspPHASESTATEPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – area of phase state, type: long.

Function returns code of phase state in point with given p, t. If pressure p or temperature t are above critical (Prk or Tkr), the result is "3" (phase state - supercritical). If the point is situated above the saturation line (in P-T diagramm) the result is "1" (phase state - liquid). If the point is situated below the saturation line (in P-T diagram) the result is "2" (phase state - steam). If point is situated below triple point, the return is error value ("-1").


wspPHS

Pressure [Pa] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspPHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – pressure [Pa], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspPKWPT

Negative logarithm (base 10) of the ionization constant of water [-] as function of pressure p [Pa], temperature t [K]:

wspPKWPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – negative logarithm (base 10) of the ionization constant of water [-], type: double.

Function is based upon the function wspPKWRT(r, t). The latest in it's turn based upon the "Release on the Ionization Constant of H2O, August 2007" from IAPWS.


wspPKWRT

Negative logarithm (10 base) of the ionization constant of water [-] as function of density r [kg/m3], temperature t [K]:

wspPKWRT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – negative logarithm (10 base) of the ionization constant of water [-], type: double.

Function is based upon the "Release on the Ionization Constant of H2O, August 2007" from IAPWS.


wspPMELTIT

Pressure at melting line of ice I [Pa] as function of temperature t [K]:

wspPMELTIT(t)

where:

  • t – temperature [K], type: double;
  • Return value – pressure at melting line of ice I [Pa], type: double.

Function is based on "Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance" IAPWS (Milan, Italy, September 1993).


wspPRANDTLEEXPANSIONPTPEFF

Prandtl number at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspPRANDTLEEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – Prandtl number at the end of expansion/compression process [-], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspPRANDTLEEXPANSIONPTXPEFF

Prandtl number at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspPRANDTLEEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – Prandtl number at the end of expansion/compression process [-], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspPRANDTLEHS

Prandtl number [-] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspPRANDTLEHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – Prandtl number [-], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspPRANDTLEMSPT

Prandtl number of meta-stable supercooled steam [-] as function of pressure p [Pa], temperature t [K]:

wspPRANDTLEMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – Prandtl number of meta-stable supercooled steam [-], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspPRANDTLEPH

Prandtl number [-] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspPRANDTLEPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – Prandtl number [-], type: double.

The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspPRANDTLEPT or wspPRANDTLESTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspPRANDTLEPS

Prandtl number [-] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspPRANDTLEPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – Prandtl number [-], type: double.

The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspPRANDTLEPT or wspPRANDLTESTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspPRANDTLEPT

Prandtl number [-] as function of pressure p [Pa], temperature t [K]:

wspPRANDTLEPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – Prandtl number [-], type: double.

The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity. The equation is: Pr = DYNVIS · CP / THERMCOND is used for calculation, where DYNVIS is calculated by the function wspDYNVISPT, CP - by wspCPPT and THERMCOND - by wspTHERMCONDPT.


wspPRANDTLEPTX

Prandtl number [-] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspPRANDTLEPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – Prandtl number [-], type: double.

The range of the validity is within that described in IF-97 and in formulations for the properties included in the equation to calculate sought quantity (see function wspPRANDTLEPT, wspTHERMCONDRT, wspDYNVISRT). The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspPRANDTLEPPT or wspPRANDTLEPSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspPRANDTLESST

Prandtl number of steam at saturation line [-] as function of temperature t [K]:

wspPRANDTLESST(t)

where:

  • t – temperature [K], type: double;
  • Return value – Prandtl number of steam at saturation line [-], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspPRANDTLESTX

Prandtl number in double-phase area [-] as function of temperature t [K], vapor fraction x [-]:

wspPRANDTLESTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – Prandtl number in double-phase area [-], type: double.

Function uses functions wspPRANDTLESST and wspPRANDTLESWT which returns Prandtl numbers of steam and water at saturation line. The function uses following formula: PRANDTLEx = (1 - X)·PRANDTLEw + X·PRANDTLEs, where PRANDTLEs = wspPRANDTLESST, PRANDTLEw = wspPRANDTLESWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.


wspPRANDTLESWT

Prandtl number of water at saturation line [-] as function of temperature t [K]:

wspPRANDTLESWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – Prandtl number of water at saturation line [-], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspPST

Pressure at saturation line [Pa] as function of temperature t [K]:

wspPST(t)

where:

  • t – temperature [K], type: double;
  • Return value – pressure at saturation line [Pa], type: double.

Function is based upon the Supplementary Release on Saturation Properties of Ordinary Water Substance from IAPWS. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspPSUBT

Pressure at sublimation line [Pa] as function of temperature t [K]:

wspPSUBT(t)

where:

  • t – temperature [K], type: double;
  • Return value – pressure at sublimation line [Pa], type: double.

Function is based on "Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance" IAPWS (Milan, Italy, September 1993).


wspPT1HS

Properties calculation result in IF-97 region 1 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspPT1HS(h, s, *p, *t)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • p – pressure [Pa], type: double. Warning! It's output parameter;
  • t – temperature [K], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 1, type: double.

Function is used to find parameters in region 1 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspPT1RH

Properties calculation result in IF-97 region 1 as function of density r [kg/m3], specific enthalpy h [J/kg]:

wspPT1RH(r, h, *p, *t)

where:

  • r – density [kg/m3], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • p – pressure [Pa], type: double. Warning! It's output parameter;
  • t – temperature [K], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 1, type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (r, h) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (r, h) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspPT2HS

Properties calculation result in IF-97 region 2 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspPT2HS(h, s, *p, *t)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • p – pressure [Pa], type: double. Warning! It's output parameter;
  • t – temperature [K], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 2, type: double.

Function is used to find parameters in region 2 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspPT2RH

Properties calculation result in IF-97 region 2 as function of density r [kg/m3], specific enthalpy h [J/kg]:

wspPT2RH(r, h, *p, *t)

where:

  • r – density [kg/m3], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • p – pressure [Pa], type: double. Warning! It's output parameter;
  • t – temperature [K], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 2, type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (r, h) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (r, h) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspPT3HS

Properties calculation result in IF-97 region 3 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspPT3HS(h, s, *p, *t)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • p – pressure [Pa], type: double. Warning! It's output parameter;
  • t – temperature [K], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 3, type: double.

Function is based on function wspRT3HS. After calling wspRT3HS the standard equations are used to determine the pressure. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspPT5HS

Properties calculation result in IF-97 region 5 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspPT5HS(h, s, *p, *t)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • p – pressure [Pa], type: double. Warning! It's output parameter;
  • t – temperature [K], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 5, type: double.

Function is used to find parameters in region 5 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspPT5RH

Properties calculation result in IF-97 region 5 as function of density r [kg/m3], specific enthalpy h [J/kg]:

wspPT5RH(r, h, *p, *t)

where:

  • r – density [kg/m3], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • p – pressure [Pa], type: double. Warning! It's output parameter;
  • t – temperature [K], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 5, type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (r, h) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (r, h) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspPTHS

Properties calculation result as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspPTHS(h, s, *p, *t)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • p – pressure [Pa], type: double. Warning! It's output parameter;
  • t – temperature [K], type: double. Warning! It's output parameter;
  • Return value – properties calculation result, type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantities are calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspR3PT

Density in IF-97 region 3 [kg/m3] as function of pressure p [Pa], temperature t [K]:

wspR3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – density in IF-97 region 3 [kg/m3], type: double.

Function calculates the density in region 3 by calling the function wspR3PTR0 with the corresponding initial estimate for density. Used for unification of the functions in all IF-97 regions. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspR3PTR0

Density in IF-97 region 3 [kg/m3] as function of pressure p [Pa], temperature t [K], initial density r0 [kg/m3]:

wspR3PTR0(p, t, r0)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • r0 – initial density [kg/m3], type: double;
  • Return value – density in IF-97 region 3 [kg/m3], type: double.

Function used the Newton method with initial estimate for density to calculate the density. Used for unification of the functions in all IF-97 regions. Since at some stages the function use iterations, to speed up calculations you may vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspRIPTL

Refractive index [-] as function of pressure p [Pa], temperature t [K], wave length wavelength [m]:

wspRIPTL(p, t, wavelength)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • wavelength – wave length [m], type: double;
  • Return value – refractive index [-], type: double.

Function is based upon the function wspRIRTL(r, t, wavelength). The latest in it's turn is based upon the "Release on the Refractive Index of Ordinary Water Substance as a Function of Wavelength, Temperature and Pressure", 1997 from IAPWS. The range of validity is: temperatures from -12 to 500°C, densities up to 1060 kg/m3, wavelengths from 0.2 mkm to 1.1 mkm. The formulation also extrapolates smoothly up to 1.9 mkm in water.


wspRIRTL

Refractive index [-] as function of density r [kg/m3], temperature t [K], wave length wavelength [m]:

wspRIRTL(r, t, wavelength)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • wavelength – wave length [m], type: double;
  • Return value – refractive index [-], type: double.

Function is based upon the "Release on the Refractive Index of Ordinary Water Substance as a Function of Wavelength, Temperature and Pressure", 1997 from IAPWS. The range of validity is: temperatures from -12 to 500°C, densities up to 1060 kg/m3, wavelengths from 0.2 mkm to 1.1 mkm. The formulation also extrapolates smoothly up to 1.9 mkm in water.


wspROUGHHSSS

Specific enthalpy of steam at saturation line [J/kg] as function of specific entropy s [J/(kg·K)]:

wspROUGHHSSS(s)

where:

  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific enthalpy of steam at saturation line [J/kg], type: double.

Function uses the special equation from Supplementory Release for IF-97 Formulation. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspROUGHHSWS

Specific enthalpy of water at saturation line [J/kg] as function of specific entropy s [J/(kg·K)]:

wspROUGHHSWS(s)

where:

  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific enthalpy of water at saturation line [J/kg], type: double.

Function uses the special equation from Supplementory Release for IF-97 Formulation. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspROUGHRSST

Rough value of density of steam at saturation line [kg/m3] as function of temperature t [K]:

wspROUGHRSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – rough value of density of steam at saturation line [kg/m3], type: double.

This function allows to calculate quickly rough value of steam density at saturation line. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspROUGHRSWT

Rough value of density of water at saturation line [kg/m3] as function of temperature t [K]:

wspROUGHRSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – rough value of density of water at saturation line [kg/m3], type: double.

This function allows to calculate quickly rough value of steam density at saturation line. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspRST

Specific evaporation heat [J/kg] as function of temperature t [K]:

wspRST(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific evaporation heat [J/kg], type: double.

The result of function is calculated by formula r = (hs - hw), where hs - specific enthalpy of steam at saturation line, hw - specific enthalpy of water at saturation line. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspRT3HS

Properties calculation result in IF-97 region 3 as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspRT3HS(h, s, *r, *t)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • r – density [kg/m3], type: double. Warning! It's output parameter;
  • t – temperature [K], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 3, type: double.

Function is used to find parameters in region 3 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspS1PT

Specific entropy in IF-97 region 1 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspS1PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific entropy in IF-97 region 1 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspS2PT

Specific entropy in IF-97 region 2 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspS2PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific entropy in IF-97 region 2 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspS3PT

Specific entropy in IF-97 region 3 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspS3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific entropy in IF-97 region 3 [J/(kg·K)], type: double.

Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspS3RT

Specific entropy in IF-97 region 3 [J/(kg·K)] as function of density r [kg/m3], temperature t [K]:

wspS3RT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – specific entropy in IF-97 region 3 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspS5PT

Specific entropy in IF-97 region 5 [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspS5PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific entropy in IF-97 region 5 [J/(kg·K)], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspSETCHECKRANGEMODE

Set and return a mode of checking the range of functions arguments as function of mode mode:

wspSETCHECKRANGEMODE(mode)

where:

  • mode – mode, type: long;
  • Return value – set and return a mode of checking the range of functions arguments, type: long.

Function adjust the mode of checking for input parameters range. It is used in functions before calculating. If argument mode equals to zero the checking is disabled and the calculation speeds up but errors may occur.


wspSETDELTAPRESSURE

Set and return maximum difference between pressure values at estimation of the area 3 parameters [Pa] as function of delta pressure delta [Pa]:

wspSETDELTAPRESSURE(delta)

where:

  • delta – delta pressure [Pa], type: double;
  • Return value – set and return maximum difference between pressure values at estimation of the area 3 parameters [Pa], type: double.

Function is obsolete. From version 6.0 it is not used!

Note: This function is obsolete and it is recommended don't use it.


wspSETDELTATS

Set and return maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K] as function of temperature delta delta [K]:

wspSETDELTATS(delta)

where:

  • delta – temperature delta [K], type: double;
  • Return value – set and return maximum difference between saturation temperature and input temperature for function wspWATERSTATEAREA [K], type: double.

Function is obsolete and is not used from version 6.0!

Note: This function is obsolete and it is recommended don't use it.


wspSETINITSTEAMDENSITY

Set and return the initial value for density of steam in IF-97 region 3 [kg/m3] as function of density r [kg/m3]:

wspSETINITSTEAMDENSITY(r)

where:

  • r – density [kg/m3], type: double;
  • Return value – set and return the initial value for density of steam in IF-97 region 3 [kg/m3], type: double.

Function is obsolete. From version 6.0 it is not used!

Note: This function is obsolete and it is recommended don't use it.


wspSETINITWATERDENSITY

Set and return initial value for density of water in IF-97 region 3 [kg/m3] as function of density r [kg/m3]:

wspSETINITWATERDENSITY(r)

where:

  • r – density [kg/m3], type: double;
  • Return value – set and return initial value for density of water in IF-97 region 3 [kg/m3], type: double.

Function is obsolete. From version 6.0 it is not used!

Note: This function is obsolete and it is recommended don't use it.


wspSETLASTERROR

Set and return a last error code as function of error code ErrCode:

wspSETLASTERROR(ErrCode)

where:

  • ErrCode – error code, type: long;
  • Return value – set and return a last error code, type: long.

This function can be used to estimate error number: all error codes are enumerated starting from zero (no error) and increase subsequently with step 1. If a parameter overruns the function returns (and sets) zero - that means no error.


wspSETMAXITERATION

Set and return maximum iterations count for Newton method as function of maximum iteration maxiteration:

wspSETMAXITERATION(maxiteration)

where:

  • maxiteration – maximum iteration, type: long;
  • Return value – set and return maximum iterations count for Newton method, type: long.

If a function uses the Newton method this number is needed. If number of iterations more than this value the error WSP_CANT_FIND_ROOT (3) occurs.


wspSETTOLERANCE

Set and return relative precision in the WaterSteamPro functions [-] as function of tolerance tolerance [-]:

wspSETTOLERANCE(tolerance)

where:

  • tolerance – tolerance [-], type: double;
  • Return value – set and return relative precision in the WaterSteamPro functions [-], type: double.

The value of tolerance is used in functions which require the relative precision (usually when the iterations used).


wspSETTOLERANCEMODE

Set and return a mode of management of make function results more precise as function of mode mode:

wspSETTOLERANCEMODE(mode)

where:

  • mode – mode, type: long;
  • Return value – set and return a mode of management of make function results more precise, type: long.

Function adjust the mode of functions result improvement. It is used when result of a function can be improved (functions with arguments (p, h), (p, s) and so on). Usually iterations used to do it. If an argument equals to zero improvement is disabled and calculation speeds up while the tolerance decreases.


wspSEXPANSIONPTPEFF

Specific entropy at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspSEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific entropy at the end of expansion/compression process [J/(kg·K)], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspSEXPANSIONPTXPEFF

Specific entropy at the end of expansion/compression process [J/(kg·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspSEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific entropy at the end of expansion/compression process [J/(kg·K)], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspSMSPT

Specific entropy of meta-stable supercooled steam [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspSMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific entropy of meta-stable supercooled steam [J/(kg·K)], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspSPH

Specific entropy [J/(kg·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspSPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – specific entropy [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspSPTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspSPT

Specific entropy [J/(kg·K)] as function of pressure p [Pa], temperature t [K]:

wspSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific entropy [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspSxPT) is used.


wspSPTX

Specific entropy [J/(kg·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspSPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific entropy [J/(kg·K)], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspSxPT or wspSSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspSSST

Specific entropy of steam at saturation line [J/(kg·K)] as function of temperature t [K]:

wspSSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific entropy of steam at saturation line [J/(kg·K)], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspSSTX

Specific entropy in double-phase area [J/(kg·K)] as function of temperature t [K], vapor fraction x [-]:

wspSSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific entropy in double-phase area [J/(kg·K)], type: double.

Function uses functions wspSSST and wspSSWT which return specific entropies of steam and water at saturation line. The function uses following formula: Sx = (1 - X)·Sw + X·Ss, where Ss = wspSSST, Sw = wspSSWT and X - vapor fraction. The range of validity is double-phase (water-vapor) area.


wspSSWT

Specific entropy of water at saturation line [J/(kg·K)] as function of temperature t [K]:

wspSSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific entropy of water at saturation line [J/(kg·K)], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspSURFTENT

Surface tension [N/m] as function of temperature t [K]:

wspSURFTENT(t)

where:

  • t – temperature [K], type: double;
  • Return value – surface tension [N/m], type: double.

The function is based on the IAPWS Release on The Surface Tension of Ordinary Water Substance 1995. The range of validity is from triple point (273.16K or 0.01°C) to 647.096 K.


wspT1HS

Temperature in IF-97 region 1 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspT1HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 1 [K], type: double.

Function is based upon "Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2001). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT1PH

Temperature in IF-97 region 1 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspT1PH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature in IF-97 region 1 [K], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT1PS

Temperature in IF-97 region 1 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspT1PS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 1 [K], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT2APH

Temperature in IF-97 region 2a [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspT2APH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature in IF-97 region 2a [K], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT2APS

Temperature in IF-97 region 2a [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspT2APS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 2a [K], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT2BPH

Temperature in IF-97 region 2b [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspT2BPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature in IF-97 region 2b [K], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT2BPS

Temperature in IF-97 region 2b [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspT2BPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 2b [K], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT2CPH

Temperature in IF-97 region 2c [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspT2CPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature in IF-97 region 2c [K], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT2CPS

Temperature in IF-97 region 2c [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspT2CPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 2c [K], type: double.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT2HS

Temperature in IF-97 region 2 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspT2HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 2 [K], type: double.

Function is based upon the "Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2001). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT2PH

Temperature in IF-97 region 2 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspT2PH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature in IF-97 region 2 [K], type: double.

Function is based upon functions wspT2APH, wspT2BPH and wspT2CPH. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT2PS

Temperature in IF-97 region 2 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspT2PS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 2 [K], type: double.

Function is based upon functions wspT2APS, wspT2BPS and wspT2CPS. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT3HS

Temperature in IF-97 region 3 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspT3HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 3 [K], type: double.

Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT3PH

Temperature in IF-97 region 3 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspT3PH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature in IF-97 region 3 [K], type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT3PS

Temperature in IF-97 region 3 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspT3PS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 3 [K], type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT3RH

Temperature in IF-97 region 3 [K] as function of density r [kg/m3], specific enthalpy h [J/kg]:

wspT3RH(r, h)

where:

  • r – density [kg/m3], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature in IF-97 region 3 [K], type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT5HS

Temperature in IF-97 region 5 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspT5HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 5 [K], type: double.

Function is used to find the temperature in region 5 by Newton method. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT5PH

Temperature in IF-97 region 5 [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspT5PH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature in IF-97 region 5 [K], type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT5PS

Temperature in IF-97 region 5 [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspT5PS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature in IF-97 region 5 [K], type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. It uses the Newton method to determine the roots of the function with two arguments. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspT23P

Temperature at line between areas 2 and 3 [K] as function of pressure p [Pa]:

wspT23P(p)

where:

  • p – pressure [Pa], type: double;
  • Return value – temperature at line between areas 2 and 3 [K], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam. Used in function wspWATERSTATEAREA when region of IF-97 is determined.


wspTB23HS

Temperature at boundary line between areas 2 and 3 [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspTB23HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature at boundary line between areas 2 and 3 [K], type: double.

Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004).


wspTEXPANSIONPTPEFF

Temperature at the end of expansion/compression process [K] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspTEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – temperature at the end of expansion/compression process [K], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTEXPANSIONPTXPEFF

Temperature at the end of expansion/compression process [K] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspTEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – temperature at the end of expansion/compression process [K], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTHERMCONDEXPANSIONPTPEFF

Thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspTHERMCONDEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTHERMCONDEXPANSIONPTXPEFF

Thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspTHERMCONDEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – thermal conductivity coefficient at the end of expansion/compression process [W/(m·K)], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTHERMCONDHS

Thermal conductivity coefficient [W/(m·K)] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspTHERMCONDHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

It is a function. The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTHERMCONDMSPT

Thermal conductivity coefficient of meta-stable supercooled steam [W/(m·K)] as function of pressure p [Pa], temperature t [K]:

wspTHERMCONDMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – thermal conductivity coefficient of meta-stable supercooled steam [W/(m·K)], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspTHERMCONDPH

Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspTHERMCONDPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspTHERMCONDPT or wspTHERMCONDSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTHERMCONDPS

Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspTHERMCONDPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspTHERMCONDPT or wspTHERMCONDSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTHERMCONDPT

Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], temperature t [K]:

wspTHERMCONDPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). The function wspTHERMCONDRT is used for calculation the argument of which is density defined by the reverse value of function wspVPT.


wspTHERMCONDPTX

Thermal conductivity coefficient [W/(m·K)] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspTHERMCONDPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

The range of the validity is within that described in IF-97 and in formulation for thermal conductivity (see function wspTHERMCONDRT). The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspTHERMCONDPT or wspTHERMCONDSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspTHERMCONDRT

Thermal conductivity coefficient [W/(m·K)] as function of density r [kg/m3], temperature t [K]:

wspTHERMCONDRT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – thermal conductivity coefficient [W/(m·K)], type: double.

Function is based upon the Revised Release on the IAPS Formulation 1985 for the Thermal Conductivity of Ordinary Water Substance with correction for ITS-90 (International Temperature Scale). The range of validity is: temperature from 0.01 to 800°C for pressure up to 40 MPa, from 0.01 to 650°C for pressure from 40 to 70 MPa, from 0.01 to 500 °C for pressure from 70 to 100 MPa.


wspTHERMCONDSST

Thermal conductivity coefficient of steam at saturation line [W/(m·K)] as function of temperature t [K]:

wspTHERMCONDSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – thermal conductivity coefficient of steam at saturation line [W/(m·K)], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspTHERMCONDSTX

Thermal conductivity coefficient in double-phase area [W/(m·K)] as function of temperature t [K], vapor fraction x [-]:

wspTHERMCONDSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – thermal conductivity coefficient in double-phase area [W/(m·K)], type: double.

Function uses functions wspTHERMCONDSST and wspTHERMCONDSWT which return thermal conductivity of steam and water at saturation line. The function uses following formula: THERMCONDx = (1 - X)·THERMCONDw + X·THERMCONDs, where THERMCONDs = wspTHERMCONDSST, THERMCONDw = wspTHERMCONDSWT and X - vapor fraction. The range of calculation is double-phase (water-vapor) area.


wspTHERMCONDSWT

Thermal conductivity coefficient of water at saturation line [W/(m·K)] as function of temperature t [K]:

wspTHERMCONDSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – thermal conductivity coefficient of water at saturation line [W/(m·K)], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspTHS

Temperature [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspTHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature [K], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTPH

Temperature [K] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspTPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – temperature [K], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTPS

Temperature [K] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspTPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature [K], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTSHS

Temperature at saturation line [K] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspTSHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – temperature at saturation line [K], type: double.

Function calculates saturation temperature on a base of thermodunamic formulas. Newton method is used to determine the root. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspTSP

Temperature at saturation line [K] as function of pressure p [Pa]:

wspTSP(p)

where:

  • p – pressure [Pa], type: double;
  • Return value – temperature at saturation line [K], type: double.

Function is based upon the Supplementary Release on Saturation Properties of Ordinary Water Substance from IAPWS. The range of validity is from triple point of water (0.01°C or 611.657 Pa) to critical point (647.096K or 373.946°C or 22.064 MPa).


wspTXSHS

Properties calculation result in double-phase area as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspTXSHS(h, s, *t, *x)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • t – saturation temperature [K], type: double. Warning! It's output parameter;
  • x – vapor fraction [-], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in double-phase area, type: double.

Function calculates saturation temperature and vapor fraction on the base of thermodunamic formulas. Newton method is used to determine the root. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE). The range of validity is double-phase (water-vapor) area.

Note: In Mathcad the function have only parameters (h, s) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (h, s) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspU1PT

Specific internal energy in IF-97 region 1 [J/kg] as function of pressure p [Pa], temperature t [K]:

wspU1PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific internal energy in IF-97 region 1 [J/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspU2PT

Specific internal energy in IF-97 region 2 [J/kg] as function of pressure p [Pa], temperature t [K]:

wspU2PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific internal energy in IF-97 region 2 [J/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspU3PT

Specific internal energy in IF-97 region 3 [J/kg] as function of pressure p [Pa], temperature t [K]:

wspU3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific internal energy in IF-97 region 3 [J/kg], type: double.

Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspU3RT

Specific internal energy in IF-97 region 3 [J/kg] as function of density r [kg/m3], temperature t [K]:

wspU3RT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – specific internal energy in IF-97 region 3 [J/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspU5PT

Specific internal energy in IF-97 region 5 [J/kg] as function of pressure p [Pa], temperature t [K]:

wspU5PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific internal energy in IF-97 region 5 [J/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspUEXPANSIONPTPEFF

Specific internal energy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspUEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific internal energy at the end of expansion/compression process [J/kg], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspUEXPANSIONPTXPEFF

Specific internal energy at the end of expansion/compression process [J/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspUEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific internal energy at the end of expansion/compression process [J/kg], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), w- specific enthalpy in initial point, h1 - specific enthalpy in final point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in final point with isoentropic expansion (s = Const). For the calculating the process of compression you must to use instead the efficiency eff the inverse number (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspUHS

Specific internal energy [J/kg] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspUHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific internal energy [J/kg], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspUMSPT

Specific internal energy of meta-stable supercooled steam [J/kg] as function of pressure p [Pa], temperature t [K]:

wspUMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific internal energy of meta-stable supercooled steam [J/kg], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspUPH

Specific internal energy [J/kg] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspUPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – specific internal energy [J/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspUxPT or wspUSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspUPS

Specific internal energy [J/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspUPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific internal energy [J/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspUxPT or wspUSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspUPT

Specific internal energy [J/kg] as function of pressure p [Pa], temperature t [K]:

wspUPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific internal energy [J/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspUxPT) is used.


wspUPTX

Specific internal energy [J/kg] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspUPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific internal energy [J/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspUxPT or wspUSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspUSST

Specific internal energy of steam at saturation line [J/kg] as function of temperature t [K]:

wspUSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific internal energy of steam at saturation line [J/kg], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspUSTX

Specific internal energy in double-phase area [J/kg] as function of temperature t [K], vapor fraction x [-]:

wspUSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific internal energy in double-phase area [J/kg], type: double.

Function uses functions wspUSST and wspUSWT which return specific internal energies of steam and water at saturation line. The function uses following formula: Ux = (1 - X)·Uw + X·Us, where Us = wspUSST, Uw = wspUSWT and X - vapor fraction. The range of validity is double-phase (water-vapor) area.


wspUSWT

Specific internal energy of water at saturation line [J/kg] as function of temperature t [K]:

wspUSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific internal energy of water at saturation line [J/kg], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspV1PT

Specific volume in IF-97 region 1 [m3/kg] as function of pressure p [Pa], temperature t [K]:

wspV1PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific volume in IF-97 region 1 [m3/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspV2PT

Specific volume in IF-97 region 2 [m3/kg] as function of pressure p [Pa], temperature t [K]:

wspV2PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific volume in IF-97 region 2 [m3/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspV3HS

Specific volume in IF-97 region 3 [m3/kg] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspV3HS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific volume in IF-97 region 3 [m3/kg], type: double.

Function is based upon "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (September 2004). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspV3PH

Specific volume in IF-97 region 3 [m3/kg] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspV3PH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – specific volume in IF-97 region 3 [m3/kg], type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspV3PS

Specific volume in IF-97 region 3 [m3/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspV3PS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific volume in IF-97 region 3 [m3/kg], type: double.

Function is based upon IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam. The function uses the Newton method to determine the roots. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspV3PT

Specific volume in IF-97 region 3 [m3/kg] as function of pressure p [Pa], temperature t [K]:

wspV3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific volume in IF-97 region 3 [m3/kg], type: double.

Function is based upon function wspR3PT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspV5PT

Specific volume in IF-97 region 5 [m3/kg] as function of pressure p [Pa], temperature t [K]:

wspV5PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific volume in IF-97 region 5 [m3/kg], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspVEXPANSIONPTPEFF

Specific volume at the end of expansion/compression process [m3/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspVEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific volume at the end of expansion/compression process [m3/kg], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspVEXPANSIONPTXPEFF

Specific volume at the end of expansion/compression process [m3/kg] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – specific volume at the end of expansion/compression process [m3/kg], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspVHS

Specific volume [m3/kg] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspVHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific volume [m3/kg], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspVMSPT

Specific volume of meta-stable supercooled steam [m3/kg] as function of pressure p [Pa], temperature t [K]:

wspVMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific volume of meta-stable supercooled steam [m3/kg], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspVPH

Specific volume [m3/kg] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspVPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – specific volume [m3/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspVPTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspVPS

Specific volume [m3/kg] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspVPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – specific volume [m3/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspVxPT or wspVPTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspVPT

Specific volume [m3/kg] as function of pressure p [Pa], temperature t [K]:

wspVPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – specific volume [m3/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspVxPT) is used.


wspVPTX

Specific volume [m3/kg] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspVPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific volume [m3/kg], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspVxPT or wspVSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspVSST

Specific volume of steam at saturation line [m3/kg] as function of temperature t [K]:

wspVSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific volume of steam at saturation line [m3/kg], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspVSTX

Specific volume in double-phase area [m3/kg] as function of temperature t [K], vapor fraction x [-]:

wspVSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – specific volume in double-phase area [m3/kg], type: double.

Function uses the functions wspVSST and wspVSWT which return specific volumes of steam and water at saturation line. The function uses following formula: Vx = (1 - X)·Vw + X·Vs, where Vs = wspVSST, Vw = wspVSWT and X - vapor fraction. The range of validity is double-phase (water-vapor) area.


wspVSWT

Specific volume of water at saturation line [m3/kg] as function of temperature t [K]:

wspVSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – specific volume of water at saturation line [m3/kg], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspVUSHCVWDERPT1PT

Properties calculation result in IF-97 region 1 as function of pressure p [Pa], temperature t [K]:

wspVUSHCVWDERPT1PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
  • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
  • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
  • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
  • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
  • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
  • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
  • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
  • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
  • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 1, type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably.

Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspVUSHCVWDERPT2PT

Properties calculation result in IF-97 region 2 as function of pressure p [Pa], temperature t [K]:

wspVUSHCVWDERPT2PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
  • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
  • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
  • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
  • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
  • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
  • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
  • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
  • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
  • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 2, type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably.

Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspVUSHCVWDERPT3PT

Properties calculation result in IF-97 region 3 as function of pressure p [Pa], temperature t [K]:

wspVUSHCVWDERPT3PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
  • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
  • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
  • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
  • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
  • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
  • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
  • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
  • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
  • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 3, type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).

Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspVUSHCVWDERPT3RT

Properties calculation result in IF-97 region 3 as function of density r [kg/m3], temperature t [K]:

wspVUSHCVWDERPT3RT(r, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
  • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
  • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
  • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
  • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
  • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
  • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
  • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
  • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
  • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 3, type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably.

Note: In Mathcad the function have only parameters (r, t) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (r, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspVUSHCVWDERPT5PT

Properties calculation result in IF-97 region 5 as function of pressure p [Pa], temperature t [K]:

wspVUSHCVWDERPT5PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
  • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
  • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
  • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
  • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
  • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
  • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
  • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
  • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
  • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • Return value – properties calculation result in IF-97 region 5, type: double.

The function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and returns the set of properties that speed up calculation considerably.

Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspVUSHCVWDERPTMSPT

Properties calculation result of super-cooled steam (meta-stable region) as function of pressure p [Pa], temperature t [K]:

wspVUSHCVWDERPTMSPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
  • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
  • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
  • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
  • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
  • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
  • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
  • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
  • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
  • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • Return value – properties calculation result of super-cooled steam (meta-stable region), type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.

Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspVUSHCVWDERPTPT

Properties calculation result as function of pressure p [Pa], temperature t [K]:

wspVUSHCVWDERPTPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
  • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
  • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
  • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
  • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
  • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
  • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
  • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
  • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
  • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • Return value – properties calculation result, type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspVUSHDERPTxPT) is used to return the set of properties and so speed up calculation of several values in one point.

Note: In Mathcad the function have only parameters (p, t) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (p, t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspVUSHCVWDERPTSST

Properties calculation result for steam at saturation line as function of temperature t [K]:

wspVUSHCVWDERPTSST(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

where:

  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
  • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
  • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
  • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
  • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
  • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
  • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
  • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
  • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
  • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • Return value – properties calculation result for steam at saturation line, type: double.

The function is based upon IF-97 formulation. It returns the property set that speed up calculation considerably. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

Note: In Mathcad the function have only parameters (t) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspVUSHCVWDERPTSWT

Properties calculation result for water at saturation line as function of temperature t [K]:

wspVUSHCVWDERPTSWT(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

where:

  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double. Warning! It's output parameter;
  • u – specific internal energy [J/kg], type: double. Warning! It's output parameter;
  • s – specific entropy [J/(kg·K)], type: double. Warning! It's output parameter;
  • h – specific enthalpy [J/kg], type: double. Warning! It's output parameter;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double. Warning! It's output parameter;
  • w – speed of sound [m/sec], type: double. Warning! It's output parameter;
  • DVDPt – derivate of specific volume on pressure with constant temperature [m3/(kg·Pa)], type: double. Warning! It's output parameter;
  • DUDPt – derivate of specific internal energy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DSDPt – derivate of specific entropy on pressure with constant temperature [J/(kg·K·Pa)], type: double. Warning! It's output parameter;
  • DHDPt – derivate of specific enthalpy on pressure with constant temperature [J/(kg·Pa)], type: double. Warning! It's output parameter;
  • DVDTp – derivate of specific volume on temperature with constant pressure [m3/(kg·K)], type: double. Warning! It's output parameter;
  • DUDTp – derivate of specific internal energy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • DSDTp – derivate of specific entropy on temperature with constant pressure [J/(kg·K·K)], type: double. Warning! It's output parameter;
  • DHDTp – derivate of specific enthalpy on temperature with constant pressure [J/(kg·K)], type: double. Warning! It's output parameter;
  • Return value – properties calculation result for water at saturation line, type: double.

The function is based upon IF-97 formulation. It returns the property set that speed up calculation considerably. The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).

Note: In Mathcad the function have only parameters (t) and return an array containing output (return) parameters in SI units system.

Note: In Excel the function have only parameters (t) and return an array which contains output (return) parameters in SI units system. By default you will receive only first output parameter (only one element from array). To retrieve all values in array do next: 1) Enter formula with this function to any cell (as example B2). 2) Select cells: first cell with inputted formula and some cells on right hand (as example 2 cells from B2 to C2). 3) Press F2. 4) Press Ctrl+Shift+Enter. If you want to retrive values in vertical way (as example for cells from B2 to B3) please use the Excel built-in "TRANSPOSE" function.


wspW1PT

Sound velocity in IF-97 region 1 [m/sec] as function of pressure p [Pa], temperature t [K]:

wspW1PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – sound velocity in IF-97 region 1 [m/sec], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspW2PT

Sound velocity in IF-97 region 2 [m/sec] as function of pressure p [Pa], temperature t [K]:

wspW2PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – sound velocity in IF-97 region 2 [m/sec], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspW3PT

Sound velocity in IF-97 region 3 [m/sec] as function of pressure p [Pa], temperature t [K]:

wspW3PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – sound velocity in IF-97 region 3 [m/sec], type: double.

Function is based upon functions wspR3PT and wspU3RT. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspW3RT

Sound velocity in IF-97 region 3 [m/sec] as function of density r [kg/m3], temperature t [K]:

wspW3RT(r, t)

where:

  • r – density [kg/m3], type: double;
  • t – temperature [K], type: double;
  • Return value – sound velocity in IF-97 region 3 [m/sec], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspW5PT

Sound velocity in IF-97 region 5 [m/sec] as function of pressure p [Pa], temperature t [K]:

wspW5PT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – sound velocity in IF-97 region 5 [m/sec], type: double.

Function is based upon the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam.


wspWATERSTATEAREA

IF-97 region as function of pressure p [Pa], temperature t [K]:

wspWATERSTATEAREA(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – IF-97 region, type: long.

Function is based upon the regions allocation in the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam and used in functions.


wspWATERSTATEAREA2

IF-97 region (version 2) as function of pressure p [Pa], temperature t [K]:

wspWATERSTATEAREA2(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – IF-97 region (version 2), type: long.

Function is based upon the regions allocation in the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam (version 2 - without region 4 - saturation line) and used in functions.


wspWATERSTATEAREAHS

IF-97 region as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspWATERSTATEAREAHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – IF-97 region, type: long.

Function is based upon allocation of additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and used in functions to determine the IF-97 region.


wspWATERSTATEAREAPH

IF-97 region as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspWATERSTATEAREAPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – IF-97 region, type: long.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and used in functions to determine the IF-97 region.


wspWATERSTATEAREAPS

IF-97 region as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspWATERSTATEAREAPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – IF-97 region, type: long.

Function is based upon additional equations of the IAPWS Industrial Formulation 1997 for Thermodynamic Properties of Water and Steam and used in functions to determine the IF-97 region.


wspWEXPANSIONPTPEFF

Sound velocity at the end of expansion/compression process [m/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspWEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – sound velocity at the end of expansion/compression process [m/sec], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspWEXPANSIONPTXPEFF

Sound velocity at the end of expansion/compression process [m/sec] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspWEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – sound velocity at the end of expansion/compression process [m/sec], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspWHS

Speed of sound [m/sec] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspWHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – speed of sound [m/sec], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspWMSPT

Sound velocity of meta-stable supercooled steam [m/sec] as function of pressure p [Pa], temperature t [K]:

wspWMSPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – sound velocity of meta-stable supercooled steam [m/sec], type: double.

This function calculates the properties of super-cooled steam (in meta-stable region). The parameters range: pressure up to 10 MPa, vapor fraction above 95%. Special equation for meta-stable vapor region is used for calculation which is based upon IAPWS IF-97.


wspWPH

Speed of sound [m/sec] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspWPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – speed of sound [m/sec], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPH is used to determine the IF-97 region. Then the necessary function (wspTxPH) is used. Finally, the necessary function (wspWxPT or wspWSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspWPS

Speed of sound [m/sec] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspWPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – speed of sound [m/sec], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREAPS is used to determine the IF-97 region. Then the necessary function (wspTxPS) is used. Finally, the necessary function (wspWxPT or wspWSTX) is called. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspWPT

Speed of sound [m/sec] as function of pressure p [Pa], temperature t [K]:

wspWPT(p, t)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • Return value – speed of sound [m/sec], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA2 is used to determine the IF-97 region. Then the necessary function (wspWxPT) is used.


wspWPTX

Speed of sound [m/sec] as function of pressure p [Pa], temperature t [K], vapor fraction x [-]:

wspWPTX(p, t, x)

where:

  • p – pressure [Pa], type: double;
  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – speed of sound [m/sec], type: double.

The range of the validity is within that described in IF-97. The function wspWATERSTATEAREA is used to determine the IF-97 region. Then the necessary function (wspWxPT or wspWSTX) is used. If the point is out of the double-phase area the value of vapor fraction is ignored.


wspWSST

Sound velocity in steam at saturation line [m/sec] as function of temperature t [K]:

wspWSST(t)

where:

  • t – temperature [K], type: double;
  • Return value – sound velocity in steam at saturation line [m/sec], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspWSTX

Sound velocity in double-phase area [m/sec] as function of temperature t [K], vapor fraction x [-]:

wspWSTX(t, x)

where:

  • t – temperature [K], type: double;
  • x – vapor fraction [-], type: double;
  • Return value – sound velocity in double-phase area [m/sec], type: double.

Function uses function wspKSTX to calculate sound velocity in double-phase area conforming with thermodynamic. The function neglects the flow structure. Until version 5.6 this function used following formula: Wx = (1 - X)·Ww + X·Ws, where Ws = wspWSST, Ww = wspWSWT and X - vapor fraction, which disagrees with thermodynamic because it neglects the property jump at saturation line. The range of validity is double-phase (water-vapor) area.


wspWSWT

Sound velocity in water at saturation line [m/sec] as function of temperature t [K]:

wspWSWT(t)

where:

  • t – temperature [K], type: double;
  • Return value – sound velocity in water at saturation line [m/sec], type: double.

The range of validity is from triple point of water (0.01°C) to critical point (647.096K or 373.946°C).


wspXEXPANSIONPTPEFF

Vapor fraction at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspXEXPANSIONPTPEFF(p0, t0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – vapor fraction at the end of expansion/compression process [-], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspXEXPANSIONPTXPEFF

Vapor fraction at the end of expansion/compression process [-] as function of pressure at initial point p0 [Pa], temperature at initial point t0 [K], vapor fraction at initial point x0 [-], pressure at final point p1 [Pa], internal efficiency of process eff [-]:

wspXEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

where:

  • p0 – pressure at initial point [Pa], type: double;
  • t0 – temperature at initial point [K], type: double;
  • x0 – vapor fraction at initial point [-], type: double;
  • p1 – pressure at final point [Pa], type: double;
  • eff – internal efficiency of process [-], type: double;
  • Return value – vapor fraction at the end of expansion/compression process [-], type: double.

It is a function. The range of the validity is within that described in IF-97. Function returns a parameter at the end of the expansion process from initial point with arguments p0, t0, x0 to pressure p1 with relative efficiency eff. The process is calculated by the formula: h1 = h0 - eff * (h0 - h1isoent), where h0 - specific enthalpy in initial point, h1 - specific enthalpy in finite point of the expansion, eff - efficiency, h1isoentr - specific enthalpy in finite point at isoentropic equilibrium expansion (s = Const). For compression process calculation it is necessary to use the value inverse to the efficiency eff (i.e. 1/eff). Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspXHS

Vapor fraction [-] as function of specific enthalpy h [J/kg], specific entropy s [J/(kg·K)]:

wspXHS(h, s)

where:

  • h – specific enthalpy [J/kg], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – vapor fraction [-], type: double.

It is a function. The range of the validity is within that described in IF-97. Function works as follows. For first the IF-97 region is determined by function wspWATERSTATEAREAHS. Then the original variables are defined for basic equation of IF-97 region at this point (by functions wspPTxHS and wspRT3HS). Then the sought quantity is calculated on these data. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspXPH

Vapor fraction [-] as function of pressure p [Pa], specific enthalpy h [J/kg]:

wspXPH(p, h)

where:

  • p – pressure [Pa], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – vapor fraction [-], type: double.

It is a function. The range of the validity is within that described in IF-97. The IF-97 region is determined for given p and h (by function wspWATERSTATEAREAPH). If the region is double-phase the sought parameter is calculated. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspXPS

Vapor fraction [-] as function of pressure p [Pa], specific entropy s [J/(kg·K)]:

wspXPS(p, s)

where:

  • p – pressure [Pa], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – vapor fraction [-], type: double.

It is a function. The range of the validity is within that described in IF-97. The IF-97 region is determined for given p and s (by function wspWATERSTATEAREAPS). If the region is double-phase the sought parameter is calculated. Since at some stages the function use iterations, to speed up calculations you may disable precision mode (functions wspGETTOLERANCEMODE and wspSETTOLERANCEMODE) or vary relative precision for internal iterations (functions wspGETTOLERANCE and wspSETTOLERANCE).


wspXSTCP

Vapor fraction [-] as function of temperature t [K], specific isobaric heat capacity Cp [J/(kg·K)]:

wspXSTCP(t, Cp)

where:

  • t – temperature [K], type: double;
  • Cp – specific isobaric heat capacity [J/(kg·K)], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (CP - CPw)/(CPs - CPw), where CPw = wspCPSWT, CPs = wspCPSST. The range of calculation is double-phase (water-vapor) area.


wspXSTCV

Vapor fraction [-] as function of temperature t [K], specific isochoric heat capacity Cv [J/(kg·K)]:

wspXSTCV(t, Cv)

where:

  • t – temperature [K], type: double;
  • Cv – specific isochoric heat capacity [J/(kg·K)], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (CV - CVDPw)/(CVDPs - CVDPw), where CVDPw = wspCVDPSWT, CVDPs = wspCVDPSST. The range of validity is double-phase (water-vapor) area.


wspXSTD

Vapor fraction [-] as function of temperature t [K], density r [kg/m3]:

wspXSTD(t, r)

where:

  • t – temperature [K], type: double;
  • r – density [kg/m3], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = rs * (rw - r) / (r * (rw - rs)), where rw = wspDSWT, rs = wspDSST. The range of validity is double-phase (water-vapor) area.


wspXSTDYNVIS

Vapor fraction [-] as function of temperature t [K], dynamic viscosity dv [Pa·sec]:

wspXSTDYNVIS(t, dv)

where:

  • t – temperature [K], type: double;
  • dv – dynamic viscosity [Pa·sec], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (DV - DVw)/(DVs - DVw), where DVw = wspDYNVISSWT, DVs = wspDYNVISSST. The range of calculation is double-phase (water-vapor) area.


wspXSTH

Vapor fraction [-] as function of temperature t [K], specific enthalpy h [J/kg]:

wspXSTH(t, h)

where:

  • t – temperature [K], type: double;
  • h – specific enthalpy [J/kg], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (H - Hw)/(Hs - Hw), where Hw = wspHSWT, Hs = wspHSST. The range of validity is double-phase (water-vapor) area.


wspXSTJOULETHOMPSON

Vapor fraction [-] as function of temperature t [K], Joule-Thomson coefficient jt [K/Pa]:

wspXSTJOULETHOMPSON(t, jt)

where:

  • t – temperature [K], type: double;
  • jt – Joule-Thomson coefficient [K/Pa], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (JOULETHOMPSON - JOULETHOMPSONw)/(JOULETHOMPSONs - JOULETHOMPSONw), where JOULETHOMPSONw = wspJOULETHOMPSONSWT, JOULETHOMPSONs = wspJOULETHOMPSONSST. The range of validity is double-phase (water-vapor) area.


wspXSTK

Vapor fraction [-] as function of temperature t [K], isoentropic exponent k [-]:

wspXSTK(t, k)

where:

  • t – temperature [K], type: double;
  • k – isoentropic exponent [-], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (K - Kw)/(Ks - Kw), where Kw = wspKSWT, Ks = wspKSST. The range of validity is double-phase (water-vapor) area.


wspXSTKINVIS

Vapor fraction [-] as function of temperature t [K], kinematic viscosity kv [m2/sec]:

wspXSTKINVIS(t, kv)

where:

  • t – temperature [K], type: double;
  • kv – kinematic viscosity [m2/sec], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (KV - KVw)/(KVs - KVw), where KVw = wspKINVISSWT, KVs = wspKINVISSST. The range of calculation is double-phase (water-vapor) area.


wspXSTPRANDTLE

Vapor fraction [-] as function of temperature t [K], Prandtl number pr [-]:

wspXSTPRANDTLE(t, pr)

where:

  • t – temperature [K], type: double;
  • pr – Prandtl number [-], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (PR - PRw)/(PRs - PRw), where PRw = wspPRANDTLESWT, PRs = wspPRANDTLESST. The range of calculation is double-phase (water-vapor) area.


wspXSTS

Vapor fraction [-] as function of temperature t [K], specific entropy s [J/(kg·K)]:

wspXSTS(t, s)

where:

  • t – temperature [K], type: double;
  • s – specific entropy [J/(kg·K)], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (S - Sw)/(Ss - Sw), where Sw = wspSSWT, Ss = wspSSST. The range of validity is double-phase (water-vapor) area.


wspXSTTHERMCOND

Vapor fraction [-] as function of temperature t [K], thermal conductivity coefficient tc [W/(m·K)]:

wspXSTTHERMCOND(t, tc)

where:

  • t – temperature [K], type: double;
  • tc – thermal conductivity coefficient [W/(m·K)], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (TC - TCw)/(TCs - TCw), where TCw = wspTHERMCONDSWT, TCs = wspTHERMCONDSST. The range of calculation is double-phase (water-vapor) area.


wspXSTU

Vapor fraction [-] as function of temperature t [K], specific internal energy u [J/kg]:

wspXSTU(t, u)

where:

  • t – temperature [K], type: double;
  • u – specific internal energy [J/kg], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (U - Uw)/(Us - Uw), where Uw = wspUSWT, Us = wspUSST. The range of validity is double-phase (water-vapor) area.


wspXSTV

Vapor fraction [-] as function of temperature t [K], specific volume v [m3/kg]:

wspXSTV(t, v)

where:

  • t – temperature [K], type: double;
  • v – specific volume [m3/kg], type: double;
  • Return value – vapor fraction [-], type: double.

This function uses formula: X = (V - Vw)/(Vs - Vw), where Vw = wspVSWT, Vs = wspVSST. The range of validity is double-phase (water-vapor) area.


wspXSTW

Vapor fraction [-] as function of temperature t [K], speed of sound w [m/sec]:

wspXSTW(t, w)

where:

  • t – temperature [K], type: double;
  • w – speed of sound [m/sec], type: double;
  • Return value – vapor fraction [-], type: double.

From version 5.6 this function calculates value of sound velocity in double-phase region from isoentropic exponent that is conform to thermodynamic. Until version 5.6 this function used formula: X = (W - Ww)/(Ws - Ww), where Ww = wspWSWT, Ws = wspWSST which was not right. Now it is calculated correctly. The range of validity is double-phase (water-vapor) area.