О программе

Сертифицированный набор программ
для вычислений свойств воды/водяного пара, газов и смесей газов
"WaterSteamPro"TM

Авторы:

  • к.т.н., доцент Константин Александрович Орлов, E-mail: orlov@twt.mpei.ac.ru
  • д.т.н., профессор Алексей Александрович Александров, E-mail: AlexandrovAA@mpei.ru, почетный член IAPWS
  • Алексей Валерьевич Очков, E-mail: al@twt.mpei.ac.ru
  • д.т.н., профессор Валерий Федорович Очков, WWW-сайт: http://twt.mpei.ac.ru/ochkov

WWW-site программы WaterSteamPro: http://www.wsp.ru

Copyright © Авторы, Московский энергетический институт (технический университет), 1999–2010

(версия 6.5)

- Москва 1999-2010 -


Аннотация

Пакет программ "WaterSteamPro" предназначен для вычислений теплофизических свойств воды и водяного пара в широком диапазоне исходных данных.

В пакете "WaterSteamPro" определено более 200 функций для вычислений свойств воды и водяного пара по формулам, предложенным Международной Ассоциацией по Свойствам Воды и Водяного Пара. Термодинамические свойства вычисляются по Формуляции 1997 для технических расчетов, а остальные свойства – по соответствующим им Формуляциям.

Пакет программ "WaterSteamPro" официально зарегистрирован в Российском Агенстве по Патентам и Товарным Знакам (РОСПАТЕНТ), свидетельство №2000610803 от 25.08.2001.

Госстандартом России выдано свидетельство № АК-35/4 от 16.04.2001 о том, что программа WaterSteamPro воспроизводит величины, соответствующие данным, рекомендованным Государственной службой стандартных справочных данных (ГСССД Р-776-98) и уравнениям "IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" ("Система уравнений Международной ассоциации по свойствам воды и водяного пара для вычисления термодинамических свойств воды и водяного пара в промышленных расчетах 1997 года").

Программа WaterSteamPro рекомендована Департаментом генеральной инспекции по эксплуатации электрических станций и сетей Российского акционерного общества энергетики и электрификации "ЕЭС России" для использования в энергетике (информационное письмо № ИП-14-27-2001 от 03.08.2001).

Программа "WaterSteamPro" может быть подключена практически ко всем программным средам (Microsoft Excel, Mathcad, Fortran, C++, Visual Basic, Delphi и т.д.), используемых для теплотехнических расчетов.

В данной версии поставляются примеры использования "WaterSteamPro" в следующих программах:

  • Mathcad Professional фирмы MathSoft, Inc.;
  • Microsoft Excel, один из компонентов Microsoft Office фирмы Microsoft, Inc.;
  • Microsoft Visual Basic 6.0, один из компонентов Microsoft Visual Studio 6.0 фирмы Microsoft, Inc.;
  • Delphi, фирмы Borland International;
  • Windows Scripting Host (пример на JScript и VBScript);
  • HTML Example - использование WaterSteamPro в Internet и Intranet.


Что нового

Что нового в WaterSteamPro 6.5

  1. Увеличена область определения функций для расчета свойств воды/водяного пара до 50 МПа при температурах от 800°C до 2000°C (раньше было до 10 МПа). Изменения основаны на новых уравнениях от МАСВП (IAPWS - http://www.iapws.org)
  2. Функции для расчета вязкости (и основанные на них функции) теперь используют новые уравнения от МАСВП (IAPWS - http://www.iapws.org).
  3. Внесены изменения для правильной работы отдельных составляющих WaterSteamPro в Windows Vista.
  4. Добавлены модули для использования функций WaterSteamPro в Matlab. Эти модули не включены в состав пакета установки WaterSteamPro и может быть скачано с сайта WaterSteamPro: http://www.wsp.ru.
  5. Добавлены функции для вычисления производной (d density / d pressure)enthalpy по уравнениям IF-97 в однофазной и двухфазной областях.
  6. Добавлены функции для вычисления производной (d density / d enthalpy)pressure по уравнениям IF-97 в однофазной и двухфазной областях.
  7. Добавлены функции для вычисления плотности воды/водяного пара по уравнениям IF-97.
  8. Добавлены функции для расчета диэлектрической проницаемости воды/водяного пара.
  9. Добавлены функции для расчета ионного произведения воды.
  10. Добавлена функция для расчета набора свойств (включая производные) в метастабильной области.
  11. В состав поставки включен рабочий документ Microsoft Excel: "WaterSteamPro Excel Calculator", который позволяет быстро и легко производить расчеты свойств воды/водяного пара в Excel.
  12. В Microsoft Excel теперь работают функции, возвращающие несколько значений. Возврат значений осуществляется в виде массива. Дополнительная информация приведена в документации к программе в справке о функции. Пример использования функций, возвращающих массив приведен в файле WSP Excel Calculator.
  13. Решена проблема отображения справки по функциям WaterSteamPro в Mathcad 12 и выше. В предыдущих версиях Mathcad справка не отображалась.
  14. Внесены изменения в Active-X объект. Теперь при его использовании настройки индивидуальны для каждого экземпляра объекта. Ранее настройки были общими для всего приложения, использующего WaterSteamPro.
  15. Предыдущее изменение позволило создать Интернет-ресурс http://www.wsp.ru/ru/test, который позволяет вызвать любую из функций WaterSteamPro в он-лайн режиме без предварительной установки программы.
  16. Изменена область определения функций для расчета свойств воды - теперь расчет проводится до линии плавления (ранее расчет проводился до температуры 273.15 К).
  17. В диалоге "Вставка функции" в Mathcad добавлена информация о возможности использования размерных функций WaterSteamPro.
  18. Добавлена единица измерения "кПа" в программу "WSP Calculator".
  19. Исправлена ошибка в программе установки, которая связана с неправильной установкой документов для Mathcad в случае, если конечная папка для документов не существовала.
  20. Внесены изменения в программу установки.
  21. Внесены изменения в документацию.
  22. Изменен механизм регистрации.


Системные требования

Для установки "WaterSteamPro" необходимо:

  • Windows 9x/Me/NT 4.0/2000/XP/2003
  • около 4 мегабайт на жестком диске (зависит от предустановленного программного обеспечения);
  • для чтения документации рекомендуется обновить версию Html Help. Обновление Html Help доступно по адресу http://msdn.microsoft.com/library/tools/htmlhelp;
  • программы, примеры использования "WaterSteamPro" в которых поставляются вместе с основными файлам "WaterSteamPro" (Mathcad, Excel, Visual Basic, etc), предъявляют собственные системные требования.

Для работы ActiveX-компонента "WaterSteamPro" требуется:

  • поддержка DCOM. Обновление DCOM для Windows 95/98 доступно по адресу http://www.microsoft.com/com/resources/downloads.asp;
  • Microsoft Internet Explorer 4.0;

Для установки "WaterSteamPro" рекомендуется:

  • поддержка DCOM. Обновление DCOM для Windows 95/98 доступно по адресу http://www.microsoft.com/com/resources/downloads.asp;
  • Microsoft Internet Explorer 5.0;
  • Microsoft Office 2000;
  • Mathsoft Mathcad 8 Professional или выше;


Официальная сертификация программы WaterSteamPro

1. Программе WaterSteamPro Госстандартом России (http://www.gost.ru) выдано Свидетельство № АК-35/4 от 16.04.2001 о том, что программа WaterSteamPro воспроизводит величины, соответствующие данным, рекомендованным Государственной службой стандартных справочных данных (ГСССД Р-776-98) и уравнениям the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam.

Электронная копия сертификата приведена на www-сайте программы: http://www.wsp.ru/ru/certif.htm.

2. 25 августа 2000 программа "WaterSteamPro" стала официально зарегистрированной программой для ЭВМ в Российском Агенстве по Патентам и Товарным Знакам (РОСПАТЕНТ) (http://www.rupto.ru). Электронная копия свидетельства № 2000610803 приведена ниже:

Электронная копия сертификата приведена на www-сайте программы: http://www.wsp.ru/ru/certif.htm.

3. 3 августа 2001 программа "WaterSteamPro" рекомендована Департаментом генеральной инспекции по эксплуатации электрических станций и сетей Российского акционерного общества энергетики и электрификации "ЕЭС России" для использования в энергетике (информационное письмо № ИП-14-27-2001 от 03.08.2001).

Электронная копия информационного письма приведена на www-сайте программы: http://www.wsp.ru/ru/certif.htm.


Комплект поставки

В комплект поставки "WaterSteamPro" входят следующие компоненты:

  • Библиотека "OKAWSP6.DLL" – основная библиотека с непосредственно определениями функций для расчета свойств воды и водяного пара;
  • Программа "WaterSteamPro Calculator" – средство для вычислений свойств воды и водяного пара без использования дополнительных программных продуктов (Excel, Mathcad, etc). Данная программа написана на Microsoft Visual C++ 6.0 (SP3). Также поставляются исходные тексты аналогичной программы, написанной на Microsoft Visual Basic 6.0.
  • Набор файлов для использования "WaterSteamPro" в Mathcad.
  • Документ Microsoft Excel 97 "WSP EXCEL.XLS" с примером использования библиотеки в программе Microsoft Excel (и других программах, "понимающих" VBA – Visual Basic for Applications).
  • Файл надстройки "wspexcel.xll" для облегчения использования непосредственно всех функций пакета "WaterSteamPro" в Microsoft Excel.
  • Два файла для WSH (Windows Scripting Host), написанные на языках VBScript и JScript, в которых приведен пример использования ActiveX-объекта "WSP.WSPCalculator" для вычислений свойств воды и водяного пара.
  • Файлы в формате HTML, иллюстрирующие примеры использования "WaterSteamPro" в Excel и Mathcad.
  • Файлы, иллюстрирующие использование функций "WaterSteamPro" в Maple.
  • Программа "WaterSteamPro Updater" для удобного обновления пакета WaterSteamPro.
  • Документация.


Лицензионное соглашение

Положения лицензионного соглашения:

  1. Все права на пакет "WaterSteamPro" принадлежат автору – Константину Александровичу Орлову.
  2. Автор оставляет за собой право в дальнейшем изменять условия данного лицензионного соглашения.
  3. Пробная версия может свободно распространяться и копироваться только в том виде, в котором она поставляется (инсталляционный архив). Ни одно частное лицо или организация не может брать плату за распространение пакета "WaterSteamPro" без письменного разрешения автора. Использование пробной версии по времени неограниченно.
  4. Зарегистрированная персональная версия может использоваться только на одном компьютере без права передачи другому физическому или юридическому лицу.
  5. Для использования пакета "WaterSteamPro" в коммерческих проектах требуется заключение специального лицензионного соглашения. Для согласования условий необходимо обратиться к автору "WaterSteamPro" – Константину Орлову.
  6. Поставляемый исходный, не скомпилированный код программ, входящих в состав пакета "WaterSteamPro" разрешается копировать и/или использовать в собственных разработках.
  7. По данной лицензии Вы имеете право использовать любую из частей "WaterSteamPro" только в индивидуальных и некоммерческих целях. Для использования в других целях необходимо приобретение специальных лицензий.
  8. Запрещается создание, распространение, продажа и т.д. программ на основе "WaterSteamPro", могущих быть конкурентами "WaterSteamPro". Это означает, что запрещается создание, распространение, продажа и т.д. программ, использующих любые из частей "WaterSteamPro" и воспроизводящие функциональность "WaterSteamPro".
  9. При использовании какого-либо программного продукта из пакета WaterSteamPro в каких-либо разработках, как-то научные, учебные, исследовательские, коммерческие и т.д. необходимо давать ссылку об использовании WaterSteamPro (например, в окошке About, либо в списке литературы) с указанием авторов программы, правообладателем и www-адресом программы (http://www.wsp.ru).
  10. Запрещается использовать, копировать, эмулировать, создавать новые версии, сдавать в наем или аренду, продавать, изменять, декомпилировать, дизассемблировать, изучать код программы другими способами, передавать зарегистрированную программу или любые из ее составляющих, иначе, чем определено настоящим лицензионным соглашением (или специальным для коммерческого использования). Любое такое нелегальное использование означает автоматическое и немедленное прекращение действия настоящего соглашения и может преследоваться по закону.
  11. Пакет "WaterSteamPro" поставляется по принципу "AS IS". Никаких гарантий не прилагается и не предусматривается. Вы используете это программное обеспечение на свой риск. Автор не будет отвечать ни за какие потери или искажения данных, любую упущенную выгоду в процессе использования или неправильного использования этого программного обеспечения.
  12. Установка и использование пакета "WaterSteamPro" означает, что вы понимаете и принимаете положения данного лицензионного соглашения. Если вы не согласны с данным соглашением, вам необходимо удалить файлы пакета "WaterSteamPro" с ваших устройств хранения и прекратить его использование.
  13. Все права, не указанные явно в настоящем лицензионном соглашении, остаются за автором программы – Константином Орловым.

Изменения в лицензировании для студентов ВУЗов

Очные студенты высших учебных заведений могут получить одну лицензию (лицензия "Educational") для использования только в учебном процессе. При этом существуют следующие ограничения:

  1. Функции пакета WaterSteamPro будут доступны только в пакете Mathcad. Все другие модули, входящие в состав WaterSteamPro не поддерживаются.
  2. Результаты, полученные с использованием функций WaterSteamPro могут быть использованы только в учебных целях.
  3. Получение коммерческой прибыли, полученной от результатов, в свою очередь полученных с использованием функций WaterSteamPro, запрещено.
  4. В студенческих работах, где используются результаты, полученные с использованием функций WaterSteamPro, необходимо дать ссылку на то, что расчеты проводились с использованием функций WaterSteamPro (www.wsp.ru).
  5. Срок действия лицензии может быть ограничен.
  6. В выдаче лицензии может быть отказано без объяснения причин.
  7. Условия выдачи лицензии/лицензирования могут быть изменены по усмотрению авторов.

Для получения лицензии "Educational" необходимо отослать Константину Александровичу Орлову письмо по электронной почте (orlov@twt.mpei.ac.ru), в котором будет указано следующее (все из указанного):

  1. Ф.И.О. студента
  2. Полное название высшего учебного заведения
  3. Полное название подразделения (факультета/института) вуза
  4. Полное название кафедры
  5. Название группы
  6. Год поступления
  7. Предполагаемый год выпуска
  8. Строка "Системная информация: [НОМЕР]", которая выводится в окне регистрации программы (появляется после запуска, например, "WaterSteamPro Calculator")
  9. Сканированный с разрешением не менее 90 и не более 100 dpi (точек на дюйм) студенческий билет (набор цветов - оттенки серого).

С уважением,
Константин Орлов.


Регистрация

Для приобретения лицензии на право использования программы "WaterSteamPro" необходимо обратиться к автору, Константину Александровичу Орлову, предварительно заполнив регистрационную форму.

Ответ будет выслан Вам с минимальной задержкой. В письме, пожалуйста, укажите неоходимый Вам вид лицензии.

Существует следующие типы лицензии:

1. "Professional" - Персональная лицензия на право использования зарегистрированной программы WaterSteamPro на одном компьютере (для физических лиц).

2. "Enterprise" - Лицензия на право использования зарегистрированной программы WaterSteamPro на нескольких компьютерах, принадлежащих одной организации (для юридических лиц) без права создания коммерческих программ на основе WaterSteamPro. В состав дополнительно входит пакет разработчика WaterSteamPro SDK.

3. "Developer" - Лицензия на право использования зарегистрированной программы WaterSteamPro в коммерческих разработках (с передачей WaterSteamPro SDK и персонального кода локальной регистрации).

4. "Educational" - Персональная лицензия только для очных студентов ВУЗов на право использования зарегистрированной программы WaterSteamPro на одном компьютере (для физических лиц).

Лицензирование для студентов ВУЗов

Очные студенты высших учебных заведений могут получить одну лицензию (лицензия "Educational") для использования только в учебном процессе. При этом существуют следующие ограничения:

  1. Функции пакета WaterSteamPro будут доступны только в пакете Mathcad. Все другие модули, входящие в состав WaterSteamPro не поддерживаются.
  2. Результаты, полученные с использованием функций WaterSteamPro могут быть использованы только в учебных целях.
  3. Получение коммерческой прибыли, полученной от результатов, в свою очередь полученных с использованием функций WaterSteamPro, запрещено.
  4. В студенческих работах, где используются результаты, полученные с использованием функций WaterSteamPro, необходимо дать ссылку на то, что расчеты проводились с использованием функций WaterSteamPro (www.wsp.ru).
  5. Срок действия лицензии может быть ограничен.
  6. В выдаче лицензии может быть отказано без объяснения причин.
  7. Условия выдачи лицензии/лицензирования могут быть изменены по усмотрению авторов.

Для получения лицензии "Educational" необходимо отослать Константину Александровичу Орлову письмо по электронной почте (orlov@twt.mpei.ac.ru), в котором будет указано следующее (все из указанного):

  1. Ф.И.О. студента
  2. Полное название высшего учебного заведения
  3. Полное название подразделения (факультета/института) вуза
  4. Полное название кафедры
  5. Название группы
  6. Год поступления
  7. Предполагаемый год выпуска
  8. Строка "Системная информация: [НОМЕР]", которая выводится в окне регистрации программы (появляется после запуска, например, "WaterSteamPro Calculator")
  9. Сканированный с разрешением не менее 90 и не более 100 dpi (точек на дюйм) студенческий билет (набор цветов - оттенки серого).

Контактная информация:

  • по электронной почте: orlov@twt.mpei.ac.ru Константину Александровичу Орлову


Регистрационная форма

Фамилия:
________________________________________________________________

Имя:
________________________________________________________________

Отчество:
________________________________________________________________

Место работы/учебы (опционально):
________________________________________________________________

Адрес (опционально):
________________________________________________________________

Город:
________________________________________________________________

Страна:
________________________________________________________________

Телефон (опционально):
________________________________________________________________

E-mail/www-адрес домашней страницы:
________________________________________________________________

Откуда Вы узнали о программе WaterSteamPro (опционально):
________________________________________________________________

Для каких целей предполагается использование пакета "WaterSteamPro" (опционально):
________________________________________________________________
________________________________________________________________
________________________________________________________________
________________________________________________________________

Лицензирование для студентов ВУЗов

Очные студенты высших учебных заведений могут получить одну лицензию (лицензия "Educational") для использования только в учебном процессе. При этом существуют следующие ограничения:

  1. Функции пакета WaterSteamPro будут доступны только в пакете Mathcad. Все другие модули, входящие в состав WaterSteamPro не поддерживаются.
  2. Результаты, полученные с использованием функций WaterSteamPro могут быть использованы только в учебных целях.
  3. Получение коммерческой прибыли, полученной от результатов, в свою очередь полученных с использованием функций WaterSteamPro, запрещено.
  4. В студенческих работах, где используются результаты, полученные с использованием функций WaterSteamPro, необходимо дать ссылку на то, что расчеты проводились с использованием функций WaterSteamPro (www.wsp.ru).
  5. Срок действия лицензии может быть ограничен.
  6. В выдаче лицензии может быть отказано без объяснения причин.
  7. Условия выдачи лицензии/лицензирования могут быть изменены по усмотрению авторов.

Для получения лицензии "Educational" необходимо отослать Константину Александровичу Орлову письмо по электронной почте (orlov@twt.mpei.ac.ru), в котором будет указано следующее (все из указанного):

  1. Ф.И.О. студента
  2. Полное название высшего учебного заведения
  3. Полное название подразделения (факультета/института) вуза
  4. Полное название кафедры
  5. Название группы
  6. Год поступления
  7. Предполагаемый год выпуска
  8. Строка "Системная информация: [НОМЕР]", которая выводится в окне регистрации программы (появляется после запуска, например, "WaterSteamPro Calculator")
  9. Сканированный с разрешением не менее 90 и не более 100 dpi (точек на дюйм) студенческий билет (набор цветов - оттенки серого).


Возможные способы использования WaterSteamPro

Использовать пакет "WaterSteamPro" для вычислений свойств воды и водяного пара можно следующими способами:

  • для обычного использования – с помощью программы "WaterSteamPro Calculator";
  • в физико-математическом пакете Mathcad (см. "Использование WaterSteamPro в Mathcad");
  • для более специализированных задач – через обращение к библиотеке OKAWSP6.DLL, которая экспортирует все необходимые функции. Пример использования – программа "WaterSteamPro Calculator", файл надстройки Microsoft Excel "OKAWSP6.XLA";
  • через ActiveX объект с PROGID "WSP.WSPCalculator". Пример использования – Microsoft Excel и WSH;
  • для использования "WaterSteamPro" в других программах возможно создание библиотеки-заглушки, которая обращается к "OKAWSP6.DLL". Пример такого использования – библиотека "WSPMCAD.DLL", которая является "посредником" между Mathcad и "OKAWSP6.DLL".


Использование библиотеки OKAWSP5.DLL

С версии 6.0 библиотека OKAWSP5.DLL не поставляется. Вместо нее необходимо использовать библиотеку OKAWSP6.DLL.

В случае необходимости библиотеку можно взять из пакета поставки WaterSteamPro версии 5.


Использование библиотеки OKAWSP6.DLL

В библиотеке "OKAWSP6.DLL" содержится непосредственно код, ответственный за вычисление свойств воды и водяного пара. Библиотека является стандартной динамически линкуемой библиотекой Windows (Dynamic link library) и поэтому может использоваться во всех программах, «умеющих» обращаться к DLL.

Местонахождение библиотеки – в папке "SYSTEM" каталога Windows. Обычно для Windows 9x это папка "C:\WINDOWS\SYSTEM", а для WinNT - "C:\WINNT\SYSTEM32".

Список экспортируемых функций приведен в разделе "Описание функций WaterSteamPro", поэтому остановимся только на особенностях библиотеки.

Все экспортируемые функции принимают аргументы и возвращают значения в системе единиц СИ, поэтому для других размерностей требуется перерасчет. Один из примеров работы с различными размерностями приведен в программе "WaterSteamPro Calculator", которая описана выше и поставляется с исходным кодом.

Пример работы с данной библиотекой в среде программирования Visual Basic приведен в программе "WaterSteamPro Calculator". Возможно также использование данной библиотеки в других языках.


WaterSteamPro Calculator

Программа WaterSteamPro Calculator

Данная программа предназначена для вычислений свойств воды и водяного пара без использования дополнительных программных продуктов.

Она поставляется с исходным кодом аналогичной программы, написанной на языке Visual Basic из Microsoft Visual Studio 6.0 Professional Edition (Service Pack 3).

На рис. 1 представлено основное окно программы.

Рис. 1. Основное окно программы WaterSteamPro Calculator

Существует несколько режимов использования программы, которые определяются различными аргументами функций пакета WaterSteamPro.

Настройка программы WaterSteamPro Calculator описана в разделе "Настройка WaterSteamPro Calculator".


Возможные режимы расчетов

Возможные режимы расчетов в программе WaterSteamPro Calculator

  • "Общие свойства" – свойства воды/водяного пара вычисляются по давлении и температуре. При этом автоматически определяется область состояния воды. В случае нахождения рассчитываемой точки на линии насыщения возвращаются параметры для пара.

    Рис. 1. Расчет свойств по общим функциям

  • "Линия насыщения – по давлении" – свойства воды/водяного пара на линии насыщения в зависимости от давления.
  • "Линия насыщения – по температуре" – свойства воды/водяного пара на линии насыщения в зависимости от температуры.
  • "Двухфазная область - по давлении" – свойства воды/водяного пара по давлении и степени сухости в двухфазной области.
  • "Двухфазная область – по температуре" – расчет свойств в двухфазной области по температуре и степени сухости.


Настройка программы

Настройка программы WaterSteamPro Calculator

Программа "WaterSteamPro Calculator" позволяет настраивать вывод значений свойств воды и водяного пара для различных единиц измерения. Для каждого из рассчитываемых значений существует несколько возможных единиц измерения, которые можно выбирать из списка, находящегося справа от поля с выводимым числовым значением. Окно программы с одним из вариантов размерностей приведен на рис. 1.

Рис. 1. Основное окно программы WaterSteamPro Calculator

Также в программе WaterSteamPro Calculator возможны следующие настройки:

  • Настройка количества выводимых значащих цифр. Настройка производится выбором в меню "Настройки" пункта "Точность...". В появившемся диалоге необходимо ввести количество выводимых цифр рассчитываемых величин. Диапазон изменения - от 1 до 15.
  • Настройка режима ведения проверки диапазона аргументов. При снятии флажка с пункта "Вести проверку диапазона" в меню "Настройки" будет отключаться проверка на соответствие диапазона аргументов. Это производится вызовом функции пакета WaterSteamPro "wspSETCHECKRANGEMODE(mode)". Аналогично производится обратное действие.


WaterSteamPro Calculator

Программа WaterSteamPro Calculator (Visual Basic)

В комплект поставки WaterSteamPro входит исходный код программы, аналогичной WaterSteamPro Calculator. Этот исходный код написан на Microsoft Visual Basic 6.0 (Professional Edition), потому программа называется WaterSteamPro Calculator (Visual Basic), в отличие от просто программы WaterSteamPro Calculator, которая написана на Visual C++.

Так сложилось исторически, что программа WaterSteamPro Calculator сначала создавалась на Visual Basic и была вполне закончена. Однако потом оказалось, что необходимо распространять очень большой объем дополнительных библиотек поддержки Visual Basic. Поэтому программа была переписана на Visual C++. При этом она поменяла свои функциональные возможности, но "дух программы" остался неизменным.

Для использования программы WaterSteamPro Calculator (Visual Basic) необходимо скомпилировать проект "watersteampro.vbp" используя Microsoft Visual Basic 6.0.

Настройка программы WaterSteamPro Calculator (Visual Basic) описана в разделе "Настройка WaterSteamPro Calculator (Visual Basic)".


Настройка программы

Настройка программы WaterSteamPro Calculator (только в программе на Visual Basic)

Программа "WaterSteamPro Calculator" позволяет настраивать режима ведения проверки диапазона аргументов. При снятии флажка с пункта "Вести проверку диапазона" в меню "Настройки" будет отключаться проверка на соответствие диапазона аргументов. Это производится вызовом функции пакета WaterSteamPro "wspSETCHECKRANGEMODE(mode)". Аналогично производится обратное действие.

Программа "WaterSteamPro Calculator" также позволяет настраивать вывод значений свойств воды и водяного пара для различных единиц измерения и форматов. Для этого в каталоге с программой "WaterSteamPro Calculator" находится файл "WATERSTEAPRO.INI". Данный файл – это стандартный файл настроек Windows, в котором содержатся секции, ключи и соответствующие им значения. Далее приводится описание формата этого файла.

Секция [Format]

В данной секции производится настройка формата вывода значений свойств воды и водяного пара. Параметры форматирования используются при вызове встроенной функции "FORMAT" языка программирования Visual Basic, поэтому их описание можно взять из любого источника, посвященного работе с Visual Basic.

Возможные ключи в данной секции:

  • "SaturationPressure" - формат для вывода значения давления насыщения;
  • "SaturationTemperature" - формат температуры насыщения;
  • "EvaporationHeat" - формат удельной теплоты парообразования;
  • "Volume" - формат удельного объема;
  • "InternalEnergy" - формат удельной внутренней энергии;
  • "Entropy" - формат удельной энтропии;
  • "Entalphy" - формат удельной энтальпии;
  • "HeatCapacityAtConstantPressure" - формат удельной изобарной теплоемкости;
  • "HeatCapacityAtConstantVolume" - формат удельной изохорной теплоемкости;
  • "SoundVelocity" - формат скорости звука;
  • "ThermoConductivity" - формат теплопроводности;
  • "DynamicViscosity" - формат динамической вязкости;
  • "KinematicViscosity" - формат кинематической вязкости;
  • "Prandtle" - формат числа Прандтля;
  • "IsoEntropyCoefficient" - формат коэффициента изоэнтропы;
  • "SurfaceTension" - формат поверхностного натяжения;

Настройка единиц измерения

Все функции в библиотеке OKAWSP6.DLL получают аргументы и возвращают значения в международной системе единиц СИ. Для перерасчета в другие единицы измерения в программе "WaterSteamPro Calculator" введена поддержка задания новых размерностей. Для этого в файле "WATERSTEAMPRO.INI" существует несколько секций, в которых производится настройка соответствия между пользовательскими размерностями и стандартными из СИ. Структура каждой секции следующая: для каждой размерности должно быть два ключа - один "название" размерности, а второй - "переводной коэффициент", между новой размерностью и стандартной. Имя ключа для "названия" размерности составляется по следующему правилу: строка "Name_" и "№", где "№" - порядковый номер текущей размерности в данной секции. А имя ключа для "переводного коэффициента" размерности - строка "Value_" и "№". Нумерация начинается с единицы и не должна иметь пропусков.

Рассмотрим пример создания набора размерностей для давления. Соответствующая секция имеет имя "Pressure". Поэтому в файле "WATERSTEAMPRO.INI" могут быть следующие строки:

[Pressure]
Name_1=бар
Value_1=100000
Name_2=МПа
Value_2=1000000
Name_3=Psi
Value_3=6894.75729316836
Name_4=атм
Value_4=101325
Name_5=дюйм рт. ст.
Value_5=3376.86427794708
Name_6=torr
Value_6=133.322312022206
Name_7=мм рт. ст.
Value_7=133.322312022206

В рассматриваемом примере определено семь дополнительных размерностей со следующими названиями: "бар", "МПа", "Psi", "атм", "дюйм рт. ст.", "torr", "мм рт. ст.". Каждой размерности соответствует переводной коэффициент. Базовая единица измерения давления в СИ - это Па. В одном баре содержится 100 000 Па, поэтому переводной коэффициент для размерности "бар" - 100 000. Аналогичным образом вычисляются переводные коэффициенты для оставшихся размерностей. Количество возможных размерностей ограничивается только системными ресурсами.

Секции в файле настроек для указания размерностей:

  • [Pressure] - размерности давления. Используются для вывода: "давления на линии насыщения" и ввода "давления". Базовая размерность - Па.
  • [DegreeOfDryness] - размерности степени сухости. Используются для ввода "степени сухости". Базовая размерность - безразмерная величина (доли).
  • [Volume] - размерности удельного объема. Используются для вывода "удельного объема". Базовая размерность - м3/кг.
  • [Energy] - размерности энергии. Используются для вывода "удельной энтальпии", "удельной внутренней энергии" и "теплоты парообразования". Базовая размерность - Дж/кг.
  • [Entropy] - размерности энтропии. Используются для вывода "удельной энтропии", "удельной изобарной теплоемкости" и "удельной изохорной теплоемкости". Базовая размерность - Дж/(кг·К).
  • [Velocity] - размерности скорости. Используются для вывода "скорости звука". Базовая размерность - м/с.
  • [ThermCond] - размерности теплопроводности. Используются для вывода "теплопроводности". Базовая размерность - Вт/(м·К).
  • [DynVis] - размерности динамической вязкости. Используются для вывода "динамической вязкости". Базовая размерность - Па·с.
  • [KinVis] - размерности кинематической вязкости. Используются для вывода "кинематической вязкости". Базовая размерность - м2/с.
  • [SurfaceTension] - размерности поверхностного натяжения. Используются для вывода "поверхностного натяжения". Базовая размерность - Н/м.


Использование объекта ActiveX

Использование ActiveX объекта WSP.WSPCalculator

Библиотека "OKAWSP6.DLL" является "сервером" для ActiveX объекта с ProgID "WSP.WSPCalculator". Данный объект экспортирует функции, аналогичные функциям библиотеки "OKAWSP6.DLL". В принципе, в нем просто производится переадресация вызова функции в библиотеку "OKAWSP6.DLL", поэтому отличие использования непосредственно библиотеки "OKAWSP6.DLL" от использования ActiveX объекта "WSP.WSPCalculator" – только в приемах обращения к функциям.

Для функционирования ActiveX объекта "WSP.WSPCalculator" необходимо, чтобы он был зарегистрирован в реестре Windows. Если происходит ошибка обращения к данному объекту, то для регистрации его в системе необходимо выполнить следующую программу:

Regsvr32.exe okawsp6.dll

Программа "Regsvr32.exe" входит в поставку Windows 98 и находится в каталоге "SYSTEM" (там же должна находиться библиотека "OKAWSP6.DLL").

Примеры использования ActiveX объекта "WSP.WSPCalculator" приведены в файле Microsoft Excel с именем "WSP EXCEL.XLS" и в двух файлах Windows Scripting Host с именами "WSP.JS" и "WSP.VBS". Описания примеров даны в соответствующих разделах.

Имена функций ActiveX объекта "WSP.WSPCalculator" совпадают с именами функций, экспортируемых библиотекой "OKAWSP6.DLL", поэтому их перечень в данном разделе не приводится, а дан в пункте "Описание функций пакета "WaterSteamPro".


Использование ActiveX-объекта "WSP.WSPCalculator" в Microsoft Excel

В файле "WSP EXCEL.XLS" приводится пример использования пакета "WaterSteamPro" в программе Microsoft Excel. Версия Microsoft Excel должна быть не ниже 8.0 (Microsoft Excel 97).

Для доступа к функциям пакета "WaterSteamPro" в рассматриваемом примере используется ActiveX-объект "WSP.WSPCalculator". Для этого в редакторе Visual Basic for Applications (VBA) создается новый модуль, в котором будет находиться непосредственно код создаваемых функций-заглушек. Для перехода к редактору Visual Basic необходимо либо нажать сочетание клавиш Alt-F11, либо выбрать пункт "Редактор Visual Basic" в меню "Сервис/Макрос".

Далее есть два пути доступа к объекту "WSP.WSPCalculator". Первый – создавать экземпляр объекта через функцию "CreateObject(class,[servername])", которая создает ActiveX-объект с именем "class" и сервером с именем "servername". В этом случае код функции для вычисления, например, давления насыщения по температуре, будет таким:

Function PST(t as double) as double
Dim wsp as object
Set wsp = CreateObject("WSP.WSPCalculator")
PST = wsp.wspPST(t)
End function

Разберем этот пример. Мы определяем функцию с именем "PST" (тип "double"), которая по температуре "t" (тип "double") возвращает давление насыщения. Далее мы объявляем переменную с именем "wsp" и типом "object". В следующей строке переменной "wsp" присваиваем результат, возвращаемый функцией "CreateObject" с параметром "WSP.WSPCalculator". После этого в качестве результата функции "PST" используется значение, возвращаемое функцией "wspPST" созданного экземпляра объекта "WSP.WSPCalculator" с именем "wsp".

Недостаток данного метода в том, что при каждом обращении к функции будет производиться создание нового экземпляра объекта "WSP.WSPCalculator".

Второй способ организации доступа – это подключение всех ActiveX объектов из библиотеки OKAWSP6.DLL в документ Excel. Для этого в редакторе Visual Basic в меню "Tools" выбираем пункт "References". В появившемся списке (рис. 4) отмечаем элемент "WaterSteamPro" и нажимаем кнопку OK.

Рис. 4. Вставка ссылки на библиотеку

При этом нам становятся доступными все ActiveX объекты из подключенной библиотеки. И теперь для доступа к функциям "WaterSteamPro" можно использовать следующий код (определим второй вариант функции, высчитывающей давление насыщения по температуре):

Public wsp2 As New Wsp.WSPCalculator
Function PST2(t as double) as double
PST2 = wsp2.wspPST(t)
End function

Разберем пример. Мы в модуле (не в функции) объявляем переменную "wsp2" с типом "Wsp.WSPCalculator". А в функциях-заглушках производим обращения к методам этой переменной.

Преимущество второго метода в том, что при написании функций можно использовать технологию Microsoft IntelliSence, которая позволяет выводить список всех доступных функций. Для этого также можно использовать Object Browser (клавиша F2). Второе преимущество – в скорости работы функций – ActiveX-объект будет создан лишь один раз, а не при каждом обращении к функции.

Аналогичным образом можно использовать пакет "WaterSteamPro" в любых программах, "понимающих" Visual Basic. В принципе, в программе "WaterSteamPro Calculator" (версия для Microsoft Visual Basic) можно было бы организовать доступ к функциям аналогичным образом, но прямое обращения к DLL производится более быстро, чем через объекты ActiveX.


Использование WaterSteamPro в Microsoft Excel

В программе Microsoft Excel для программирования используется язык Visual Basic for Applications (VBA). В нем заложены возможности как обращения к ActiveX-объектам, так и непосредственно к системным библиотекам Windows. Это позволяет использовать пакет "WaterSteamPro" в Excel двумя способами. Первый способ – через обращение к ActiveX-объекту "WSP.WSPCalculator". Второй способ –непосредственное использование библиотеки "OKAWSP6.DLL".

В поставку пакета "WaterSteamPro" входит файл "WSP EXCEL.XLS", в котором находится пример использования пакета в Microsoft Excel. Этот файл предназначен для демонстрации способов доступа к функциям из различных программ. В нем используются только часть функций и приведены примеры расчетов свойств воды/водяного пара с их помощью.

Для непосредственного (и самого простого!) использования функций для расчетов свойств воды и водяного пара в Microsoft Excel необходимо использовать надстройку "OKAWSP6.XLA", которая также входит в комплект поставки пакета "WaterSteamPro". Механизм ее использования описан в разделе "Использование надстройки для Microsoft Excel".


Использование надстройки для Microsoft Excel

В программе Microsoft Excel возможно использование т.н. "надстроек". Они представляют собой программы, в которых производятся какие-либо действия, вычисления, отсутствующие в стандартных возможностях Excel.

В комплекте поставки WaterSteamPro находится модуль (файл с расширением "xll"), в котором импортируются функции из главной библиотеки "OKAWSP6.DLL", и которые затем становятся доступными для использования в Microsoft Excel (в рабочем листе или в Visual Basic). При этом перечень функций WaterSteamPro появляется в диалоге "Мастер функций" (см. рис. 5) Microsoft Excel.

Рис. 5. Мастер функций Microsoft Excel

Для использования XLL-надстройки WaterSteamPro необходимо, чтобы данный файл (обычно с именем wspexcel.xll) находился в каталоге пользовательских надстроек Microsoft Excel. Обычно файлы надстроек хранятся в папке, которая находится в "[OFFICE_PATH]\OFFICE\LIBRARY" (где [OFFICE_PATH] - папка установки Microsoft Office). Однако, возможно другое расположение файла надстроек – при этом в диалоге "Надстройки" (подключение надстройки) необходимо будет указать путь до XLL-файла, который по умолчанию устанавливается в каталог "[OFFICE_PATH]\OFFICE\LIBRARY", где "OFFICE_PATH" – каталог установки пакета Microsoft Office.

Для подключения файла-надстройки в Microsoft Excel необходимо в меню "Сервис" выбрать пункт "Надстройки". При этом появится диалог с перечнем доступных расширений (см. рис. 6а). Если XLL-файл WaterSteamPro находится в каталоге настроек Microsoft Excel, то пункт "WaterSteamPro" автоматически появится в рассматриваемом диалоге. В противном случае необходимо нажать на кнопку "Обзор…" и указать месторасположение XLL-файла. Далее необходимо отметить пункт "WaterSteamPro", что сигнализирует о том, что вы хотите подключить данную надстройку и нажать на кнопку "OK".

Рис. 6а Диалог "Надстройки" в Microsoft Excel

После этого все функции пакета "WaterSteamPro" станут доступными не только в течение текущего сеанса работы с Microsoft Excel, но при последующих запусках. Для отключения автозагрузки XLL-надстройки WaterSteamPro необходимо отменить в вышерассмотренном диалоге "Надстройки" пункт "WaterSteamPro".

В версиях Microsoft Office, начиная с 2007, для включения XLL-надстройки необходимо сделать несколько больше шагов. Их последовательность показана на рис. 6б-6в.

Рис. 6, б Переход к диалогу "Параметры" в Microsoft Excel

Рис. 6, в Переход к диалогу "Надстройки" в Microsoft Excel

Рис. 6, а Диалог "Надстройки" в Microsoft Excel


Использование WaterSteamPro в WSH

Использование WaterSteamPro в WSH (Windows Scripting Host)

Windows Scripting Host – это технология создания программ в Windows с использованием скриптовых языков. Она явилась на смену bat файлам из MS-DOS. В стандартной поставке Windows 98 входят два скриптовых языка: JScript (аналог JavaScript) и VBScript (Visual Basic Scripting Edition). Программа для WSH представляет собой текстовый файл, который хранит программу, написанную на языке, поддерживаемом WSH.

Далее приведено содержимое двух файлов для WSH, написанных на JScript и VBScript, в которых производится вычисление удельных объема, энтальпии и энтропии для точки с давлением и температурой, задаваемыми в качестве аргументов при вызове файла-программы. При отсутствии аргументов вычисляются значения для параметров по умолчанию. В противном случае первый аргумент – давление (Па), а второй – температура (К).

Файл "WaterSteamPro.js", язык программирования – JScript:

var wsp = WScript.CreateObject("WSP.WSPCalculator");
var wshshell = WScript.CreateObject("WScript.Shell")
if (! wsp)
{
   wshshell.Popup('Error with creating ActiveX object!',0,'',0)
   WScript.Quit();
}else
{
   var arg = WScript.Arguments;
   var p = 1000000;
   var t = 400;
   if (arg.length > 1)
   {
      p = arg.Item(0);
      t = arg.Item(1);
   }else
   {
      wshshell.Popup('Arguments absent. Loaded default values!',0,'',0);
   };
   var v = wsp.wspVPT(p, t);
   var s = wsp.wspSPT(p, t);
   var h = wsp.wspHPT(p, t);
   wshshell.Popup('P='+p+'Pa;T='+t+'K;V='+v+'m3/kg;S='+s+'J/kg*K;H='+h+'J/kg',0,'',0);
}

В данном примере используется подход, описанный в разделе "Использование "WaterSteamPro" в Microsoft Excel" с обращением к функции "CreateObject", поэтому описывать пример досконально не будем, а остановимся только на общих деталях.

В первых строках производится создание двух объектов, один из которых служит для доступа к функциям для расчета свойств воды и водяного пара, а второй – для вывода сообщений. После этого проверяется был ли создан объект "WSP.WSPCalculator" и в противном случае выводится предупреждающее сообщение и программа завершает работу. Если экземпляр объекта был создан успешно, то создаются: переменная "arg" с коллекцией аргументов при вызове файла (указываемых в командной строке), две переменные со значениями расчетных параметров по умолчанию (для давления "p" – это 1000000, а для температуры "t" – 400). После этого проверяется на количество аргументов и если их число больше единицы (два и больше), то в переменные "p" и "t" заносятся соответственно первый и второй аргументы (их номера – ноль и единица). В противном случае выводится сообщение, что аргументы отсутствуют и используются значения по умолчанию. На следующем шаге производится обращение к методам созданного объекта "wsp" (с типом "WSP.WSPCalculator"), которые озвращают значения удельных объема, энтропии и энтальпии. Завершает программу вывод сообщения с полученными результатами расчетов.

Рассмотрим файл "WaterSteamPro.vbs", язык программирования – VBScript. Алгоритм программы полностью идентичен описанному выше, а все отличия связаны только со спецификой языка программирования:

Set wsp = WScript.CreateObject("WSP.WSPCalculator")
Set wshshell = WScript.CreateObject("WScript.Shell")
if Not IsObject(wsp) Then
   wshshell.Popup "Error with creating ActiveX object!",0,"",0
   WScript.Quit
Else
   Set arg = WScript.Arguments
   Dim p
   p = 1000000
   Dim t
   t = 400
   if arg.length > 1 Then
      p = arg.Item(0)
      t = arg.Item(1)
   else
      wshshell.Popup "Arguments absent. Loaded default values!",0,"",0
   End if
   dim v
   v = wsp.wspVPT(p, t)
   dim s
   s = wsp.wspSPT(p, t)
   dim h
   h = wsp.wspHPT(p, t)
   wshshell.Popup "P=" & p & ";T=" & t & ";V=" & v & ";S=" & s & ";H=" & h & "”,0,"",0
end if


Использование WaterSteamPro в Mathcad Professional

Использование WaterSteamPro в Mathcad

Пользователям Mathcad 12

Mathcad Professional – это математический пакет, созданный фирмой MathSoft, Inc. Исторически сложилось так, что первые версии "WaterSteamPro" были созданы в Mathcad и могли использоваться только в нем. Но, начиная с 5-ой версии, функции были переписаны на язык C++, что позволило использовать "WaterSteamPro" в других программах.

В старых версиях "WaterSteamPro" для использования в Mathcad функций для расчета свойств воды и водяного пара необходимо было импортировать документ Mathcad с определениями функций в новый документ. Для этого использовался механизм Ссылок (Reference). В новой версии для доступа к функциям из библиотеки OKAWSP6.DLL написана библиотека-заглушка WSPMCAD.DLL, которая переадресует вызовы из Mathcad в OKAWSP6.DLL. Библиотека WSPMCAD.DLL написана по механизму USEREFI, который позволяет подключать функции, написанные на языке C в Mathcad. К сожалению, политика фирмы MathSoft основана на том, что только в версиях Mathcad Professional возможен доступ к пользовательским функциям. Это привело к следующим требованиям к пакету Mathcad:

  • версия Professional (Mathcad Standard не подходит);
  • версия Mathcad не ниже 8.0. В принципе, возможно использование Mathcad 7 Professional, но при этом будут недоступны описание функций пакета "WaterSteamPro" в диалоге "Insert Function" и встроенная возможность пакета Mathcad работы с использованием размерностей.
  • возможна также работа в демо-версии Mathcad – Mathcad Explorer, но в тестируемой версии Mathcad 8 Explorer (SP2) наблюдались непонятные баги, хотя сами функции работали.

Как уже отмечалось, для использования возможностей новой версии пакета "WaterSteamPro" в Mathcad Professional написана библиотека WSPMCAD.DLL. Эта библиотека должна находиться в папке USEREFI каталога Mathcad.

Внимание: к сожалению, из соображений унификации, версия 5 пакета "WaterSteamPro" несовместима с предыдущими версиями по названиям функций. Поэтому для документов Mathcad, использующих старые версии необходимо изменить имена на новые. Также в 5-ой версии не определена часть функций для расчетов свойств воды/водяного пара на линии насыщения (которые, впрочем, мало использовались). В документах, их использующих, необходимо использовать старые версии программы. Второй вариант – использовать одновременно старую и новую версии пакета "WaterSteamPro" (данная возможность успешно протестирована).

Одной из новых возможностей стала доступность к вставке функций для расчета свойств воды и водяного пара в рабочий документ через стандартный диалог вставки функций "Insert Function", который доступен либо на панели инструментов, либо через пункт "Insert Function …" в меню "Insert". Для появления в этом диалоге перечня функций необходимо, чтобы в папке DOC\FUNCDOC каталога Mathcad находился файл WSPMCAD.XML, в котором приведены описания функций пакета "WaterSteamPro". Отсутствие возможности использования данного файла в Mathcad 7 Professional привело к отсутствию в данной версии Mathcad описаний функций в диалоге "Insert Function".

При успешной установке для доступа к функциям расчета свойств воды и водяного пара необходимо будет просто вставлять их из диалога "Insert Function", описанного ниже. При отсутствии в нем перечня функций необходимо либо заново произвести установку, либо вручную прописать все файлы, как это описано выше. В крайнем случае, можно обратиться к автору программы, Константину Орлову по e-mail: orlov@twt.mpei.ac.ru.

Все функции пакета "WaterSteamPro" в диалоге "Insert Function" приведены в разделах, начинающихся со строки "WaterSteamPro" (см. рис. 7).

Рис. 7. Диалог "Insert Function" c функциями пакета "WaterSteamPro"

Внимание: Настоятельно рекомендуется использовать размерные функции пакета WaterSteamPro в Mathcad. Для этого необходимо включить (Reference) файл "WaterSteamPro.mcd" в рабочий документ Mathcad. Как это сделать описано в документации по Mathcad. Описание использования размерных функций дано в разделе "Два способа использования функций в Mathcad".

Пользователям Mathcad 12

В пакете Mathcad 12 (вплоть до Mathcad 12.0a на момент написания данного раздела) есть ошибка, связанная с невозможностью использования русских букв в сообщениях об ошибках. Для решения этой проблемы в русской версии WaterSteamPro 6.0 производится проверка на версию Mathcad и если она равна 12, то производится "транслитерация", т.е. русские буквы заменяются на аналогичные по звучанию латинские.

В пакете Mathcad 12 фирмой-разработчиком пакета были внесены значительные изменения в работу пользовательских функций в связи с введением т.н. "namespaces" (пространств имен).

В связи с этим содержание файлов "watersteampro.mcd" для версий Mathcad до 12 и с 12 различаются. Поэтому для разных версий пакета требуются разные файлы "watersteampro.mcd". Все версии WaterSteamPro до 6.0 beta 8 включительно не были совместимы с Mathcad 12.

Для того, чтобы решить проблему использования размерных функций WaterSteamPro в Mathcad 12 и других версиях (что осуществляется в файле "watersteampro.mcd") в окончательной версии WaterSteamPro 6.0 было сделано следующее:

  • При установке инсталлятор WaterSteamPro 6.0 проверяет версию пакета Mathcad. В случае, если версия меньше 12, то устанавливается файл "watersteampro.mcd" для версий Mathcad от 8 до 11. Если версия больше, либо равна 12, то устанавливается новый файл "watersteampro.mcd" для Mathcad 12.
  • Помимо этого, файл "watersteampro.mcd" для версий Mathcad до 12 устанавливается в папки "[WATERSTEAMPRO_INSTALL_PATH]\Samples\Mathcad\MC8" и "[MATHCAD_DOCS]\WaterSteamPro\MC8", независимо от установленной версии Mathcad. "[WATERSTEAMPRO_INSTALL_PATH]" - это папка, в которую установлен пакет WaterSteamPro, а "[MATHCAD_DOCS]" - папка, в которую установлены документы для Mathcad.
  • Аналогично файл "watersteampro.mcd" для версий Mathcad 12 и выше устанавливается в папки "[WATERSTEAMPRO_INSTALL_PATH]\Samples\Mathcad\MC12" и "[MATHCAD_DOCS]\WaterSteamPro\MC12", независимо от установленной версии Mathcad.

Это позволяет использовать файл для той версии Mathcad, которая установлена у пользователя. В случае перехода на новую версию можно, не переустанавливая WaterSteamPro, заменить файл "watersteampro.mcd" на требуемый из папок "MC8" или "MC12".

В случае, если одновременно установлено несколько версий пакета Mathcad (например Mathcad 11 и Mathcad 12), то необходимо создавать ссылки на соответствующий данной версии Mathcad файл "watersteampro.mcd". В этом случае работа с одним документом в разных версиях Mathcad несколько затруднительна.


Два способа использования функций в Mathcad

В пакете Mathcad есть встроенная возможность работы с размерными величинами. Это позволяет более мощно организовать работу с теми величинами, которые имеют размерность.

Возможны следующие режимы использования пакета "WaterSteamPro" в Mathcad:

  • без размерностей. В этом случае все аргументы функций должны быть в системе СИ. Аналогично возвращаются значения также в системе СИ.
  • с использованием размерностей. В этом случае контроль размерностей и их перерасчет автоматически обеспечивает Mathcad.

Первый режим доступен сразу после запуска Mathcad (библиотека WSPMCAD.DLL должна находиться в папке USEREFI и быть загружена). В этом случае пользователь должен самостоятельно следить, чтобы все аргументы функций пакета "WaterSteamPro" были в СИ.

Для работы во втором режиме (режим работы с размерностями) необходимо через пункт "Reference …" в меню "Insert" включить в рабочий документ файл с именем "WATERSTEAMPRO.MCD". В этом файле производится переопределение функций, чтобы они могли работать с размерностями.

На рис. 8 показано различие между вышерассмотренными режимами.

Рис. 8. Режимы использования WaterSteamPro в Mathcad

Рекомендуется использование второго режима. Все примеры для Mathcad, входящие в состав поставки "WaterSteamPro", работают с размерностями.

Внимание: не рекомендуется более одного включения (Reference) файла "watersetampro.mcd" в рабочий документ Mathcad. В этом случае возникнут проблемы с размерностями – будут использоваться размерности в степени, равной количеству включений.


Описание функций для расчета свойств воды и водяного пара в пакете WaterSteamPro

Все функции в пакете "WaterSteamPro" принимают аргументы и возвращают размерности в системе единиц СИ. Дополнительные возможности использования размерных величин существуют в программе Mathcad Professional фирмы MathSoft, Inc.

Тип аргументов и результатов – в подавляющем большинстве функций (кроме части служебных) – double (вещественное с двойной точностью).

В случае возникновения ошибки все функции возвращают значение –1 (минус один). Проанализировать код ошибки можно с помощью функции "wspGETLASTERROR()". Код ошибки сохраняется только до следующего вызова какой-либо функции из пакета "WaterSteamPro", кроме служебных.

Имена функций пакета "WaterSteamPro" унифицированы (они имеют одинаковые названия в различных программах) и формируются по следующим правилам:

  • в начале названия стоит префикс "wsp" (маленькими буквами);
  • далее идет идентификатор искомой величины, которую возвращает функция. Например, для удельной энтальпии это "H" (заглавными буквами);
  • следующая составляющая – это идентификатор области и состояния воды/водяного пара. Например, для воды на линии насыщения это "SW". Для обобщенных функций (например, удельный объем как функция давления и температуры) эта составляющая отсутствует.
  • Завершают название функции идентификаторы аргументов. Так, для удельного объема как функции давления, температуры и степени сухости это "PTX" – от "P" – "Pressure" (давление); "T" – "Temperature" (температура); "X" – "degree of dryness (X)" (степень сухости).

Строковые идентификаторы величин и их размерности в системе СИ:

  • давление "Pressure" – "P", [Па];
  • температура "Temperature" – "T", [К];
  • удельный объем "specific Volume" – "V", [м3/кг];
  • удельная внутренняя энергия "specific internal energy (U)" – "U", [Дж/кг];
  • удельная энтропия "specific entropy (S)" – "S", [Дж/(кг·К)];
  • удельная энтальпия "specific enthalpy (H)" – "H", [Дж/кг];
  • удельная изобарная теплоемкость "specific heat Capacity at constant Pressure" – "CP", [Дж/(кг·К)];
  • удельная изохорная теплоемкость "specific heat Capacity at constant Volume" – "CV", [Дж/(кг·К)];
  • скорость звука "sound velocity (W)" – "W", [м/с];
  • плотность "density (R)" – "R", [кг/м3];
  • удельная теплота парообразования "specific evaporation heat (R)" – "R", [Дж/кг];
  • теплопроводность "THERMal CONDuctivity" – "THERMCOND", [Вт/(м·К)];
  • динамическая вязкость "DYNamic VIScosity" – "DYNVIS", [Па·с] = [кг/(м·с)];
  • кинематическая вязкость "KINematic VIScosity" – "KINVIS", [м2/с];
  • коэффициент поверхностного натяжения "SURFace TENsion" – "SURFTEN", [Н/м];
  • число Прандтля "PRANDTLE’s number" – "PRANDTLE", [–];
  • показатель изоэнтропы "isoentropic coefficient (K)" – "K", [–];

Идентификаторы областей и состояния воды:

  • обобщенные функции (область определения – весь диапазон) – без идентификатора;
  • функции свойств воды на линии насыщения "Saturation Water" – "SW";
  • функции свойств пара на линии насыщения "Saturation Steam" – "SS";
  • функции свойств в двухфазной области "Saturation" – "S";


Описание исходных уравнений WaterSteamPro

Исходными формулами для функций расчета термодинамических свойств воды и водяного пара являются основные уравнения Международной системы уравнений 1997 г. для термодинамических свойств воды и водяного пара (предложенные Международной ассоциацией по свойствам воды и водяного пара), предназначенной для промышленных расчетов, далее называемой Формуляция IF-97. Краткое описание этой Формуляции приводится в последующих разделах.


Основные константы

Удельная газовая постоянная воды R = 0,461526 кДж/(кг·К).

Критические параметры:

  • абсолютная температура Ткр = 647,096 К по Международной температурной шкале 1990 г. (МТШ – 90);
  • давление Pкр = 22,064 МПа;
  • плотность rкр = 322 кг/м3.


Структура Формуляции IF–97

Формуляция состоит из набора уравнений для различных областей, в совокупности охватывающих область параметров:

273.15 К ≤ T ≤ 1073.15 К при p ≤ 100 МПа

1073.15 К ≤ T ≤ 2273.15 К при p ≤ 50 МПа

Расположение этих областей в р-Т диаграмме показано на рис. 1, а на других диаграммах - на рис. 2-4. Области 1, 2, 5 описаны фундаментальным уравнением для энергии Гиббса g(р, Т), область 3 – фундаментальным уравнением для энергии Гельмгольца f(ρ, Т), а линия насыщения представлена уравнениями Ps(Тs) и Ts(Ps). Эти пять уравнений составляют группу основных уравнений Формуляции. Кроме них имеется группа дополнительных уравнений, позволяющих избегать итерационных вычислений. Описание их приведено в [3].

Рис. 1. Области применения уравнений Формуляции IF – 97

Границы областей ясны из рис. 1, за исключением границы между областями 2 и 3, которая является линией, близкой к изоэнтропе: значения энтропии на ней изменяются от 5,047 до 5,126 кДж/(кг·К). Эта граница может быть представлена уравнениями вида:

P = n1 + n2·T + n3·T2 (1)

или

T = n4 + ((P - n5)/n3)(1/2) (2)

Уравнения (1) и (2) действительны в интервале температур от 623,15 К при давлении 16,5292 МПа до 863,15 К при 100 МПа.

В IF-97 есть также уравнения для метастабильного (переохлажденного) пара. Они описывают термодинамические свойства метастабильного переохлажденного пара в области состояний, ограниченной линией сухого насыщенного пара и линией, соответствующей степени сухости пара x = 0,95. При этом степень сухости пара x определена по значениям энтальпии пара h'' и жидкости h' в равновесном состоянии при давлениях от давления в тройной точке до 10 МПа. Границы области метастабильного пара на различных диаграммах показаны на рис. 5-6.

Рис. 2. Области применения уравнений Формуляции IF - 97

Рис. 3. Области применения уравнений Формуляции IF - 97

Рис. 4. Области применения уравнений Формуляции IF - 97

Рис. 5. Области применения уравнений метастабильного пара Формуляции IF - 97

Рис. 6. Области применения уравнений метастабильного пара Формуляции IF - 97


Согласование значений термодинамических величин на границах областей

Расхождения значений термодинамических свойств, рассчитанных по основным уравнениям граничащих областей в однофазной области, показаны в табл. 1. Расхождения значений давления, температуры и энергии Гиббса на линии насыщения приведены в табл. 2, где выделена точка при Т = 623,15 К, в которой стыкуются уравнения для трех областей.

Таблица 1. Расхождение термодинамических свойств, рассчитанных по основным уравнениям, на границах областей

Величина, х | Границы областей 1, 3 |  | Границы областей 2, 3 |  | Границы областей 2, 5
 | |Δx|max | σ*1 | |Δx|max | σ | |Δx|max | σ
v, % | 0,004 | 0,002 | 0,018 | 0,007 | 0,002 | 0,001
h, кДж/кг | 0,031 | 0,014 | 0,134 | 0,073 | 0,020 | 0,012
СР, % | 0,195 | 0,058 | 0,353 | 0,169 | 0,081 | 0,048
s, Дж/(кг*К) | 0,042 | 0,022 | 0,177 | 0,094 | 0,042 | 0,025
g, кДж/кг | 0,005 | 0,005 | 0,005 | 0,003 | 0,026 | 0,021
w, % | 0,299 | 0,087 | 0,403 | 0,073 | 0,021 | 0,009

Таблица 2. Расхождения термодинамических величин, рассчитанных по различным уравнениям, на линии насыщения

Величина, х | T1 ≤ T ≤ 623.15 K |  | 623.15 K ≤ T ≤ Tкр |  | Т = 623,15 К
 | |Δx|max | σ*2 | |Δx|max | σ
PS, % | 0,0069 | 0,0033 | 0,0026 | 0,0015 | 0,0041
ТS, % | 0,0006 | 0,0003 | 0,0003 | 0,0002 | 0,0006
g, кДж/кг | 0,012 | 0,006 | 0,002 | 0,001 | 0,005

*1 Среднеквадратическое расхождение σ рассчитано для 3000 точек, равномерно распределенных вдоль двух частей линии насыщения

*2 Среднеквадратическое расхождение σ рассчитано для 3000 точек, равномерно распределенных вдоль двух частей линии насыщения


Оценка погрешностей

Оценки погрешностей рассчитанных по уравнениям Формуляции IF–97 значений удельного объема, изобарной теплоемкости, давления насыщения и скорости звука показаны на рис. 2, 3, 4, 5. Они представляют собой допуски, в пределах которых могут находиться значения рассматриваемого свойства, и не имеют статического смысла. Указание «погрешность не может быть определена» относится к области, где в качестве исходных данных для уравнения использованы экстраполированные по [1] значения.

Погрешность определения динамической вязкости при давлениях до 100 МПа для жидкости составляет: до 250 °С – 1%, при 300 °С – 2%, при 350 °С и выше – 3%. Для водяного пара при давлениях до 50 МПа и температурах до 475 °С она равна 2%, при более высоких давления и температурах – 3%.

Погрешность определения теплопроводности в области жидкости при температурах от 25 до 200 °С и давлениях до 5 МПа составляет 1.5%, а при более высоких давлениях и температурах до 300 °С – 2%. Для водяного пара при температурах до 550 °С при давлении 0.1 МПа она равна 1.5%, а при давлениях до 40 МПа – 3%. Используемое уравнение для вычисления теплопроводности дает конечное значение в критической точке, в то время как по теоретическим представлениям она должна быть бесконечной. Соответственно, вблизи критической точки погрешность вычисляемых значений теплопроводности оценить невозможно.

Рис. 2. Относительная погрешность значений удельного объема
Для критической области (заштрихованный треугольник), ограниченной изохорами 0,0019 и 0,0069 м3/кг и изобарой 30 МПа, указана относительная погрешность давления.

Рис. 3. Относительная погрешность значений изобарной теплоемкости
Ограничение критической области (заштрихованный треугольник) – см. рис. 2

Рис. 4. Относительная погрешность значений скорости звука
Ограничение критической области (заштрихованный треугольник) – см. рис. 2

Рис. 5. Относительная погрешность значений давления насыщения


Общая характеристика и области применения функций

В пакете WaterSteamPro доступны функции для вычислений термодинамических свойств, кинематической и динамической вязкостей, теплопроводности, числе Прандтля, коэффициента изоэнтропы, коэффициента Джоуля-Томсона и т.д. для воды и водяного пара в состояниях насыщения и в однофазной области, а также коэффициента поверхностного натяжения воды в равновесии с паром.

Все термодинамические свойства воды и водяного пара определены по уравнениям Формуляции IF–97 [2]. При этом значения термодинамических свойств воды и водяного пара в состояниях насыщения при температурах выше 350 °С (давлениях выше 16,5 МПа) вычисляются по неявному уравнению для области 3 при задании значений температуры и давления, определяемых уравнениями линии насыщения (область 4). Все термодинамические функции охватывают область температур от 0.01 до 2000°С при давлениях до 10 МПа и от 0.01 до 800°С при давлении до 100 МПа.

Значения динамической вязкости воды и водяного пара в состоянии насыщения вычисляются по уравнению IAPWS–85 [5], скорректированному для температурной шкалы МТШ–90. При этом значения плотности, являющейся аргументом уравнения, для заданных температуры и давления определяются по уравнениям Формуляции IF–97.

Значения кинематической вязкости вычисляются по уравнению:

ν = μ / ρ

где: μ - динамическая вязкость, определяемая по вышеописанному уравнению; ρ - плотность, вычисляемая как обратная величина удельному объему, определяемому по Формуляции IF-97.

Значения теплопроводности воды и водяного пара в состоянии насыщения вычисляются по уравнению IAPWS–85, рекомендованному для промышленных расчетов [6], скорректированному для температурной шкалы МТШ–90. При этом значения плотности, так же, как и в случае динамической вязкости, являющейся аргументом этого уравнения, определялись по уравнениям Формуляции IF–97.Область вычислений соответствует области, для которой это уравнение рекомендовала IAPWS: температуры от 0.01 до 800°С для давления до 40 МПа, от 0 до 650°С для давления от 40 до 70 МПа, от 0 до 500°С для давлений от 70 до 100 МПа.

Значения числа Прандтля вычисляются по уравнению:

Pr = (μ·Cp) / λ

где: μ - динамическая вязкость; Cp - удельная изобарная теплоемкость, вычисляемая по Формуляции IF-97; λ - теплопроводность. Область параметров, охваченных этим уравнением, соответствует указанной выше области применения уравнения для теплопроводности.

Значения коэффициента изоэнтропы вычисляются по уравнению:

K = w * w / (p * v)

где: w - скорость звука; p - давление; v - удельный объем. Область параметров, охваченных этим уравнением, соответствует области параметров исходной Формуляции IF-97.

Значения коэффициента Джоуля-Томсона (JT = (dt/dp)h) вычисляются по уравнениям, специфичным для каждой области Формуляции IF-97.


Замечания к составу функций ("нефизические" функции)

В пакете WaterSteamPro существует определенный набор функций, которые вычисляют значения свойств воды и водяного пара, не имеющие под собой никакого физического смысла. Пример – функция wspCPSTX(t, x), вычисляющая удельную изобарную теплоемкость в двухфазной области по температуре насыщения t и степени сухости x. В действительности, изобарная теплоемкость в двухфазной области равна бесконечности, т.к. фазовый переход происходит при постоянных давлении и температуре (Dt = 0, Dp = 0), а изменение энтальпии не равно нулю (Dh ≠ 0). Поэтому, cp = (Dh / Dt)p = ∞. Функция лишь возвращает значение, определяемое как:

cpsw(t)·(1 - x) + cpss(t)·x,

где cpsw(t) – изобарная теплоемкость воды на линии насыщения; cpss(t) – изобарная теплоемкость пара на линии насыщения.

Все аналогичные функции, отмеченные в списке функций пакета WaterSteamPro значком [image], определены только для тех случаев, когда необходимо проводить поиск корня или оптимизацию, и возникает необходимость в вычислении значений свойств. Это может произойти автоматически при использовании, например, метода Ньютона. Второй пример: в современных математических пакетах, таких как, например, Mathcad, существуют встроенные функции для поиска корней, минимумов, максимумов и т.д. При этом, если функция будет не гладкой (с разрывом), то корень может быть не найден, даже если он находится в области допустимых параметров.

Для решения этой проблемы было решено из соображений универсальности, определить дополнительные функции для вычислений свойств воды и водяного пара, но возвращающие не реальные (физические) значения свойств.

Для этой же цели в функциях вычислений свойств введена возможность отмены ведения проверки аргументов на допустимый диапазон. По умолчанию при вызове функции проводится проверка на правильность аргументов, а уже потом проводится непосредственно расчет. При выходе аргументов за пределы допустимого диапазона генерируется ошибка с кодом 2 (WSP_OUT_OF_RANGE).

Для отмены проверки на диапазон в WaterSteamPro определена функция wspSETCHECKRANGEMODE(mode). При вызове этой функции с аргументом равным нулю прекращается проверка на допустимый диапазон аргументов, который определяется по областям допустимых параметров исходных уравнений. Это позволяет проводить вычисления за пределами исходных областей, но со значениями свойств не соответствующих действительности.

Внимание!

Начиная с версии 6.5, все "нефизические" функции при включенной по умолчанию проверке аргументов на допустимый диапазон генерируют ошибку с кодом 2 (WSP_OUT_OF_RANGE).

Также все функции, основанные на "нефизических" функциях, для определенных наборов аргументов тоже могут генерировать ошибку с таким же номером.

Например, функция wspCPSTX(t, x) генерирует ошибку при любых наборах аргументов (в случае включенного режима проверки на диапазон - см. далее), а функция wspCPPH(p, h), которая "внутри себя" обращается к функции wspCPSTX(t, x) - только при сочетаниях давления p и удельной энтальпии h, которые соответствуют двухфазной области.

Таким образом, по умолчанию "нефизические" функции работать не будут (будут только возвращать значение "-1.0").

Для "включения" "нефизических" функций необходимо отменить режим проверки аргументов на допустимый диапазон. Это можно выполнить путем предварительного вызова функции wspSETCHECKRANGEMODE(mode) с параметром mode = 0.


Расчет свойств метастабильного переохлажденного пара

Для расчета некоторых тепловых процессов, прежде всего процессов расширения пара в турбинах, важно знать свойства метастабильного переохлажденного пара в области, примыкающей к области 2 формуляции со стороны правой пограничной кривой. Ввиду полного отсутствия экспериментальных данных о термодинамических свойствах переохлажденного водяного пара, расчет их может быть проведен лишь при экстраполяции какого-либо уравнения состояния, составленного для стабильного перегретого пара, в эту область. Результаты анализа поведения ряда уравнений, таких как основное уравнение для области 2 данной формуляции, уравнение для перегретого пара из формуляции IFC-67 и Международное уравнение состояния для общего и научного применения IAPWS-95, показали, что все они при экстраполяции дают значительно различающиеся данные. Такая ситуация типична для сложных многоконстантных уравнений. Поэтому в качестве исходных для уравнения состояния метастабильного переохлажденного пара приняты данные, полученные по более простому уравнению, составленному как вспомогательное при разработке Международного уравнения состояния IAPWS-95 [1].

Для расчета метастабильной области переохлажденного пара используется уравнение, приведенное в [3]. Перечень функций для расчета свойств переохлажденного метастабильного пара приведен здесь.

Уравнение применимо для области метастабильного пара от верхней пограничной кривой до линии 5 %-ной влажности пара в равновесной h,s — диаграмме при давлениях до 10 МПа. Согласование вычисляемых по нему величин на линии насыщения с основным уравнением области 2 характеризуется следующими данными:

|Δv|мax = 0.014 % | |Δs|мax = 0.082 Дж/(кг·K)
|Δh|мax = 0.043 кДж/кг | |Δg|мax = 0.023 кДж/кг
|Δcp|мax = 0.78 % | |Δw|мax = 0.05 %

Вдоль изобары 10 МПа в области метастабильного пара переход от уравнения для области метастабильного пара к уравнению для области 2 происходит скачкообразно, но это не имеет существенного практического значения.

Контрольные значения термодинамических свойств метастабильного переохлажденного пара приведены в табл. 1.

Таблица 1. Термодинамические свойства метастабильного водяного пара
Свойство | t = 450 К, р = 1 МПа | t = 440 К, р = 1 МПа | t = 450 К, р = 1.5 МПа
v, м3/кг | 0.192516540 | 0.186212297 | 0.121685206
h, кДж/кг | 0.276881115·104 | 0.274015123·104 | 0.272134539·104
u, кДж/кг | 0.257629461·104 | 0.255393894·104 | 0.253881785·104
s, кДж/(кг·K) | 0.656660377·101 | 0.650218759·101 | 0.629170440·101
cp, кДж/(кг·K) | 0.276349265·101 | 0.298166443·101 | 0.362795578·101
w, м/с | 0.498408101·103 | 0.489363295·103 | 0.481941819·103


Коды ошибок, возникающих при вычислениях в пакете WaterSteamPro

Код ошибки, возникшей в результате последнего вызова функции из пакета "WaterSteamPro" возвращается функцией "wspGETLASTERROR()".

Возможные значения:

  • "0" – ошибки не произошло;
  • "1" – неправильные параметры – ошибка при вычислениях с плавающей точкой;
  • "2" – аргументы вне области определения вызываемой функции;
  • "3" – превышен лимит количества итераций. Это происходит, если за заданное число итераций (функция "wspGETMAXITERATION()") необходимая точность при поиске корня какой-либо функции не достигается;
  • "4" – неизвестная область состояния воды;
  • "5" – время тестирования бета-версии истекло (в полной версии отсутствует);
  • "6" - ошибка защиты (возникает при работе с незарегистрированной версией). Рекомендуется переустановить WaterSteamPro.
  • "7" - данная функция не работает в незарегистрированной версии.
  • "8" - данная функция в используемой версии WaterSteamPro не работает. Это означает, что функция только "заявлена", но не реализована. Иначе говоря, автор "говорит", что он может запрограммировать эту функцию в будущей версии в том случае, если она кому-нибудь понадобится, либо если у него дойдут до нее руки.
    Этот код ошибки также устанавливается при вызове устаревших функций.
  • "9" - Недостаточно памяти.
  • "10" - Срок регистрации истек.
  • "11" - Синтаксическая ошибка (при наборе строки спецификации газов).
  • "12" - Газ не найден.


Расчет свойств газов и их смесей

Описание

Перечень встроенных газов

Способы использования функций для расчета свойств газов

Функции на основе идентификаторов газов

Функции на основе спецификаций газов

Формат строки - спецификации газа

Пользователям бета-версий пакета WaterSteamPro 6.0

В пакете WaterSteamPro, начиная с версии 6.0 доступны функции для расчета свойств газов. Функции предназначены для вычисления термодинамических свойств 11-ти, входящих в состав воздуха и продуктов сгорания, газов, а также их смесей, в идеальном состоянии при температурах от 200 до 2500 К. Описание используемых формул и числовые коэффициенты приведены в [57, 74].

Функции для расчета свойств газов имеют в пакете WaterSteamPro префикс "wspg".

Область применения функций для расчета свойств газов - это расчеты термодинамических свойств воздуха, продуктов сгорания и отдельных газов при умеренных давлениях (т.к. газы рассматриваются как идеальные) в диапазоне температур от 200К до 2500К. Смеси газов также рассматриваются как идеальные.

Необходимость создания функций связана с тем, что для расчета термодинамических свойств воздуха и продуктов сгорания (для котельных агрегатов, газовых турбин и т.д.) в настоящее время используются различные методики, в которых сделаны упрощения, такие как расчет процессов расширения и сжатия по показателю адиабаты, в то время как проще и нагляднее использование удельных энтальпии и энтропии. Также является искусственным введение понятия «раздельного» расширения воздуха и продуктов сгорания в газовой турбине, при котором они расширяются до одного давления, но температура на выходе у них разная. Такой расчет гораздо проще выполнить по уравнениям для смесей газов, рассматривая смесь как единое целое и проводя расчет по значениям удельных энтальпии и энтропии.

При создании функций также ставилась цель обеспечить возможность простого, удобного и быстрого расчета термодинамических свойств газов и смесей на их основе в различных программных средах.

Перечень встроенных газов

В перечень веществ, для которых производится вычисление свойств в идеально-газовом состоянии, включены газы, наиболее часто встречающиеся при расчете процессов теплоэнергетики:

  • азот N2;
  • кислород O2;
  • оксид углерода CO;
  • диоксид углерода CO2;
  • водяной пар H2O;
  • диоксид серы SO2;
  • воздух;
  • атмосферный азот;
  • оксид азота NO;
  • диоксид азота NO2;
  • аргон Ar;
  • неон Ne;
  • водород H2.

Помимо исходных газов также являются встроенными воздух и атмосферный азот, которые определены как смеси газов принятого состава.

Состав воздуха (по объему), как и в [12], принят следующим:

  • азот - 78,03%;
  • кислород - 20,99%;
  • аргон - 0,94%;
  • водород - 0,01%;
  • диоксид углерода - 0,03%.

Состав атмосферного азота (по объему), как и в [12], принят следующим:

  • азот - 98,76%;
  • аргон - 1,19%;
  • водород - 0,01%;
  • диоксид углерода - 0,04%.

Основные используемые константы:

  • универсальная газовая постоянная: R = 8.31451 Дж/(моль·К);
  • молярные массы отдельных газов приведены в табл. 1;
  • стандартное давление P0 = 105 Па = 1 бар = 0.1 МПа.

В табл. 1 приведен перечень встроенных (доступных в любое время) газов, их имена и идентификаторы. Более подробная информация по именам и идентификаторам газов приведена в следующих разделах.

Табл. 1. Перечень встроенных газов.

Название газа | Имя газа | Молярная масса, кг/моль | Уникальный идентификатор
Азот | N2 | 0.0280134 [14] | 0
Кислород | O2 | 0.0319988 [14] | 1
Оксид углерода | CO | 0.0280104 [14] | 2
Диоксид углерода | CO2 | 0.0440098 [14] | 3
Водяной пар | H2O | 0.0180152 [14] | 4
Диоксид серы | SO2 | 0.064059 [14] | 5
Воздух (единый газ)* | Air | 0.02896431986** | 6
Атмосферный азот (единый газ)* | N2Air | 0.02815922054** | 7
Оксид азота | NO | 0.0300061 [14] | 8
Диоксид азота | NO2 | 0.0460055 [14] | 9
Аргон | Ar | 0.039948 [14] | 10
Неон | Ne | 0.020179 [14] | 11
Водород | H2 | 0.0020158 [14] | 12
Воздух как смесь газов | AirMix | 0.02896431986** | 13
Атмосферный азот как смесь газов | N2AirMix | 0.02815922054** | 14

* Выражение "единый газ" означает, что с точки зрения программы это не смесь газов, а единый газ со свойствами, эквивалентными смеси газов, его составляющих. Это позволяет рассчитывать свойства данных смесей без учета диссоциации.

** Рассчитано согласно принятому объемному составу [12].

Способы использования функций для расчета свойств газов

Существует два способа и два набора функций для работы со свойствами газов и смесей на их основе:

  1. Использование идентификаторов газов.
  2. Использование спецификаций газов.

Оба этих метода имееют как достоинства так и недостатки и выбор одного из них зависит от используемого программного обеспечения и пожеланий пользователя. Далее приведено описание этих способов работы с функциями для расчета свойств газов и их смесей.

Функции на основе идентификаторов газов

При данном способе работы все газы, как встроенные, так и создаваемые пользователем представляются т.н. "идентификатором газа" (или id), который представляет собой число (типа long). Функции для расчета свойств газов по передаваемому идентификатору (числу) находят данные для этого газа и вычисляют требуемое значение.

Перечень идентификаторов для встроенных газов приведен в табл. 1.

Преимущества данного способа работы - это высокая скорость доступа к данным и возможность работы в большинстве приложений.

Недостатки - это необходимость жесткого порядка вызова функций, что не всегда можно обеспечить в таких пакетах, как Excel, а также необходимость освобождать память, занятую под созданные пользователем газы (смеси).

Для расчета свойств газов при использовании идентификатором определены функции (полный их перечень приведен в разделе "Список функций"), в названии которых есть строка "ID":

  • wspgCPIDT(id, t) - расчет удельной изобарной теплоемкости газа с идентификатором id при температуре t;
  • wspgHIDT(id, t) - расчет удельной энтальпии газа с идентификатором id при температуре t;
  • wspgSIDT(id, t) - расчет удельной энтропии газа с идентификатором id при температуре t и давлении P0 = 1 бар;
  • wspgSIDPT(id, p, t) - расчет удельной энтропии газа с идентификатором id при температуре t и давлении p;
  • wspgTIDPS(id, p, s) - расчет температуры газа с идентификатором id при давлении p и удельной энтропии s;
  • ...
  • wspgIDNAME(gas_name) - идентификатор ранее определенного (или встроенного) газа с именем gas_name;
  • wspgNEWID() - идентификатор нового (пользовательского) газа;
  • wspgNEWIDNAME(gas_name) - идентификатор нового (пользовательского) газа с новым уникальным именем gas_name;
  • wspgNEWIDGS(gas_specification) - идентификатор нового (пользовательского) газа, состав которого соответствует заданной спецификации gas_specification (более подробно работа со спецификациями газов определена в последующих разделах);
  • wspgADDGASM(id_target, id_source, mass) - добавление массы mass газа с идентификатором id_source в состав газа, задаваемого идентификатором id_target;
  • wspgADDGASV(id_target, id_source, volume) - добавление объема volume газа с идентификатором id_source в состав газа, задаваемого идентификатором id_target;
  • wspgMFIDID(gas_id_looked, gas_id_looked_for) - массовая доля газа с идентификатором gas_id_looked_for в газе с идентификатором gas_id_looked;
  • wspgVFIDID(gas_id_looked, gas_id_looked_for) - объемная доля газа с идентификатором gas_id_looked_for в газе с идентификатором gas_id_looked;
  • wspgDELETEGASID(id) - удаление ранее созданного пользовательского газа с идентификатором gas_id;
  • wspgDELETEGASES() - удаление всех созданных пользователем газов.
  • wspgGASESCOUNT() - число всех газов, как встроенных, так и определенных пользователем.

Порядок работы с вышеперечисленными функциями следующий:

  1. Для расчета свойств встроенных газов (см. табл. 1) необходимо передавать в соответствующие функции требуемые идентификаторы газов (табл. 1).
  2. Для создания нового (пользовательского) газа, который будет в дальнейшем представлять смесь, состоящую из других газов, требуется вызвать функцию wspgNEWID(), wspgNEWIDNAME(gas_name) или wspgNEWIDGS(gas_specification). Любая из этих функций вернет уникальное число, однозначно идентифицирующее новый газ.
  3. После того, как получен идентификатор нового газа, необходимо указать его состав. Для этого предназначены две функции: wspgADDGASM(id_target, id_source, mass) и wspgADDGASV(id_target, id_source, volume). Первая из них предназначена для случая, когда известен массовый состав газа, а вторая - когда известен объемный состав. В качестве id_target требуется указывать полученный на предыдущем шаге идентификатор нового газа, а в качестве id_source - идентификатор ранее определенного газа (встроенного или пользовательского).
  4. После указания состава газа можно обращаться, как и в п. 1, к требуемым функциям для расчета свойств этого газа, который будет уже представлять собой смесь других газов. При этом необходимо использовать полученный в п. 2 идентфикатор.
  5. Для определения массовой или объемной долей одного газа в другом можно воспользоваться функциями wspgMFIDID(gas_id_looked, gas_id_looked_for) или wspgVFIDID(gas_id_looked, gas_id_looked_for).
  6. После окончания работы с пользовательским газом необходимо произвести освобождение памяти, занятой под этот газ. Для этого предназначена функция wspgDELETEGASID(id). После освобождения памяти, занятой под газ любое обращение к нему будет вызывать ошибку. Для удаления всех определенных пользователем газов (т.е. кроме встроенных) можно использовать функцию wspgDELETEGASES(). После ее вызова любое обращение к пользовательским газам, удаленным с ее помощью, будет также вызывать ошибку.

Узнать общее число газов, как определенных пользователем, так и встроенных, можно с помощью функции wspgGASESCOUNT().

При создании газа (п. 2) можно сразу указать его состав (что делается в п. 3) с помощью функции wspgNEWIDGS(gas_specification) указывая спецификацию газа. Более подробно спецификация газов описана в следующем разделе. При этом использование функций wspgADDGASM(id_target, id_source, mass) и wspgADDGASV(id_target, id_source, volume) необязательно.

На основе вышеописанного порядка работы можно также создавать смеси смесей газов. Для этого в функциях wspgADDGASM(id_target, id_source, mass) и wspgADDGASV(id_target, id_source, volume) необходимо использовать в качестве id_source идентификаторы ранее созданных пользовательских газов (смесей).

В качестве примера работы рассмотрим работу в гипотетическом пакете по расчету свойств влажного воздуха. Состав сухого воздуха будет аналогичен принятому в пакете WaterSteamPro, а массовое содержание водяного пара - 0.007 кг/кг (т.е. 0.007 кг водяного пара/кг сухого воздуха).

id_dry_air = wspgNEWID() // Получение идентификатора нового газа - сухого воздуха.
wspgADDGASV(id_dry_air, 0, 78.03) // Добавление в состав сухого воздуха газа с идентификатором 0 (азот) (см. табл. 1) в количестве 78,03 единиц объема.
wspgADDGASV(id_dry_air, 1, 20.99) // Добавление в состав сухого воздуха газа с идентификатором 1 (кислород) (см. табл. 1) в количестве 20,99 единиц объема.
wspgADDGASV(id_dry_air, 10, 0.94) // Добавление в состав сухого воздуха газа с идентификатором 10 (аргон) (см. табл. 1) в количестве 0,94 единиц объема.
wspgADDGASV(id_dry_air, 12, 0.01) // Добавление в состав сухого воздуха газа с идентификатором 12 (водород) (см. табл. 1) в количестве 0,01 единиц объема.
wspgADDGASV(id_dry_air, 3, 0.03) // Добавление в состав сухого воздуха газа с идентификатором 3 (диоксид углерода) (см. табл. 1) в количестве 0,03 единиц объема.
id_wet_air = wspgNEWID() // Получение идентификатора нового газа - влажного воздуха воздуха.
wspgADDGASM(id_wet_air, id_dry_air, 1) // Добавление в состав влажного воздуха газа (сухого воздуха) в количестве 1 единицы массы.
wspgADDGASM(id_wet_air, 4, 0.007) // Добавление в состав влажного воздуха газа с идентификатором 4 (водяного пара) (см. табл. 1) в количестве 0.007 единиц массы.
h_wet = wspgHIDT(id_wet_air, 500) // Энтальпия влажного воздуха при температуре 500К.
s_wet = wspgSIDPT(id_wet_air, 300000.0, 500) // Энтропия влажного воздуха при температуре 500К и давлении 300000 Па.
wspgDELETEGASID(id_wet_air) // Очистка памяти, занятой под сухой воздух
wspgDELETEGASID(id_dry_air) // Очистка памяти, занятой под влажный воздух

Использование идентификаторов газов требуется в Mathcad 8, т.к. в нем нельзя использовать функции, использующие строки. Однако в последующих версиях Mathcad функции для работы со строками доступны и, поэтому, возможно использование функций со спецификациями газов.

Функции на основе спецификаций газов

При данном способе работы все газы, как встроенные, так и создаваемые пользователем представляются "спецификацией газа" (или gas specification).

Под спецификацией газов в пакете WaterSteamPro понимается строка содержащая описание состава газа (смеси газов). Формат этой строки приведен далее.

Преимущества данного способа работы - это наглядность описания состава газа, отсутствие необходимости освобождать память и отсутствие требования к жесткому порядку обращения к функциям.

Недостаток - это несколько большие затраты на доступ к газам и разбору строки спецификации. Этот недостаток несколько нивелируется тем, что данные по газам кэшируются, в результате чего разбор строки спецификации и создание на ее основе газа, производится только при первом обращении к свойствам газа с такой спецификацией.

Описание формата спецификации газа приведено в следующем разделе.

Для расчета свойств газов при использовании спецификаций определены функции (полный их перечень приведен в разделе "Список функций"), в названии которых есть строка "GS" (от "Gas Specification"):

  • wspgCPGST(gas_specification, t) - расчет удельной изобарной теплоемкости газа со спецификацией gas_specification при температуре t;
  • wspgHGST(gas_specification, t) - расчет удельной энтальпии газа со спецификацией gas_specification при температуре t;
  • wspgSGST(gas_specification, t) - расчет удельной энтропии газа со спецификацией gas_specification при температуре t и давлении P0 = 1 бар;
  • wspgSGSPT(gas_specification, p, t) - расчет удельной энтропии газа со спецификацией gas_specification при температуре t и давлении p;
  • wspgTGSPS(gas_specification, p, s) - расчет температуры газа со спецификацией gas_specification при давлении p и удельной энтропии s;
  • ...
  • wspgNEWIDGS(gas_specification) - идентификатор нового (пользовательского) газа, состав которого соответствует заданной спецификации gas_specification (после вызова функции и работы с полученным идентификатором необходимо очистить память путем обращения к функции wspgDELETEGASID(id));
  • wspgMFGSGS(gas_spec_looked, gas_spec_looked_for) - массовая доля газа со спецификацией gas_spec_looked_for в газе со спецификацией gas_spec_looked;
  • wspgVFGSGS(gas_spec_looked, gas_spec_looked_for) - объемная доля газа со спецификацией gas_spec_looked_for в газе со спецификацией gas_spec_looked;

Для расчета свойств газов, задаваемых спецификацией, необходимо просто передавать в соответствующие функции требуемые строки.

Очищать память под газы, задаваемыми спецификациями, не требуется.

В качестве примера работы рассмотрим работу в гипотетическом пакете по расчету свойств влажного воздуха. Состав сухого воздуха будет аналогичен принятому в пакете WaterSteamPro, а массовое содержание водяного пара - 0.007 кг/кг (т.е. 0.007 кг водяного пара/кг сухого воздуха).

wet_air_spec = "{N2:78.03;O2:20.99;Ar:0.94;H2:0.01;CO2:0.03}:1M;H2O:0.007M" // спецификация газа - влажного воздуха
h_wet = wspgHGST(wet_air_spec, 500) // Энтальпия влажного воздуха при температуре 500К.
s_wet = wspgSGSPT(wet_air_spec, 300000.0, 500) // Энтропия влажного воздуха при температуре 500К и давлении 300000 Па.

Использование спецификаций газов требуется в пакете Excel, где нельзя жестко задать порядок перерасчета формул в ячейках.

Использование идентификаторов газов требуется в Mathcad 8, т.к. в нем нельзя использовать функции, использующие строки. Однако в последующих версиях Mathcad функции для работы со строками доступны и, поэтому, возможно использование функций со спецификациями газов.

Формат строки - спецификации газа

Gas1Name[:Gas1Part][;Gas2Name[:Gas2Part]][;Gas3Name[:Gas3Part]]...

где:

Gas1Name - имя первого компонента газа или спецификация смеси.

Gas1Part - количество первого компонента газа.

Gas2Name - имя второго компонента газа или спецификация смеси.

Gas2Part - количество второго компонента газа.

Gas3Name - имя третьего компонента газа или спецификация смеси.

Gas3Part - количество третьего компонента газа.

и т.д.

Примером спецификации газа может быть строка:

O2;CO2;H2O;SO2

которая представляет собой смесь из газов "О2", "CO2", "H2O", "SO2" при объемном составе: 1:1:1:1 (т.е. смесь из 1 объемной доли "O2", 1 объемной доли "CO2", 1 объемной доли "H2O", 1 объемной доли "SO2").

Спецификация газа:

O2:1;CO2:3;H2O:5

описывает смесь, состояющую из 1 объемной доли "O2", 3 объемных долей "CO2" и 5 объемных долей "H2O".

По умолчанию в качестве GasPart используется значение 1 моль, т.е. 1 объемная доля. Для указания того, чтобы использовать массовые доли требуется указать суффикс "M". Так спецификация

O2:1M;CO2:2M

описывает смесь, состояющую из 1 массовой доли "O2" и 2 массовых долей "CO2".

Помимо этого существует еще несколько суффиксов для указания типа количества компонента:

  • "V" - использование объемной доли. Это аналогично отсутствию суффикса.
  • "%" - использование одной сотой объемной доли. Запись "N2:78.03%" аналогична записи "N2:0.7803".
  • "M" - использование массовой доли.
  • "KG" - использование массовой доли. Эквивалентно использованию суффикса "M".
  • "G" - использование одной тысячной массовой доли.

В качестве имени газа может выступать:

  • имя встроенного газа (например "O2", "H2O" и т.д.);
  • имя созданного с помощью функции wspgNEWIDNAME(gas_name) пользовательского газа;
  • специальная спецификация газа - смеси.

Последняя запись означает, что возможен расчет смеси смесей газов. Так, например, спецификация

{O2;CO2:2};{H2O;CO2:2}:3

описывает смесь, состояющую из одной объемной доли смеси, которая, в свою очередь, состоит из одной объемной доли "O2" и двух объемных долей "CO2", и трех объемных долей другой смеси, которая состоит из одной объемной доли "H2O" и двух объемных долей "CO2".

Пользователям бета-версий пакета WaterSteamPro 6.0

В бета-версиях пакета WaterSteamPro 6.0 (вплоть до beta 8) использовались функции, основанные на раздельных понятиях газа и смеси. В окончательной верси WaterSteamPro 6.0 эти два понятия объединены. Помимо этого в указанных бета-версиях отсутствовал механизм работы со спецификациями газов, что делало практически невозможным использование функций для расчета свойств газов в Microsoft Excel.

В связи с таким изменением концепции работы с газами и смесями на их основе, часть функций, доступных в бета-версиях была удалена, а часть изменена. В табл. 2 представлены функции, доступные в бета-версиях и их аналоги в окончательной версии WaterSteamPro 6.0.

Табл. 2. Перечень функций для расчета свойств газов в бета-версии и их аналоги в окончательной версии WaterSteamPro 6.0.

Имя функции в бета-версии | Имя функции - аналога | Примечание
wspgCPIDT | wspgCPIDT |
wspgHIDT | wspgHIDT |
wspgS0IDT | wspgSIDT | В целях унификации имя функции изменено.
wspgMMID | wspgMMID |
wspgSIDPT | wspgSIDPT |
wspgNEWMIX | - отсутствует - | Понятие mixture (смесь) отсутствует в окончательной версии. Вместо этого используется общее понятие - "газ".
wspgADDGASM2MIX | wspgADDGASM | В окончательной версии отсутствует понятие mixture. Поэтому имя функции изменено, хотя смысл ее действий остался прежним.
wspgADDGASMO2MIX | wspgADDGASV | В окончательной версии отсутствует понятие mixture. Поэтому имя функции изменено, хотя смысл ее действий остался прежним.
wspgNEWGASFROMMIX | - отсутствует - | В окончательной версии нет необходимости в данной функции, т.к. отсутствует понятие mixture, а свойства газа можно вычислять в любой момент.
wspgDELETEGAS | wspgDELETEGASID | Имя функции изменено, чтобы охарактеризовать ее аргумент. Смысл действий остался прежним.
wspgDELETEMIX | - отсутствует - | В окончательной версии нет необходимости в данной функции, т.к. отсутствует понятие mixture.
wspgDELETEALLGASES | wspgDELETEGASES | Имя функции изменено для краткости.
wspgDELETEALLMIX | - отсутствует - | В окончательной версии нет необходимости в данной функции, т.к. отсутствует понятие mixture.
wspgGETGASESCOUNT | wspgGASESCOUNT | Имя функции изменено для краткости.
wspgGETMIXCOUNT | - отсутствует - |
wspgCVIDT | wspgCVIDT |
wspgUIDT | wspgUIDT |
wspgCPINTIDTT | - отсутствует - | Для расчета среднеинтегральной теплоемкости в диапазоне температур от t1 до t2 можно воспользоваться формулой: cp_int = (wspgHIDT(id, t2) - wspgHIDT(id, t1)) / (t2 - t1).
wspgTIDH | wspgTIDH |
wspgTIDS0 | wspgTIDS | В целях унификации имя функции изменено.
wspgTIDPS | wspgTIDPS |
wspgGASWFINMIX | wspgMFIDID | В окончательной версии отсутствует понятие mixture. Поэтому имя функции изменено, хотя смысл ее действий остался прежним.
wspgGASMFINMIX | wspgVFIDID | В окончательной версии отсутствует понятие mixture. Поэтому имя функции изменено, хотя смысл ее действий остался прежним.
wspgVIDT | wspgVIDT |
wspgVIDPT | wspgVIDPT |
wspgGCID | wspgGCID |
wspgCPIDPT | - отсутствует - | Т.к. газы рассматриваются как идеальные, то удельная изобарная теплоемкость не зависит от давления.
wspgHIDPT | - отсутствует - | Т.к. газы рассматриваются как идеальные, то удельная энтальпия не зависит от давления.
wspgPIDTS | wspgPIDTS |


Список функций WaterSteamPro

  • General: обобщенные функции, которые рекомендуется использовать.
  • Saturation Line: функции свойств на линии насыщения.
  • Double-phase area: функции свойств в двухфазной области: вода-пар.
  • Sublimation and Melting Lines: функции свойств на линиях сублимации и плавления.
  • MetaStable: функции для расчета свойств в метастабильной области (переохлажденный пар)
  • Source: функции по Формуляции IF-97 и другим формуляциям от Международной Ассоциации по Свойствам Воды и Водяного Пара.
  • Gases: функции для работы со свойствами газов.
  • System: системные функции.

    Категория: General

    Обобщенные функции, которые рекомендуется использовать.

  1. Удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspCPEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  2. Удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspCPEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  3. Удельная изобарная теплоемкость [Дж/(кг·К)] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspCPHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость [Дж/(кг·К)], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  4. Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspCPPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspCPPTX.

  5. Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspCPPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspCPPTX.

  6. Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCPPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspCPxPT).

  7. Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspCPPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspCPxPT или wspCPSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  8. Удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspCVEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  9. Удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspCVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  10. Удельная изохорная теплоемкость [Дж/(кг·К)] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspCVHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  11. Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspCVPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspCVPTX.

  12. Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspCVPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspCVPTX.

  13. Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCVPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspCVxPT).

  14. Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspCVPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspCVxPT или wspCVSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  15. Диэлектрическая проницаемость воды [-] как функция величин: давление p [Па], температура t [K]:

    wspDCPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – диэлектрическая проницаемость воды [-], тип: double.

    Основана на функции wspDCRT(r, t), которая, в свою очередь, основана на "Release on the Static Dielectric Constant of Ordinary Water Substance for Temperatures from 238K to 873K and Pressures up to 1000 MPa", 1997 от IAPWS. Диапазон использования: при температурах от 238 до 273K для метастабильной жидкости при атмосферном давлении (101 325 Па), при температурах от 273 до 323 К - при давлениях до низшей точки плавления льда IV или 1000 МПа, свыше 323 К - при давлениях до 600 МПа. Используемые уравнения экстраполируются достаточно гладко до температур 1200К и давлений 1200 МПа.

  16. Производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspDDDHPPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspDDDHPxPT).

  17. Производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5] как функция величин: давление p [Па], температура t [K]:

    wspDDDHPPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspDDDHPxPT).

  18. Производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspDDDHPPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspDDDHPxPT или wspDDDHPSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  19. Производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspDDDPHPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspDDDPHxPT).

  20. Производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2] как функция величин: давление p [Па], температура t [K]:

    wspDDDPHPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspDDDPHxPT).

  21. Производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspDDDPHPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspDDDPHxPT или wspDDDPHSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  22. Плотность [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspDPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – плотность [кг/м3], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspDxPT).

  23. Плотность [кг/м3] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspDPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – плотность [кг/м3], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspDxPT или wspDSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  24. Динамическая вязкость в конце процесса расширения/сжатия [Па·с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspDYNVISEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – динамическая вязкость в конце процесса расширения/сжатия [Па·с], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  25. Динамическая вязкость в конце процесса расширения/сжатия [Па·с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspDYNVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – динамическая вязкость в конце процесса расширения/сжатия [Па·с], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  26. Динамическая вязкость [Па·с] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspDYNVISHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  27. Динамическая вязкость [Па·с] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspDYNVISPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspDYNVISPTX.

  28. Динамическая вязкость [Па·с] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspDYNVISPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspDYNVISPTX.

  29. Динамическая вязкость [Па·с] как функция величин: давление p [Па], температура t [K]:

    wspDYNVISPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97 и формуляцией для вычисления динамической вязкости. Для вычисления используется функция wspDYNVISRT с аргументом-плотностью, вычисляемому по обобщенной функции wspVPT.

  30. Динамическая вязкость [Па·с] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspDYNVISPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

    Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspDYNVISPT или wspDYNVISSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  31. Удельная энтальпия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspHEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная энтальпия в конце процесса расширения/сжатия [Дж/кг], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  32. Удельная энтальпия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspHEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная энтальпия в конце процесса расширения/сжатия [Дж/кг], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  33. Удельная энтальпия [Дж/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspHPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspHPTX.

  34. Удельная энтальпия [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspHPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspHxPT).

  35. Удельная энтальпия [Дж/кг] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspHPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspHxPT или wspHSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  36. Коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspJOULETHOMPSONEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  37. Коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspJOULETHOMPSONEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff). Примечание: в ActiveX-объекте "WSP.WSPCalculator" эта функция называется "wspJOULETHOMPSONEXPANSIONPTXPEF" в связи с ограничениями на длину имени в COM.

  38. Коэффициент Джоуля-Томсона [K/Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspJOULETHOMPSONHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  39. Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspJOULETHOMPSONPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspJOULETHOMPSONPTX.

  40. Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspJOULETHOMPSONPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspJOULETHOMPSONPTX.

  41. Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSONPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspJOULETHOMPSONxPT).

  42. Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspJOULETHOMPSONPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspJOULETHOMPSONxPT или wspJOULETHOMPSONSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  43. Коэффициент изоэнтропы в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspKEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы в конце процесса расширения/сжатия [-], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  44. Коэффициент изоэнтропы в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspKEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы в конце процесса расширения/сжатия [-], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  45. Коэффициент изоэнтропы [-] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspKHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  46. Кинематическая вязкость в конце процесса расширения/сжатия [м2/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspKINVISEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – кинематическая вязкость в конце процесса расширения/сжатия [м2/с], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  47. Кинематическая вязкость в конце процесса расширения/сжатия [м2/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspKINVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – кинематическая вязкость в конце процесса расширения/сжатия [м2/с], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  48. Кинематическая вязкость [м2/с] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspKINVISHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  49. Кинематическая вязкость [м2/с] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspKINVISPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspKINVISPTX.

  50. Кинематическая вязкость [м2/с] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspKINVISPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspKINVISPTX.

  51. Кинематическая вязкость [м2/с] как функция величин: давление p [Па], температура t [K]:

    wspKINVISPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97 и формуляцией для вычисления динамической вязкости. Для вычислений используется формула: KINVIS = DYNVIS · V, где DYNVIS вычисляется по функции wspDYNVISPT, а V - по функции wspVPT.

  52. Кинематическая вязкость [м2/с] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspKINVISPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

    Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspKINVISPT или wspKINVISSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  53. Коэффициент изоэнтропы [-] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspKPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspKPTX.

  54. Коэффициент изоэнтропы [-] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspKPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspKPTX.

  55. Коэффициент изоэнтропы [-] как функция величин: давление p [Па], температура t [K]:

    wspKPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. Для вычислений используется формула: K = W · W / (P · V), где W (скорость звука) вычисляется по функции wspWPT, P - давление и V (удельный объем) - по функции wspVPT.

  56. Коэффициент изоэнтропы [-] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspKPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

    Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspKPT или wspKSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  57. Давление [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – давление [Па], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  58. Отрицательный десятичный логарифм ионного произведения воды [-] как функция величин: давление p [Па], температура t [K]:

    wspPKWPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – отрицательный десятичный логарифм ионного произведения воды [-], тип: double.

    Основана на функции wspPKWRT(r, t), которая, в свою очередь, основана на "Release on the Ionization Constant of H2O, August 2007" от IAPWS.

  59. Число Прандтля в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspPRANDTLEEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – число Прандтля в конце процесса расширения/сжатия [-], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  60. Число Прандтля в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspPRANDTLEEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – число Прандтля в конце процесса расширения/сжатия [-], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  61. Число Прандтля [-] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPRANDTLEHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – число Прандтля [-], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  62. Число Прандтля [-] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspPRANDTLEPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – число Прандтля [-], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspPRANDTLEPTX.

  63. Число Прандтля [-] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspPRANDTLEPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – число Прандтля [-], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspPRANDTLEPTX.

  64. Число Прандтля [-] как функция величин: давление p [Па], температура t [K]:

    wspPRANDTLEPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – число Прандтля [-], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97 и соответствующими формуляциями для входящих в формулу свойств. Для вычислений используется формула: Pr = DYNVIS · CP / THERMCOND, где DYNVIS вычисляется по функции wspDYNVISPT, CP - по функции wspCPPT и THERMCOND - по функции wspTHERMCONDPT.

  65. Число Прандтля [-] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspPRANDTLEPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – число Прандтля [-], тип: double.

    Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspPRANDTLEPT или wspPRANDTLESTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  66. Результат вычисления свойств как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPTHS(h, s, *p, *t)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • p – давление [Па], тип: double. Внимание! Это выходной параметр;
    • t – температура [K], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств, тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

    Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  67. Показатель преломления [-] как функция величин: давление p [Па], температура t [K], длина волны wavelength [м]:

    wspRIPTL(p, t, wavelength)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • wavelength – длина волны [м], тип: double;
    • Возвращаемый результат – показатель преломления [-], тип: double.

    Основана на функции wspRIRTL(r, t, wavelength), которая, в свою очередь, основана на "Release on the Refractive Index of Ordinary Water Substance as a Function of Wavelength, Temperature and Pressure", 1997 от IAPWS. Диапазон использования: температура от -12 до 500°C, плотность до 1060 кг/м3 и длина волны от 0.2 мкм до 1.1 мкм. Используемые уравнения экстраполируются достаточно гладко длины волны 1.9 мкм для жидкости.

  68. Удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspSEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  69. Удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspSEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  70. Удельная энтропия [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspSPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspSPTX.

  71. Удельная энтропия [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspSxPT).

  72. Удельная энтропия [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspSPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspSxPT или wspSSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  73. Коэффициент поверхностного натяжения [Н/м] как функция величин: температура t [K]:

    wspSURFTENT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент поверхностного натяжения [Н/м], тип: double.

    Функция основана на "Release on The Surface Tension of Ordinary Water Substance 1995" от Международной Ассоциации по Свойствам Воды и Водяного Пара. Область определения функции от тройной точки (273.16K или 0.01°C) до 647.096 K.

  74. Температура в конце процесса расширения/сжатия [K] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspTEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – температура в конце процесса расширения/сжатия [K], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  75. Температура в конце процесса расширения/сжатия [K] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspTEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – температура в конце процесса расширения/сжатия [K], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  76. Коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspTHERMCONDEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  77. Коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspTHERMCONDEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  78. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTHERMCONDHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  79. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspTHERMCONDPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspTHERMCONDPTX.

  80. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspTHERMCONDPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspTHERMCONDPTX.

  81. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], температура t [K]:

    wspTHERMCONDPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97 и формуляцией для вычисления теплопроводности. Для вычисления используется функция wspTHERMCONDRT с аргументом-плотностью, вычисляемому по обобщенной функции wspVPT.

  82. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspTHERMCONDPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

    Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspTHERMCONDPT или wspTHERMCONDSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  83. Температура [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура [K], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  84. Температура [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspTPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура [K], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH).

  85. Температура [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspTPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура [K], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS).

  86. Удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspUEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  87. Удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspUEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  88. Удельная внутренняя энергия [Дж/кг] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspUHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  89. Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspUPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspUPTX.

  90. Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspUPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspUPTX.

  91. Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspUPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspUxPT).

  92. Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspUPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspUxPT или wspUSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  93. Удельный объем в конце процесса расширения/сжатия [м3/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspVEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельный объем в конце процесса расширения/сжатия [м3/кг], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  94. Удельный объем в конце процесса расширения/сжатия [м3/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – удельный объем в конце процесса расширения/сжатия [м3/кг], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  95. Удельный объем [м3/кг] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspVHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельный объем [м3/кг], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  96. Удельный объем [м3/кг] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspVPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – удельный объем [м3/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspVPTX.

  97. Удельный объем [м3/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspVPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельный объем [м3/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspVPTX.

  98. Удельный объем [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspVPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем [м3/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspVxPT).

  99. Удельный объем [м3/кг] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspVPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельный объем [м3/кг], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspVxPT или wspVSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  100. Результат вычисления свойств как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPTPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
    • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
    • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
    • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
    • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств, тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspVUSHDERPTxPT) в зависимости от области. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

    Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  101. Скорость звука в конце процесса расширения/сжатия [м/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspWEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – скорость звука в конце процесса расширения/сжатия [м/с], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  102. Скорость звука в конце процесса расширения/сжатия [м/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspWEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – скорость звука в конце процесса расширения/сжатия [м/с], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  103. Скорость звука [м/с] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspWHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – скорость звука [м/с], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  104. Скорость звука [м/с] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspWPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – скорость звука [м/с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspWPTX.

  105. Скорость звука [м/с] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspWPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – скорость звука [м/с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspWPTX.

  106. Скорость звука [м/с] как функция величин: давление p [Па], температура t [K]:

    wspWPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – скорость звука [м/с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspWxPT).

  107. Скорость звука [м/с] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspWPTX(p, t, x)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – скорость звука [м/с], тип: double.

    Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspWxPT или wspWSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.

  108. Степень сухости в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspXEXPANSIONPTPEFF(p0, t0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – степень сухости в конце процесса расширения/сжатия [-], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  109. Степень сухости в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspXEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

    где:

    • p0 – давление в начальной точке [Па], тип: double;
    • t0 – температура в начальной точке [K], тип: double;
    • x0 – степень сухости в начальной точке [-], тип: double;
    • p1 – давление в конечной точке [Па], тип: double;
    • eff – внутренний относительный КПД процесса [-], тип: double;
    • Возвращаемый результат – степень сухости в конце процесса расширения/сжатия [-], тип: double.

    Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).

  110. Степень сухости [-] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspXHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Если эта область двухфазная, то вызывается функция для определения искомой величины. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

  111. Степень сухости [-] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspXPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Алгоритм работы функции следующий: по заданным p и h определяется область состояния (по функции wspWATERSTATEAREAPH). Если эта область двухфазная, то вызывается функция для определения искомой величины.

  112. Степень сухости [-] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspXPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Алгоритм работы функции следующий: по заданным p и s определяется область состояния (по функции wspWATERSTATEAREAPS). Если эта область двухфазная, то вызывается функция для определения искомой величины.

    113. Категория: Saturation Line

    Функции свойств на линии насыщения.

  113. Удельная изобарная теплоемкость (Cp) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCPSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  114. Удельная изобарная теплоемкость (Cp) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCPSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  115. Удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны двухфазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCVDPSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны двухфазной области [Дж/(кг·К)], тип: double.

    Функция возвращает сумму изохорной теплоемкости со стороны однофазной области (функция wspCVSST) и дополнительного приращения, рассчитываемого по термодинамическим соотношениям.

  116. Удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны двухфазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCVDPSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны двухфазной области [Дж/(кг·К)], тип: double.

    Функция возвращает сумму изохорной теплоемкости со стороны однофазной области (функция wspCVSWT) и дополнительного приращения, рассчитываемого по термодинамическим соотношениям.

  117. Удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCVSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  118. Удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCVSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  119. Производная плотности по энтальпии при постоянном давлении пара на линии насыщения [кг·с2/м5] как функция величин: температура t [K]:

    wspDDDHPSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении пара на линии насыщения [кг·с2/м5], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  120. Производная плотности по энтальпии при постоянном давлении воды на линии насыщения [кг·с2/м5] как функция величин: температура t [K]:

    wspDDDHPSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении воды на линии насыщения [кг·с2/м5], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  121. Производная плотности по давлении при постоянной энтальпии пара на линии насыщения [с2/м2] как функция величин: температура t [K]:

    wspDDDPHSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии пара на линии насыщения [с2/м2], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  122. Производная плотности по давлении при постоянной энтальпии воды на линии насыщения [с2/м2] как функция величин: температура t [K]:

    wspDDDPHSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии воды на линии насыщения [с2/м2], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  123. Производная давления на линии насыщения по температуре насыщения [Па/К] как функция величин: температура t [K]:

    wspDPDTST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – производная давления на линии насыщения по температуре насыщения [Па/К], тип: double.

    Функция основана на "Supplementary Release on Saturation Properties of Ordinary Water Substance" от Международной Ассоциации по Свойствам Воды и Водяного Пара. Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  124. Плотность пара на линии насыщения [кг/м3] как функция величин: температура t [K]:

    wspDSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – плотность пара на линии насыщения [кг/м3], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  125. Плотность воды на линии насыщения [кг/м3] как функция величин: температура t [K]:

    wspDSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – плотность воды на линии насыщения [кг/м3], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  126. Динамическая вязкость пара на линии насыщения [Па·с] как функция величин: температура t [K]:

    wspDYNVISSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – динамическая вязкость пара на линии насыщения [Па·с], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  127. Динамическая вязкость воды на линии насыщения [Па·с] как функция величин: температура t [K]:

    wspDYNVISSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – динамическая вязкость воды на линии насыщения [Па·с], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  128. Удельная энтальпия пара на линии насыщения [Дж/кг] как функция величин: температура t [K]:

    wspHSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия пара на линии насыщения [Дж/кг], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  129. Удельная энтальпия воды на линии насыщения [Дж/кг] как функция величин: температура t [K]:

    wspHSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия воды на линии насыщения [Дж/кг], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  130. Коэффициент Джоуля-Томсона пара на линии насыщения со стороны однофазной области [K/Па] как функция величин: температура t [K]:

    wspJOULETHOMPSONSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона пара на линии насыщения со стороны однофазной области [K/Па], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  131. Коэффициент Джоуля-Томсона воды на линии насыщения со стороны однофазной области [K/Па] как функция величин: температура t [K]:

    wspJOULETHOMPSONSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона воды на линии насыщения со стороны однофазной области [K/Па], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  132. Кинематическая вязкость пара на линии насыщения [м2/с] как функция величин: температура t [K]:

    wspKINVISSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – кинематическая вязкость пара на линии насыщения [м2/с], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  133. Кинематическая вязкость воды на линии насыщения [м2/с] как функция величин: температура t [K]:

    wspKINVISSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – кинематическая вязкость воды на линии насыщения [м2/с], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  134. Коэффициент изоэнтропы пара на линии насыщения со стороны однофазной области [-] как функция величин: температура t [K]:

    wspKSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы пара на линии насыщения со стороны однофазной области [-], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  135. Коэффициент изоэнтропы воды на линии насыщения со стороны однофазной области [-] как функция величин: температура t [K]:

    wspKSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы воды на линии насыщения со стороны однофазной области [-], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  136. Число Прандтля пара на линии насыщения [-] как функция величин: температура t [K]:

    wspPRANDTLESST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – число Прандтля пара на линии насыщения [-], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  137. Число Прандтля воды на линии насыщения [-] как функция величин: температура t [K]:

    wspPRANDTLESWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – число Прандтля воды на линии насыщения [-], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  138. Давление на линии насыщения [Па] как функция величин: температура t [K]:

    wspPST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – давление на линии насыщения [Па], тип: double.

    Функция основана на "Supplementary Release on Saturation Properties of Ordinary Water Substance" от Международной Ассоциации по Свойствам Воды и Водяного Пара. Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  139. Удельная энтальпия пара на линии насыщения [Дж/кг] как функция величин: удельная энтропия s [Дж/(кг·К)]:

    wspROUGHHSSS(s)

    где:

    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная энтальпия пара на линии насыщения [Дж/кг], тип: double.

    Функция использует функцию из дополнительного набора уравнений для Формуляции IF-97.

  140. Удельная энтальпия воды на линии насыщения [Дж/кг] как функция величин: удельная энтропия s [Дж/(кг·К)]:

    wspROUGHHSWS(s)

    где:

    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная энтальпия воды на линии насыщения [Дж/кг], тип: double.

    Функция использует функцию из дополнительного набора уравнений для Формуляции IF-97.

  141. Приближенное значение плотности пара на линии насыщения [кг/м3] как функция величин: температура t [K]:

    wspROUGHRSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – приближенное значение плотности пара на линии насыщения [кг/м3], тип: double.

    Данная функция позволяет быстро вычислить приближенное значение плотности пара на линии насыщения.

  142. Приближенное значение плотности воды на линии насыщения [кг/м3] как функция величин: температура t [K]:

    wspROUGHRSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – приближенное значение плотности воды на линии насыщения [кг/м3], тип: double.

    Данная функция позволяет быстро вычислить приближенное значение плотности воды на линии насыщения.

  143. Удельная теплота парообразования [Дж/кг] как функция величин: температура t [K]:

    wspRST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная теплота парообразования [Дж/кг], тип: double.

    Вычисляется по формуле r = (hs - hw), где hs - удельная энтальпия пара на линии насыщения, hw - удельная энтальпия воды на линии насыщения.

  144. Удельная энтропия пара на линии насыщения [Дж/(кг·К)] как функция величин: температура t [K]:

    wspSSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия пара на линии насыщения [Дж/(кг·К)], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  145. Удельная энтропия воды на линии насыщения [Дж/(кг·К)] как функция величин: температура t [K]:

    wspSSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия воды на линии насыщения [Дж/(кг·К)], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  146. Коэффициент теплопроводности пара на линии насыщения [Вт/(м·K)] как функция величин: температура t [K]:

    wspTHERMCONDSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности пара на линии насыщения [Вт/(м·K)], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  147. Коэффициент теплопроводности воды на линии насыщения [Вт/(м·K)] как функция величин: температура t [K]:

    wspTHERMCONDSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности воды на линии насыщения [Вт/(м·K)], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  148. Температура на линии насыщения [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTSHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура на линии насыщения [K], тип: double.

    Функция вычисляет на основе термодинамических соотношений температуру на линии насыщения для заданных h и s. При поиске используется метод Ньютона.

  149. Температура на линии насыщения [K] как функция величин: давление p [Па]:

    wspTSP(p)

    где:

    • p – давление [Па], тип: double;
    • Возвращаемый результат – температура на линии насыщения [K], тип: double.

    Функция основана на "Supplementary Release on Saturation Properties of Ordinary Water Substance" от Международной Ассоциации по Свойствам Воды и Водяного Пара. Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  150. Удельная внутренняя энергия пара на линии насыщения [Дж/кг] как функция величин: температура t [K]:

    wspUSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия пара на линии насыщения [Дж/кг], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  151. Удельная внутренняя энергия воды на линии насыщения [Дж/кг] как функция величин: температура t [K]:

    wspUSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия воды на линии насыщения [Дж/кг], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  152. Удельный объем пара на линии насыщения [м3/кг] как функция величин: температура t [K]:

    wspVSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем пара на линии насыщения [м3/кг], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  153. Удельный объем воды на линии насыщения [м3/кг] как функция величин: температура t [K]:

    wspVSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем воды на линии насыщения [м3/кг], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  154. Результат вычисления свойств для пара на линии насыщения как функция величин: температура насыщения t [K]:

    wspVUSHCVWDERPTSST(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    где:

    • t – температура насыщения [K], тип: double;
    • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
    • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
    • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
    • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
    • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств для пара на линии насыщения, тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

    Примечание: В пакете Mathcad функция имеет только аргументы (t) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  155. Результат вычисления свойств для воды на линии насыщения как функция величин: температура насыщения t [K]:

    wspVUSHCVWDERPTSWT(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    где:

    • t – температура насыщения [K], тип: double;
    • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
    • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
    • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
    • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
    • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств для воды на линии насыщения, тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

    Примечание: В пакете Mathcad функция имеет только аргументы (t) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  156. Скорость звука в паре на линии насыщения со стороны однофазной области [м/с] как функция величин: температура t [K]:

    wspWSST(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – скорость звука в паре на линии насыщения со стороны однофазной области [м/с], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

  157. Скорость звука в воде на линии насыщения со стороны однофазной области [м/с] как функция величин: температура t [K]:

    wspWSWT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – скорость звука в воде на линии насыщения со стороны однофазной области [м/с], тип: double.

    Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).

    158. Категория: Double-phase area

    Функции свойств в двухфазной области: вода-пар.

  158. Удельная изобарная теплоемкость (Cp) в двухфазной области [Дж/(кг·К)] как функция величин: температура t [K], степень сухости x [-]:

    wspCPSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в двухфазной области [Дж/(кг·К)], тип: double.

    Данная функция использует функции wspCPSST и wspCPSWT, которые возвращают удельные изобарные теплоемкости пара и воды на линии насыщения. При вычислениях используется следующая формула: CPx = (1 - X)·CPw + X·CPs, где CPs = wspCPSST, CPw = wspCPSWT и X - степень сухости.

  159. Удельная изохорная теплоемкость (Cv) в двухфазной области [Дж/(кг·К)] как функция величин: температура t [K], степень сухости x [-]:

    wspCVSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в двухфазной области [Дж/(кг·К)], тип: double.

    Данная функция использует функции wspCVDPSST и wspCVDPSWT, которые возвращают удельные изохорные теплоемкости пара и воды на линии насыщения со стороны двухфазной области. При вычислениях используется следующая формула: CVx = (1 - X)·CVDPw + X·CVDPs, где CVDPs = wspCVDPSST, CVDPw = wspCVDPSWT и X - степень сухости. До версии 5.6 эта функция использовала функции wspCVSWT и wspCVSST, что, с точки зрения термодинамики, неверно, т.к. не учитывался скачок свойств на линии насыщения.

  160. Плотность в двухфазной области [кг/м3] как функция величин: температура t [K], степень сухости x [-]:

    wspDSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – плотность в двухфазной области [кг/м3], тип: double.

    Данная функция использует функцию wspVSTX, которая возвращает удельный объем в двухфазной области. При вычислениях используется следующая формула: Dx = 1 / Vx, где Vx = wspVSTX(t, x).

  161. Динамическая вязкость в двухфазной области [Па·с] как функция величин: температура t [K], степень сухости x [-]:

    wspDYNVISSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – динамическая вязкость в двухфазной области [Па·с], тип: double.

    Данная функция использует функции wspDYNVISSST и wspDYNVISSWT, которые возвращают динамическую вязкость пара и воды на линии насыщения. При вычислениях используется следующая формула: DYNVISx = (1 - X)·DYNVISw + X·DYNVISs, где DYNVISs = wspDYNVISSST, DYNVISw = wspDYNVISSWT и X - степень сухости.

  162. Удельная энтальпия в двухфазной области [Дж/кг] как функция величин: температура t [K], степень сухости x [-]:

    wspHSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная энтальпия в двухфазной области [Дж/кг], тип: double.

    Данная функция использует функции wspHSST и wspHSWT, которые возвращают удельные энтальпии пара и воды на линии насыщения. При вычислениях используется следующая формула: Hx = (1 - X)·Hw + X·Hs, где Hs = wspHSST, Hw = wspHSWT и X - степень сухости.

  163. Коэффициент Джоуля-Томсона в двухфазной области [K/Па] как функция величин: температура t [K], степень сухости x [-]:

    wspJOULETHOMPSONSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона в двухфазной области [K/Па], тип: double.

    Данная функция напрямую вычисляет (dT/dP)h в двухфазной области по уравнению для линии насыщения в Формуляции IF-97. До версии 5.6 данная функция возвращала результат, основанный на степени сухости, что неверно с точки зрения термодинамики, т.к. согласно теории коэффициент Джоуля-Томсона постоянен в двухфазной области.

  164. Кинематическая вязкость в двухфазной области [м2/с] как функция величин: температура t [K], степень сухости x [-]:

    wspKINVISSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – кинематическая вязкость в двухфазной области [м2/с], тип: double.

    Данная функция использует функции wspKINVISSST и wspKINVISSWT, которые возвращают кинематическую вязкость пара и воды на линии насыщения. При вычислениях используется следующая формула: KINVISx = (1 - X)·KINVISw + X·KINVISs, где KINVISs = wspKINVISSST, KINVISw = wspKINVISSWT и X - степень сухости.

  165. Коэффициент изоэнтропы в двухфазной области [-] как функция величин: температура t [K], степень сухости x [-]:

    wspKSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – коэффициент изоэнтропы в двухфазной области [-], тип: double.

    Функция возвращает значение коэффициента изоэнтропы в двухфазной области с учетом сдвига на линии насыщения. Для этого используются функции wspCVDPSWT, wspCVDPSST и wspDPDTST и соответствующие термодинамические соотношения. До версии 5.6 данная функция использовала неправильное, с точки зрения термодинамики, выражение: Kx = (1 - X)·Kw + X·Ks, где Ks = wspKSST, Kw = wspKSWT и X - степень сухости.

  166. Число Прандтля в двухфазной области [-] как функция величин: температура t [K], степень сухости x [-]:

    wspPRANDTLESTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – число Прандтля в двухфазной области [-], тип: double.

    Данная функция использует функции wspPRANDTLESST и wspPRANDTLESWT, которые возвращают число Прандтля пара и воды на линии насыщения. При вычислениях используется следующая формула: PRANDTLEx = (1 - X)·PRANDTLEw + X·PRANDTLEs, где PRANDTLEs = wspPRANDTLESST, PRANDTLEw = wspPRANDTLESWT и X - степень сухости.

  167. Удельная энтропия в двухфазной области [Дж/(кг·К)] как функция величин: температура t [K], степень сухости x [-]:

    wspSSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная энтропия в двухфазной области [Дж/(кг·К)], тип: double.

    Данная функция использует функции wspSSST и wspSSWT, которые возвращают удельные энтропии пара и воды на линии насыщения. При вычислениях используется следующая формула: Sx = (1 - X)·Sw + X·Ss, где Ss = wspSSST, Sw = wspSSWT и X - степень сухости.

  168. Коэффициент теплопроводности в двухфазной области [Вт/(м·K)] как функция величин: температура t [K], степень сухости x [-]:

    wspTHERMCONDSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности в двухфазной области [Вт/(м·K)], тип: double.

    Данная функция использует функции wspTHERMCONDSST и wspTHERMCONDSWT, которые возвращают коэффициент теплопроводности пара и воды на линии насыщения. При вычислениях используется следующая формула: THERMCONDx = (1 - X)·THERMCONDw + X·THERMCONDs, где THERMCONDs = wspTHERMCONDSST, THERMCONDw = wspTHERMCONDSWT и X - степень сухости.

  169. Параметры в двухфазной области как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTXSHS(h, s, *t, *x)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • t – температура насыщения [K], тип: double. Внимание! Это выходной параметр;
    • x – степень сухости [-], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – параметры в двухфазной области, тип: double.

    Функция вычисляет на основе термодинамических соотношений температуру на линии насыщения и степень сухости для заданных h и s. При поиске используется метод Ньютона.

    Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  170. Удельная внутренняя энергия в двухфазной области [Дж/кг] как функция величин: температура t [K], степень сухости x [-]:

    wspUSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия в двухфазной области [Дж/кг], тип: double.

    Данная функция использует функции wspUSST и wspUSWT, которые возвращают удельные внутренние энергии пара и воды на линии насыщения. При вычислениях используется следующая формула: Ux = (1 - X)·Uw + X·Us, где Us = wspUSST, Uw = wspUSWT и X - степень сухости.

  171. Удельный объем в двухфазной области [м3/кг] как функция величин: температура t [K], степень сухости x [-]:

    wspVSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – удельный объем в двухфазной области [м3/кг], тип: double.

    Данная функция использует функции wspVSST и wspVSWT, которые возвращают удельные объемы пара и воды на линии насыщения. При вычислениях используется следующая формула: Vx = (1 - X)·Vw + X·Vs, где Vs = wspVSST, Vw = wspVSWT и X - степень сухости.

  172. Скорость звука в двухфазной области [м/с] как функция величин: температура t [K], степень сухости x [-]:

    wspWSTX(t, x)

    где:

    • t – температура [K], тип: double;
    • x – степень сухости [-], тип: double;
    • Возвращаемый результат – скорость звука в двухфазной области [м/с], тип: double.

    Данная функция использует функцию wspKSTX для вычисления скорости звука, с точки зрения термодинамики. Функция не учитывает структуру потока и поэтому не может использоваться без ее учета. До версии 5.6 данная функция использовала функции wspWSST и wspWSWT, которые возвращают скорости звука пара и воды на линии насыщения, что было неправильно с точки зрения термодинамики (при вычислениях использовалась следующая формула: Wx = (1 - X)·Ww + X·Ws, где Ws = wspWSST, Ww = wspWSWT и X - степень сухости).

  173. Степень сухости [-] как функция величин: температура t [K], удельная изобарная теплоемкость (Cp) Cp [Дж/(кг·К)]:

    wspXSTCP(t, Cp)

    где:

    • t – температура [K], тип: double;
    • Cp – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (CP - CPw)/(CPs - CPw), где CPw = wspCPSWT, CPs = wspCPSST.

  174. Степень сухости [-] как функция величин: температура t [K], удельная изохорная теплоемкость (Cv) Cv [Дж/(кг·К)]:

    wspXSTCV(t, Cv)

    где:

    • t – температура [K], тип: double;
    • Cv – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Начиная с версии 5.6 функция использует следующую формулу: X = (CV - CVDPw)/(CVDPs - CVDPw), где CVDPw = wspCVDPSWT, CVDPs = wspCVDPSST. До версии 5.6 функция использовала формулу без учета скачка значений изохорной теплоемкости на линии насыщения.

  175. Степень сухости [-] как функция величин: температура t [K], плотность r [кг/м3]:

    wspXSTD(t, r)

    где:

    • t – температура [K], тип: double;
    • r – плотность [кг/м3], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = rs * (rw - r) / (r * (rw - rs)), где rw = wspDSWT, rs = wspDSST.

  176. Степень сухости [-] как функция величин: температура t [K], динамическая вязкость dv [Па·с]:

    wspXSTDYNVIS(t, dv)

    где:

    • t – температура [K], тип: double;
    • dv – динамическая вязкость [Па·с], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (DV - DVw)/(DVs - DVw), где DVw = wspDYNVISSWT, DVs = wspDYNVISSST.

  177. Степень сухости [-] как функция величин: температура t [K], удельная энтальпия h [Дж/кг]:

    wspXSTH(t, h)

    где:

    • t – температура [K], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (H - Hw)/(Hs - Hw), где Hw = wspHSWT, Hs = wspHSST.

  178. Степень сухости [-] как функция величин: температура t [K], коэффициент Джоуля-Томсона jt [K/Па]:

    wspXSTJOULETHOMPSON(t, jt)

    где:

    • t – температура [K], тип: double;
    • jt – коэффициент Джоуля-Томсона [K/Па], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Начиная с версии 5.6 эта функция возвращает значение, правильное с точки зрения термодинамики. Согласно последнему, значение коэффициента Джоуля-Томсона в двухфазной области постоянно. Поэтому, эта функция производит проверку на соответствие параметра jt и вычисленного для температуры t. При их рассогласовании выдается ошибка с кодом 2. Иначе функция возвращает значение 0. До версии 5.6 функция использовала формулу: X = (JT - JTW)/(JTS - JTW), где JTW = wspJOULETHOMPSONSWT, Ws = wspJOULETHOMPSONSST.

  179. Степень сухости [-] как функция величин: температура t [K], коэффициент изоэнтропы k [-]:

    wspXSTK(t, k)

    где:

    • t – температура [K], тип: double;
    • k – коэффициент изоэнтропы [-], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (K - Kw)/(Ks - Kw), где Kw = wspKSWT, Ks = wspKSST. Функция возвращает правильное, с точки зрения термодинамики, значение, начиная с версии 5.6.

  180. Степень сухости [-] как функция величин: температура t [K], кинематическая вязкость kv [м2/с]:

    wspXSTKINVIS(t, kv)

    где:

    • t – температура [K], тип: double;
    • kv – кинематическая вязкость [м2/с], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (KV - KVw)/(KVs - KVw), где KVw = wspKINVISSWT, KVs = wspKINVISSST.

  181. Степень сухости [-] как функция величин: температура t [K], число Прандтля pr [-]:

    wspXSTPRANDTLE(t, pr)

    где:

    • t – температура [K], тип: double;
    • pr – число Прандтля [-], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (PR - PRw)/(PRs - PRw), где PRw = wspPRANDTLESWT, PRs = wspPRANDTLESST.

  182. Степень сухости [-] как функция величин: температура t [K], удельная энтропия s [Дж/(кг·К)]:

    wspXSTS(t, s)

    где:

    • t – температура [K], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (S - Sw)/(Ss - Sw), где Sw = wspSSWT, Ss = wspSSST.

  183. Степень сухости [-] как функция величин: температура t [K], коэффициент теплопроводности tc [Вт/(м·K)]:

    wspXSTTHERMCOND(t, tc)

    где:

    • t – температура [K], тип: double;
    • tc – коэффициент теплопроводности [Вт/(м·K)], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (TC - TCw)/(TCs - TCw), где TCw = wspTHERMCONDSWT, TCs = wspTHERMCONDSST.

  184. Степень сухости [-] как функция величин: температура t [K], удельная внутренняя энергия u [Дж/кг]:

    wspXSTU(t, u)

    где:

    • t – температура [K], тип: double;
    • u – удельная внутренняя энергия [Дж/кг], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (U - Uw)/(Us - Uw), где Uw = wspUSWT, Us = wspUSST.

  185. Степень сухости [-] как функция величин: температура t [K], удельный объем v [м3/кг]:

    wspXSTV(t, v)

    где:

    • t – температура [K], тип: double;
    • v – удельный объем [м3/кг], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Данная функция использует следующую формулу: X = (V - Vw)/(Vs - Vw), где Vw = wspVSWT, Vs = wspVSST.

  186. Степень сухости [-] как функция величин: температура t [K], скорость звука w [m/с]:

    wspXSTW(t, w)

    где:

    • t – температура [K], тип: double;
    • w – скорость звука [m/с], тип: double;
    • Возвращаемый результат – степень сухости [-], тип: double.

    Начиная с версии 5.6 данная функция вычисляет значение через коэффициент изоэнтропы, что правильно с точки зрения термодинамики. До версии 5.6 функция использовала формулу: X = (W - Ww)/(Ws - Ww), где Ww = wspWSWT, Ws = wspWSST.

    187. Категория: Sublimation and Melting Lines

    Функции свойств на линиях сублимации и плавления.

  187. Давление на линии плавления льда модификации I [Па] как функция величин: температура t [K]:

    wspPMELTIT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – давление на линии плавления льда модификации I [Па], тип: double.

    Функция основана на "Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance" IAPWS (Milan, Italy, September 1993).

  188. Давление на линии сублимации [Па] как функция величин: температура t [K]:

    wspPSUBT(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – давление на линии сублимации [Па], тип: double.

    Функция основана на "Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance" IAPWS (Milan, Italy, September 1993).

    189. Категория: MetaStable

    Функции для расчета свойств в метастабильной области (переохлажденный пар)

  189. Удельная изобарная теплоемкость (Cp) в метастабильной области [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCPMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в метастабильной области [Дж/(кг·К)], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  190. Удельная изохорная теплоемкость (Cv) в метастабильной области [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCVMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в метастабильной области [Дж/(кг·К)], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  191. Динамическая вязкость в метастабильной области [Па·с] как функция величин: давление p [Па], температура t [K]:

    wspDYNVISMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – динамическая вязкость в метастабильной области [Па·с], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  192. Удельная энтальпия в метастабильной области [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspHMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия в метастабильной области [Дж/кг], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  193. Коэффициент Джоуля-Томсона в метастабильной области [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSONMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона в метастабильной области [K/Па], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  194. Кинематическая вязкость в метастабильной области [м2/с] как функция величин: давление p [Па], температура t [K]:

    wspKINVISMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – кинематическая вязкость в метастабильной области [м2/с], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  195. Показатель изоэнтропы в метастабильной области [-] как функция величин: давление p [Па], температура t [K]:

    wspKMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – показатель изоэнтропы в метастабильной области [-], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  196. Число Прандтля в метастабильной области [-] как функция величин: давление p [Па], температура t [K]:

    wspPRANDTLEMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – число Прандтля в метастабильной области [-], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  197. Удельная энтропия в метастабильной области [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspSMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия в метастабильной области [Дж/(кг·К)], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  198. Коэффициент теплопроводности в метастабильной области [Вт/(м·K)] как функция величин: давление p [Па], температура t [K]:

    wspTHERMCONDMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности в метастабильной области [Вт/(м·K)], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  199. Удельная внутренняя энергия в метастабильной области [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspUMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия в метастабильной области [Дж/кг], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  200. Удельный объем в метастабильной области [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspVMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем в метастабильной области [м3/кг], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

  201. Результат вычисления свойств переохлажденного пара (метастабильная область) как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPTMSPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
    • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
    • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
    • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
    • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств переохлажденного пара (метастабильная область), тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

    Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  202. Скорость звука в метастабильной области [м/с] как функция величин: давление p [Па], температура t [K]:

    wspWMSPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – скорость звука в метастабильной области [м/с], тип: double.

    Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

    203. Категория: Source

    Функции по Формуляции IF-97 и другим формуляциям от Международной Ассоциации по Свойствам Воды и Водяного Пара.

  203. Удельная изобарная теплоемкость (Cp) в области 1 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [К]:

    wspCP1PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [К], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 1 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  204. Удельная изобарная теплоемкость (Cp) в области 2 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCP2PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 2 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  205. Удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCP3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)], тип: double.

    Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.

  206. Удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)] как функция величин: плотность r [кг/м3], температура t [K]:

    wspCP3RT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  207. Удельная изобарная теплоемкость (Cp) в области 5 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCP5PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 5 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  208. Удельная изохорная теплоемкость (Cv) в области 1 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCV1PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 1 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  209. Удельная изохорная теплоемкость (Cv) в области 2 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCV2PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 2 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  210. Удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCV3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)], тип: double.

    Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.

  211. Удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)] как функция величин: плотность r [кг/м3], температура t [K]:

    wspCV3RT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  212. Удельная изохорная теплоемкость (Cv) в области 5 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCV5PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 5 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  213. Плотность в области 1 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspD1PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – плотность в области 1 [кг/м3], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  214. Плотность в области 2 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspD2PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – плотность в области 2 [кг/м3], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  215. Плотность в области 3 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspD3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – плотность в области 3 [кг/м3], тип: double.

    Функция рассчитывает плотность в области 3 с использованием функции wspR3PTR0 с соответствующими начальными приближениями для воды и пара. Используется для унификации функций в различных областях Формуляции IF-97.

  216. Плотность в области 5 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspD5PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – плотность в области 5 [кг/м3], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  217. Диэлектрическая проницаемость воды [-] как функция величин: плотность r [кг/м3], температура t [K]:

    wspDCRT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – диэлектрическая проницаемость воды [-], тип: double.

    Основана на "Release on the Static Dielectric Constant of Ordinary Water Substance for Temperatures from 238K to 873K and Pressures up to 1000 MPa", 1997 от IAPWS. Диапазон использования: при температурах от 238 до 273K для метастабильной жидкости при атмосферном давлении (101 325 Па), при температурах от 273 до 323 К - при давлениях до низшей точки плавления льда IV или 1000 МПа, свыше 323 К - при давлениях до 600 МПа. Используемые уравнения экстраполируются достаточно гладко до температур 1200К и давлений 1200 МПа.

  218. Динамическая вязкость [Па·с] как функция величин: плотность r [кг/м3], температура t [K]:

    wspDYNVISRT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

    Основана на "the IAPWS Formulation 1985 for the Viscosity of Ordinary Water Substance" с коррекцией для Международной Температурной Шкалы 1990.

  219. Удельная энтальпия в области 1 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspH1PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия в области 1 [Дж/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  220. Удельная энтальпия на линии между областями 2b и 2c [Дж/кг] как функция величин: давление p [Па]:

    wspH2B2CP(p)

    где:

    • p – давление [Па], тип: double;
    • Возвращаемый результат – удельная энтальпия на линии между областями 2b и 2c [Дж/кг], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  221. Удельная энтальпия в области 2 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspH2PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия в области 2 [Дж/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  222. Удельная энтальпия в области 3 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspH3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия в области 3 [Дж/кг], тип: double.

    Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.

  223. Удельная энтальпия в области 3 [Дж/кг] как функция величин: плотность r [кг/м3], температура t [K]:

    wspH3RT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия в области 3 [Дж/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  224. Удельная энтальпия в области 5 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspH5PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия в области 5 [Дж/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  225. Удельная энтальпия на линии между областями 1 и 3 [Дж/кг] как функция величин: удельная энтропия s [Дж/(кг·К)]:

    wspHB13S(s)

    где:

    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельная энтальпия на линии между областями 1 и 3 [Дж/кг], тип: double.

    Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).

  226. Коэффициент Джоуля-Томсона в области 1 [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSON1PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона в области 1 [K/Па], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара и использует формулу: JT = (T*(dV/dT)p - V)/Cp.

  227. Коэффициент Джоуля-Томсона в области 2 [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSON2PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона в области 2 [K/Па], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара и использует формулу: JT = (T*(dV/dT)p - V)/Cp.

  228. Коэффициент Джоуля-Томсона в области 3 [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSON3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона в области 3 [K/Па], тип: double.

    Функция использует функцию wspR3PT для расчета плотности по давлению и температуре и далее вызывает функцию wspJOULETHOMPSON3RT.

  229. Коэффициент Джоуля-Томсона в области 3 [K/Па] как функция величин: плотность r [кг/м3], температура t [K]:

    wspJOULETHOMPSON3RT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона в области 3 [K/Па], тип: double.

    Функция возвращает коэффициент Джоуля-Томсона в области 3 Формуляции IF-97.

  230. Коэффициент Джоуля-Томсона в области 5 [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSON5PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент Джоуля-Томсона в области 5 [K/Па], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара и использует формулу: JT = (T*(dV/dT)p - V)/Cp.

  231. Давление в области 1 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspP1HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – давление в области 1 [Па], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  232. Давление на линии между областями 2 и 3 [Па] как функция величин: температура t [K]:

    wspP23T(t)

    где:

    • t – температура [K], тип: double;
    • Возвращаемый результат – давление на линии между областями 2 и 3 [Па], тип: double.

    Функция основана на Формуляции 1997 для теплофизических свойств воды и водяного пара. Используется в функции wspWATERSTATEAREA при определении области параметров.

  233. Давление на линии между областями 2b и 2c [Па] как функция величин: удельная энтальпия h [Дж/кг]:

    wspP2B2CH(h)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – давление на линии между областями 2b и 2c [Па], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  234. Давление в области 2 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspP2HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – давление в области 2 [Па], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. При расчете используются функции wspP2AHS(h, s), wspP2BHS(h, s) и wspP2CHS(h, s).

  235. Давление в области 3 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspP3HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – давление в области 3 [Па], тип: double.

    Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).

  236. Давление в области 3 [Па] как функция величин: плотность r [кг/м3], температура t [K]:

    wspP3RT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – давление в области 3 [Па], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  237. Давление в области 5 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspP5HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – давление в области 5 [Па], тип: double.

    Функция основана на использовании термодинамических соотношений для поиска давления в области 5 методом Ньютона.

  238. Давление на линии между областями 2 и 3 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPB23HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – давление на линии между областями 2 и 3 [Па], тип: double.

    Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).

  239. Область фазового состояния как функция величин: давление p [Па], температура t [K]:

    wspPHASESTATEPT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – область фазового состояния, тип: long.

    Функция возвращает фазовое состояние в точке, заданной параметрами (p, t). Результат функции вычисляется следущим образом: если давление p или температура t больше критических значений (Pкр или Tкр), то возвращается значение "3" (закритическая область). Если точка лежит выше линии насыщения (в диаграмме P-T), то возвращается значение "1" (фазовое состояние - жидкость). Если точка лежит ниже линии насыщения (в диаграмме P-T), то возвращается значение "2" (фазовое состояние - пар). Если точка находится ниже тройной точки, то возвращается значение ошибки ("-1").

  240. Отрицательный десятичный логарифм ионного произведения воды [-] как функция величин: плотность r [кг/м3], температура t [K]:

    wspPKWRT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – отрицательный десятичный логарифм ионного произведения воды [-], тип: double.

    Основана на "Release on the Ionization Constant of H2O, August 2007" от IAPWS.

  241. Параметры в области 1 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPT1HS(h, s, *p, *t)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • p – давление [Па], тип: double. Внимание! Это выходной параметр;
    • t – температура [K], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – параметры в области 1, тип: double.

    Функция основана на использовании термодинамических соотношений для поиска параметров в области 1 методом Ньютона.

    Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  242. Параметры в области 1 как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

    wspPT1RH(r, h, *p, *t)

    где:

    • r – плотность [кг/м3], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • p – давление [Па], тип: double. Внимание! Это выходной параметр;
    • t – температура [K], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – параметры в области 1, тип: double.

    Функция использует основные уравнения Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара для определения давления и температуры по заданным плотности и удельной энтальпии. Для определения корней функции используется метод Ньютона.

    Примечание: В пакете Mathcad функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  243. Параметры в области 2 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPT2HS(h, s, *p, *t)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • p – давление [Па], тип: double. Внимание! Это выходной параметр;
    • t – температура [K], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – параметры в области 2, тип: double.

    Функция основана на использовании термодинамических соотношений для поиска параметров в области 2 методом Ньютона.

    Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  244. Параметры в области 2 как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

    wspPT2RH(r, h, *p, *t)

    где:

    • r – плотность [кг/м3], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • p – давление [Па], тип: double. Внимание! Это выходной параметр;
    • t – температура [K], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – параметры в области 2, тип: double.

    Функция использует основные уравнения Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара для определения давления и температуры по заданным плотности и удельной энтальпии. Для определения корней функции используется метод Ньютона.

    Примечание: В пакете Mathcad функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  245. Параметры в области 3 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPT3HS(h, s, *p, *t)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • p – давление [Па], тип: double. Внимание! Это выходной параметр;
    • t – температура [K], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – параметры в области 3, тип: double.

    Функция основана на работе функции wspRT3HS. После вызова последней по основным уравнениям формуляции IF-97 определяется давление.

    Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  246. Параметры в области 5 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPT5HS(h, s, *p, *t)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • p – давление [Па], тип: double. Внимание! Это выходной параметр;
    • t – температура [K], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – параметры в области 5, тип: double.

    Функция основана на использовании термодинамических соотношений для поиска параметров в области 5 методом Ньютона.

    Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  247. Параметры в области 5 как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

    wspPT5RH(r, h, *p, *t)

    где:

    • r – плотность [кг/м3], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • p – давление [Па], тип: double. Внимание! Это выходной параметр;
    • t – температура [K], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – параметры в области 5, тип: double.

    Функция использует основные уравнения Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара для определения давления и температуры по заданным плотности и удельной энтальпии. Для определения корней функции используется метод Ньютона.

    Примечание: В пакете Mathcad функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  248. Плотность в области 3 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspR3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – плотность в области 3 [кг/м3], тип: double.

    Функция рассчитывает плотность в области 3 с использованием функции wspR3PTR0 с соответствующими начальными приближениями для воды и пара. Используется для унификации функций в различных областях Формуляции IF-97.

  249. Плотность в области 3 [кг/м3] как функция величин: давление p [Па], температура t [K], начальная плотность r0 [кг/м3]:

    wspR3PTR0(p, t, r0)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • r0 – начальная плотность [кг/м3], тип: double;
    • Возвращаемый результат – плотность в области 3 [кг/м3], тип: double.

    В данной функции используется метод Ньютона с начальным приближением для определения плотности в зависимости от p и t. Используется для унификации функций в различных областях Формуляции IF-97.

  250. Показатель преломления [-] как функция величин: плотность r [кг/м3], температура t [K], длина волны wavelength [м]:

    wspRIRTL(r, t, wavelength)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • wavelength – длина волны [м], тип: double;
    • Возвращаемый результат – показатель преломления [-], тип: double.

    Основана на "Release on the Refractive Index of Ordinary Water Substance as a Function of Wavelength, Temperature and Pressure", 1997 от IAPWS. Диапазон использования: температура от -12 до 500°C, плотность до 1060 кг/м3 и длина волны от 0.2 мкм до 1.1 мкм. Используемые уравнения экстраполируются достаточно гладко длины волны 1.9 мкм для жидкости.

  251. Параметры в области 3 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspRT3HS(h, s, *r, *t)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • r – плотность [кг/м3], тип: double. Внимание! Это выходной параметр;
    • t – температура [K], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – параметры в области 3, тип: double.

    Функция основана на использовании термодинамических соотношений для поиска параметров в области 3 методом Ньютона.

    Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  252. Удельная энтропия в области 1 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspS1PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия в области 1 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  253. Удельная энтропия в области 2 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspS2PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия в области 2 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  254. Удельная энтропия в области 3 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspS3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия в области 3 [Дж/(кг·К)], тип: double.

    Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.

  255. Удельная энтропия в области 3 [Дж/(кг·К)] как функция величин: плотность r [кг/м3], температура t [K]:

    wspS3RT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия в области 3 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  256. Удельная энтропия в области 5 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspS5PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия в области 5 [Дж/(кг·К)], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  257. Температура в области 1 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspT1HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 1 [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  258. Температура в области 1 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT1PH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура в области 1 [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  259. Температура в области 1 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT1PS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 1 [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  260. Температура на линии между областями 2 и 3 [K] как функция величин: давление p [Па]:

    wspT23P(p)

    где:

    • p – давление [Па], тип: double;
    • Возвращаемый результат – температура на линии между областями 2 и 3 [K], тип: double.

    Функция основана на Формуляции 1997 для теплофизических свойств воды и водяного пара. Используется в функции wspWATERSTATEAREA при определении области параметров.

  261. Температура в области 2a [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT2APH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура в области 2a [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  262. Температура в области 2a [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT2APS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 2a [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  263. Температура в области 2b [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT2BPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура в области 2b [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  264. Температура в области 2b [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT2BPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 2b [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  265. Температура в области 2c [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT2CPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура в области 2c [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  266. Температура в области 2c [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT2CPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 2c [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  267. Температура в области 2 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspT2HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 2 [K], тип: double.

    Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  268. Температура в области 2 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT2PH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура в области 2 [K], тип: double.

    Функция для расчета использует функции wspT2APH, wspT2BPH и wspT2CPH.

  269. Температура в области 2 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT2PS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 2 [K], тип: double.

    Функция для расчета использует функции wspT2APS, wspT2BPS и wspT2CPS.

  270. Температура в области 3 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspT3HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 3 [K], тип: double.

    Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).

  271. Температура в области 3 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT3PH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура в области 3 [K], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.

  272. Температура в области 3 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT3PS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 3 [K], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.

  273. Температура в области 3 [K] как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

    wspT3RH(r, h)

    где:

    • r – плотность [кг/м3], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура в области 3 [K], тип: double.

    Функция использует основные уравнения Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара для определения температуры по заданным плотности и удельной энтальпии. Для определения корня функции используется метод Ньютона.

  274. Температура в области 5 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspT5HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 5 [K], тип: double.

    Функция основана на использовании термодинамических соотношений для поиска температуры в области 5 методом Ньютона.

  275. Температура в области 5 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT5PH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура в области 5 [K], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.

  276. Температура в области 5 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT5PS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура в области 5 [K], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.

  277. Температура на линии между областями 2 и 3 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTB23HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура на линии между областями 2 и 3 [K], тип: double.

    Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).

  278. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: плотность r [кг/м3], температура t [K]:

    wspTHERMCONDRT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

    Основана на "the IAPWS Formulation 1985 for thermal Conductivity" с коррекцией для Международной Температурной Шкалы 1990.

  279. Удельная внутренняя энергия в области 1 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspU1PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия в области 1 [Дж/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  280. Удельная внутренняя энергия в области 2 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspU2PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия в области 2 [Дж/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  281. Удельная внутренняя энергия в области 3 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspU3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия в области 3 [Дж/кг], тип: double.

    Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.

  282. Удельная внутренняя энергия в области 3 [Дж/кг] как функция величин: плотность r [кг/м3], температура t [K]:

    wspU3RT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия в области 3 [Дж/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  283. Удельная внутренняя энергия в области 5 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspU5PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия в области 5 [Дж/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  284. Удельный объем в области 1 [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspV1PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем в области 1 [м3/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  285. Удельный объем в области 2 [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspV2PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем в области 2 [м3/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  286. Удельный объем в области 3 [м3/kg] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspV3HS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельный объем в области 3 [м3/kg], тип: double.

    Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).

  287. Удельный объем в области 3 [м3/кг] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspV3PH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – удельный объем в области 3 [м3/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.

  288. Удельный объем в области 3 [м3/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspV3PS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – удельный объем в области 3 [м3/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.

  289. Удельный объем в области 3 [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspV3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем в области 3 [м3/кг], тип: double.

    Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.

  290. Удельный объем в области 5 [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspV5PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем в области 5 [м3/кг], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  291. Результат вычисления свойств в области 1 как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPT1PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
    • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
    • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
    • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
    • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств в области 1, тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

    Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  292. Результат вычисления свойств в области 2 как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPT2PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
    • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
    • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
    • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
    • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств в области 2, тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

    Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  293. Результат вычисления свойств в области 3 как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPT3PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
    • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
    • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
    • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
    • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств в области 3, тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

    Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  294. Результат вычисления свойств в области 3 как функция величин: плотность r [кг/м3], температура t [K]:

    wspVUSHCVWDERPT3RT(r, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
    • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
    • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
    • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
    • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств в области 3, тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

    Примечание: В пакете Mathcad функция имеет только аргументы (r, t) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (r, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  295. Результат вычисления свойств в области 5 как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPT5PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
    • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
    • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
    • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
    • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
    • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
    • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
    • Возвращаемый результат – результат вычисления свойств в области 5, тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

    Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

    Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".

  296. Скорость звука в области 1 [м/с] как функция величин: давление p [Па], температура t [K]:

    wspW1PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – скорость звука в области 1 [м/с], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  297. Скорость звука в области 2 [м/с] как функция величин: давление p [Па], температура t [K]:

    wspW2PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – скорость звука в области 2 [м/с], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  298. Скорость звука в области 3 [м/с] как функция величин: давление p [Па], температура t [K]:

    wspW3PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – скорость звука в области 3 [м/с], тип: double.

    Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.

  299. Скорость звука в области 3 [м/с] как функция величин: плотность r [кг/м3], температура t [K]:

    wspW3RT(r, t)

    где:

    • r – плотность [кг/м3], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – скорость звука в области 3 [м/с], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  300. Скорость звука в области 5 [м/с] как функция величин: давление p [Па], температура t [K]:

    wspW5PT(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – скорость звука в области 5 [м/с], тип: double.

    Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.

  301. Область параметров Формуляции IF-97 как функция величин: давление p [Па], температура t [K]:

    wspWATERSTATEAREA(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – область параметров Формуляции IF-97, тип: long.

    Функция основана на распределении областей в Формуляции 1997 для теплофизических свойств воды и водяного пара. Используется в обобщенных функциях.

  302. Область параметров Формуляции IF-97 (версия 2) как функция величин: давление p [Па], температура t [K]:

    wspWATERSTATEAREA2(p, t)

    где:

    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – область параметров Формуляции IF-97 (версия 2), тип: long.

    Функция основана на распределении областей в Формуляции 1997 для теплофизических свойств воды и водяного пара. Второй вариант - без двухфазной области - при параметрах на линии насыщения возвращается вторая область. Используется в обобщенных функциях.

  303. Область параметров Формуляции IF-97 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspWATERSTATEAREAHS(h, s)

    где:

    • h – удельная энтальпия [Дж/кг], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – область параметров Формуляции IF-97, тип: long.

    Функция основана на распределении областей Дополнительных уравнений для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Используется в обобщенных функциях.

  304. Область параметров Формуляции IF-97 как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspWATERSTATEAREAPH(p, h)

    где:

    • p – давление [Па], тип: double;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – область параметров Формуляции IF-97, тип: long.

    Функция основана на распределении областей Дополнительных уравнений для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Используется в обобщенных функциях.

  305. Область параметров Формуляции IF-97 как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspWATERSTATEAREAPS(p, s)

    где:

    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – область параметров Формуляции IF-97, тип: long.

    Функция основана на распределении областей Дополнительных уравнений для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Используется в обобщенных функциях.

    306. Категория: Gases

    Функции для работы со свойствами газов.

  306. Добавление одного газа в состав другого как функция величин: идентификатор исходного газа id_target, идентификатор добавляемого газа id_source, масса добавляемого газа mass:

    wspgADDGASM(id_target, id_source, mass)

    где:

    • id_target – идентификатор исходного газа, тип: long;
    • id_source – идентификатор добавляемого газа, тип: long;
    • mass – масса добавляемого газа, тип: double;
    • Возвращаемый результат – добавление одного газа в состав другого, тип: long.

    Функция производит добавление указанной массы одного газа (заданного идентификатором id_source) в состав другого газа (заданного идентификатором id_target).

  307. Добавление одного газа в состав другого как функция величин: идентификатор исходного газа id_target, идентификатор добавляемого газа id_source, объем добавляемого газа volume:

    wspgADDGASV(id_target, id_source, volume)

    где:

    • id_target – идентификатор исходного газа, тип: long;
    • id_source – идентификатор добавляемого газа, тип: long;
    • volume – объем добавляемого газа, тип: double;
    • Возвращаемый результат – добавление одного газа в состав другого, тип: long.

    Функция производит добавление указанного объема (или количества молей) одного газа (заданного идентификатором id_source) в состав другого газа (заданного идентификатором id_target).

  308. Удельная изобарная теплоемкость [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgCPGST(gas_specification, t)

    где:

    • gas_specification – спецификация газа, тип: string;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость [Дж/(кг·К)], тип: double.

    Функция вычисляет удельную изобарную теплоемкость для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  309. Удельная изобарная теплоемкость [Дж/(кг·К)] как функция величин: идентификатор газа id, температура t [K]:

    wspgCPIDT(id, t)

    где:

    • id – идентификатор газа, тип: long;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изобарная теплоемкость [Дж/(кг·К)], тип: double.

    Функция вычисляет удельную изобарную теплоемкость заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  310. Удельная изохорная теплоемкость [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgCVGST(gas_specification, t)

    где:

    • gas_specification – спецификация газа, тип: string;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double.

    Функция вычисляет удельную изохорную теплоемкость для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  311. Удельная изохорная теплоемкость [Дж/(кг·К)] как функция величин: идентификатор газа id, температура t [K]:

    wspgCVIDT(id, t)

    где:

    • id – идентификатор газа, тип: long;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double.

    Функция вычисляет удельную изохорную теплоемкость заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  312. Удаление всех определенных пользователем газов:

    wspgDELETEGASES()

    где:

    • Возвращаемый результат – удаление всех определенных пользователем газов, тип: long.

    Функция удаляет все определенные пользователем газы. При этом происходит освобождение памяти, занятой под газы. После вызова функции доступны для расчетов только встроенные газы.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  313. Удаление определенного ранее газа как функция величин: идентификатор газа id:

    wspgDELETEGASID(id)

    где:

    • id – идентификатор газа, тип: long;
    • Возвращаемый результат – удаление определенного ранее газа, тип: long.

    Функция удаляет газ с заданным идентификатором. При этом происходит освобождение памяти, занятой под данный газ.

  314. Количество всех доступных газов:

    wspgGASESCOUNT()

    где:

    • Возвращаемый результат – количество всех доступных газов, тип: long.

    Функция возвращает число доступных газов: встроенных и определенных пользователем.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  315. Удельная газовая постоянная [Дж/(кг·К)] как функция величин: спецификация газа gas_specification:

    wspgGCGS(gas_specification)

    где:

    • gas_specification – спецификация газа, тип: string;
    • Возвращаемый результат – удельная газовая постоянная [Дж/(кг·К)], тип: double.

  316. Удельная газовая постоянная [Дж/(кг·К)] как функция величин: идентификатор газа id:

    wspgGCID(id)

    где:

    • id – идентификатор газа, тип: long;
    • Возвращаемый результат – удельная газовая постоянная [Дж/(кг·К)], тип: double.

  317. Удельная энтальпия [Дж/кг] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgHGST(gas_specification, t)

    где:

    • gas_specification – спецификация газа, тип: string;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

    Функция вычисляет удельную энтальпию для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  318. Удельная энтальпия [Дж/кг] как функция величин: идентификатор газа id, температура t [K]:

    wspgHIDT(id, t)

    где:

    • id – идентификатор газа, тип: long;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

    Функция вычисляет удельную энтальпию заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  319. Идентификатор газа как функция величин: имя ранее созданного газа name:

    wspgIDNAME(name)

    где:

    • name – имя ранее созданного газа, тип: string;
    • Возвращаемый результат – идентификатор газа, тип: long.

    Функция возвращает идентификатор ранее определенного газа (или встроенного). Если газа с таким именем не существует, то генерируется ошибка с кодом WSP_E_BAD_PARAMS.

  320. Массовая доля (MF) газа как функция величин: спецификация исходного газа gas_spec_looked, спецификация искомого газа gas_spec_looked_for:

    wspgMFGSGS(gas_spec_looked, gas_spec_looked_for)

    где:

    • gas_spec_looked – спецификация исходного газа, тип: string;
    • gas_spec_looked_for – спецификация искомого газа, тип: string;
    • Возвращаемый результат – массовая доля (MF) газа, тип: double.

    Функция вычисляет удельную (относительную) массовую долю газа (задаваемого спецификацией gas_spec_looked_for) в газе (задаваемого спецификацией gas_spec_looked).

  321. Массовая доля (MF) газа как функция величин: идентификатор исходного газа id_looked, идентификатор искомого газа id_looked_for:

    wspgMFIDID(id_looked, id_looked_for)

    где:

    • id_looked – идентификатор исходного газа, тип: long;
    • id_looked_for – идентификатор искомого газа, тип: long;
    • Возвращаемый результат – массовая доля (MF) газа, тип: double.

    Функция вычисляет удельную (относительную) массовую долю газа (задаваемого идентификатором id_looked_for) в газе (задаваемого идентификатором id_looked).

  322. Молярная масса [кг/моль] как функция величин: спецификация газа gas_specification:

    wspgMMGS(gas_specification)

    где:

    • gas_specification – спецификация газа, тип: string;
    • Возвращаемый результат – молярная масса [кг/моль], тип: double.

  323. Молярная масса [кг/моль] как функция величин: идентификатор газа id:

    wspgMMID(id)

    где:

    • id – идентификатор газа, тип: long;
    • Возвращаемый результат – молярная масса [кг/моль], тип: double.

  324. Идентификатор нового газа:

    wspgNEWID()

    где:

    • Возвращаемый результат – идентификатор нового газа, тип: long.

    Функция создает новый газ и возвращает идентификатор этого газа. После окончания работы с данным идентификатором необходимо удалить выделенную под газ память вызовом функции wspgDELETEGASID или wspgDELETEGASES. Иначе память будет освобождена только при окончании работы текущей программы.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  325. Идентификатор нового газа как функция величин: спецификация газа gas_specification:

    wspgNEWIDGS(gas_specification)

    где:

    • gas_specification – спецификация газа, тип: string;
    • Возвращаемый результат – идентификатор нового газа, тип: long.

    Функция создает новый газ и возвращает идентификатор этого газа соответствующего заданной спецификации. После окончания работы с данным идентификатором необходимо удалить выделенную под газ память вызовом функции wspgDELETEGASID или wspgDELETEGASES. Иначе память будет освобождена только при окончании работы текущей программы.

  326. Идентификатор газа как функция величин: имя нового газа name:

    wspgNEWIDNAME(name)

    где:

    • name – имя нового газа, тип: string;
    • Возвращаемый результат – идентификатор газа, тип: long.

    Функция создает новый газ с заданным именем и возвращает его идентификатор. Если газ с таким именем существует, то генерируется ошибка с кодом WSP_E_BAD_PARAMS. После окончания работы с данным идентификатором необходимо удалить выделенную под газ память вызовом функции wspgDELETEGASID или wspgDELETEGASES. Иначе память будет освобождена только при окончании работы текущей программы.

  327. Давление [Па] как функция величин: спецификация газа gas_specification, температура t [K], удельная энтропия s [Дж/(кг·К)]:

    wspgPGSTS(gas_specification, t, s)

    где:

    • gas_specification – спецификация газа, тип: string;
    • t – температура [K], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – давление [Па], тип: double.

    Функция определяет давление для заданной спецификации газа (смеси) в идеальном состоянии при заданных температуре и удельной энтропии. Функция определена при температурах от 200 до 2500К.

  328. Давление [Па] как функция величин: идентификатор газа id, температура t [K], удельная энтропия s [Дж/(кг·К)]:

    wspgPIDTS(id, t, s)

    где:

    • id – идентификатор газа, тип: long;
    • t – температура [K], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – давление [Па], тип: double.

    Функция определяет давление для заданного газа (идентификатор id) в идеальном состоянии при заданных температуре и удельной энтропии. Функция определена при температурах от 200 до 2500К.

  329. Удельная энтропия [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, давление p [Па], температура t [K]:

    wspgSGSPT(gas_specification, p, t)

    где:

    • gas_specification – спецификация газа, тип: string;
    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

    Функция вычисляет удельную энтропию для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  330. Удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgSGST(gas_specification, t)

    где:

    • gas_specification – спецификация газа, тип: string;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)], тип: double.

    Функция вычисляет удельную энтропию для заданной спецификации газа (смеси) в идеальном состоянии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.

  331. Удельная энтропия [Дж/(кг·К)] как функция величин: идентификатор газа id, давление p [Па], температура t [K]:

    wspgSIDPT(id, p, t)

    где:

    • id – идентификатор газа, тип: long;
    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

    Функция вычисляет удельную энтропию заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  332. Удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)] как функция величин: идентификатор газа id, температура t [K]:

    wspgSIDT(id, t)

    где:

    • id – идентификатор газа, тип: long;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)], тип: double.

    Функция вычисляет удельную энтропию заданного газа (идентификатор id) в идеальном состоянии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.

  333. Температура [K] как функция величин: спецификация газа gas_specification, удельная энтальпия h [Дж/кг]:

    wspgTGSH(gas_specification, h)

    где:

    • gas_specification – спецификация газа, тип: string;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура [K], тип: double.

    Функция определяет температуру для заданной спецификации газа (смеси) в идеальном состоянии при заданной удельной энтальпии. Функция определена при температурах от 200 до 2500К.

  334. Температура [K] как функция величин: спецификация газа gas_specification, давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspgTGSPS(gas_specification, p, s)

    где:

    • gas_specification – спецификация газа, тип: string;
    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура [K], тип: double.

    Функция определяет температуру для заданной спецификации газа (смеси) в идеальном состоянии при заданных давлении и удельной энтропии. Функция определена при температурах от 200 до 2500К.

  335. Температура при давлении p0 = 100 кПа [K] как функция величин: спецификация газа gas_specification, удельная энтропия s [Дж/(кг·К)]:

    wspgTGSS(gas_specification, s)

    где:

    • gas_specification – спецификация газа, тип: string;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура при давлении p0 = 100 кПа [K], тип: double.

    Функция определяет температуру для заданной спецификации газа (смеси) в идеальном состоянии при заданной удельной энтропии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.

  336. Температура [K] как функция величин: идентификатор газа id, удельная энтальпия h [Дж/кг]:

    wspgTIDH(id, h)

    где:

    • id – идентификатор газа, тип: long;
    • h – удельная энтальпия [Дж/кг], тип: double;
    • Возвращаемый результат – температура [K], тип: double.

    Функция вычисляет температуру для заданного газа (идентификатор id) в идеальном состоянии при заданной удельной энтальпии. Функция определена при температурах от 200 до 2500К.

  337. Температура [K] как функция величин: идентификатор газа id, давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspgTIDPS(id, p, s)

    где:

    • id – идентификатор газа, тип: long;
    • p – давление [Па], тип: double;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура [K], тип: double.

    Функция определяет температуру для заданного газа (идентификатор id) в идеальном состоянии при заданных удельной энтропии и давлении. Функция определена при температурах от 200 до 2500К.

  338. Температура при давлении p0 = 100 кПа [K] как функция величин: идентификатор газа id, удельная энтропия s [Дж/(кг·К)]:

    wspgTIDS(id, s)

    где:

    • id – идентификатор газа, тип: long;
    • s – удельная энтропия [Дж/(кг·К)], тип: double;
    • Возвращаемый результат – температура при давлении p0 = 100 кПа [K], тип: double.

    Функция определяет температуру для заданного газа (идентификатор id) в идеальном состоянии при заданной удельной энтропии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.

  339. Удельная внутренняя энергия [Дж/кг] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgUGST(gas_specification, t)

    где:

    • gas_specification – спецификация газа, тип: string;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

    Функция вычисляет удельную внутреннюю энергию для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  340. Удельная внутренняя энергия [Дж/кг] как функция величин: идентификатор газа id, температура t [K]:

    wspgUIDT(id, t)

    где:

    • id – идентификатор газа, тип: long;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

    Функция вычисляет удельную внутреннюю энергию заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  341. Объемная доля (VF) газа как функция величин: спецификация исходного газа gas_spec_looked, спецификация искомого газа gas_spec_looked_for:

    wspgVFGSGS(gas_spec_looked, gas_spec_looked_for)

    где:

    • gas_spec_looked – спецификация исходного газа, тип: string;
    • gas_spec_looked_for – спецификация искомого газа, тип: string;
    • Возвращаемый результат – объемная доля (VF) газа, тип: double.

    Функция вычисляет удельную (относительную) объемную долю газа (задаваемого спецификацией gas_spec_looked_for) в газе (задаваемого спецификацией gas_spec_looked).

  342. Объемная доля (VF) газа как функция величин: идентификатор исходного газа id_looked, идентификатор искомого газа id_looked_for:

    wspgVFIDID(id_looked, id_looked_for)

    где:

    • id_looked – идентификатор исходного газа, тип: long;
    • id_looked_for – идентификатор искомого газа, тип: long;
    • Возвращаемый результат – объемная доля (VF) газа, тип: double.

    Функция вычисляет удельную (относительную) объемную долю газа (задаваемого идентификатором id_looked_for) в газе (задаваемого идентфикатором id_looked).

  343. Удельный объем [м3/кг] как функция величин: спецификация газа gas_specification, давление p [Па], температура t [K]:

    wspgVGSPT(gas_specification, p, t)

    где:

    • gas_specification – спецификация газа, тип: string;
    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем [м3/кг], тип: double.

    Функция вычисляет удельный объем для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  344. Удельный объем при давлении p0 = 100 кПа [м3/кг] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgVGST(gas_specification, t)

    где:

    • gas_specification – спецификация газа, тип: string;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем при давлении p0 = 100 кПа [м3/кг], тип: double.

    Функция вычисляет удельный объем для заданной спецификации газа (смеси) в идеальном состоянии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.

  345. Удельный объем [м3/кг] как функция величин: идентификатор газа id, давление p [Па], температура t [K]:

    wspgVIDPT(id, p, t)

    где:

    • id – идентификатор газа, тип: long;
    • p – давление [Па], тип: double;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем [м3/кг], тип: double.

    Функция вычисляет удельный объем заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.

  346. Удельный объем при давлении p0 = 100 кПа [м3/кг] как функция величин: идентификатор газа id, температура t [K]:

    wspgVIDT(id, t)

    где:

    • id – идентификатор газа, тип: long;
    • t – температура [K], тип: double;
    • Возвращаемый результат – удельный объем при давлении p0 = 100 кПа [м3/кг], тип: double.

    Функция вычисляет удельный объем заданного газа (идентификатор id) в идеальном состоянии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.

    347. Категория: System

    Системные функции.

  347. Универсальная газовая постоянная [Дж/(моль·К)]:

    wspGETABSOLUTEGASCONSTANT()

    где:

    • Возвращаемый результат – универсальная газовая постоянная [Дж/(моль·К)], тип: double.

    Функция возвращает значение абсолютной газовой постоянной, используемой в расчетах.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  348. Режим ведения проверки диапазона аргументов функций:

    wspGETCHECKRANGEMODE()

    где:

    • Возвращаемый результат – режим ведения проверки диапазона аргументов функций, тип: long.

    Функция возвращает ноль если проверка не производится.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  349. Максимальная разность между значениями давлений при вычислении параметров в области 3 [Па]:

    wspGETDELTAPRESSURE()

    где:

    • Возвращаемый результат – максимальная разность между значениями давлений при вычислении параметров в области 3 [Па], тип: double.

    Функция устарела. Начиная с версии 6.0 она не используется!

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

    Примечание: Данная функция устарела и не рекомендуется к использованию.

  350. Максимальная разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K]:

    wspGETDELTATS()

    где:

    • Возвращаемый результат – максимальная разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K], тип: double.

    Функция устарела. Начиная с версии 6.0 она не используется!

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

    Примечание: Данная функция устарела и не рекомендуется к использованию.

  351. Начальное приближение плотности пара в области 3 [кг/м3]:

    wspGETINITSTEAMDENSITY()

    где:

    • Возвращаемый результат – начальное приближение плотности пара в области 3 [кг/м3], тип: double.

    Функция устарела. Начиная с версии 6.0 она не используется!

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

    Примечание: Данная функция устарела и не рекомендуется к использованию.

  352. Начальное приближение плотности воды в области 3 [кг/м3]:

    wspGETINITWATERDENSITY()

    где:

    • Возвращаемый результат – начальное приближение плотности воды в области 3 [кг/м3], тип: double.

    Функция устарела. Начиная с версии 6.0 она не используется!

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

    Примечание: Данная функция устарела и не рекомендуется к использованию.

  353. Код последней ошибки:

    wspGETLASTERROR()

    где:

    • Возвращаемый результат – код последней ошибки, тип: long.

    Функция возвращает код последней ошибки, которая возникла при вычислениях в функциях WaterSteamPro (за исключением системных функций). Обращение к любой функции (за исключением системных) сбрасывает код последней ошибки в значение ноль (ошибка отсутствует).

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  354. Описание последней ошибки:

    wspGETLASTERRORDESCRIPTION()

    где:

    • Возвращаемый результат – описание последней ошибки, тип: string.

    Функция возвращает описание последней ошибки, которая возникла при вычислениях в функциях WaterSteamPro (за исключением системных функций). Результат определен в библиотеке OKAWSP6.DLL как LPCSTR (1-байтные ANSI-символы), но в ActiveX-объекте WSP.WSPCalculator - как BSTR (Unicode кодировка). В Visual Basic необходимо использовать ActiveX-версию функции. При использовании функции не из Active-X компонента Вам не нужно заботиться об освобождении памяти, т.к. в этой функции используется статический буфер, каждый раз заполняемый соответствующим значением.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  355. Описание последней ошибки:

    wspGETLASTERRORDESCRIPTIONW()

    где:

    • Возвращаемый результат – описание последней ошибки, тип: unicodestring.

    Функция возвращает описание последней ошибки, которая возникла при вычислениях в функциях WaterSteamPro (за исключением системных функций).

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  356. Максимальное число итераций в методе Ньютона:

    wspGETMAXITERATION()

    где:

    • Возвращаемый результат – максимальное число итераций в методе Ньютона, тип: long.

    Это число используется в функциях, где используется метод Ньютона. Если число итераций больше, чем данное значение, то генерируется ошибка с кодом WSP_CANT_FIND_ROOT (3).

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  357. Относительная точность в функциях WaterSteamPro [-]:

    wspGETTOLERANCE()

    где:

    • Возвращаемый результат – относительная точность в функциях WaterSteamPro [-], тип: double.

    Используется в функциях, требующих понятия точности вычисления.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  358. Режим ведения уточнения результатов функций:

    wspGETTOLERANCEMODE()

    где:

    • Возвращаемый результат – режим ведения уточнения результатов функций, тип: long.

    Используется в функциях, где может вестить уточнение результата (например, функции с аргументами (p, h) и (p, s)). Если аргумент данной функции равен нулю, то уточнение запрещается и скорость вычислений увеличивается, в то время как точность уменьшается.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  359. Внутренняя версия WaterSteamPro:

    wspGETWSPVERSION()

    где:

    • Возвращаемый результат – внутренняя версия WaterSteamPro, тип: double.

    Формат версии: x.yzzz, где x - главная версия, y - младшая версия, zzz - номер реализации.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  360. Режим ведения расчета диссоциации при расчете смесей газов:

    wspgGETCALCDISSMODE()

    где:

    • Возвращаемый результат – режим ведения расчета диссоциации при расчете смесей газов, тип: long.

    Используется в функциях для расчета свойств газов. Если установлен режим равный 0, то расчет диссоциации не ведется. Если установлен режим равный 1, то диссоциация считается для смесей всегда. Если установлен режим равный 2, то диссоциация считается для температур свыше 1200 К.

    Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

  361. Устанавливает и возвращает режим ведения расчета диссоциации при расчете смесей газов как функция величин: mode mode:

    wspgSETCALCDISSMODE(mode)

    где:

    • mode – mode, тип: long;
    • Возвращаемый результат – устанавливает и возвращает режим ведения расчета диссоциации при расчете смесей газов, тип: long.

    Используется в функциях для расчета свойств газов. Если установлен режим равный 0, то расчет диссоциации не ведется. Если установлен режим равный 1, то диссоциация считается для смесей всегда. Если установлен режим равный 2, то диссоциация считается для температур свыше 1200 К.

  362. Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационное код key:

    wspLOCALREGISTRATION(name, key)

    где:

    • name – регистрационное имя, тип: string;
    • key – регистрационное код, тип: string;
    • Возвращаемый результат – процессозависимая регистрация WaterSteamPro, тип: void.

    Используется в лицензии "Developer". Данная функция не используется, начиная с версии 6.0 и при ее вызове ничего не делается.

    Примечание: Данная функция устарела и не рекомендуется к использованию.

  363. Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационные данные data:

    wspLOCALREGISTRATIONEXA(name, data)

    где:

    • name – регистрационное имя, тип: string;
    • data – регистрационные данные, тип: long;
    • Возвращаемый результат – процессозависимая регистрация WaterSteamPro, тип: double.

    Используется в лицензии "Developer".

  364. Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационные данные data:

    wspLOCALREGISTRATIONEXW(name, data)

    где:

    • name – регистрационное имя, тип: unicodestring;
    • data – регистрационные данные, тип: long;
    • Возвращаемый результат – процессозависимая регистрация WaterSteamPro, тип: double.

    Используется в лицензии "Developer".

  365. Устанавливает и возвращает режим ведения проверки диапазона аргументов функций как функция величин: mode mode:

    wspSETCHECKRANGEMODE(mode)

    где:

    • mode – mode, тип: long;
    • Возвращаемый результат – устанавливает и возвращает режим ведения проверки диапазона аргументов функций, тип: long.

    Используется в функциях перед вычислениями. Если аргумент функции равен нулю, то проверка не производится и скорость вычислений увеличивается, в то время как могут быть ошибки при вычислениях за областью определения.

  366. Устанавливает и возвращает максимальную разность между значениями давлений при вычислении параметров в области 3 [Па] как функция величин: разность давлений delta [Па]:

    wspSETDELTAPRESSURE(delta)

    где:

    • delta – разность давлений [Па], тип: double;
    • Возвращаемый результат – устанавливает и возвращает максимальную разность между значениями давлений при вычислении параметров в области 3 [Па], тип: double.

    Функция устарела. Начиная с версии 6.0 она не используется!

    Примечание: Данная функция устарела и не рекомендуется к использованию.

  367. Устанавливает и возвращает максимальную разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K] как функция величин: разность температур delta [K]:

    wspSETDELTATS(delta)

    где:

    • delta – разность температур [K], тип: double;
    • Возвращаемый результат – устанавливает и возвращает максимальную разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K], тип: double.

    Функция устарела. Начиная с версии 6.0 она не используется!

    Примечание: Данная функция устарела и не рекомендуется к использованию.

  368. Устанавливает и возвращает начальное приближение плотности пара в области 3 [кг/м3] как функция величин: плотность r [кг/м3]:

    wspSETINITSTEAMDENSITY(r)

    где:

    • r – плотность [кг/м3], тип: double;
    • Возвращаемый результат – устанавливает и возвращает начальное приближение плотности пара в области 3 [кг/м3], тип: double.

    Функция устарела. Начиная с версии 6.0 она не используется!

    Примечание: Данная функция устарела и не рекомендуется к использованию.

  369. Устанавливает и возвращает начальное приближение плотности воды в области 3 [кг/м3] как функция величин: плотность r [кг/м3]:

    wspSETINITWATERDENSITY(r)

    где:

    • r – плотность [кг/м3], тип: double;
    • Возвращаемый результат – устанавливает и возвращает начальное приближение плотности воды в области 3 [кг/м3], тип: double.

    Функция устарела. Начиная с версии 6.0 она не используется!

    Примечание: Данная функция устарела и не рекомендуется к использованию.

  370. Устанавливает и возвращает код последней ошибки как функция величин: код ошибки ErrCode:

    wspSETLASTERROR(ErrCode)

    где:

    • ErrCode – код ошибки, тип: long;
    • Возвращаемый результат – устанавливает и возвращает код последней ошибки, тип: long.

    Данная функция может быть использована для подсчета количества ошибок: все коды ошибок пакета WaterSteamPro начинаются с нуля (ноль - это ошибка отсутствует) и последовательно увеличиваются с шагом 1. В случае если параметр данной функции больше максимального, то функция возвращает ноль, а иначе код установленной ошибки.

  371. Устанавливает и возвращает максимальное число итераций в методе Ньютона как функция величин: максимальное число итераций maxiteration:

    wspSETMAXITERATION(maxiteration)

    где:

    • maxiteration – максимальное число итераций, тип: long;
    • Возвращаемый результат – устанавливает и возвращает максимальное число итераций в методе Ньютона, тип: long.

    Это число используется в функциях, где используется метод Ньютона. Если число итераций больше, чем данное значение, то генерируется ошибка с кодом WSP_CANT_FIND_ROOT (3).

  372. Устанавливает и возвращает относительную точность функций WaterSteamPro [-] как функция величин: точность tolerance [-]:

    wspSETTOLERANCE(tolerance)

    где:

    • tolerance – точность [-], тип: double;
    • Возвращаемый результат – устанавливает и возвращает относительную точность функций WaterSteamPro [-], тип: double.

    Используется в функциях, требующих понятия точности вычисления.

  373. Устанавливает и возвращает режим ведения уточнения результатов функций как функция величин: mode mode:

    wspSETTOLERANCEMODE(mode)

    где:

    • mode – mode, тип: long;
    • Возвращаемый результат – устанавливает и возвращает режим ведения уточнения результатов функций, тип: long.

    Используется в функциях, где может вестить уточнение результата (например, функции с аргументами (p, h) и (p, s)). Если аргумент данной функции равен нулю, то уточнение запрещается и скорость вычислений увеличивается, в то время как точность уменьшается.


Список функций WaterSteamPro по версиям

  • Версия 6.5
  • Версия 6.0
  • Версия 5.6
  • Версия 5.5
  • Версия 5.4
  • Версия 5.3
  • Версия 5.2
  • Версия 5.1
  • Версия 5.0

Версия 6.5

  1. Плотность [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspDPT(p, t)

  2. Производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2] как функция величин: давление p [Па], температура t [K]:

    wspDDDPHPT(p, t)

  3. Производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspDDDPHPTX(p, t, x)

  4. Производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspDDDPHPH(p, h)

  5. Производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5] как функция величин: давление p [Па], температура t [K]:

    wspDDDHPPT(p, t)

  6. Производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspDDDHPPTX(p, t, x)

  7. Производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspDDDHPPH(p, h)

  8. Плотность [кг/м3] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspDPTX(p, t, x)

  9. Отрицательный десятичный логарифм ионного произведения воды [-] как функция величин: давление p [Па], температура t [K]:

    wspPKWPT(p, t)

  10. Диэлектрическая проницаемость воды [-] как функция величин: давление p [Па], температура t [K]:

    wspDCPT(p, t)

  11. Показатель преломления [-] как функция величин: давление p [Па], температура t [K], длина волны wavelength [м]:

    wspRIPTL(p, t, wavelength)

  12. Плотность пара на линии насыщения [кг/м3] как функция величин: температура t [K]:

    wspDSST(t)

  13. Производная плотности по давлении при постоянной энтальпии пара на линии насыщения [с2/м2] как функция величин: температура t [K]:

    wspDDDPHSST(t)

  14. Производная плотности по давлении при постоянной энтальпии воды на линии насыщения [с2/м2] как функция величин: температура t [K]:

    wspDDDPHSWT(t)

  15. Производная плотности по энтальпии при постоянном давлении пара на линии насыщения [кг·с2/м5] как функция величин: температура t [K]:

    wspDDDHPSST(t)

  16. Производная плотности по энтальпии при постоянном давлении воды на линии насыщения [кг·с2/м5] как функция величин: температура t [K]:

    wspDDDHPSWT(t)

  17. Плотность воды на линии насыщения [кг/м3] как функция величин: температура t [K]:

    wspDSWT(t)

  18. Плотность в двухфазной области [кг/м3] как функция величин: температура t [K], степень сухости x [-]:

    wspDSTX(t, x)

  19. Степень сухости [-] как функция величин: температура t [K], плотность r [кг/м3]:

    wspXSTD(t, r)

  20. Результат вычисления свойств переохлажденного пара (метастабильная область) как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPTMSPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  21. Плотность в области 1 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspD1PT(p, t)

  22. Плотность в области 2 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspD2PT(p, t)

  23. Плотность в области 3 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspD3PT(p, t)

  24. Плотность в области 5 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspD5PT(p, t)

  25. Отрицательный десятичный логарифм ионного произведения воды [-] как функция величин: плотность r [кг/м3], температура t [K]:

    wspPKWRT(r, t)

  26. Диэлектрическая проницаемость воды [-] как функция величин: плотность r [кг/м3], температура t [K]:

    wspDCRT(r, t)

  27. Показатель преломления [-] как функция величин: плотность r [кг/м3], температура t [K], длина волны wavelength [м]:

    wspRIRTL(r, t, wavelength)

Версия 6.0

  1. Давление [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPHS(h, s)

  2. Температура [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTHS(h, s)

  3. Результат вычисления свойств как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPTHS(h, s, *p, *t)

  4. Удельный объем [м3/кг] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspVHS(h, s)

  5. Удельная внутренняя энергия [Дж/кг] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspUHS(h, s)

  6. Удельная изобарная теплоемкость [Дж/(кг·К)] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspCPHS(h, s)

  7. Удельная изохорная теплоемкость [Дж/(кг·К)] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspCVHS(h, s)

  8. Скорость звука [м/с] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspWHS(h, s)

  9. Коэффициент Джоуля-Томсона [K/Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspJOULETHOMPSONHS(h, s)

  10. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTHERMCONDHS(h, s)

  11. Динамическая вязкость [Па·с] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspDYNVISHS(h, s)

  12. Число Прандтля [-] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPRANDTLEHS(h, s)

  13. Кинематическая вязкость [м2/с] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspKINVISHS(h, s)

  14. Коэффициент изоэнтропы [-] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspKHS(h, s)

  15. Степень сухости [-] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspXHS(h, s)

  16. Степень сухости [-] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspXPH(p, h)

  17. Степень сухости [-] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspXPS(p, s)

  18. Приближенное значение плотности пара на линии насыщения [кг/м3] как функция величин: температура t [K]:

    wspROUGHRSST(t)

  19. Приближенное значение плотности воды на линии насыщения [кг/м3] как функция величин: температура t [K]:

    wspROUGHRSWT(t)

  20. Удельная энтальпия пара на линии насыщения [Дж/кг] как функция величин: удельная энтропия s [Дж/(кг·К)]:

    wspROUGHHSSS(s)

  21. Удельная энтальпия воды на линии насыщения [Дж/кг] как функция величин: удельная энтропия s [Дж/(кг·К)]:

    wspROUGHHSWS(s)

  22. Температура на линии насыщения [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTSHS(h, s)

  23. Параметры в двухфазной области как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTXSHS(h, s, *t, *x)

  24. Давление на линии сублимации [Па] как функция величин: температура t [K]:

    wspPSUBT(t)

  25. Давление на линии плавления льда модификации I [Па] как функция величин: температура t [K]:

    wspPMELTIT(t)

  26. Давление в области 1 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspP1HS(h, s)

  27. Температура в области 1 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspT1HS(h, s)

  28. Параметры в области 1 как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

    wspPT1RH(r, h, *p, *t)

  29. Давление в области 2 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspP2HS(h, s)

  30. Температура в области 2 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspT2HS(h, s)

  31. Параметры в области 2 как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

    wspPT2RH(r, h, *p, *t)

  32. Давление в области 3 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspP3HS(h, s)

  33. Температура в области 3 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspT3HS(h, s)

  34. Удельный объем в области 3 [м3/kg] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspV3HS(h, s)

  35. Удельный объем в области 3 [м3/кг] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspV3PH(p, h)

  36. Удельный объем в области 3 [м3/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspV3PS(p, s)

  37. Температура в области 3 [K] как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

    wspT3RH(r, h)

  38. Параметры в области 5 как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

    wspPT5RH(r, h, *p, *t)

  39. Область фазового состояния как функция величин: давление p [Па], температура t [K]:

    wspPHASESTATEPT(p, t)

  40. Область параметров Формуляции IF-97 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspWATERSTATEAREAHS(h, s)

  41. Температура на линии между областями 2 и 3 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspTB23HS(h, s)

  42. Давление на линии между областями 2 и 3 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPB23HS(h, s)

  43. Удельная энтальпия на линии между областями 1 и 3 [Дж/кг] как функция величин: удельная энтропия s [Дж/(кг·К)]:

    wspHB13S(s)

  44. Давление в области 5 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspP5HS(h, s)

  45. Температура в области 5 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspT5HS(h, s)

  46. Параметры в области 1 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPT1HS(h, s, *p, *t)

  47. Параметры в области 2 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPT2HS(h, s, *p, *t)

  48. Параметры в области 3 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspRT3HS(h, s, *r, *t)

  49. Параметры в области 3 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPT3HS(h, s, *p, *t)

  50. Параметры в области 5 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

    wspPT5HS(h, s, *p, *t)

  51. Удельная изобарная теплоемкость [Дж/(кг·К)] как функция величин: идентификатор газа id, температура t [K]:

    wspgCPIDT(id, t)

  52. Удельная изобарная теплоемкость [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgCPGST(gas_specification, t)

  53. Удельная энтальпия [Дж/кг] как функция величин: идентификатор газа id, температура t [K]:

    wspgHIDT(id, t)

  54. Удельная энтальпия [Дж/кг] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgHGST(gas_specification, t)

  55. Удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)] как функция величин: идентификатор газа id, температура t [K]:

    wspgSIDT(id, t)

  56. Удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgSGST(gas_specification, t)

  57. Удельная энтропия [Дж/(кг·К)] как функция величин: идентификатор газа id, давление p [Па], температура t [K]:

    wspgSIDPT(id, p, t)

  58. Удельная энтропия [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, давление p [Па], температура t [K]:

    wspgSGSPT(gas_specification, p, t)

  59. Удельная изохорная теплоемкость [Дж/(кг·К)] как функция величин: идентификатор газа id, температура t [K]:

    wspgCVIDT(id, t)

  60. Удельная изохорная теплоемкость [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgCVGST(gas_specification, t)

  61. Удельная внутренняя энергия [Дж/кг] как функция величин: идентификатор газа id, температура t [K]:

    wspgUIDT(id, t)

  62. Удельная внутренняя энергия [Дж/кг] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgUGST(gas_specification, t)

  63. Молярная масса [кг/моль] как функция величин: идентификатор газа id:

    wspgMMID(id)

  64. Молярная масса [кг/моль] как функция величин: спецификация газа gas_specification:

    wspgMMGS(gas_specification)

  65. Удельная газовая постоянная [Дж/(кг·К)] как функция величин: идентификатор газа id:

    wspgGCID(id)

  66. Удельная газовая постоянная [Дж/(кг·К)] как функция величин: спецификация газа gas_specification:

    wspgGCGS(gas_specification)

  67. Удельный объем при давлении p0 = 100 кПа [м3/кг] как функция величин: идентификатор газа id, температура t [K]:

    wspgVIDT(id, t)

  68. Удельный объем при давлении p0 = 100 кПа [м3/кг] как функция величин: спецификация газа gas_specification, температура t [K]:

    wspgVGST(gas_specification, t)

  69. Удельный объем [м3/кг] как функция величин: идентификатор газа id, давление p [Па], температура t [K]:

    wspgVIDPT(id, p, t)

  70. Удельный объем [м3/кг] как функция величин: спецификация газа gas_specification, давление p [Па], температура t [K]:

    wspgVGSPT(gas_specification, p, t)

  71. Температура [K] как функция величин: идентификатор газа id, удельная энтальпия h [Дж/кг]:

    wspgTIDH(id, h)

  72. Температура [K] как функция величин: спецификация газа gas_specification, удельная энтальпия h [Дж/кг]:

    wspgTGSH(gas_specification, h)

  73. Температура при давлении p0 = 100 кПа [K] как функция величин: идентификатор газа id, удельная энтропия s [Дж/(кг·К)]:

    wspgTIDS(id, s)

  74. Температура при давлении p0 = 100 кПа [K] как функция величин: спецификация газа gas_specification, удельная энтропия s [Дж/(кг·К)]:

    wspgTGSS(gas_specification, s)

  75. Температура [K] как функция величин: идентификатор газа id, давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspgTIDPS(id, p, s)

  76. Температура [K] как функция величин: спецификация газа gas_specification, давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspgTGSPS(gas_specification, p, s)

  77. Давление [Па] как функция величин: идентификатор газа id, температура t [K], удельная энтропия s [Дж/(кг·К)]:

    wspgPIDTS(id, t, s)

  78. Давление [Па] как функция величин: спецификация газа gas_specification, температура t [K], удельная энтропия s [Дж/(кг·К)]:

    wspgPGSTS(gas_specification, t, s)

  79. Объемная доля (VF) газа как функция величин: спецификация исходного газа gas_spec_looked, спецификация искомого газа gas_spec_looked_for:

    wspgVFGSGS(gas_spec_looked, gas_spec_looked_for)

  80. Массовая доля (MF) газа как функция величин: спецификация исходного газа gas_spec_looked, спецификация искомого газа gas_spec_looked_for:

    wspgMFGSGS(gas_spec_looked, gas_spec_looked_for)

  81. Объемная доля (VF) газа как функция величин: идентификатор исходного газа id_looked, идентификатор искомого газа id_looked_for:

    wspgVFIDID(id_looked, id_looked_for)

  82. Массовая доля (MF) газа как функция величин: идентификатор исходного газа id_looked, идентификатор искомого газа id_looked_for:

    wspgMFIDID(id_looked, id_looked_for)

  83. Идентификатор газа как функция величин: имя ранее созданного газа name:

    wspgIDNAME(name)

  84. Идентификатор нового газа:

    wspgNEWID()

  85. Идентификатор газа как функция величин: имя нового газа name:

    wspgNEWIDNAME(name)

  86. Идентификатор нового газа как функция величин: спецификация газа gas_specification:

    wspgNEWIDGS(gas_specification)

  87. Удаление определенного ранее газа как функция величин: идентификатор газа id:

    wspgDELETEGASID(id)

  88. Удаление всех определенных пользователем газов:

    wspgDELETEGASES()

  89. Количество всех доступных газов:

    wspgGASESCOUNT()

  90. Добавление одного газа в состав другого как функция величин: идентификатор исходного газа id_target, идентификатор добавляемого газа id_source, масса добавляемого газа mass:

    wspgADDGASM(id_target, id_source, mass)

  91. Добавление одного газа в состав другого как функция величин: идентификатор исходного газа id_target, идентификатор добавляемого газа id_source, объем добавляемого газа volume:

    wspgADDGASV(id_target, id_source, volume)

  92. Устанавливает и возвращает режим ведения расчета диссоциации при расчете смесей газов как функция величин: mode mode:

    wspgSETCALCDISSMODE(mode)

  93. Режим ведения расчета диссоциации при расчете смесей газов:

    wspgGETCALCDISSMODE()

  94. Описание последней ошибки:

    wspGETLASTERRORDESCRIPTIONW()

  95. Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационные данные data:

    wspLOCALREGISTRATIONEXA(name, data)

  96. Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационные данные data:

    wspLOCALREGISTRATIONEXW(name, data)

  97. Универсальная газовая постоянная [Дж/(моль·К)]:

    wspGETABSOLUTEGASCONSTANT()

Версия 5.6

  1. Результат вычисления свойств как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPTPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  2. Производная давления на линии насыщения по температуре насыщения [Па/К] как функция величин: температура t [K]:

    wspDPDTST(t)

  3. Удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны двухфазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCVDPSST(t)

  4. Удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны двухфазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCVDPSWT(t)

  5. Результат вычисления свойств для воды на линии насыщения как функция величин: температура насыщения t [K]:

    wspVUSHCVWDERPTSWT(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  6. Результат вычисления свойств для пара на линии насыщения как функция величин: температура насыщения t [K]:

    wspVUSHCVWDERPTSST(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  7. Результат вычисления свойств в области 1 как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPT1PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  8. Результат вычисления свойств в области 2 как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPT2PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  9. Результат вычисления свойств в области 3 как функция величин: плотность r [кг/м3], температура t [K]:

    wspVUSHCVWDERPT3RT(r, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  10. Результат вычисления свойств в области 3 как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPT3PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

  11. Результат вычисления свойств в области 5 как функция величин: давление p [Па], температура t [K]:

    wspVUSHCVWDERPT5PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

Версия 5.5

  1. Удельный объем в метастабильной области [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspVMSPT(p, t)

  2. Удельная внутренняя энергия в метастабильной области [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspUMSPT(p, t)

  3. Удельная энтропия в метастабильной области [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspSMSPT(p, t)

  4. Удельная энтальпия в метастабильной области [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspHMSPT(p, t)

  5. Удельная изобарная теплоемкость (Cp) в метастабильной области [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCPMSPT(p, t)

  6. Удельная изохорная теплоемкость (Cv) в метастабильной области [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCVMSPT(p, t)

  7. Скорость звука в метастабильной области [м/с] как функция величин: давление p [Па], температура t [K]:

    wspWMSPT(p, t)

  8. Коэффициент теплопроводности в метастабильной области [Вт/(м·K)] как функция величин: давление p [Па], температура t [K]:

    wspTHERMCONDMSPT(p, t)

  9. Динамическая вязкость в метастабильной области [Па·с] как функция величин: давление p [Па], температура t [K]:

    wspDYNVISMSPT(p, t)

  10. Число Прандтля в метастабильной области [-] как функция величин: давление p [Па], температура t [K]:

    wspPRANDTLEMSPT(p, t)

  11. Кинематическая вязкость в метастабильной области [м2/с] как функция величин: давление p [Па], температура t [K]:

    wspKINVISMSPT(p, t)

  12. Показатель изоэнтропы в метастабильной области [-] как функция величин: давление p [Па], температура t [K]:

    wspKMSPT(p, t)

  13. Коэффициент Джоуля-Томсона в метастабильной области [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSONMSPT(p, t)

Версия 5.4

  1. Температура в конце процесса расширения/сжатия [K] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspTEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  2. Удельный объем в конце процесса расширения/сжатия [м3/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  3. Удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspUEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  4. Удельная энтальпия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspHEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  5. Удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspSEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  6. Удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspCPEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  7. Удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspCVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  8. Скорость звука в конце процесса расширения/сжатия [м/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspWEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  9. Коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspTHERMCONDEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  10. Кинематическая вязкость в конце процесса расширения/сжатия [м2/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspKINVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  11. Динамическая вязкость в конце процесса расширения/сжатия [Па·с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspDYNVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  12. Число Прандтля в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspPRANDTLEEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  13. Коэффициент изоэнтропы в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspKEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  14. Коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspJOULETHOMPSONEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  15. Степень сухости в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspXEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

  16. Степень сухости в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspXEXPANSIONPTPEFF(p0, t0, p1, eff)

Версия 5.3

  1. Температура в конце процесса расширения/сжатия [K] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspTEXPANSIONPTPEFF(p0, t0, p1, eff)

  2. Удельный объем в конце процесса расширения/сжатия [м3/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspVEXPANSIONPTPEFF(p0, t0, p1, eff)

  3. Удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspUEXPANSIONPTPEFF(p0, t0, p1, eff)

  4. Удельная энтальпия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspHEXPANSIONPTPEFF(p0, t0, p1, eff)

  5. Удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspSEXPANSIONPTPEFF(p0, t0, p1, eff)

  6. Удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspCPEXPANSIONPTPEFF(p0, t0, p1, eff)

  7. Удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspCVEXPANSIONPTPEFF(p0, t0, p1, eff)

  8. Скорость звука в конце процесса расширения/сжатия [м/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspWEXPANSIONPTPEFF(p0, t0, p1, eff)

  9. Коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspTHERMCONDEXPANSIONPTPEFF(p0, t0, p1, eff)

  10. Кинематическая вязкость в конце процесса расширения/сжатия [м2/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspKINVISEXPANSIONPTPEFF(p0, t0, p1, eff)

  11. Динамическая вязкость в конце процесса расширения/сжатия [Па·с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspDYNVISEXPANSIONPTPEFF(p0, t0, p1, eff)

  12. Число Прандтля в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspPRANDTLEEXPANSIONPTPEFF(p0, t0, p1, eff)

  13. Коэффициент изоэнтропы в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspKEXPANSIONPTPEFF(p0, t0, p1, eff)

  14. Коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

    wspJOULETHOMPSONEXPANSIONPTPEFF(p0, t0, p1, eff)

Версия 5.2

  1. Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSONPT(p, t)

  2. Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspJOULETHOMPSONPTX(p, t, x)

  3. Температура [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspTPH(p, h)

  4. Температура [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspTPS(p, s)

  5. Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspUPH(p, h)

  6. Удельный объем [м3/кг] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspVPH(p, h)

  7. Удельная энтропия [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspSPH(p, h)

  8. Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspCPPH(p, h)

  9. Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspCVPH(p, h)

  10. Скорость звука [м/с] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspWPH(p, h)

  11. Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspJOULETHOMPSONPH(p, h)

  12. Динамическая вязкость [Па·с] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspDYNVISPH(p, h)

  13. Кинематическая вязкость [м2/с] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspKINVISPH(p, h)

  14. Число Прандтля [-] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspPRANDTLEPH(p, h)

  15. Коэффициент изоэнтропы [-] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspKPH(p, h)

  16. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspTHERMCONDPH(p, h)

  17. Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspUPS(p, s)

  18. Удельный объем [м3/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspVPS(p, s)

  19. Удельная энтальпия [Дж/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspHPS(p, s)

  20. Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspCPPS(p, s)

  21. Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspCVPS(p, s)

  22. Скорость звука [м/с] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspWPS(p, s)

  23. Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspJOULETHOMPSONPS(p, s)

  24. Динамическая вязкость [Па·с] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspDYNVISPS(p, s)

  25. Кинематическая вязкость [м2/с] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspKINVISPS(p, s)

  26. Число Прандтля [-] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspPRANDTLEPS(p, s)

  27. Коэффициент изоэнтропы [-] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspKPS(p, s)

  28. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspTHERMCONDPS(p, s)

  29. Коэффициент Джоуля-Томсона пара на линии насыщения со стороны однофазной области [K/Па] как функция величин: температура t [K]:

    wspJOULETHOMPSONSST(t)

  30. Коэффициент Джоуля-Томсона воды на линии насыщения со стороны однофазной области [K/Па] как функция величин: температура t [K]:

    wspJOULETHOMPSONSWT(t)

  31. Коэффициент Джоуля-Томсона в двухфазной области [K/Па] как функция величин: температура t [K], степень сухости x [-]:

    wspJOULETHOMPSONSTX(t, x)

  32. Степень сухости [-] как функция величин: температура t [K], коэффициент Джоуля-Томсона jt [K/Па]:

    wspXSTJOULETHOMPSON(t, jt)

  33. Коэффициент Джоуля-Томсона в области 1 [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSON1PT(p, t)

  34. Коэффициент Джоуля-Томсона в области 2 [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSON2PT(p, t)

  35. Коэффициент Джоуля-Томсона в области 3 [K/Па] как функция величин: плотность r [кг/м3], температура t [K]:

    wspJOULETHOMPSON3RT(r, t)

  36. Коэффициент Джоуля-Томсона в области 3 [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSON3PT(p, t)

  37. Коэффициент Джоуля-Томсона в области 5 [K/Па] как функция величин: давление p [Па], температура t [K]:

    wspJOULETHOMPSON5PT(p, t)

  38. Температура в области 1 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT1PH(p, h)

  39. Температура в области 1 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT1PS(p, s)

  40. Температура в области 2a [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT2APH(p, h)

  41. Температура в области 2a [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT2APS(p, s)

  42. Температура в области 2b [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT2BPH(p, h)

  43. Температура в области 2b [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT2BPS(p, s)

  44. Температура в области 2c [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT2CPH(p, h)

  45. Температура в области 2c [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT2CPS(p, s)

  46. Температура в области 2 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT2PH(p, h)

  47. Температура в области 2 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT2PS(p, s)

  48. Температура в области 3 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT3PH(p, h)

  49. Температура в области 3 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT3PS(p, s)

  50. Температура в области 5 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspT5PH(p, h)

  51. Температура в области 5 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspT5PS(p, s)

  52. Давление на линии между областями 2b и 2c [Па] как функция величин: удельная энтальпия h [Дж/кг]:

    wspP2B2CH(h)

  53. Удельная энтальпия на линии между областями 2b и 2c [Дж/кг] как функция величин: давление p [Па]:

    wspH2B2CP(p)

  54. Область параметров Формуляции IF-97 как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

    wspWATERSTATEAREAPH(p, h)

  55. Область параметров Формуляции IF-97 как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

    wspWATERSTATEAREAPS(p, s)

  56. Устанавливает и возвращает относительную точность функций WaterSteamPro [-] как функция величин: точность tolerance [-]:

    wspSETTOLERANCE(tolerance)

  57. Относительная точность в функциях WaterSteamPro [-]:

    wspGETTOLERANCE()

  58. Устанавливает и возвращает режим ведения уточнения результатов функций как функция величин: mode mode:

    wspSETTOLERANCEMODE(mode)

  59. Режим ведения уточнения результатов функций:

    wspGETTOLERANCEMODE()

  60. Внутренняя версия WaterSteamPro:

    wspGETWSPVERSION()

Версия 5.1

  1. Описание последней ошибки:

    wspGETLASTERRORDESCRIPTION()

  2. Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационное код key:

    wspLOCALREGISTRATION(name, key)

Версия 5.0

  1. Коэффициент поверхностного натяжения [Н/м] как функция величин: температура t [K]:

    wspSURFTENT(t)

  2. Удельный объем [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspVPT(p, t)

  3. Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspUPT(p, t)

  4. Удельная энтропия [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspSPT(p, t)

  5. Удельная энтальпия [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspHPT(p, t)

  6. Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCPPT(p, t)

  7. Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCVPT(p, t)

  8. Скорость звука [м/с] как функция величин: давление p [Па], температура t [K]:

    wspWPT(p, t)

  9. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], температура t [K]:

    wspTHERMCONDPT(p, t)

  10. Динамическая вязкость [Па·с] как функция величин: давление p [Па], температура t [K]:

    wspDYNVISPT(p, t)

  11. Число Прандтля [-] как функция величин: давление p [Па], температура t [K]:

    wspPRANDTLEPT(p, t)

  12. Кинематическая вязкость [м2/с] как функция величин: давление p [Па], температура t [K]:

    wspKINVISPT(p, t)

  13. Коэффициент изоэнтропы [-] как функция величин: давление p [Па], температура t [K]:

    wspKPT(p, t)

  14. Удельный объем [м3/кг] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspVPTX(p, t, x)

  15. Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspUPTX(p, t, x)

  16. Удельная энтропия [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspSPTX(p, t, x)

  17. Удельная энтальпия [Дж/кг] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspHPTX(p, t, x)

  18. Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspCPPTX(p, t, x)

  19. Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspCVPTX(p, t, x)

  20. Скорость звука [м/с] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspWPTX(p, t, x)

  21. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspTHERMCONDPTX(p, t, x)

  22. Динамическая вязкость [Па·с] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspDYNVISPTX(p, t, x)

  23. Число Прандтля [-] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspPRANDTLEPTX(p, t, x)

  24. Кинематическая вязкость [м2/с] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspKINVISPTX(p, t, x)

  25. Коэффициент изоэнтропы [-] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

    wspKPTX(p, t, x)

  26. Давление на линии насыщения [Па] как функция величин: температура t [K]:

    wspPST(t)

  27. Температура на линии насыщения [K] как функция величин: давление p [Па]:

    wspTSP(p)

  28. Удельный объем пара на линии насыщения [м3/кг] как функция величин: температура t [K]:

    wspVSST(t)

  29. Удельный объем воды на линии насыщения [м3/кг] как функция величин: температура t [K]:

    wspVSWT(t)

  30. Удельная внутренняя энергия пара на линии насыщения [Дж/кг] как функция величин: температура t [K]:

    wspUSST(t)

  31. Удельная внутренняя энергия воды на линии насыщения [Дж/кг] как функция величин: температура t [K]:

    wspUSWT(t)

  32. Удельная энтропия пара на линии насыщения [Дж/(кг·К)] как функция величин: температура t [K]:

    wspSSST(t)

  33. Удельная энтропия воды на линии насыщения [Дж/(кг·К)] как функция величин: температура t [K]:

    wspSSWT(t)

  34. Удельная энтальпия пара на линии насыщения [Дж/кг] как функция величин: температура t [K]:

    wspHSST(t)

  35. Удельная энтальпия воды на линии насыщения [Дж/кг] как функция величин: температура t [K]:

    wspHSWT(t)

  36. Удельная изобарная теплоемкость (Cp) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCPSST(t)

  37. Удельная изобарная теплоемкость (Cp) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCPSWT(t)

  38. Удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCVSST(t)

  39. Удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

    wspCVSWT(t)

  40. Скорость звука в паре на линии насыщения со стороны однофазной области [м/с] как функция величин: температура t [K]:

    wspWSST(t)

  41. Скорость звука в воде на линии насыщения со стороны однофазной области [м/с] как функция величин: температура t [K]:

    wspWSWT(t)

  42. Коэффициент теплопроводности пара на линии насыщения [Вт/(м·K)] как функция величин: температура t [K]:

    wspTHERMCONDSST(t)

  43. Коэффициент теплопроводности воды на линии насыщения [Вт/(м·K)] как функция величин: температура t [K]:

    wspTHERMCONDSWT(t)

  44. Динамическая вязкость пара на линии насыщения [Па·с] как функция величин: температура t [K]:

    wspDYNVISSST(t)

  45. Динамическая вязкость воды на линии насыщения [Па·с] как функция величин: температура t [K]:

    wspDYNVISSWT(t)

  46. Число Прандтля пара на линии насыщения [-] как функция величин: температура t [K]:

    wspPRANDTLESST(t)

  47. Число Прандтля воды на линии насыщения [-] как функция величин: температура t [K]:

    wspPRANDTLESWT(t)

  48. Кинематическая вязкость пара на линии насыщения [м2/с] как функция величин: температура t [K]:

    wspKINVISSST(t)

  49. Кинематическая вязкость воды на линии насыщения [м2/с] как функция величин: температура t [K]:

    wspKINVISSWT(t)

  50. Коэффициент изоэнтропы пара на линии насыщения со стороны однофазной области [-] как функция величин: температура t [K]:

    wspKSST(t)

  51. Коэффициент изоэнтропы воды на линии насыщения со стороны однофазной области [-] как функция величин: температура t [K]:

    wspKSWT(t)

  52. Удельная теплота парообразования [Дж/кг] как функция величин: температура t [K]:

    wspRST(t)

  53. Удельный объем в двухфазной области [м3/кг] как функция величин: температура t [K], степень сухости x [-]:

    wspVSTX(t, x)

  54. Удельная внутренняя энергия в двухфазной области [Дж/кг] как функция величин: температура t [K], степень сухости x [-]:

    wspUSTX(t, x)

  55. Удельная энтропия в двухфазной области [Дж/(кг·К)] как функция величин: температура t [K], степень сухости x [-]:

    wspSSTX(t, x)

  56. Удельная энтальпия в двухфазной области [Дж/кг] как функция величин: температура t [K], степень сухости x [-]:

    wspHSTX(t, x)

  57. Удельная изобарная теплоемкость (Cp) в двухфазной области [Дж/(кг·К)] как функция величин: температура t [K], степень сухости x [-]:

    wspCPSTX(t, x)

  58. Удельная изохорная теплоемкость (Cv) в двухфазной области [Дж/(кг·К)] как функция величин: температура t [K], степень сухости x [-]:

    wspCVSTX(t, x)

  59. Скорость звука в двухфазной области [м/с] как функция величин: температура t [K], степень сухости x [-]:

    wspWSTX(t, x)

  60. Коэффициент теплопроводности в двухфазной области [Вт/(м·K)] как функция величин: температура t [K], степень сухости x [-]:

    wspTHERMCONDSTX(t, x)

  61. Динамическая вязкость в двухфазной области [Па·с] как функция величин: температура t [K], степень сухости x [-]:

    wspDYNVISSTX(t, x)

  62. Число Прандтля в двухфазной области [-] как функция величин: температура t [K], степень сухости x [-]:

    wspPRANDTLESTX(t, x)

  63. Кинематическая вязкость в двухфазной области [м2/с] как функция величин: температура t [K], степень сухости x [-]:

    wspKINVISSTX(t, x)

  64. Коэффициент изоэнтропы в двухфазной области [-] как функция величин: температура t [K], степень сухости x [-]:

    wspKSTX(t, x)

  65. Степень сухости [-] как функция величин: температура t [K], удельный объем v [м3/кг]:

    wspXSTV(t, v)

  66. Степень сухости [-] как функция величин: температура t [K], удельная внутренняя энергия u [Дж/кг]:

    wspXSTU(t, u)

  67. Степень сухости [-] как функция величин: температура t [K], удельная энтропия s [Дж/(кг·К)]:

    wspXSTS(t, s)

  68. Степень сухости [-] как функция величин: температура t [K], удельная энтальпия h [Дж/кг]:

    wspXSTH(t, h)

  69. Степень сухости [-] как функция величин: температура t [K], удельная изобарная теплоемкость (Cp) Cp [Дж/(кг·К)]:

    wspXSTCP(t, Cp)

  70. Степень сухости [-] как функция величин: температура t [K], удельная изохорная теплоемкость (Cv) Cv [Дж/(кг·К)]:

    wspXSTCV(t, Cv)

  71. Степень сухости [-] как функция величин: температура t [K], скорость звука w [m/с]:

    wspXSTW(t, w)

  72. Степень сухости [-] как функция величин: температура t [K], коэффициент теплопроводности tc [Вт/(м·K)]:

    wspXSTTHERMCOND(t, tc)

  73. Степень сухости [-] как функция величин: температура t [K], динамическая вязкость dv [Па·с]:

    wspXSTDYNVIS(t, dv)

  74. Степень сухости [-] как функция величин: температура t [K], кинематическая вязкость kv [м2/с]:

    wspXSTKINVIS(t, kv)

  75. Степень сухости [-] как функция величин: температура t [K], число Прандтля pr [-]:

    wspXSTPRANDTLE(t, pr)

  76. Степень сухости [-] как функция величин: температура t [K], коэффициент изоэнтропы k [-]:

    wspXSTK(t, k)

  77. Давление на линии между областями 2 и 3 [Па] как функция величин: температура t [K]:

    wspP23T(t)

  78. Температура на линии между областями 2 и 3 [K] как функция величин: давление p [Па]:

    wspT23P(p)

  79. Область параметров Формуляции IF-97 как функция величин: давление p [Па], температура t [K]:

    wspWATERSTATEAREA(p, t)

  80. Область параметров Формуляции IF-97 (версия 2) как функция величин: давление p [Па], температура t [K]:

    wspWATERSTATEAREA2(p, t)

  81. Коэффициент теплопроводности [Вт/(м·K)] как функция величин: плотность r [кг/м3], температура t [K]:

    wspTHERMCONDRT(r, t)

  82. Динамическая вязкость [Па·с] как функция величин: плотность r [кг/м3], температура t [K]:

    wspDYNVISRT(r, t)

  83. Удельный объем в области 1 [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspV1PT(p, t)

  84. Удельная внутренняя энергия в области 1 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspU1PT(p, t)

  85. Удельная энтропия в области 1 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspS1PT(p, t)

  86. Удельная энтальпия в области 1 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspH1PT(p, t)

  87. Удельная изобарная теплоемкость (Cp) в области 1 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [К]:

    wspCP1PT(p, t)

  88. Удельная изохорная теплоемкость (Cv) в области 1 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCV1PT(p, t)

  89. Скорость звука в области 1 [м/с] как функция величин: давление p [Па], температура t [K]:

    wspW1PT(p, t)

  90. Удельный объем в области 2 [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspV2PT(p, t)

  91. Удельная внутренняя энергия в области 2 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspU2PT(p, t)

  92. Удельная энтропия в области 2 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspS2PT(p, t)

  93. Удельная энтальпия в области 2 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspH2PT(p, t)

  94. Удельная изобарная теплоемкость (Cp) в области 2 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCP2PT(p, t)

  95. Удельная изохорная теплоемкость (Cv) в области 2 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCV2PT(p, t)

  96. Скорость звука в области 2 [м/с] как функция величин: давление p [Па], температура t [K]:

    wspW2PT(p, t)

  97. Давление в области 3 [Па] как функция величин: плотность r [кг/м3], температура t [K]:

    wspP3RT(r, t)

  98. Плотность в области 3 [кг/м3] как функция величин: давление p [Па], температура t [K], начальная плотность r0 [кг/м3]:

    wspR3PTR0(p, t, r0)

  99. Плотность в области 3 [кг/м3] как функция величин: давление p [Па], температура t [K]:

    wspR3PT(p, t)

  100. Удельная внутренняя энергия в области 3 [Дж/кг] как функция величин: плотность r [кг/м3], температура t [K]:

    wspU3RT(r, t)

  101. Удельная энтропия в области 3 [Дж/(кг·К)] как функция величин: плотность r [кг/м3], температура t [K]:

    wspS3RT(r, t)

  102. Удельная энтальпия в области 3 [Дж/кг] как функция величин: плотность r [кг/м3], температура t [K]:

    wspH3RT(r, t)

  103. Удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)] как функция величин: плотность r [кг/м3], температура t [K]:

    wspCP3RT(r, t)

  104. Удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)] как функция величин: плотность r [кг/м3], температура t [K]:

    wspCV3RT(r, t)

  105. Скорость звука в области 3 [м/с] как функция величин: плотность r [кг/м3], температура t [K]:

    wspW3RT(r, t)

  106. Удельный объем в области 3 [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspV3PT(p, t)

  107. Удельная внутренняя энергия в области 3 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspU3PT(p, t)

  108. Удельная энтропия в области 3 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspS3PT(p, t)

  109. Удельная энтальпия в области 3 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspH3PT(p, t)

  110. Удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCP3PT(p, t)

  111. Удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCV3PT(p, t)

  112. Скорость звука в области 3 [м/с] как функция величин: давление p [Па], температура t [K]:

    wspW3PT(p, t)

  113. Удельный объем в области 5 [м3/кг] как функция величин: давление p [Па], температура t [K]:

    wspV5PT(p, t)

  114. Удельная внутренняя энергия в области 5 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspU5PT(p, t)

  115. Удельная энтропия в области 5 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspS5PT(p, t)

  116. Удельная энтальпия в области 5 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

    wspH5PT(p, t)

  117. Удельная изобарная теплоемкость (Cp) в области 5 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCP5PT(p, t)

  118. Удельная изохорная теплоемкость (Cv) в области 5 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

    wspCV5PT(p, t)

  119. Скорость звука в области 5 [м/с] как функция величин: давление p [Па], температура t [K]:

    wspW5PT(p, t)

  120. Устанавливает и возвращает режим ведения проверки диапазона аргументов функций как функция величин: mode mode:

    wspSETCHECKRANGEMODE(mode)

  121. Режим ведения проверки диапазона аргументов функций:

    wspGETCHECKRANGEMODE()

  122. Устанавливает и возвращает код последней ошибки как функция величин: код ошибки ErrCode:

    wspSETLASTERROR(ErrCode)

  123. Код последней ошибки:

    wspGETLASTERROR()

  124. Устанавливает и возвращает максимальную разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K] как функция величин: разность температур delta [K]:

    wspSETDELTATS(delta)

  125. Максимальная разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K]:

    wspGETDELTATS()

  126. Устанавливает и возвращает максимальное число итераций в методе Ньютона как функция величин: максимальное число итераций maxiteration:

    wspSETMAXITERATION(maxiteration)

  127. Максимальное число итераций в методе Ньютона:

    wspGETMAXITERATION()

  128. Устанавливает и возвращает максимальную разность между значениями давлений при вычислении параметров в области 3 [Па] как функция величин: разность давлений delta [Па]:

    wspSETDELTAPRESSURE(delta)

  129. Максимальная разность между значениями давлений при вычислении параметров в области 3 [Па]:

    wspGETDELTAPRESSURE()

  130. Устанавливает и возвращает начальное приближение плотности воды в области 3 [кг/м3] как функция величин: плотность r [кг/м3]:

    wspSETINITWATERDENSITY(r)

  131. Начальное приближение плотности воды в области 3 [кг/м3]:

    wspGETINITWATERDENSITY()

  132. Устанавливает и возвращает начальное приближение плотности пара в области 3 [кг/м3] как функция величин: плотность r [кг/м3]:

    wspSETINITSTEAMDENSITY(r)

  133. Начальное приближение плотности пара в области 3 [кг/м3]:

    wspGETINITSTEAMDENSITY()


Список устаревших функций WaterSteamPro

  1. Максимальная разность между значениями давлений при вычислении параметров в области 3 [Па]:

    wspGETDELTAPRESSURE()

  2. Максимальная разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K]:

    wspGETDELTATS()

  3. Начальное приближение плотности пара в области 3 [кг/м3]:

    wspGETINITSTEAMDENSITY()

  4. Начальное приближение плотности воды в области 3 [кг/м3]:

    wspGETINITWATERDENSITY()

  5. Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационное код key:

    wspLOCALREGISTRATION(name, key)

  6. Устанавливает и возвращает максимальную разность между значениями давлений при вычислении параметров в области 3 [Па] как функция величин: разность давлений delta [Па]:

    wspSETDELTAPRESSURE(delta)

  7. Устанавливает и возвращает максимальную разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K] как функция величин: разность температур delta [K]:

    wspSETDELTATS(delta)

  8. Устанавливает и возвращает начальное приближение плотности пара в области 3 [кг/м3] как функция величин: плотность r [кг/м3]:

    wspSETINITSTEAMDENSITY(r)

  9. Устанавливает и возвращает начальное приближение плотности воды в области 3 [кг/м3] как функция величин: плотность r [кг/м3]:


История создания WaterSteamPro

Что нового в WaterSteamPro 6.5

  1. Увеличена область определения функций для расчета свойств воды/водяного пара до 50 МПа при температурах от 800°C до 2000°C (раньше было до 10 МПа). Изменения основаны на новых уравнениях от МАСВП (IAPWS - http://www.iapws.org)
  2. Добавлены функции для вычисления производной (d density / d pressure)enthalpy по уравнениям IF-97 в однофазной и двухфазной областях.
  3. Добавлены функции для вычисления производной (d density / d enthalpy)pressure по уравнениям IF-97 в однофазной и двухфазной областях.
  4. Добавлены функции для вычисления плотности воды/водяного пара по уравнениям IF-97.
  5. Добавлены функции для расчета диэлектрической проницаемости воды/водяного пара.
  6. Добавлены функции для расчета ионного произведения воды.
  7. Добавлены функции для расчета коэффициента преломления воды.
  8. Добавлена функция для расчета набора свойств (включая производные) в метастабильной области.
  9. Функции для расчета вязкости (и основанные на них функции) теперь используют новые уравнения от МАСВП (IAPWS - http://www.iapws.org).
  10. Внесены изменения в работу "нефизических" функций (например, wspCPSTX(t, x) - изобарная теплоемкость в двухфазной области). Теперь они (или функции их использующие при определенных параметрах - например, wspCPPH(p, h) - изобарная теплоемкость, как функция давления и энтальпии) работают только при отключенном режиме проверки на диапазон (см. функции wspSETCHECKRANGEMODE(mode) и wspGETCHECKRANGEMODE()).
  11. Внесены изменения в модуль проверки на диапазон входных данных. Теперь проверки при различных вариантах входных параметров ([p, t]; [p, h]; [p, s]; [h, s]) осуществляются более строго и с более высокой скоростью.
  12. Внесены изменения для правильной работы отдельных составляющих WaterSteamPro в Windows Vista/7.
  13. Программа WaterSteamPro теперь полностью поддерживает 32-х и 64-битные версии Windows (от Windows 98 до Windows 7 и более старшие версии).
  14. Модуль для Excel теперь поддерживает как 32-х, так и 64-битные версии Microsoft Excel (от Microsoft Office 97 до Microsoft Office 2010 и более старшие версии).
  15. Добавлены модули для использования функций WaterSteamPro в MATLAB (32-х и 64-битные версии). Эти модули не включены в состав пакета установки WaterSteamPro и могут быть скачаны с сайта WaterSteamPro: http://www.wsp.ru.
  16. Добавлены модули для использования функций WaterSteamPro в Scilab (32-х и 64-битные версии). Эти модули не включены в состав пакета установки WaterSteamPro и могут быть скачаны с сайта WaterSteamPro: http://www.wsp.ru.
  17. В состав поставки включен рабочий документ Microsoft Excel: "WaterSteamPro Excel Calculator", который позволяет быстро и легко производить расчеты свойств воды/водяного пара в Excel.
  18. В Microsoft Excel теперь работают функции, возвращающие несколько значений. Возврат значений осуществляется в виде массива. Дополнительная информация приведена в документации к программе в справке о функции. Пример использования функций, возвращающих массив приведен в файле WSP Excel Calculator.
  19. Решена проблема отображения справки по функциям WaterSteamPro в Mathcad 12 и выше. В предыдущих версиях Mathcad справка не отображалась.
  20. Внесены изменения в Active-X объект. Теперь при его использовании настройки индивидуальны для каждого экземпляра объекта. Ранее настройки были общими для всего приложения, использующего WaterSteamPro.
  21. Добавлена поддержка 64-битной версии Active-X объекта.
  22. Предыдущее изменение позволило создать Интернет-ресурс http://www.wsp.ru/ru/test, который позволяет вызвать любую из функций WaterSteamPro в он-лайн режиме без предварительной установки программы.
  23. Изменена область определения функций для расчета свойств воды - теперь расчет проводится до линии плавления (ранее расчет проводился до температуры 273.15 К).
  24. В диалоге "Вставка функции" в Mathcad добавлена информация о возможности использования размерных функций WaterSteamPro.
  25. Добавлена единица измерения "кПа" в программу "WSP Calculator".
  26. Исправлена ошибка в программе установки, которая связана с неправильной установкой документов для Mathcad в случае, если конечная папка для документов не существовала.
  27. Внесены изменения в программу установки.
  28. Внесены изменения в документацию.
  29. Изменен механизм регистрации.
  30. Это последняя версия программы WaterSteamPro, которая поддерживает Windows 9x/Me. Следующие версии будут поддерживать только Windows 2000 и выше.

Что нового в версии 6.0

  1. Добавлены функции для вычислений свойств в зависимости от переменных (h, s) для всех областей Формуляции IF-97.
  2. Добавлены функции для ускорения вычислений свойств в третьей области Формуляции IF-97 в зависимости от переменных (p, h), (p, s).
  3. Добавлены функции для вычислений исходных свойств областей №№ 1, 2, 3, 5 Формуляции IF-97 в зависимости от переменных (r, h).
  4. Добавлены функции для расчета примерных значений плотности на линии насыщения для воды и пара (wspROUSGHRSWT(t), wspROUGHRSST(t)).
  5. Добавлены функции для расчета примерных значений удельной энтальпии на линии насыщения для воды и пара (wspROUGHHSWS(s), wspROUGHHSSS(s)) в зависимости от удельной энтропии.
  6. Добавлены функции для вычисления лучшего начального приближения в третьей области при определении плотности по давлению и температуре, а также изменен механизм поиска решения в этой области. Это значительно ускорило поиск плотности по давлении и температуре (по моим данным, в 3 - 5 раз).
  7. Добавлены функции для расчета давлений на линии сублимации и линии плавления.
  8. Изменен механизм определения граничных значений и точности расчетов. В связи с этим часть функций устарела и более не используется.
  9. Добавлены функции для расчета термодинамических свойств 11-ти, входящих в состав воздуха и продуктов сгорания, газов и смесей на их основе в диапазоне температур от 200 до 2500К. Газы и их смеси рассматриваются как идеальные.
  10. Добавлены примеры использования функций для расчета свойств газов в пакетах Excel и Mathcad.
  11. Добавлен пример использования функций WaterSteamPro в Maple.
  12. Добавлен документ интеграции функций WaterSteamPro в Maple.
  13. Переписана программа WaterSteamPro Calculator. В нее добавлены новые возможности.
  14. Полностью переписан модуль для использования WaterSteamPro в Excel (по технологии xll).
  15. Решен вопрос о показе справки о функции WaterSteamPro в Microsoft Excel.
  16. В комплект поставки добавлена программа "WaterSteamPro Updater", которая позволяет быстро и удобно осуществлять проверку на наличие новых версий программы WaterSteamPro.
  17. Решена проблема с использованием функций WaterSteamPro в пакете Mathcad 12. Дополнительная информация приведена в разделе "Использование WaterSteamPro в Mathcad".
  18. Исправлены ошибки при вычислении функций wspJOULETHOMPSON2PT(p, t), wspCPMSPT(p, t), wspJOULETHOMPSON5PT(p, t), wspVUSHCVWDERPT5PT(p, t), wspPT5RH(r, h), wspPT5HS(h, s).
  19. Добавлена поддержка на проверку диапазона исходных данных для двухфазной области.
  20. Переписан инсталлятор с использованием новой программы. Старая программа (IS 5.1) "отказалась" создавать установочную программу.
  21. Практически заново переписан весь механизм вычислений функций. В связи с этим и другими причинами, главная библиотека пакета WaterSteamPro называется OKAWSP6.DLL.
  22. Внесены изменения в документацию.
  23. Изменен механизм регистрации.

Что нового в версии 5.6

  1. Программа WaterSteamPro рекомендована Департаментом генеральной инспекции по эксплуатации электрических станций и сетей Российского акционерного общества энергетики и электрификации "ЕЭС России" для использования в энергетике (информационное письмо № ИП-14-27-2001 от 03.08.2001).
  2. Значительное ускорение времени счета функций. Это явилось результатом специализированного подхода к вычислениям функций. Примерное ускорение счета функций приведено здесь.
  3. Добавлено 8 новых функций для комлексного вычисления свойств, что позволяет ускорить время расчета нескольких свойств в одной точке. Помимо этого, новые функции позволяют вычислять производные основых свойств по давлению и температуре. Список новых функций приведен здесь.
  4. Добавлена функция wspDPDTST для вычисления производной давления на линии насыщения по температуре насыщения.
  5. Значительная переработка вычислений свойств в двухфазной области.
  6. Добавлено 2 новые функции для вычисления изохорной теплоемкости на линии насыщения со стороны двухфазной области. Эти функции позволяют правильно, с точки зрения термодинамики, рассчитывать следующие свойства в двухфазной области: изохорная теплоемкость, коэффициент изоэнтропы, скорость звука. Список новых функций приведен здесь.
  7. Функция wspCVSTX теперь использует функции, упомянутые выше, которые учитывают скачок значения изохорной теплоемкости на линии насыщения. Это привело к тому, что эта функция была удалена из разряда "нефизических".
  8. Функция wspKSTX теперь использует функции, упомянутые выше, которые учитывают скачок значений свойств при переходе из однофазной области в двухфазную. Это привело к тому, что эта функция была удалена из разряда "нефизических".
  9. Функция wspWSTX теперь использует функции, упомянутые выше, которые учитывают скачок значений свойств при переходе из однофазной области в двухфазную. Это привело к тому, что эта функция была удалена из разряда "нефизических", хотя значение, возвращаемое функцией, не учитывает структуры потока.
  10. Коэффициент Джоуля-Томсона в двухфазной области (функция wspJOULETHOMPSONSTX) теперь вычисляется согласно термодинамическим представлениям: JT = (dt/dp)h=const, а не через степень сухости (как было в предыдущих версиях). Это привело к тому, что эта функция была удалена из разряда "нефизических".
  11. В документацию программы добавлен поиск.

Что нового в версии 5.5

  1. Программе WaterSteamPro Госстандартом России (http://www.gost.ru) выдано Свидетельство № АК-35/4 от 16.04.2001 о том, что программа WaterSteamPro воспроизводит величины, соответствующие данным, рекомендованным Государственной службой стандартных справочных данных (ГСССД Р-776-98) и уравнениям the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam.
  2. Добавлено 13 новых функций для вычисления свойств метастабильного переохлажденного пара. Список новых функций приведен здесь.
  3. Поддержка новых функций введена в программу WaterSteamPro Calculator.
  4. Небольшие улучшения в коде функций. Скорость вычислений всех функций повысилась.
  5. Большие изменения в примерах для Mathcad. Они теперь занимают меньше места и выглядят по-новому.
  6. Все примеры для Mathcad переименованы в формат 8.3 и теперь устанавливаются в подпапку "WaterSteamPro" папки "Мои документы".
  7. Переписан код обслуживания регистрации. Это не затрагивает зарегистрированных пользователей и они не нуждаются в новом регистрационном коде.
  8. Файл "Системы единиц.mcd" для унификации теперь переименован в файл "wspunits.mcd". Старый файл "Системы единиц.mcd" включен только из соображений совместимости и может отсутствовать в следующих версиях.
  9. Внесены мелкие изменения в документацию.

Что нового в версии 5.4

  1. Программе WaterSteamPro Госстандартом России (http://www.gost.ru) выдано Свидетельство № АК-35/4 от 16.04.2001 о том, что программа WaterSteamPro воспроизводит величины, соответствующие данным, рекомендованным Государственной службой стандартных справочных данных (ГСССД Р-776-98) и уравнениям the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam.
  2. Добавлено 16 новых функций для вычисления свойств в процессах расширения/сжатия в двухфазной области. Список новых функций приведен здесь.
  3. В WaterSteamPro теперь введена полная поддержка вычислений процессов расширения/сжатия в двухфазной области.
  4. Добавлено три примера использования функций расчета процессов расширения/сжатия в Mathcad. По умолчанию они устанавливаются в папку "Мои документы".
  5. Небольшое улучшение в программе WSP Calculator.
  6. Изменения в механизме регистрации.

Что нового в версии 5.3

  1. Добавлено 14 новых функций для вычисления свойств в процессах расширения/сжатия. Список новых функций приведен здесь.
  2. Изменены условия регистрации, подробности изменения приведены в разделе F.A.Q..
  3. Исправлен файл watersteampro.mcd для работы с бета-версией пакета Mathcad 2001.

Что нового в версии 5.2

  1. Добавлено 59 новых функций, в том числе теплофизические свойства с аргументами: давление и энтальпия/энтропия. Список новых функций приведен здесь. Также обновленно описание всех функций.
  2. Добавлены функции для вычисления коэффициента Джоуля-Томсона.
  3. В комплект поставки включены файлы для Delphi: пример использования WaterSteamPro в Delphi и модуль с описанием всех функций. Дополнительная информация приведена здесь.
  4. В документацию добавлен разделы: FAQ, список функций по версиям.
  5. Внутренняя структура главной библиотеки в этой версии очень сильно изменена. Если возникли какие-либо сложности, либо непонятные ошибки просьба обратиться к Константину Орлову (orlov@twt.mpei.ac.ru).
  6. Существенно переработана документация.
  7. В файл-надстройку для Microsoft Excel добавлено описание функций. Теперь при вставке функции в рабочий документ через "Мастер Функций" выводится краткая информация о функции, ее аргументах и возвращаемом результате.
  8. В Mathcad при вставке функции в рабочий документ через "Мастер Функций" краткая информация о функции теперь приведена на русском языке.
  9. Внесены изменения в инсталлятор.
  10. Исправлена ошибка в программе WSP Calculator: значение Коэффициента Поверхностного Натяжения при размерности мН/м было в 10 раз больше правильного. При других размерностях результат был правильным.
  11. Исправлена незначительная ошибка в библиотеке OKAWSP5.DLL: при отключении проверки на диапазон значений аргументов с помощью функции wspSETCHECKRANGEMODE и при возникновении ошибки в вычислениях с плавающей запятой в какой-либо функции (функция вернет значение - признак ошибки - равное -1), функция wspGETLASTERROR могла возвращать код равный нулю (ошибки нет).

Что нового в версии 5.1

  1. Добавлена функция wspGETLASTERRORDESCRIPTION(), возвращающая описание ошибки.
  2. Переделана программа "WaterSteamPro Calculator".
  3. Исправлена ошибка в функции wspXSTH(T, H), которая не возвращала значение степени сухости по температуре и энтальпии.
  4. Внесены изменения в файл-надстройку для Microsoft Excel, которая устанавливается теперь в каталог MS Excel.
  5. Переделан инсталлятор.
  6. Внесены изменения в документацию.

Что нового в версии 5.0

  1. Все функции переписаны на язык C++ и скомпонованы в динамически линкуемую библиотеку (DLL).
  2. Скорость вычислений в пакете Mathcad увеличилась в среднем на порядок (в 8 – 14 раз) по сравнению со старыми версиями.
  3. Стало возможным использование пакета "WaterSteamPro" в других программах.
  4. В комплект поставки входит программа "WaterSteamPro Calculator" для расчета свойств воды и водяного пара в среде Microsoft Windows вместе с исходными текстами.
  5. Также поставляются примеры использования "WaterSteamPro" в Microsoft Visual Basic, Microsoft Excel и даже Windows Scripting Host.
  6. Добавлены новые функции для расчета свойств воды и водяного пара (см. "Список функций для расчета свойств воды и водяного пара").
  7. Из соображений унификации все функции получили новые имена (несовместимость с версиями "WaterSteamPro" ниже 5.0).
  8. Появился инсталлятор.


F.A.Q.

F.A.Q. (Часто Задаваемые Вопросы)

Q: Чем WaterSteamPro отличается от других программ?

Q: Что означает зарегистрировать программу?

Q: Какова продолжительность персональной регистрации?

Q: Что такое переохлажденный пар?

Q: Как в рабочих документах Mathcad программы WaterSteamPro используются градуса Цельсия?

Q: Как в Mathcad 11 подключить описания функций пакета WaterSteamPro при отсутствии их описания в диалоге "Вставка функции"?

Q: Почему в WaterSteamPro 6.0 нет функций для перебора компонентов смеси газов

Ответы

вверх

Q: Чем WaterSteamPro отличается от других программ?

A: В качестве исходных уравнений в WaterSteamPro взяты уравнения Формуляции-97 Международной Ассоциации по Свойствам Воды и водяного Пара (http://www.iapws.org). Данная система уравнений была разработана с целью замены более старой Формуляции от 1967 г., на которой основано большинство на текущий момент программ. При разработке новой Формуляции ставилась цель увеличить скорость и точность расчетов (при использовании вычислительной техники), поэтому новая Формуляция более точно передает значения в промежуточных точках скелетной таблицы свойств воды и водяного пара и к тому же расчет производится быстрее. В WaterSteamPro введена дополнительная надстройка над исходными уравнениями Формуляции-97, которая позволяет рассчитывать свойства независимо от области состояния воды.

Следующая особенность пакета WaterSteamPro в том, что Вы можете обращаться к его функциям из различных программ (например Mathcad, C/C++, Delphi, Basic, JavaScript/VBScript, HTML-страницы). При этом названия функций, их аргументы и возвращаемые результаты будут совпадать. .

вверх

Q: Что означает зарегистрировать программу?

A: При регистрации программы Вы получаете свой уникальный регистрационный ключ, который по лицензии только Вы имеете право использовать. Дополнительная информация о регистрации приведена здесь.

вверх

Q: Какова продолжительность персональной регистрации?

A: Регистрация распространяется на текущую версию WaterSteamPro или до смены регистрационного ключа. Зарегистрированные пользователи смогут получать регистрацию на новую версию со скидкой.

вверх

Q: Что такое переохлажденный пар?

A: Это состояние существует при определенных условиях: дело в том, что обычно процесс конденсации начинается на различных мелких частицах (например пыли), т.н. центрах конденсации, которые при интенсивном отводе тепла довольно быстро "обрастают" каплями влаги. Однако существуют случаи, когда таких центров конденсации очень-очень мало, а процесс конденсации протекает относительно медленно. В этом случае происходит переохлаждение пара - температура пара меньше, чем температура насыщения при давлении пара. При резком изменении условий (например взбалтывании сосуда с переохлажденным паром) происходит резкая конденсация пара по всему объему.

Обратный эффект - перегретая жидкость (температура жидкости больше, чем температура насыщения при давлении жидкости) - используется, например, в камере Вильсона, в которой регистрируются пузырьки пара, образовавшиеся при прохождении субмолекулярных частиц через перегретую жидкость. При этом, о размере и импульсе частицы можно судить по паровому следу, который виден на делаемой фотографии.

вверх

Q: Как в рабочих документах Mathcad программы WaterSteamPro используются градуса Цельсия?

A: Это довольно хитрая штука. Дело в том, что шкала Цельсия - не абсолютная шкала и поэтому просто определить в Mathcad градус Цельсия как другие размерности (см. файл wspunits.mcd) нельзя. Для работы с градусом Цельсия в пакете WaterSteamPro используется следующий подход:

1. ВСЕ значения переменных хранятся в градусах Кельвина (т.е. абсолютной шкале). Градусы Цельсия используются только при вводе или выводе.

2. Для ввода градуса Цельсия (с автоматическим пересчетом в градусы Кельвина) используется функция (определенная в файле wspunits.mcd) с именем "°C" (градус вводится как: Alt+0176: при нажатой клавише Alt набирается на цифровой группе клавиш (на клавиатуре слева) число 0176; а "C" - английская). Эта функция достаточно проста, ее формула выглядит как: °C(x) = (x + 273.15) * K. Если непосредственно использовать в Mathcad такую функцию, то ее вызов будет выглядеть как: t = °C(20), что, согласитесь, не очень "хорошо" выглядит. Поэтому для ввода используется т.н. постфиксный оператор (он находится на закладке "Evaluation" в Mathcad 2001 и выглядит как "x f"). При этом вышеприведенный оператор ввода выглядит так: t = 20 °C, что выглядит как в общепринятой нотации.

3. Для вывода температуры в градусах Цельсия (т.е. осуществлении пересчета с градусов Кельвина на Цельсия) используется тот факт, что в английском алфавите для обозначения единицы измерения заряда (у нас кулон) используется буква "C". Поэтому в файле "wspunits.mcd" введена функция с именем " " (пробел), которая использует следующую формулу: (x) = (x/K - 273.15) * C При выводе температуры используется префиксный оператор (в пункте 2 - постфиксный), который позволяет выводить в нашем случае такое изображение: t = 20 С, где С - это кулон.

Для ввода имени функции " " используется специальный режим в Mathcad вставки спецсимволов. Для этого необходимо в режиме ввода формулы нажать сочетание клавиш Ctrl-Shift-K, при этом цвет формулы станет красным. Далее небходимо ввести имя, состоящее только из одного пробела, а после этого введенное имя можно копировать, вставлять и т.д., в том числе и в префиксный оператор.

вверх

Q: Как в Mathcad 11 подключить описания функций пакета WaterSteamPro при отсутствии их описания в диалоге "Вставка функции"?

A: Для решения этой проблемы необходимо проделать следующие:

1. В каталоге установки пакета Mathcad (обычно это папка с именем "C:\Program Files\MathSoft\Mathcad 11") есть каталог с именем "DOC". Далее в нем, в свою очередь, есть подкаталог с именем "Funcdoc". В последнем есть файл с именем "wspmcad.xml", который необходимо переименовать в файл "wspmcad_EN.xml".

вверх

Q: Почему в WaterSteamPro 6.0 нет функций для перебора компонентов смеси газов?

A: Дать этому объяснение не очень легко, но будет проще, если привести сначала пример.

Пусть будут определены функции для определения компонентов смеси: функция количества газов в смеси и функция, возвращающая, допустим, спецификацию компонента в смеси в зависимости от передаваемого индекса. Назовем эти функции wspgGETGASCOMPONENTSCOUNT(gas_spec) и wspgGETGSINDEX(gas_spec, index) соответственно. Примечание: будем рассматривать работу со спецификациями газов, чтобы было более наглядно, хотя аналогичные функции легко сделать и для идентификаторов газов.

Очень важно, что предназначением таких функций, скорее всего, будет использование их результатов для определения состава (объемного или массового) смеси газов с помощью встроенных в WaterSteamPro 6.0 функций wspgVFGSGS(gs_1, gs_2) и wspgMFGSGS(gs_1, gs_2).

Так, можно рассмотреть следующий сценарий (на некоем языке программирования), который производит заполнение массива x_gs[] объемными долями входящих в смесь газов (задаваемую спецификацией gs) компонентов:

gs = "..." // Здесь задается спецификация газа (смеси)
for i = 0 to wspgGETGASCOMPONENTSCOUNT(gs) - 1
    x_gs[i] = wspgVFGSGS(gs, wspgGETGSINDEX(gs, i))
end for

Такой код позволяет получить состав смеси газов. Он достаточно простой и не требует особых пояснений.

Представим себе, что мы имеем следующую спецификацию газа: "{H2O:1;CO2:1}:1;H2O:1". Для такой спецификации функция wspgGETGASCOMPONENTSCOUNT() вернет значение 2 (смесь состоит из двух газов: "H2O" и другой смеси).

При переборе компонентов первым будет, допустим (но это не обязательно), "H2O:1;CO2:1". Для этого компонента функция wspgVFGSGS() вернет значение 0.5, как и ожидалось.

Однако, для второго компонента - "H2O" результат, возвращаемый функцией wspgVFGSGS() будет отличным от ожидаемого: функция вернет значение 0.75. При суммировании 0.5 и 0.75 получится, что суммарное количество компонентов составляет 1.25, что неправильно, т.к. сумма долей компонентов должна быть равна 1.0.

Результат, возвращаемый функцией wspgVFGSGS(), равный 0.75 для "H2O" в данном случае, связан с алгоритмом работы функций для определения состава смесей газов.

Рассмотрим их работу более подробно на примере той же функции wspgVFGSGS(gs_1, gs_2), которая возвращает объемную долю газа, задаваемого спецификацией gs_2 в газе (смеси), задаваемого спецификацией gs_1.

Пусть у нас будет смесь gs_1 = "H2O:1;CO2:1", что означает смешение равных объемов "H2O" и "CO2". Тогда результат вызова функции wspgVFGSGS(gs_1, "H2O") будет равен 0.5, т.е. газ "H2O" по объему составляет половину от газа, задаваемого спецификацией gs_1. В этом случае результат, возвращаемый функцией ясен и не требует разъяснения.

Пусть у нас будет более сложная смесь gs_2 = "{H2O:1;CO2:1}:1;N2:1", т.е. смешение равных объемов "N2" и смеси, состоящей из равных объемов "H2O" и "CO2". В этом случае результат вызова функции wspgVFGSGS(gs_2, "H2O") будет равен 0.25: содержание "H2O" в "H2O:1;CO2:1" равно 0.5, а содержание "H2O:1;CO2:1" в gs_2 равно 0.5, что дает в итоге содержание "H2O" в gs_2 равное 0.25. Последнее означает, что функции определения доли компонентов "просматривают" вложенные смеси, определяя в итоге абсолютную долю газа в смеси.

Таким образом, при таком алгоритме работы функций для определения долей компонентов в смеси, создавать функции для перебора компонентов в смеси бессмысленно - использование их результатов будет приводить к ошибкам.

Гораздо более правильным, при текущем алгоритме работы функций для определения долей компонентов в смеси, является перебор всех базовых газов и определение доли каждого из них в смеси. Это можно сделать используя доступные в WaterSteamPro 6.0 функции. Следует однако помнить, что газы "AirMix" и "N2AirMix", в отличие от других встроенных газов, представляют собой смеси газов принятого состава.

Хотелось бы также отметить, что функции для перебора компонентов смеси были бы более нужны, если бы можно было создавать только одну смесь или смесь только из базовых газов (и нельзя было бы создавать смеси смесей). Однако в WaterSteamPro 6.0 можно создавать как несколько смесей газов одновременно, так и вложенные смеси.


Тестирование WaterSteamPro

Удельная изобарная теплоемкость

Пример вычислений свойств воды и водяного пара с использованием WaterSteamPro

Введите параметры состояния:

Давление:

Температура:

P = 100000 Па; T = 373.15 K

Рассчитанные свойства:

Удельный объем: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. м3/кг

Удельная внутренняя энергия: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. кДж/кг

Удельная энтальпия: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. кДж/кг

Удельная энтропия: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. Дж/(кг·K)

Удельная изобарная теплоемкость: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. Дж/(кг·K)

Удельная изохорная теплоемкость: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. Дж/(кг·K)

Скорость звука: error creating ActiveX object "WSP.WspCalculator". Please reinstall WaterSteamPro. м/с


Литература

1. Release on The IAPWS Formulation-1995 for the Thermodynamic Properties of Ordinary Water Substance for General and Scientific Use. International Association for the Properties of Water and Steam / Executive Secretary R.B. Dooley. Electric Power Research Institute. Palo Alto. CA 94304, USA.

2. IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam. International Association for the Properties of Water and Steam / Executive Secretary R.B. Dooley. Electric Power Research Institute. Palo Alto. CA 94304, USA.

3. Александров А.А. Система уравнений IAPWS-IF97 для вычисления термодинамических свойств воды и водяного пара в промышленных расчетах. 2. Дополнительные уравнения / Теплоэнергетика. 1998. № 10. С. 64 – 72.

4. Supplementary Release on Saturation Properties of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A143-149.

5. Release on The IAPS Formulation 1985 for the Viscosity of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A33-48.

6. Release on The IAPWS Formulation 1985 for the Thermal Conductivity of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A49-70.

7. Release on The Surface Tension of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A143-149.

8. А.А. Александров, Б.А. Григорьев - Таблицы теплофизических свойств воды и водяного пара. Справочник. Рек. Гос. службой стандартных справочных данных. ГСССД Р-776-98. – М.: Издательство МЭИ, 1999. – 168 с.: ил.

9. Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam (September 2004).

10. Supplementary Release on Backward Equations for the Functions T(p,h), v(p,h) and T(p,s), v(p,s) for the Critical and Supercritical Regions to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam (August 2003).

11. Supplementary Release on Backward Equations for Pressure as a Function of Enthalpy and Entropy p(h,s) to the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam (September 2001).

12. Ривкин С.Л. Термодинамические свойства газов. Справочник. - 4-е изд., перераб. М.: Энергоатомиздат, 1987. с. 288: ил.

13. Комплекс прикладных и учебных интерактивных программ для вычисления термодинамических свойств рабочих тел и теплоносителей / В.В. Сычев, А.А. Александров, А.В. Матвеев, И.В. Царев, З.А. Ершова //Известия вузов. Энергетика, 1990, № 9, 126 - 128.

14. Термодинамические свойства индивидуальных веществ. Справочное издание: в 4-х т./Л.В. Гурвич, И.В. Вейц, В.А. Медведев и др. 3-е изд., перераб. и расширен. Т.1. Кн. 2 М.: Наука, 1978. 328 с.

15. Release on the IAPWS Formulation-1995 for the Thermodynamic Properties of Ordinary Water Substance for General and Scientific Use. International Association for the Properties of Water and Steam / Executive Secretary R.B. Dooley. Electric Power Research Institute. Palo Alto. CA 94304, USA.

16. Cooper, J.R. Representation of the Ideal-Gas Thermodynamic Properties of Water. Int. J. Thermophys. 1982. V. 3. P.35 - 43.

17. Friedman A.S., Haar L. High Speed Machine Computing of Ideal Gas Thermodynamic Functions - I. Isotopic Water Molecules. J. Chem. Phys. 1954. V. 22. P. 2051 - 2058.

18. Vidler M., Tennyson J. Accurate partition function and thermodynamic data for water. Journal of Chemical Physics. Volume 113, Number 21. 1 December 2000.

19. Woolley, H.W., 1980, Thermodynamic Properties for H2O in the Ideal Gas State. Water and Steam: Their Properties and Current Industrial Application, Proceedings of the 9th International Conference on the Properties of Water and Steam, J. Straub and K. Scheffler, eds., Pergamon Press, New York, pp. 166 - 175.

20. Woolley, H.W., 1987, Ideal Gas Thermodynamic Functions for Water. J. Res. Natl. Bur. Stand., 92, pp.35 - 51.

21. Bucker, D., Span, R., Wagner, W. Thermodynamic Property Models for Moist Air and Combustion Gases. ASME Journal of Engineering for Gas Turbines and Power. Vol. 125 January 2003, pp. 374-384.

22. Woolley, H.W., 1954, Thermodynamic Functions for Carbon Dioxide in the Ideal Gas State, Journal of Research of the National Bureau of Standards, 52(6):289.

23. Диоксид углерода жидкий и газообразный. Плотность, фактор сжимаемости, энтальпия, энтропия, изобарная теплоемкость, скорость звука и коэффициент объемного расширения при температурах 220...1300 К и давлениях 0.1...100 МПа. Таблицы стандартных справочных данных. Изд-во стандартов, 1986 г.

24. Термодинамические свойства кислорода: ГСССД. Серия монографии / В.В. Сычев, А.А. Вассерман, А.Д. Козлов, Г.А. Спиридонов, В.А. Цымарный. М.: Изд-во стандартов, 1981., - 340 с., ил.

25. Термодинамические свойства азота. Сычев В.В. и др. М., Изд-во стандартов, 1977. с. 352.

26. Термодинамические свойства воздуха. / Сычев В.В., Вассерман А.А., Козлов А.Д., Спиридонов Г.А., Цымарный В.А. - ГСССД. Серия монографии. М.: Издательство стандартов, 1978. с. 276.

27. Набор программ для расчета теплофизических свойств воды и водяного пара ("WaterSteamPro"). РОСПАТЕНТ, Свидетельство № 2000610803 от 25 августа 2000 г.

28. IVTANTHERMO for Windows. Database on thermodynamic properties of individual substances and thermodynamic modeling software. V.S. Yungman at al. Version 3.0. Glushko Thermocenter of RAS. 1992-2003.

29. McBride, B.J., Gordon, S., 1996, Computer Program for Calculation of Complex Chemical Equilibrium Composition and Applications. NASA RP-1311, National Aeronautics and Space Administration, Washington, DC.

30. McBride, B.J., Gordon, S., 2003, Computer Program for Calculation of Complex Chemical Equilibrium Composition and Applications Version 2 (CEA2). NASA RP-1311, National Aeronautics and Space Administration, Washington, DC.

31. Guideline on the Use of Fundamental Physical Constants and Basic Constants of Water. The International Association for the Properties of Water and Steam (September 2001).

32. Guideline: Tabular Taylor Series Expansion (TTSE) Method for Calculation of Thermodynamic Properties of Water and Steam Applied to IAPWS-95 as an Example. International Association for the Properties of Water and Steam (August 2003).

33. IAPS Supplementary Release: Saturation Properties of Ordinary Water Substance. (September 1992).

34. IAPWS Release on the Values of Temperature, Pressure and Density of Ordinary and Heavy Water Substances at their Respective Critical Points (September 1992).

35. Jacobsen, R.T., Penoncello, S.G., Beyerlein, S.W., Clarke, W.P. and Lemmon, E.W. A Thermodynamic Property Formulation for Air. Fluid Phase Equilibria, 79:113-124, 1992.

36. Jacobsen, R.T., Stewart, R.B., and Jahangiri, M. Thermodynamic Properties of Nitrogen from the Freezing Line to 2000 K at Pressures to 1000 MPa. J. Phys. Chem. Ref. Data, 15(2):735-909, 1986.

37. Katti, R.S., Jacobsen, R.T., Stewart, R.B., and Jahangiri, M. Thermodynamic Properties for Neon for Temperatures from the Triple Point to 700 K at Pressures to 700 MPa. Adv. Cryo. Eng., 31: 1189-1197, 1986.

38. Kretzsehmar, H-J., St?cker, I., Willkommen, T., Tr?benback, J., Dittmann, A. Supplementary equations v(p, t) for the critical region to the new industrial formulation IAPWS-IF97 for water and steam. Steam, water and hydrothermal systems: Physics and chemistry Meeting the Needs of Industry. Proc. of the 13th International Conference on Properties of Water and Steam. NRC Research Press. Ottawa, 2000. p. 225 - 264.

39. McCarty, R.D. and Arp, V.D. A New Wide Range Equation of State for Helium. Adv. Cryo. Eng., 35:1465-1475, 1990.

40. McCarty, R.D. Hydrogen, Technological Survey - Thermophysical Properties. NASA SP-3089, National Aeronautics and Space Administration, 1975.

41. Periodic Table of the Elements at Los Alamos National Laboratory. http://periodic.lanl.gov/default.htm.

42. Release on the IAPWS Formulation-1995 for the Thermodynamic Properties of Ordinary Water Substance for General and Scientific Use. International Association for the Properties of Water and Steam / Executive Secretary R.B. Dooley. Electric Power Research Institute. Palo Alto. CA 94304, USA.

43. Release on the ion product of water substance. International Association for the Properties of Steam (May 1980).

44. Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance". The International Association for the Properties of Water and Steam (September 1993).

45. Revised Release on the IAPS Formulation 1985 for the Viscosity of Ordinary Water Substance. (August 2003).

46. Schmidt, R. and Wagner, W. A New Form of Equation of State for Pure Substances and Its Application to Oxygen. Fluid Phase Equilib., 19:175-200, 1985.

47. Setzmann, U. and Wagner, W. A New Equation of State and Tables of Thermodynamic Properties for Methane Covering the Range from the Melting Line to 625 K at Pressures up to 1000 MPa. J. Phys. Chem. Ref. Data, 20(6):1061-1151, 1991.

48. Span, R. and Wagner, W. A New Equation of State for Carbon Dioxide Covering the Fluid Region from the Triple-Point Temperature to 1100 K at Pressures up to 800 MPa. J. Phys. Chem. Ref. Data, 25(6):1509-1596, 1996.

49. Span, R., Lemmon, E.W., Jacobsen, R.T., Wagner, W., and Yokozeki, A., 2000, "A Reference Equation of State for the Thermodynamic Properties of Nitrogen for Temperature from 63.151 to 1000 K and Pressures up to 2200 MPa." J. Phys. Chem. Ref. Data, accepted for publication 29, pp. 1361 - 1433.

50. Stewart, R.B. and Jacobsen, R.T. Thermodynamic Properties of Argon from the Triple Point to 1200 K at Pressures to 1000 MPa. J. Phys. Chem. Ref. Data, 18(2):639-798, 1989.

51. Supplementary Release on Saturation Properties of Ordinary Water Substance. IAPWS / Proc. 12th Int, Conf. Prop. Water and Steam. H. White and J.V. Sengers, ed. Begell House. NY, 1995. P. A143-149.

52. Thermodynamic derivatives for water and steam. Solomon L. Rivkin, Aleksey A. Alexandrov, Elena A. Kremenevskaya. Washington, D.C., V.H. Winston & Sons, 1978. - 264 pp., ill.

53. Thermophysical Properties of Humid Air and Combustion-Gas Mixtures. The International Association for the Properties of Water and Steam (July 2002).

54. Александров А.А. Международное уравнение состояния воды и водяного пара / Теплоэнергетика. 1997. № 10. С. 68 - 72.

55. Александров А.А. Система уравнений IAPWS-IF97 для вычисления термодинамических свойств воды и водяного пара в промышленных расчетах. Ч. 1. Основные уравнения / Теплоэнергетика. 1998. № 9. С. 69 - 77.

56. Александров А.А. Система уравнений IAPWS-IF97 для вычисления термодинамических свойств воды и водяного пара в промышленных расчетах. Ч. 2. Дополнительные уравнения / Теплоэнергетика. 1998. № 10. С. 64 - 72.

57. Александров А.А., Орлов К.А., Очков В.Ф. Уравнения и программа для расчета свойств газов и продуктов сгорания / Теплоэнергетика, В печати.

58. Александров А.А., Орлов К.А., Очков В.Ф. Открытые расчеты в энергетике на базе Mathcad Application Server. В печати.

59. Воронец Д., Козич Д. Влажный воздух: термодинамические свойства и применение. Пер. с сербохорв. М.: Энергоатомиздат, 1984. с. 136.

60. Диоксид углерода жидкий и газообразный. Плотность, фактор сжимаемости, энтальпия, энтропия, изобарная теплоемкость, скорость звука и коэффициент объемного расширения при температурах 220:1300 К и давлениях 0.1:100 МПа. Таблицы стандартных справочных данных. Изд-во стандартов, 1986 г.

61. Комплекс прикладных и учебных интерактивных программ для вычисления термодинамических свойств рабочих тел и теплоносителей / В.В. Сычев, А.А. Александров, А.В. Матвеев, И.В. Царев, З.А. Ершова //Известия вузов. Энергетика, 1990, № 9, 126 - 128.

62. Метан жидкий и газообразный, термодинамические свойства, коэффициенты динамической вязкости и теплопроводности при температурах 91...700 К и давлениях 0.1...100 МПа. ГСССД / Козлов А.Д., Мамонов Ю.В., Роговин М.Д., Рыбаков С.И., Степанов С.А., Сычев В.В. М. 2000. 43 c.

63. Набор программ для расчета теплофизических свойств воды и водяного пара ("WaterSteamPro"). РОСПАТЕНТ, Свидетельство № 2000610803 от 25 августа 2000 г.

64. Орлов К.А., Александров А.А., Очков В.Ф., Кондакова Г.Ю., Очков А.В. Разработка современных программных средств для расчета термодинамических свойств воды и свойств водных растворов на основе системы уравнений ISF-95 // VIII Междунар. науч.-техн. конф. студентов и аспирантов: тез. докл. М.: Изд-во МЭИ, 2002. Т. 3. с. 183 - 185.

65. Орлов К.А., Александров А.А., Очков В.Ф., Очков А.В. Программный комплекс "WaterSteamPro" для расчета теплофизических свойств воды и водяного пара // Х Российская Конференция по Теплофизическим Свойствам Веществ: тезисы докладов. Казань: изд-во "Бутлеровские сообщения", 2002. С. 187 - 188.

66. Орлов К.А. Программа "WaterSteamPro" // Компьютерная математика, КомпьютерПресс, № 4'2001.

67. Орлов К.А. Теплофизические свойства воды и водяного пара в Mathcad Professional // Компьютерная математика, КомпьютерПресс, № 12'1999.

68. Очков В.Ф., Утенков В.Ф., Орлов К.А. Теплотехнические расчеты в среде Mathcad. //Теплоэнергетика, 2000. с. 73 - 78.

69. Очков В.Ф. Раздел 5.5.2. "Решение инженерно-технических задач в среде Mathcad" справочника "Теплоэнергетика и теплотехника" Кн.1. М.: Издательство МЭИ, 1999 - 522 с.: ил.

70. Сычев В.В. Новое уравнение для показателя адиабаты влажного пара. // Теплоэнергетика №3 , 1961. с. 67 - 70.

71. Теоретические основы теплотехники. Теплотехнический эксперимент: Справочник / Под общ. ред. чл.-корр. РАН А.В. Клименко и проф. В.М. Зорина. - 3-е изд., перераб. и доп. - М.: Изд-во МЭИ, 2001. - 564 с., ил. - (Теплоэнергетика и теплотехника; Кн. 2).

72. Теплофизические свойства технических важных газов при высоких температурах и давлениях. Справочник / В.Н. Зубарев, А.Д. Козлов, В.М. Кузнецов и др. М.: Энергоатомиздат, 1989. с. 232: ил.

73. Термодинамика парогазовых смесей: Учебное пособие / Г.А. Мухачев. Изд-во Казан. Гос. техн. ун-та. Казань, 1995. 67 с.

74. Орлов К.А. Исследование схем парогазовых установок с впрыском водяного пара в газовый тракт (ПГУ контактного типа) на основе разработанных прикладных программ по свойствам рабочих тел ПГУ // Диссертация на соискание степени кандидата технических наук, МЭИ, 2004.


WaterSteamPro Special Thanks

Мое отдельное спасибо

  • Для начала я хотел бы сказать огромное спасибо всем тем, кто зарегистрировал программу. Они помогли мне убедиться в том, что программа нужна и удобна для пользования. Ведь в самом начале она создавалась только для моего собственного использования и только спустя некоторое время превратилась в то, что Вы видите сейчас.
  • Во-вторых я хотел бы сказать спасибо David E. Baugh из Benham Electrosynthesis Company. Он до сих пор не утратил надежды исправить мой ужасный английский язык.
  • Отдельное спасибо Сергею Ивановичу Ивлюшкину за поддержку в создании WaterSteamPro. Благодаря ему появился раздел использования WaterSteamPro в Borland Delphi.
  • Спасибо Андрею Владимировичу Агееву за критическое отношение к документации. Благодаря ему в документации стало меньше ошибок (описание делается в спешке и поэтому допускаются ошибки, что не скажешь о самих функциях - прим. К.А. Орлова).
  • Мое специальное спасибо всем остальным авторам WaterSteamPro. Без Их помощи я бы не выпустил и первой версии программы.

С уважением,
Константин Орлов.


Copyrights & Trademarks

WaterSteamPro – зарегистрированная программа и торговая марка Московского Энергетического Института (технического университета).

Mathcad – зарегистрированная торговая марка MathSoft, Inc.

Microsoft, Microsoft Windows, Microsoft Visual Basic, Microsoft Visual Studio, Microsoft Visual C++, Microsoft Office, Visual Basic for Applications (VBA), Microsoft Excel – зарегистрированные торговые марки Microsoft Corp. Windows NT – зарегистрированная торговая марка Microsoft Corp.

Остальные имена и названия являются торговыми марками или зарегистрированными торговыми марками их владельцев.

Раздел "Описание Формуляции IF-97" практически полностью основан на книге: А.А. Александров, Б.А. Григорьев - Таблицы теплофизических свойств воды и водяного пара. Справочник. Рек. Гос. службой стандартных справочных данных. ГСССД Р-776-98. - М.: Издательство МЭИ, 1999. - 168 с.: ил.


Устаревшие и неиспользуемые функции WaterSteamPro

В пакете WaterSteamPro, начиная с версии 6.0, есть функции, которые больше не используются. Из соображений совместимости вхождения функций остались, однако при попытке обращения к ним генерируется ошибка с кодом 8 (см. список кодов ошибок WaterSteamPro).

Все эти функции помечены в перечне функций WaterSteamPro значком [image].

Список устаревших функций приведен здесь.


Ускорение счета функций в версии 5.6

В версии 5.6 значительно переработан механизм вычисления функций, что позволило значительно увеличить скорость вычисления функций. Далее приведен перечень базовых функций пакета WaterSteamPro с примерным ускорением счета функции.

Формат вывода: сначала идет имя функции, далее относительное время, занимаемое для вычисления контрольной точки в старой версии (версия 5.5) и на следующей строке - относительное время вычисления той же самой контрольной точки в новой версии (5.6).

Отсутствующие функции пакета WaterSteamPro, так или иначе, основаны на нижеприведенных функциях и, поэтому, тоже вычисляются быстрее.

wspV1PT

Old time: 7.170

New time: 3.314

wspU1PT

Old time: 14.330

New time: 3.575

wspS1PT

Old time: 7.531

New time: 3.665

wspH1PT

Old time: 7.561

New time: 3.274

wspCP1PT

Old time: 6.829

New time: 3.324

wspCV1PT

Old time: 19.828

New time: 4.076

wspW1PT

Old time: 21.270

New time: 3.915

wspT1PH

Old time: 3.715

New time: 2.373

wspT1PS

Old time: 3.725

New time: 2.383

wspJOULETHOMPSON1PT

Old time: 13.419

New time: 3.825

wspDYNVISRT

Old time: 4.477

New time: 2.944

wspV2PT

Old time: 8.852

New time: 4.176

wspU2PT

Old time: 18.216

New time: 4.997

wspS2PT

Old time: 14.981

New time: 4.596

wspH2PT

Old time: 9.774

New time: 4.556

wspCP2PT

Old time: 10.214

New time: 4.616

wspCV2PT

Old time: 26.888

New time: 4.947

wspW2PT

Old time: 25.576

New time: 4.977

wspT2APH

Old time: 7.090

New time: 3.425

wspT2BPH

Old time: 7.771

New time: 3.715

wspT2CPH

Old time: 4.546

New time: 2.473

wspT2APS

Old time: 8.963

New time: 6.529

wspT2BPS

Old time: 7.651

New time: 3.355

wspT2CPS

Old time: 5.488

New time: 2.523

wspJOULETHOMPSON2PT

Old time: 17.365

New time: 4.486

wspP3RT

Old time: 7.611

New time: 3.595

wspU3RT

Old time: 7.741

New time: 3.545

wspS3RT

Old time: 15.502

New time: 3.835

wspH3RT

Old time: 15.091

New time: 3.635

wspCP3RT

Old time: 22.372

New time: 4.046

wspCV3RT

Old time: 7.42

New time: 3.625

wspW3RT

Old time: 23.624

New time: 4.076

wspJOULETHOMPSON3RT

Old time: 22.993

New time: 4.066

wspT3PH

Old time: 7.000

New time: 0.881

wspT3PS

Old time: 19.778

New time: 2.473

wspV5PT

Old time: 9.654

New time: 12.177

wspU5PT

Old time: 8.181

New time: 4.797

wspS5PT

Old time: 8.543

New time: 4.867

wspH5PT

Old time: 5.177

New time: 4.646

wspCP5PT

Old time: 5.317

New time: 4.786

wspCV5PT

Old time: 10.885

New time: 5.237

wspW5PT

Old time: 10.996

New time: 5.337

wspT5PH

Old time: 4.706

New time: 2.443

wspT5PS

Old time: 4.767

New time: 2.533

wspJOULETHOMPSON5PT

Old time: 8.031

New time: 4.877

wspVMSPT

Old time: 12.468

New time: 11.386

wspUMSPT

Old time: 15.232

New time: 12.227

wspSMSPT

Old time: 15.001

New time: 12.187

wspHMSPT

Old time: 12.878

New time: 12.087

wspCPMSPT

Old time: 12.848

New time: 12.157

wspCVMSPT

Old time: 17.305

New time: 12.327

wspWMSPT

Old time: 17.365

New time: 12.387

wspJOULETHOMPSONMSPT

Old time: 15.071

New time: 12.147


wspCP1PT

Удельная изобарная теплоемкость (Cp) в области 1 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [К]:

wspCP1PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [К], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 1 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspCP2PT

Удельная изобарная теплоемкость (Cp) в области 2 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCP2PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 2 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspCP3PT

Удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCP3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)], тип: double.

Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.


wspCP3RT

Удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)] как функция величин: плотность r [кг/м3], температура t [K]:

wspCP3RT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 3 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspCP5PT

Удельная изобарная теплоемкость (Cp) в области 5 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCP5PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в области 5 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspCPEXPANSIONPTPEFF

Удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspCPEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspCPEXPANSIONPTXPEFF

Удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspCPEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspCPHS

Удельная изобарная теплоемкость [Дж/(кг·К)] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspCPHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость [Дж/(кг·К)], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspCPMSPT

Удельная изобарная теплоемкость (Cp) в метастабильной области [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCPMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в метастабильной области [Дж/(кг·К)], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspCPPH

Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspCPPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspCPPTX.


wspCPPS

Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspCPPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspCPPTX.


wspCPPT

Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCPPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspCPxPT).


wspCPPTX

Удельная изобарная теплоемкость (Cp) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspCPPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspCPxPT или wspCPSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspCPSST

Удельная изобарная теплоемкость (Cp) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

wspCPSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspCPSTX

Удельная изобарная теплоемкость (Cp) в двухфазной области [Дж/(кг·К)] как функция величин: температура t [K], степень сухости x [-]:

wspCPSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) в двухфазной области [Дж/(кг·К)], тип: double.

Данная функция использует функции wspCPSST и wspCPSWT, которые возвращают удельные изобарные теплоемкости пара и воды на линии насыщения. При вычислениях используется следующая формула: CPx = (1 - X)·CPw + X·CPs, где CPs = wspCPSST, CPw = wspCPSWT и X - степень сухости.


wspCPSWT

Удельная изобарная теплоемкость (Cp) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

wspCPSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость (Cp) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspCV1PT

Удельная изохорная теплоемкость (Cv) в области 1 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCV1PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 1 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspCV2PT

Удельная изохорная теплоемкость (Cv) в области 2 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCV2PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 2 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspCV3PT

Удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCV3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)], тип: double.

Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.


wspCV3RT

Удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)] как функция величин: плотность r [кг/м3], температура t [K]:

wspCV3RT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 3 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspCV5PT

Удельная изохорная теплоемкость (Cv) в области 5 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCV5PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в области 5 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspCVDPSST

Удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны двухфазной области [Дж/(кг·К)] как функция величин: температура t [K]:

wspCVDPSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны двухфазной области [Дж/(кг·К)], тип: double.

Функция возвращает сумму изохорной теплоемкости со стороны однофазной области (функция wspCVSST) и дополнительного приращения, рассчитываемого по термодинамическим соотношениям.


wspCVDPSWT

Удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны двухфазной области [Дж/(кг·К)] как функция величин: температура t [K]:

wspCVDPSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны двухфазной области [Дж/(кг·К)], тип: double.

Функция возвращает сумму изохорной теплоемкости со стороны однофазной области (функция wspCVSWT) и дополнительного приращения, рассчитываемого по термодинамическим соотношениям.


wspCVEXPANSIONPTPEFF

Удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspCVEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspCVEXPANSIONPTXPEFF

Удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspCVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspCVHS

Удельная изохорная теплоемкость [Дж/(кг·К)] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspCVHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspCVMSPT

Удельная изохорная теплоемкость (Cv) в метастабильной области [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCVMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в метастабильной области [Дж/(кг·К)], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspCVPH

Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspCVPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspCVPTX.


wspCVPS

Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspCVPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspCVPTX.


wspCVPT

Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspCVPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspCVxPT).


wspCVPTX

Удельная изохорная теплоемкость (Cv) [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspCVPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspCVxPT или wspCVSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspCVSST

Удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

wspCVSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) пара на линии насыщения со стороны однофазной области [Дж/(кг·К)], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspCVSTX

Удельная изохорная теплоемкость (Cv) в двухфазной области [Дж/(кг·К)] как функция величин: температура t [K], степень сухости x [-]:

wspCVSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) в двухфазной области [Дж/(кг·К)], тип: double.

Данная функция использует функции wspCVDPSST и wspCVDPSWT, которые возвращают удельные изохорные теплоемкости пара и воды на линии насыщения со стороны двухфазной области. При вычислениях используется следующая формула: CVx = (1 - X)·CVDPw + X·CVDPs, где CVDPs = wspCVDPSST, CVDPw = wspCVDPSWT и X - степень сухости. До версии 5.6 эта функция использовала функции wspCVSWT и wspCVSST, что, с точки зрения термодинамики, неверно, т.к. не учитывался скачок свойств на линии насыщения.


wspCVSWT

Удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)] как функция величин: температура t [K]:

wspCVSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость (Cv) воды на линии насыщения со стороны однофазной области [Дж/(кг·К)], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspD1PT

Плотность в области 1 [кг/м3] как функция величин: давление p [Па], температура t [K]:

wspD1PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – плотность в области 1 [кг/м3], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspD2PT

Плотность в области 2 [кг/м3] как функция величин: давление p [Па], температура t [K]:

wspD2PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – плотность в области 2 [кг/м3], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspD3PT

Плотность в области 3 [кг/м3] как функция величин: давление p [Па], температура t [K]:

wspD3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – плотность в области 3 [кг/м3], тип: double.

Функция рассчитывает плотность в области 3 с использованием функции wspR3PTR0 с соответствующими начальными приближениями для воды и пара. Используется для унификации функций в различных областях Формуляции IF-97.


wspD5PT

Плотность в области 5 [кг/м3] как функция величин: давление p [Па], температура t [K]:

wspD5PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – плотность в области 5 [кг/м3], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspDCPT

Диэлектрическая проницаемость воды [-] как функция величин: давление p [Па], температура t [K]:

wspDCPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – диэлектрическая проницаемость воды [-], тип: double.

Основана на функции wspDCRT(r, t), которая, в свою очередь, основана на "Release on the Static Dielectric Constant of Ordinary Water Substance for Temperatures from 238K to 873K and Pressures up to 1000 MPa", 1997 от IAPWS. Диапазон использования: при температурах от 238 до 273K для метастабильной жидкости при атмосферном давлении (101 325 Па), при температурах от 273 до 323 К - при давлениях до низшей точки плавления льда IV или 1000 МПа, свыше 323 К - при давлениях до 600 МПа. Используемые уравнения экстраполируются достаточно гладко до температур 1200К и давлений 1200 МПа.


wspDCRT

Диэлектрическая проницаемость воды [-] как функция величин: плотность r [кг/м3], температура t [K]:

wspDCRT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – диэлектрическая проницаемость воды [-], тип: double.

Основана на "Release on the Static Dielectric Constant of Ordinary Water Substance for Temperatures from 238K to 873K and Pressures up to 1000 MPa", 1997 от IAPWS. Диапазон использования: при температурах от 238 до 273K для метастабильной жидкости при атмосферном давлении (101 325 Па), при температурах от 273 до 323 К - при давлениях до низшей точки плавления льда IV или 1000 МПа, свыше 323 К - при давлениях до 600 МПа. Используемые уравнения экстраполируются достаточно гладко до температур 1200К и давлений 1200 МПа.


wspDDDHPPH

Производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspDDDHPPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspDDDHPxPT).


wspDDDHPPT

Производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5] как функция величин: давление p [Па], температура t [K]:

wspDDDHPPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspDDDHPxPT).


wspDDDHPPTX

Производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspDDDHPPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении воды/пара [кг·с2/м5], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspDDDHPxPT или wspDDDHPSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspDDDHPSST

Производная плотности по энтальпии при постоянном давлении пара на линии насыщения [кг·с2/м5] как функция величин: температура t [K]:

wspDDDHPSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении пара на линии насыщения [кг·с2/м5], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspDDDHPSWT

Производная плотности по энтальпии при постоянном давлении воды на линии насыщения [кг·с2/м5] как функция величин: температура t [K]:

wspDDDHPSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – производная плотности по энтальпии при постоянном давлении воды на линии насыщения [кг·с2/м5], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspDDDPHPH

Производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspDDDPHPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspDDDPHxPT).


wspDDDPHPT

Производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2] как функция величин: давление p [Па], температура t [K]:

wspDDDPHPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspDDDPHxPT).


wspDDDPHPTX

Производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspDDDPHPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии воды/пара [с2/м2], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspDDDPHxPT или wspDDDPHSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspDDDPHSST

Производная плотности по давлении при постоянной энтальпии пара на линии насыщения [с2/м2] как функция величин: температура t [K]:

wspDDDPHSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии пара на линии насыщения [с2/м2], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspDDDPHSWT

Производная плотности по давлении при постоянной энтальпии воды на линии насыщения [с2/м2] как функция величин: температура t [K]:

wspDDDPHSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – производная плотности по давлении при постоянной энтальпии воды на линии насыщения [с2/м2], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspDPDTST

Производная давления на линии насыщения по температуре насыщения [Па/К] как функция величин: температура t [K]:

wspDPDTST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – производная давления на линии насыщения по температуре насыщения [Па/К], тип: double.

Функция основана на "Supplementary Release on Saturation Properties of Ordinary Water Substance" от Международной Ассоциации по Свойствам Воды и Водяного Пара. Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspDPT

Плотность [кг/м3] как функция величин: давление p [Па], температура t [K]:

wspDPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – плотность [кг/м3], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspDxPT).


wspDPTX

Плотность [кг/м3] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspDPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – плотность [кг/м3], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspDxPT или wspDSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspDSST

Плотность пара на линии насыщения [кг/м3] как функция величин: температура t [K]:

wspDSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – плотность пара на линии насыщения [кг/м3], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspDSTX

Плотность в двухфазной области [кг/м3] как функция величин: температура t [K], степень сухости x [-]:

wspDSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – плотность в двухфазной области [кг/м3], тип: double.

Данная функция использует функцию wspVSTX, которая возвращает удельный объем в двухфазной области. При вычислениях используется следующая формула: Dx = 1 / Vx, где Vx = wspVSTX(t, x).


wspDSWT

Плотность воды на линии насыщения [кг/м3] как функция величин: температура t [K]:

wspDSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – плотность воды на линии насыщения [кг/м3], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspDYNVISEXPANSIONPTPEFF

Динамическая вязкость в конце процесса расширения/сжатия [Па·с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspDYNVISEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – динамическая вязкость в конце процесса расширения/сжатия [Па·с], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspDYNVISEXPANSIONPTXPEFF

Динамическая вязкость в конце процесса расширения/сжатия [Па·с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspDYNVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – динамическая вязкость в конце процесса расширения/сжатия [Па·с], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspDYNVISHS

Динамическая вязкость [Па·с] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspDYNVISHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspDYNVISMSPT

Динамическая вязкость в метастабильной области [Па·с] как функция величин: давление p [Па], температура t [K]:

wspDYNVISMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – динамическая вязкость в метастабильной области [Па·с], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspDYNVISPH

Динамическая вязкость [Па·с] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspDYNVISPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspDYNVISPTX.


wspDYNVISPS

Динамическая вязкость [Па·с] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspDYNVISPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspDYNVISPTX.


wspDYNVISPT

Динамическая вязкость [Па·с] как функция величин: давление p [Па], температура t [K]:

wspDYNVISPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97 и формуляцией для вычисления динамической вязкости. Для вычисления используется функция wspDYNVISRT с аргументом-плотностью, вычисляемому по обобщенной функции wspVPT.


wspDYNVISPTX

Динамическая вязкость [Па·с] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspDYNVISPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspDYNVISPT или wspDYNVISSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspDYNVISRT

Динамическая вязкость [Па·с] как функция величин: плотность r [кг/м3], температура t [K]:

wspDYNVISRT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – динамическая вязкость [Па·с], тип: double.

Основана на "the IAPWS Formulation 1985 for the Viscosity of Ordinary Water Substance" с коррекцией для Международной Температурной Шкалы 1990.


wspDYNVISSST

Динамическая вязкость пара на линии насыщения [Па·с] как функция величин: температура t [K]:

wspDYNVISSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – динамическая вязкость пара на линии насыщения [Па·с], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspDYNVISSTX

Динамическая вязкость в двухфазной области [Па·с] как функция величин: температура t [K], степень сухости x [-]:

wspDYNVISSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – динамическая вязкость в двухфазной области [Па·с], тип: double.

Данная функция использует функции wspDYNVISSST и wspDYNVISSWT, которые возвращают динамическую вязкость пара и воды на линии насыщения. При вычислениях используется следующая формула: DYNVISx = (1 - X)·DYNVISw + X·DYNVISs, где DYNVISs = wspDYNVISSST, DYNVISw = wspDYNVISSWT и X - степень сухости.


wspDYNVISSWT

Динамическая вязкость воды на линии насыщения [Па·с] как функция величин: температура t [K]:

wspDYNVISSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – динамическая вязкость воды на линии насыщения [Па·с], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspgADDGASM

Добавление одного газа в состав другого как функция величин: идентификатор исходного газа id_target, идентификатор добавляемого газа id_source, масса добавляемого газа mass:

wspgADDGASM(id_target, id_source, mass)

где:

  • id_target – идентификатор исходного газа, тип: long;
  • id_source – идентификатор добавляемого газа, тип: long;
  • mass – масса добавляемого газа, тип: double;
  • Возвращаемый результат – добавление одного газа в состав другого, тип: long.

Функция производит добавление указанной массы одного газа (заданного идентификатором id_source) в состав другого газа (заданного идентификатором id_target).


wspgADDGASV

Добавление одного газа в состав другого как функция величин: идентификатор исходного газа id_target, идентификатор добавляемого газа id_source, объем добавляемого газа volume:

wspgADDGASV(id_target, id_source, volume)

где:

  • id_target – идентификатор исходного газа, тип: long;
  • id_source – идентификатор добавляемого газа, тип: long;
  • volume – объем добавляемого газа, тип: double;
  • Возвращаемый результат – добавление одного газа в состав другого, тип: long.

Функция производит добавление указанного объема (или количества молей) одного газа (заданного идентификатором id_source) в состав другого газа (заданного идентификатором id_target).


wspgCPGST

Удельная изобарная теплоемкость [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, температура t [K]:

wspgCPGST(gas_specification, t)

где:

  • gas_specification – спецификация газа, тип: string;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость [Дж/(кг·К)], тип: double.

Функция вычисляет удельную изобарную теплоемкость для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgCPIDT

Удельная изобарная теплоемкость [Дж/(кг·К)] как функция величин: идентификатор газа id, температура t [K]:

wspgCPIDT(id, t)

где:

  • id – идентификатор газа, тип: long;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изобарная теплоемкость [Дж/(кг·К)], тип: double.

Функция вычисляет удельную изобарную теплоемкость заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgCVGST

Удельная изохорная теплоемкость [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, температура t [K]:

wspgCVGST(gas_specification, t)

где:

  • gas_specification – спецификация газа, тип: string;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double.

Функция вычисляет удельную изохорную теплоемкость для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgCVIDT

Удельная изохорная теплоемкость [Дж/(кг·К)] как функция величин: идентификатор газа id, температура t [K]:

wspgCVIDT(id, t)

где:

  • id – идентификатор газа, тип: long;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double.

Функция вычисляет удельную изохорную теплоемкость заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgDELETEGASES

Удаление всех определенных пользователем газов:

wspgDELETEGASES()

где:

  • Возвращаемый результат – удаление всех определенных пользователем газов, тип: long.

Функция удаляет все определенные пользователем газы. При этом происходит освобождение памяти, занятой под газы. После вызова функции доступны для расчетов только встроенные газы.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspgDELETEGASID

Удаление определенного ранее газа как функция величин: идентификатор газа id:

wspgDELETEGASID(id)

где:

  • id – идентификатор газа, тип: long;
  • Возвращаемый результат – удаление определенного ранее газа, тип: long.

Функция удаляет газ с заданным идентификатором. При этом происходит освобождение памяти, занятой под данный газ.


wspGETABSOLUTEGASCONSTANT

Универсальная газовая постоянная [Дж/(моль·К)]:

wspGETABSOLUTEGASCONSTANT()

где:

  • Возвращаемый результат – универсальная газовая постоянная [Дж/(моль·К)], тип: double.

Функция возвращает значение абсолютной газовой постоянной, используемой в расчетах.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspGETCHECKRANGEMODE

Режим ведения проверки диапазона аргументов функций:

wspGETCHECKRANGEMODE()

где:

  • Возвращаемый результат – режим ведения проверки диапазона аргументов функций, тип: long.

Функция возвращает ноль если проверка не производится.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspGETDELTAPRESSURE

Максимальная разность между значениями давлений при вычислении параметров в области 3 [Па]:

wspGETDELTAPRESSURE()

где:

  • Возвращаемый результат – максимальная разность между значениями давлений при вычислении параметров в области 3 [Па], тип: double.

Функция устарела. Начиная с версии 6.0 она не используется!

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

Примечание: Данная функция устарела и не рекомендуется к использованию.


wspGETDELTATS

Максимальная разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K]:

wspGETDELTATS()

где:

  • Возвращаемый результат – максимальная разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K], тип: double.

Функция устарела. Начиная с версии 6.0 она не используется!

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

Примечание: Данная функция устарела и не рекомендуется к использованию.


wspGETINITSTEAMDENSITY

Начальное приближение плотности пара в области 3 [кг/м3]:

wspGETINITSTEAMDENSITY()

где:

  • Возвращаемый результат – начальное приближение плотности пара в области 3 [кг/м3], тип: double.

Функция устарела. Начиная с версии 6.0 она не используется!

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

Примечание: Данная функция устарела и не рекомендуется к использованию.


wspGETINITWATERDENSITY

Начальное приближение плотности воды в области 3 [кг/м3]:

wspGETINITWATERDENSITY()

где:

  • Возвращаемый результат – начальное приближение плотности воды в области 3 [кг/м3], тип: double.

Функция устарела. Начиная с версии 6.0 она не используется!

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.

Примечание: Данная функция устарела и не рекомендуется к использованию.


wspGETLASTERROR

Код последней ошибки:

wspGETLASTERROR()

где:

  • Возвращаемый результат – код последней ошибки, тип: long.

Функция возвращает код последней ошибки, которая возникла при вычислениях в функциях WaterSteamPro (за исключением системных функций). Обращение к любой функции (за исключением системных) сбрасывает код последней ошибки в значение ноль (ошибка отсутствует).

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspGETLASTERRORDESCRIPTION

Описание последней ошибки:

wspGETLASTERRORDESCRIPTION()

где:

  • Возвращаемый результат – описание последней ошибки, тип: string.

Функция возвращает описание последней ошибки, которая возникла при вычислениях в функциях WaterSteamPro (за исключением системных функций). Результат определен в библиотеке OKAWSP6.DLL как LPCSTR (1-байтные ANSI-символы), но в ActiveX-объекте WSP.WSPCalculator - как BSTR (Unicode кодировка). В Visual Basic необходимо использовать ActiveX-версию функции. При использовании функции не из Active-X компонента Вам не нужно заботиться об освобождении памяти, т.к. в этой функции используется статический буфер, каждый раз заполняемый соответствующим значением.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspGETLASTERRORDESCRIPTIONW

Описание последней ошибки:

wspGETLASTERRORDESCRIPTIONW()

где:

  • Возвращаемый результат – описание последней ошибки, тип: unicodestring.

Функция возвращает описание последней ошибки, которая возникла при вычислениях в функциях WaterSteamPro (за исключением системных функций).

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspGETMAXITERATION

Максимальное число итераций в методе Ньютона:

wspGETMAXITERATION()

где:

  • Возвращаемый результат – максимальное число итераций в методе Ньютона, тип: long.

Это число используется в функциях, где используется метод Ньютона. Если число итераций больше, чем данное значение, то генерируется ошибка с кодом WSP_CANT_FIND_ROOT (3).

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspGETTOLERANCE

Относительная точность в функциях WaterSteamPro [-]:

wspGETTOLERANCE()

где:

  • Возвращаемый результат – относительная точность в функциях WaterSteamPro [-], тип: double.

Используется в функциях, требующих понятия точности вычисления.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspGETTOLERANCEMODE

Режим ведения уточнения результатов функций:

wspGETTOLERANCEMODE()

где:

  • Возвращаемый результат – режим ведения уточнения результатов функций, тип: long.

Используется в функциях, где может вестить уточнение результата (например, функции с аргументами (p, h) и (p, s)). Если аргумент данной функции равен нулю, то уточнение запрещается и скорость вычислений увеличивается, в то время как точность уменьшается.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspGETWSPVERSION

Внутренняя версия WaterSteamPro:

wspGETWSPVERSION()

где:

  • Возвращаемый результат – внутренняя версия WaterSteamPro, тип: double.

Формат версии: x.yzzz, где x - главная версия, y - младшая версия, zzz - номер реализации.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspgGASESCOUNT

Количество всех доступных газов:

wspgGASESCOUNT()

где:

  • Возвращаемый результат – количество всех доступных газов, тип: long.

Функция возвращает число доступных газов: встроенных и определенных пользователем.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspgGCGS

Удельная газовая постоянная [Дж/(кг·К)] как функция величин: спецификация газа gas_specification:

wspgGCGS(gas_specification)

где:

  • gas_specification – спецификация газа, тип: string;
  • Возвращаемый результат – удельная газовая постоянная [Дж/(кг·К)], тип: double.


wspgGCID

Удельная газовая постоянная [Дж/(кг·К)] как функция величин: идентификатор газа id:

wspgGCID(id)

где:

  • id – идентификатор газа, тип: long;
  • Возвращаемый результат – удельная газовая постоянная [Дж/(кг·К)], тип: double.


wspgGETCALCDISSMODE

Режим ведения расчета диссоциации при расчете смесей газов:

wspgGETCALCDISSMODE()

где:

  • Возвращаемый результат – режим ведения расчета диссоциации при расчете смесей газов, тип: long.

Используется в функциях для расчета свойств газов. Если установлен режим равный 0, то расчет диссоциации не ведется. Если установлен режим равный 1, то диссоциация считается для смесей всегда. Если установлен режим равный 2, то диссоциация считается для температур свыше 1200 К.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspgHGST

Удельная энтальпия [Дж/кг] как функция величин: спецификация газа gas_specification, температура t [K]:

wspgHGST(gas_specification, t)

где:

  • gas_specification – спецификация газа, тип: string;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

Функция вычисляет удельную энтальпию для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgHIDT

Удельная энтальпия [Дж/кг] как функция величин: идентификатор газа id, температура t [K]:

wspgHIDT(id, t)

где:

  • id – идентификатор газа, тип: long;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

Функция вычисляет удельную энтальпию заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgIDNAME

Идентификатор газа как функция величин: имя ранее созданного газа name:

wspgIDNAME(name)

где:

  • name – имя ранее созданного газа, тип: string;
  • Возвращаемый результат – идентификатор газа, тип: long.

Функция возвращает идентификатор ранее определенного газа (или встроенного). Если газа с таким именем не существует, то генерируется ошибка с кодом WSP_E_BAD_PARAMS.


wspgMFGSGS

Массовая доля (MF) газа как функция величин: спецификация исходного газа gas_spec_looked, спецификация искомого газа gas_spec_looked_for:

wspgMFGSGS(gas_spec_looked, gas_spec_looked_for)

где:

  • gas_spec_looked – спецификация исходного газа, тип: string;
  • gas_spec_looked_for – спецификация искомого газа, тип: string;
  • Возвращаемый результат – массовая доля (MF) газа, тип: double.

Функция вычисляет удельную (относительную) массовую долю газа (задаваемого спецификацией gas_spec_looked_for) в газе (задаваемого спецификацией gas_spec_looked).


wspgMFIDID

Массовая доля (MF) газа как функция величин: идентификатор исходного газа id_looked, идентификатор искомого газа id_looked_for:

wspgMFIDID(id_looked, id_looked_for)

где:

  • id_looked – идентификатор исходного газа, тип: long;
  • id_looked_for – идентификатор искомого газа, тип: long;
  • Возвращаемый результат – массовая доля (MF) газа, тип: double.

Функция вычисляет удельную (относительную) массовую долю газа (задаваемого идентификатором id_looked_for) в газе (задаваемого идентификатором id_looked).


wspgMMGS

Молярная масса [кг/моль] как функция величин: спецификация газа gas_specification:

wspgMMGS(gas_specification)

где:

  • gas_specification – спецификация газа, тип: string;
  • Возвращаемый результат – молярная масса [кг/моль], тип: double.


wspgMMID

Молярная масса [кг/моль] как функция величин: идентификатор газа id:

wspgMMID(id)

где:

  • id – идентификатор газа, тип: long;
  • Возвращаемый результат – молярная масса [кг/моль], тип: double.


wspgNEWID

Идентификатор нового газа:

wspgNEWID()

где:

  • Возвращаемый результат – идентификатор нового газа, тип: long.

Функция создает новый газ и возвращает идентификатор этого газа. После окончания работы с данным идентификатором необходимо удалить выделенную под газ память вызовом функции wspgDELETEGASID или wspgDELETEGASES. Иначе память будет освобождена только при окончании работы текущей программы.

Примечание: В пакете Mathcad функция имеет один параметр, значение которого никак не используется.


wspgNEWIDGS

Идентификатор нового газа как функция величин: спецификация газа gas_specification:

wspgNEWIDGS(gas_specification)

где:

  • gas_specification – спецификация газа, тип: string;
  • Возвращаемый результат – идентификатор нового газа, тип: long.

Функция создает новый газ и возвращает идентификатор этого газа соответствующего заданной спецификации. После окончания работы с данным идентификатором необходимо удалить выделенную под газ память вызовом функции wspgDELETEGASID или wspgDELETEGASES. Иначе память будет освобождена только при окончании работы текущей программы.


wspgNEWIDNAME

Идентификатор газа как функция величин: имя нового газа name:

wspgNEWIDNAME(name)

где:

  • name – имя нового газа, тип: string;
  • Возвращаемый результат – идентификатор газа, тип: long.

Функция создает новый газ с заданным именем и возвращает его идентификатор. Если газ с таким именем существует, то генерируется ошибка с кодом WSP_E_BAD_PARAMS. После окончания работы с данным идентификатором необходимо удалить выделенную под газ память вызовом функции wspgDELETEGASID или wspgDELETEGASES. Иначе память будет освобождена только при окончании работы текущей программы.


wspgPGSTS

Давление [Па] как функция величин: спецификация газа gas_specification, температура t [K], удельная энтропия s [Дж/(кг·К)]:

wspgPGSTS(gas_specification, t, s)

где:

  • gas_specification – спецификация газа, тип: string;
  • t – температура [K], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – давление [Па], тип: double.

Функция определяет давление для заданной спецификации газа (смеси) в идеальном состоянии при заданных температуре и удельной энтропии. Функция определена при температурах от 200 до 2500К.


wspgPIDTS

Давление [Па] как функция величин: идентификатор газа id, температура t [K], удельная энтропия s [Дж/(кг·К)]:

wspgPIDTS(id, t, s)

где:

  • id – идентификатор газа, тип: long;
  • t – температура [K], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – давление [Па], тип: double.

Функция определяет давление для заданного газа (идентификатор id) в идеальном состоянии при заданных температуре и удельной энтропии. Функция определена при температурах от 200 до 2500К.


wspgSETCALCDISSMODE

Устанавливает и возвращает режим ведения расчета диссоциации при расчете смесей газов как функция величин: mode mode:

wspgSETCALCDISSMODE(mode)

где:

  • mode – mode, тип: long;
  • Возвращаемый результат – устанавливает и возвращает режим ведения расчета диссоциации при расчете смесей газов, тип: long.

Используется в функциях для расчета свойств газов. Если установлен режим равный 0, то расчет диссоциации не ведется. Если установлен режим равный 1, то диссоциация считается для смесей всегда. Если установлен режим равный 2, то диссоциация считается для температур свыше 1200 К.


wspgSGSPT

Удельная энтропия [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, давление p [Па], температура t [K]:

wspgSGSPT(gas_specification, p, t)

где:

  • gas_specification – спецификация газа, тип: string;
  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

Функция вычисляет удельную энтропию для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgSGST

Удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)] как функция величин: спецификация газа gas_specification, температура t [K]:

wspgSGST(gas_specification, t)

где:

  • gas_specification – спецификация газа, тип: string;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)], тип: double.

Функция вычисляет удельную энтропию для заданной спецификации газа (смеси) в идеальном состоянии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.


wspgSIDPT

Удельная энтропия [Дж/(кг·К)] как функция величин: идентификатор газа id, давление p [Па], температура t [K]:

wspgSIDPT(id, p, t)

где:

  • id – идентификатор газа, тип: long;
  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

Функция вычисляет удельную энтропию заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgSIDT

Удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)] как функция величин: идентификатор газа id, температура t [K]:

wspgSIDT(id, t)

где:

  • id – идентификатор газа, тип: long;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия при давлении p0 = 100 кПа [Дж/(кг·К)], тип: double.

Функция вычисляет удельную энтропию заданного газа (идентификатор id) в идеальном состоянии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.


wspgTGSH

Температура [K] как функция величин: спецификация газа gas_specification, удельная энтальпия h [Дж/кг]:

wspgTGSH(gas_specification, h)

где:

  • gas_specification – спецификация газа, тип: string;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура [K], тип: double.

Функция определяет температуру для заданной спецификации газа (смеси) в идеальном состоянии при заданной удельной энтальпии. Функция определена при температурах от 200 до 2500К.


wspgTGSPS

Температура [K] как функция величин: спецификация газа gas_specification, давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspgTGSPS(gas_specification, p, s)

где:

  • gas_specification – спецификация газа, тип: string;
  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура [K], тип: double.

Функция определяет температуру для заданной спецификации газа (смеси) в идеальном состоянии при заданных давлении и удельной энтропии. Функция определена при температурах от 200 до 2500К.


wspgTGSS

Температура при давлении p0 = 100 кПа [K] как функция величин: спецификация газа gas_specification, удельная энтропия s [Дж/(кг·К)]:

wspgTGSS(gas_specification, s)

где:

  • gas_specification – спецификация газа, тип: string;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура при давлении p0 = 100 кПа [K], тип: double.

Функция определяет температуру для заданной спецификации газа (смеси) в идеальном состоянии при заданной удельной энтропии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.


wspgTIDH

Температура [K] как функция величин: идентификатор газа id, удельная энтальпия h [Дж/кг]:

wspgTIDH(id, h)

где:

  • id – идентификатор газа, тип: long;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура [K], тип: double.

Функция вычисляет температуру для заданного газа (идентификатор id) в идеальном состоянии при заданной удельной энтальпии. Функция определена при температурах от 200 до 2500К.


wspgTIDPS

Температура [K] как функция величин: идентификатор газа id, давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspgTIDPS(id, p, s)

где:

  • id – идентификатор газа, тип: long;
  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура [K], тип: double.

Функция определяет температуру для заданного газа (идентификатор id) в идеальном состоянии при заданных удельной энтропии и давлении. Функция определена при температурах от 200 до 2500К.


wspgTIDS

Температура при давлении p0 = 100 кПа [K] как функция величин: идентификатор газа id, удельная энтропия s [Дж/(кг·К)]:

wspgTIDS(id, s)

где:

  • id – идентификатор газа, тип: long;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура при давлении p0 = 100 кПа [K], тип: double.

Функция определяет температуру для заданного газа (идентификатор id) в идеальном состоянии при заданной удельной энтропии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.


wspgUGST

Удельная внутренняя энергия [Дж/кг] как функция величин: спецификация газа gas_specification, температура t [K]:

wspgUGST(gas_specification, t)

где:

  • gas_specification – спецификация газа, тип: string;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

Функция вычисляет удельную внутреннюю энергию для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgUIDT

Удельная внутренняя энергия [Дж/кг] как функция величин: идентификатор газа id, температура t [K]:

wspgUIDT(id, t)

где:

  • id – идентификатор газа, тип: long;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

Функция вычисляет удельную внутреннюю энергию заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgVFGSGS

Объемная доля (VF) газа как функция величин: спецификация исходного газа gas_spec_looked, спецификация искомого газа gas_spec_looked_for:

wspgVFGSGS(gas_spec_looked, gas_spec_looked_for)

где:

  • gas_spec_looked – спецификация исходного газа, тип: string;
  • gas_spec_looked_for – спецификация искомого газа, тип: string;
  • Возвращаемый результат – объемная доля (VF) газа, тип: double.

Функция вычисляет удельную (относительную) объемную долю газа (задаваемого спецификацией gas_spec_looked_for) в газе (задаваемого спецификацией gas_spec_looked).


wspgVFIDID

Объемная доля (VF) газа как функция величин: идентификатор исходного газа id_looked, идентификатор искомого газа id_looked_for:

wspgVFIDID(id_looked, id_looked_for)

где:

  • id_looked – идентификатор исходного газа, тип: long;
  • id_looked_for – идентификатор искомого газа, тип: long;
  • Возвращаемый результат – объемная доля (VF) газа, тип: double.

Функция вычисляет удельную (относительную) объемную долю газа (задаваемого идентификатором id_looked_for) в газе (задаваемого идентфикатором id_looked).


wspgVGSPT

Удельный объем [м3/кг] как функция величин: спецификация газа gas_specification, давление p [Па], температура t [K]:

wspgVGSPT(gas_specification, p, t)

где:

  • gas_specification – спецификация газа, тип: string;
  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем [м3/кг], тип: double.

Функция вычисляет удельный объем для заданной спецификации газа (смеси) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgVGST

Удельный объем при давлении p0 = 100 кПа [м3/кг] как функция величин: спецификация газа gas_specification, температура t [K]:

wspgVGST(gas_specification, t)

где:

  • gas_specification – спецификация газа, тип: string;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем при давлении p0 = 100 кПа [м3/кг], тип: double.

Функция вычисляет удельный объем для заданной спецификации газа (смеси) в идеальном состоянии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.


wspgVIDPT

Удельный объем [м3/кг] как функция величин: идентификатор газа id, давление p [Па], температура t [K]:

wspgVIDPT(id, p, t)

где:

  • id – идентификатор газа, тип: long;
  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем [м3/кг], тип: double.

Функция вычисляет удельный объем заданного газа (идентификатор id) в идеальном состоянии. Функция определена при температурах от 200 до 2500К.


wspgVIDT

Удельный объем при давлении p0 = 100 кПа [м3/кг] как функция величин: идентификатор газа id, температура t [K]:

wspgVIDT(id, t)

где:

  • id – идентификатор газа, тип: long;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем при давлении p0 = 100 кПа [м3/кг], тип: double.

Функция вычисляет удельный объем заданного газа (идентификатор id) в идеальном состоянии при давлении p0 = 100 кПа. Функция определена при температурах от 200 до 2500К.


wspH1PT

Удельная энтальпия в области 1 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspH1PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия в области 1 [Дж/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspH2B2CP

Удельная энтальпия на линии между областями 2b и 2c [Дж/кг] как функция величин: давление p [Па]:

wspH2B2CP(p)

где:

  • p – давление [Па], тип: double;
  • Возвращаемый результат – удельная энтальпия на линии между областями 2b и 2c [Дж/кг], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspH2PT

Удельная энтальпия в области 2 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspH2PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия в области 2 [Дж/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspH3PT

Удельная энтальпия в области 3 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspH3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия в области 3 [Дж/кг], тип: double.

Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.


wspH3RT

Удельная энтальпия в области 3 [Дж/кг] как функция величин: плотность r [кг/м3], температура t [K]:

wspH3RT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия в области 3 [Дж/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspH5PT

Удельная энтальпия в области 5 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspH5PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия в области 5 [Дж/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspHB13S

Удельная энтальпия на линии между областями 1 и 3 [Дж/кг] как функция величин: удельная энтропия s [Дж/(кг·К)]:

wspHB13S(s)

где:

  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная энтальпия на линии между областями 1 и 3 [Дж/кг], тип: double.

Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).


wspHEXPANSIONPTPEFF

Удельная энтальпия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspHEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная энтальпия в конце процесса расширения/сжатия [Дж/кг], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspHEXPANSIONPTXPEFF

Удельная энтальпия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspHEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная энтальпия в конце процесса расширения/сжатия [Дж/кг], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspHMSPT

Удельная энтальпия в метастабильной области [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspHMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия в метастабильной области [Дж/кг], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspHPS

Удельная энтальпия [Дж/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspHPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspHPTX.


wspHPT

Удельная энтальпия [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspHPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspHxPT).


wspHPTX

Удельная энтальпия [Дж/кг] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspHPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная энтальпия [Дж/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspHxPT или wspHSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspHSST

Удельная энтальпия пара на линии насыщения [Дж/кг] как функция величин: температура t [K]:

wspHSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия пара на линии насыщения [Дж/кг], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspHSTX

Удельная энтальпия в двухфазной области [Дж/кг] как функция величин: температура t [K], степень сухости x [-]:

wspHSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная энтальпия в двухфазной области [Дж/кг], тип: double.

Данная функция использует функции wspHSST и wspHSWT, которые возвращают удельные энтальпии пара и воды на линии насыщения. При вычислениях используется следующая формула: Hx = (1 - X)·Hw + X·Hs, где Hs = wspHSST, Hw = wspHSWT и X - степень сухости.


wspHSWT

Удельная энтальпия воды на линии насыщения [Дж/кг] как функция величин: температура t [K]:

wspHSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтальпия воды на линии насыщения [Дж/кг], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspJOULETHOMPSON1PT

Коэффициент Джоуля-Томсона в области 1 [K/Па] как функция величин: давление p [Па], температура t [K]:

wspJOULETHOMPSON1PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона в области 1 [K/Па], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара и использует формулу: JT = (T*(dV/dT)p - V)/Cp.


wspJOULETHOMPSON2PT

Коэффициент Джоуля-Томсона в области 2 [K/Па] как функция величин: давление p [Па], температура t [K]:

wspJOULETHOMPSON2PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона в области 2 [K/Па], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара и использует формулу: JT = (T*(dV/dT)p - V)/Cp.


wspJOULETHOMPSON3PT

Коэффициент Джоуля-Томсона в области 3 [K/Па] как функция величин: давление p [Па], температура t [K]:

wspJOULETHOMPSON3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона в области 3 [K/Па], тип: double.

Функция использует функцию wspR3PT для расчета плотности по давлению и температуре и далее вызывает функцию wspJOULETHOMPSON3RT.


wspJOULETHOMPSON3RT

Коэффициент Джоуля-Томсона в области 3 [K/Па] как функция величин: плотность r [кг/м3], температура t [K]:

wspJOULETHOMPSON3RT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона в области 3 [K/Па], тип: double.

Функция возвращает коэффициент Джоуля-Томсона в области 3 Формуляции IF-97.


wspJOULETHOMPSON5PT

Коэффициент Джоуля-Томсона в области 5 [K/Па] как функция величин: давление p [Па], температура t [K]:

wspJOULETHOMPSON5PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона в области 5 [K/Па], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара и использует формулу: JT = (T*(dV/dT)p - V)/Cp.


wspJOULETHOMPSONEXPANSIONPTPEFF

Коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspJOULETHOMPSONEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspJOULETHOMPSONEXPANSIONPTXPEFF

Коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspJOULETHOMPSONEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона в конце процесса расширения/сжатия [K/Па], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff). Примечание: в ActiveX-объекте "WSP.WSPCalculator" эта функция называется "wspJOULETHOMPSONEXPANSIONPTXPEF" в связи с ограничениями на длину имени в COM.


wspJOULETHOMPSONHS

Коэффициент Джоуля-Томсона [K/Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspJOULETHOMPSONHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspJOULETHOMPSONMSPT

Коэффициент Джоуля-Томсона в метастабильной области [K/Па] как функция величин: давление p [Па], температура t [K]:

wspJOULETHOMPSONMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона в метастабильной области [K/Па], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspJOULETHOMPSONPH

Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspJOULETHOMPSONPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspJOULETHOMPSONPTX.


wspJOULETHOMPSONPS

Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspJOULETHOMPSONPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspJOULETHOMPSONPTX.


wspJOULETHOMPSONPT

Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], температура t [K]:

wspJOULETHOMPSONPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspJOULETHOMPSONxPT).


wspJOULETHOMPSONPTX

Коэффициент Джоуля-Томсона [K/Па] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspJOULETHOMPSONPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона [K/Па], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspJOULETHOMPSONxPT или wspJOULETHOMPSONSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspJOULETHOMPSONSST

Коэффициент Джоуля-Томсона пара на линии насыщения со стороны однофазной области [K/Па] как функция величин: температура t [K]:

wspJOULETHOMPSONSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона пара на линии насыщения со стороны однофазной области [K/Па], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspJOULETHOMPSONSTX

Коэффициент Джоуля-Томсона в двухфазной области [K/Па] как функция величин: температура t [K], степень сухости x [-]:

wspJOULETHOMPSONSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона в двухфазной области [K/Па], тип: double.

Данная функция напрямую вычисляет (dT/dP)h в двухфазной области по уравнению для линии насыщения в Формуляции IF-97. До версии 5.6 данная функция возвращала результат, основанный на степени сухости, что неверно с точки зрения термодинамики, т.к. согласно теории коэффициент Джоуля-Томсона постоянен в двухфазной области.


wspJOULETHOMPSONSWT

Коэффициент Джоуля-Томсона воды на линии насыщения со стороны однофазной области [K/Па] как функция величин: температура t [K]:

wspJOULETHOMPSONSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент Джоуля-Томсона воды на линии насыщения со стороны однофазной области [K/Па], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspKEXPANSIONPTPEFF

Коэффициент изоэнтропы в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspKEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы в конце процесса расширения/сжатия [-], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspKEXPANSIONPTXPEFF

Коэффициент изоэнтропы в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspKEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы в конце процесса расширения/сжатия [-], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspKHS

Коэффициент изоэнтропы [-] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspKHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspKINVISEXPANSIONPTPEFF

Кинематическая вязкость в конце процесса расширения/сжатия [м2/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspKINVISEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – кинематическая вязкость в конце процесса расширения/сжатия [м2/с], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspKINVISEXPANSIONPTXPEFF

Кинематическая вязкость в конце процесса расширения/сжатия [м2/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspKINVISEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – кинематическая вязкость в конце процесса расширения/сжатия [м2/с], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspKINVISHS

Кинематическая вязкость [м2/с] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspKINVISHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspKINVISMSPT

Кинематическая вязкость в метастабильной области [м2/с] как функция величин: давление p [Па], температура t [K]:

wspKINVISMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – кинематическая вязкость в метастабильной области [м2/с], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspKINVISPH

Кинематическая вязкость [м2/с] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspKINVISPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspKINVISPTX.


wspKINVISPS

Кинематическая вязкость [м2/с] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspKINVISPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspKINVISPTX.


wspKINVISPT

Кинематическая вязкость [м2/с] как функция величин: давление p [Па], температура t [K]:

wspKINVISPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97 и формуляцией для вычисления динамической вязкости. Для вычислений используется формула: KINVIS = DYNVIS · V, где DYNVIS вычисляется по функции wspDYNVISPT, а V - по функции wspVPT.


wspKINVISPTX

Кинематическая вязкость [м2/с] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspKINVISPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – кинематическая вязкость [м2/с], тип: double.

Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspKINVISPT или wspKINVISSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspKINVISSST

Кинематическая вязкость пара на линии насыщения [м2/с] как функция величин: температура t [K]:

wspKINVISSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – кинематическая вязкость пара на линии насыщения [м2/с], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspKINVISSTX

Кинематическая вязкость в двухфазной области [м2/с] как функция величин: температура t [K], степень сухости x [-]:

wspKINVISSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – кинематическая вязкость в двухфазной области [м2/с], тип: double.

Данная функция использует функции wspKINVISSST и wspKINVISSWT, которые возвращают кинематическую вязкость пара и воды на линии насыщения. При вычислениях используется следующая формула: KINVISx = (1 - X)·KINVISw + X·KINVISs, где KINVISs = wspKINVISSST, KINVISw = wspKINVISSWT и X - степень сухости.


wspKINVISSWT

Кинематическая вязкость воды на линии насыщения [м2/с] как функция величин: температура t [K]:

wspKINVISSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – кинематическая вязкость воды на линии насыщения [м2/с], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspKMSPT

Показатель изоэнтропы в метастабильной области [-] как функция величин: давление p [Па], температура t [K]:

wspKMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – показатель изоэнтропы в метастабильной области [-], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspKPH

Коэффициент изоэнтропы [-] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspKPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspKPTX.


wspKPS

Коэффициент изоэнтропы [-] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspKPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspKPTX.


wspKPT

Коэффициент изоэнтропы [-] как функция величин: давление p [Па], температура t [K]:

wspKPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. Для вычислений используется формула: K = W · W / (P · V), где W (скорость звука) вычисляется по функции wspWPT, P - давление и V (удельный объем) - по функции wspVPT.


wspKPTX

Коэффициент изоэнтропы [-] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspKPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы [-], тип: double.

Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspKPT или wspKSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspKSST

Коэффициент изоэнтропы пара на линии насыщения со стороны однофазной области [-] как функция величин: температура t [K]:

wspKSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы пара на линии насыщения со стороны однофазной области [-], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspKSTX

Коэффициент изоэнтропы в двухфазной области [-] как функция величин: температура t [K], степень сухости x [-]:

wspKSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы в двухфазной области [-], тип: double.

Функция возвращает значение коэффициента изоэнтропы в двухфазной области с учетом сдвига на линии насыщения. Для этого используются функции wspCVDPSWT, wspCVDPSST и wspDPDTST и соответствующие термодинамические соотношения. До версии 5.6 данная функция использовала неправильное, с точки зрения термодинамики, выражение: Kx = (1 - X)·Kw + X·Ks, где Ks = wspKSST, Kw = wspKSWT и X - степень сухости.


wspKSWT

Коэффициент изоэнтропы воды на линии насыщения со стороны однофазной области [-] как функция величин: температура t [K]:

wspKSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент изоэнтропы воды на линии насыщения со стороны однофазной области [-], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspLOCALREGISTRATION

Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационное код key:

wspLOCALREGISTRATION(name, key)

где:

  • name – регистрационное имя, тип: string;
  • key – регистрационное код, тип: string;
  • Возвращаемый результат – процессозависимая регистрация WaterSteamPro, тип: void.

Используется в лицензии "Developer". Данная функция не используется, начиная с версии 6.0 и при ее вызове ничего не делается.

Примечание: Данная функция устарела и не рекомендуется к использованию.


wspLOCALREGISTRATIONEXA

Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационные данные data:

wspLOCALREGISTRATIONEXA(name, data)

где:

  • name – регистрационное имя, тип: string;
  • data – регистрационные данные, тип: long;
  • Возвращаемый результат – процессозависимая регистрация WaterSteamPro, тип: double.

Используется в лицензии "Developer".


wspLOCALREGISTRATIONEXW

Процессозависимая регистрация WaterSteamPro как функция величин: регистрационное имя name, регистрационные данные data:

wspLOCALREGISTRATIONEXW(name, data)

где:

  • name – регистрационное имя, тип: unicodestring;
  • data – регистрационные данные, тип: long;
  • Возвращаемый результат – процессозависимая регистрация WaterSteamPro, тип: double.

Используется в лицензии "Developer".


wspP1HS

Давление в области 1 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspP1HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – давление в области 1 [Па], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspP2B2CH

Давление на линии между областями 2b и 2c [Па] как функция величин: удельная энтальпия h [Дж/кг]:

wspP2B2CH(h)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – давление на линии между областями 2b и 2c [Па], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspP2HS

Давление в области 2 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspP2HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – давление в области 2 [Па], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. При расчете используются функции wspP2AHS(h, s), wspP2BHS(h, s) и wspP2CHS(h, s).


wspP3HS

Давление в области 3 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspP3HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – давление в области 3 [Па], тип: double.

Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).


wspP3RT

Давление в области 3 [Па] как функция величин: плотность r [кг/м3], температура t [K]:

wspP3RT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – давление в области 3 [Па], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspP5HS

Давление в области 5 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspP5HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – давление в области 5 [Па], тип: double.

Функция основана на использовании термодинамических соотношений для поиска давления в области 5 методом Ньютона.


wspP23T

Давление на линии между областями 2 и 3 [Па] как функция величин: температура t [K]:

wspP23T(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – давление на линии между областями 2 и 3 [Па], тип: double.

Функция основана на Формуляции 1997 для теплофизических свойств воды и водяного пара. Используется в функции wspWATERSTATEAREA при определении области параметров.


wspPB23HS

Давление на линии между областями 2 и 3 [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspPB23HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – давление на линии между областями 2 и 3 [Па], тип: double.

Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).


wspPHASESTATEPT

Область фазового состояния как функция величин: давление p [Па], температура t [K]:

wspPHASESTATEPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – область фазового состояния, тип: long.

Функция возвращает фазовое состояние в точке, заданной параметрами (p, t). Результат функции вычисляется следущим образом: если давление p или температура t больше критических значений (Pкр или Tкр), то возвращается значение "3" (закритическая область). Если точка лежит выше линии насыщения (в диаграмме P-T), то возвращается значение "1" (фазовое состояние - жидкость). Если точка лежит ниже линии насыщения (в диаграмме P-T), то возвращается значение "2" (фазовое состояние - пар). Если точка находится ниже тройной точки, то возвращается значение ошибки ("-1").


wspPHS

Давление [Па] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspPHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – давление [Па], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspPKWPT

Отрицательный десятичный логарифм ионного произведения воды [-] как функция величин: давление p [Па], температура t [K]:

wspPKWPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – отрицательный десятичный логарифм ионного произведения воды [-], тип: double.

Основана на функции wspPKWRT(r, t), которая, в свою очередь, основана на "Release on the Ionization Constant of H2O, August 2007" от IAPWS.


wspPKWRT

Отрицательный десятичный логарифм ионного произведения воды [-] как функция величин: плотность r [кг/м3], температура t [K]:

wspPKWRT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – отрицательный десятичный логарифм ионного произведения воды [-], тип: double.

Основана на "Release on the Ionization Constant of H2O, August 2007" от IAPWS.


wspPMELTIT

Давление на линии плавления льда модификации I [Па] как функция величин: температура t [K]:

wspPMELTIT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – давление на линии плавления льда модификации I [Па], тип: double.

Функция основана на "Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance" IAPWS (Milan, Italy, September 1993).


wspPRANDTLEEXPANSIONPTPEFF

Число Прандтля в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspPRANDTLEEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – число Прандтля в конце процесса расширения/сжатия [-], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspPRANDTLEEXPANSIONPTXPEFF

Число Прандтля в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspPRANDTLEEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – число Прандтля в конце процесса расширения/сжатия [-], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspPRANDTLEHS

Число Прандтля [-] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspPRANDTLEHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – число Прандтля [-], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspPRANDTLEMSPT

Число Прандтля в метастабильной области [-] как функция величин: давление p [Па], температура t [K]:

wspPRANDTLEMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – число Прандтля в метастабильной области [-], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspPRANDTLEPH

Число Прандтля [-] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspPRANDTLEPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – число Прандтля [-], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspPRANDTLEPTX.


wspPRANDTLEPS

Число Прандтля [-] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspPRANDTLEPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – число Прандтля [-], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspPRANDTLEPTX.


wspPRANDTLEPT

Число Прандтля [-] как функция величин: давление p [Па], температура t [K]:

wspPRANDTLEPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – число Прандтля [-], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97 и соответствующими формуляциями для входящих в формулу свойств. Для вычислений используется формула: Pr = DYNVIS · CP / THERMCOND, где DYNVIS вычисляется по функции wspDYNVISPT, CP - по функции wspCPPT и THERMCOND - по функции wspTHERMCONDPT.


wspPRANDTLEPTX

Число Прандтля [-] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspPRANDTLEPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – число Прандтля [-], тип: double.

Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspPRANDTLEPT или wspPRANDTLESTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspPRANDTLESST

Число Прандтля пара на линии насыщения [-] как функция величин: температура t [K]:

wspPRANDTLESST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – число Прандтля пара на линии насыщения [-], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspPRANDTLESTX

Число Прандтля в двухфазной области [-] как функция величин: температура t [K], степень сухости x [-]:

wspPRANDTLESTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – число Прандтля в двухфазной области [-], тип: double.

Данная функция использует функции wspPRANDTLESST и wspPRANDTLESWT, которые возвращают число Прандтля пара и воды на линии насыщения. При вычислениях используется следующая формула: PRANDTLEx = (1 - X)·PRANDTLEw + X·PRANDTLEs, где PRANDTLEs = wspPRANDTLESST, PRANDTLEw = wspPRANDTLESWT и X - степень сухости.


wspPRANDTLESWT

Число Прандтля воды на линии насыщения [-] как функция величин: температура t [K]:

wspPRANDTLESWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – число Прандтля воды на линии насыщения [-], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspPST

Давление на линии насыщения [Па] как функция величин: температура t [K]:

wspPST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – давление на линии насыщения [Па], тип: double.

Функция основана на "Supplementary Release on Saturation Properties of Ordinary Water Substance" от Международной Ассоциации по Свойствам Воды и Водяного Пара. Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspPSUBT

Давление на линии сублимации [Па] как функция величин: температура t [K]:

wspPSUBT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – давление на линии сублимации [Па], тип: double.

Функция основана на "Release on the Pressure along the Melting and the Sublimation Curves of Ordinary Water Substance" IAPWS (Milan, Italy, September 1993).


wspPT1HS

Параметры в области 1 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspPT1HS(h, s, *p, *t)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • p – давление [Па], тип: double. Внимание! Это выходной параметр;
  • t – температура [K], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – параметры в области 1, тип: double.

Функция основана на использовании термодинамических соотношений для поиска параметров в области 1 методом Ньютона.

Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspPT1RH

Параметры в области 1 как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

wspPT1RH(r, h, *p, *t)

где:

  • r – плотность [кг/м3], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • p – давление [Па], тип: double. Внимание! Это выходной параметр;
  • t – температура [K], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – параметры в области 1, тип: double.

Функция использует основные уравнения Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара для определения давления и температуры по заданным плотности и удельной энтальпии. Для определения корней функции используется метод Ньютона.

Примечание: В пакете Mathcad функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspPT2HS

Параметры в области 2 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspPT2HS(h, s, *p, *t)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • p – давление [Па], тип: double. Внимание! Это выходной параметр;
  • t – температура [K], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – параметры в области 2, тип: double.

Функция основана на использовании термодинамических соотношений для поиска параметров в области 2 методом Ньютона.

Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspPT2RH

Параметры в области 2 как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

wspPT2RH(r, h, *p, *t)

где:

  • r – плотность [кг/м3], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • p – давление [Па], тип: double. Внимание! Это выходной параметр;
  • t – температура [K], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – параметры в области 2, тип: double.

Функция использует основные уравнения Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара для определения давления и температуры по заданным плотности и удельной энтальпии. Для определения корней функции используется метод Ньютона.

Примечание: В пакете Mathcad функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspPT3HS

Параметры в области 3 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspPT3HS(h, s, *p, *t)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • p – давление [Па], тип: double. Внимание! Это выходной параметр;
  • t – температура [K], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – параметры в области 3, тип: double.

Функция основана на работе функции wspRT3HS. После вызова последней по основным уравнениям формуляции IF-97 определяется давление.

Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspPT5HS

Параметры в области 5 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspPT5HS(h, s, *p, *t)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • p – давление [Па], тип: double. Внимание! Это выходной параметр;
  • t – температура [K], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – параметры в области 5, тип: double.

Функция основана на использовании термодинамических соотношений для поиска параметров в области 5 методом Ньютона.

Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspPT5RH

Параметры в области 5 как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

wspPT5RH(r, h, *p, *t)

где:

  • r – плотность [кг/м3], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • p – давление [Па], тип: double. Внимание! Это выходной параметр;
  • t – температура [K], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – параметры в области 5, тип: double.

Функция использует основные уравнения Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара для определения давления и температуры по заданным плотности и удельной энтальпии. Для определения корней функции используется метод Ньютона.

Примечание: В пакете Mathcad функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (r, h) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspPTHS

Результат вычисления свойств как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspPTHS(h, s, *p, *t)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • p – давление [Па], тип: double. Внимание! Это выходной параметр;
  • t – температура [K], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств, тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).

Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspR3PT

Плотность в области 3 [кг/м3] как функция величин: давление p [Па], температура t [K]:

wspR3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – плотность в области 3 [кг/м3], тип: double.

Функция рассчитывает плотность в области 3 с использованием функции wspR3PTR0 с соответствующими начальными приближениями для воды и пара. Используется для унификации функций в различных областях Формуляции IF-97.


wspR3PTR0

Плотность в области 3 [кг/м3] как функция величин: давление p [Па], температура t [K], начальная плотность r0 [кг/м3]:

wspR3PTR0(p, t, r0)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • r0 – начальная плотность [кг/м3], тип: double;
  • Возвращаемый результат – плотность в области 3 [кг/м3], тип: double.

В данной функции используется метод Ньютона с начальным приближением для определения плотности в зависимости от p и t. Используется для унификации функций в различных областях Формуляции IF-97.


wspRIPTL

Показатель преломления [-] как функция величин: давление p [Па], температура t [K], длина волны wavelength [м]:

wspRIPTL(p, t, wavelength)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • wavelength – длина волны [м], тип: double;
  • Возвращаемый результат – показатель преломления [-], тип: double.

Основана на функции wspRIRTL(r, t, wavelength), которая, в свою очередь, основана на "Release on the Refractive Index of Ordinary Water Substance as a Function of Wavelength, Temperature and Pressure", 1997 от IAPWS. Диапазон использования: температура от -12 до 500°C, плотность до 1060 кг/м3 и длина волны от 0.2 мкм до 1.1 мкм. Используемые уравнения экстраполируются достаточно гладко длины волны 1.9 мкм для жидкости.


wspRIRTL

Показатель преломления [-] как функция величин: плотность r [кг/м3], температура t [K], длина волны wavelength [м]:

wspRIRTL(r, t, wavelength)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • wavelength – длина волны [м], тип: double;
  • Возвращаемый результат – показатель преломления [-], тип: double.

Основана на "Release on the Refractive Index of Ordinary Water Substance as a Function of Wavelength, Temperature and Pressure", 1997 от IAPWS. Диапазон использования: температура от -12 до 500°C, плотность до 1060 кг/м3 и длина волны от 0.2 мкм до 1.1 мкм. Используемые уравнения экстраполируются достаточно гладко длины волны 1.9 мкм для жидкости.


wspROUGHHSSS

Удельная энтальпия пара на линии насыщения [Дж/кг] как функция величин: удельная энтропия s [Дж/(кг·К)]:

wspROUGHHSSS(s)

где:

  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная энтальпия пара на линии насыщения [Дж/кг], тип: double.

Функция использует функцию из дополнительного набора уравнений для Формуляции IF-97.


wspROUGHHSWS

Удельная энтальпия воды на линии насыщения [Дж/кг] как функция величин: удельная энтропия s [Дж/(кг·К)]:

wspROUGHHSWS(s)

где:

  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная энтальпия воды на линии насыщения [Дж/кг], тип: double.

Функция использует функцию из дополнительного набора уравнений для Формуляции IF-97.


wspROUGHRSST

Приближенное значение плотности пара на линии насыщения [кг/м3] как функция величин: температура t [K]:

wspROUGHRSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – приближенное значение плотности пара на линии насыщения [кг/м3], тип: double.

Данная функция позволяет быстро вычислить приближенное значение плотности пара на линии насыщения.


wspROUGHRSWT

Приближенное значение плотности воды на линии насыщения [кг/м3] как функция величин: температура t [K]:

wspROUGHRSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – приближенное значение плотности воды на линии насыщения [кг/м3], тип: double.

Данная функция позволяет быстро вычислить приближенное значение плотности воды на линии насыщения.


wspRST

Удельная теплота парообразования [Дж/кг] как функция величин: температура t [K]:

wspRST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная теплота парообразования [Дж/кг], тип: double.

Вычисляется по формуле r = (hs - hw), где hs - удельная энтальпия пара на линии насыщения, hw - удельная энтальпия воды на линии насыщения.


wspRT3HS

Параметры в области 3 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspRT3HS(h, s, *r, *t)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • r – плотность [кг/м3], тип: double. Внимание! Это выходной параметр;
  • t – температура [K], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – параметры в области 3, тип: double.

Функция основана на использовании термодинамических соотношений для поиска параметров в области 3 методом Ньютона.

Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspS1PT

Удельная энтропия в области 1 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspS1PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия в области 1 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspS2PT

Удельная энтропия в области 2 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspS2PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия в области 2 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspS3PT

Удельная энтропия в области 3 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspS3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия в области 3 [Дж/(кг·К)], тип: double.

Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.


wspS3RT

Удельная энтропия в области 3 [Дж/(кг·К)] как функция величин: плотность r [кг/м3], температура t [K]:

wspS3RT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия в области 3 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspS5PT

Удельная энтропия в области 5 [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspS5PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия в области 5 [Дж/(кг·К)], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspSETCHECKRANGEMODE

Устанавливает и возвращает режим ведения проверки диапазона аргументов функций как функция величин: mode mode:

wspSETCHECKRANGEMODE(mode)

где:

  • mode – mode, тип: long;
  • Возвращаемый результат – устанавливает и возвращает режим ведения проверки диапазона аргументов функций, тип: long.

Используется в функциях перед вычислениями. Если аргумент функции равен нулю, то проверка не производится и скорость вычислений увеличивается, в то время как могут быть ошибки при вычислениях за областью определения.


wspSETDELTAPRESSURE

Устанавливает и возвращает максимальную разность между значениями давлений при вычислении параметров в области 3 [Па] как функция величин: разность давлений delta [Па]:

wspSETDELTAPRESSURE(delta)

где:

  • delta – разность давлений [Па], тип: double;
  • Возвращаемый результат – устанавливает и возвращает максимальную разность между значениями давлений при вычислении параметров в области 3 [Па], тип: double.

Функция устарела. Начиная с версии 6.0 она не используется!

Примечание: Данная функция устарела и не рекомендуется к использованию.


wspSETDELTATS

Устанавливает и возвращает максимальную разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K] как функция величин: разность температур delta [K]:

wspSETDELTATS(delta)

где:

  • delta – разность температур [K], тип: double;
  • Возвращаемый результат – устанавливает и возвращает максимальную разность между температурой на линии насыщения и температурой-аргументом в функции wspWATERSTATEAREA [K], тип: double.

Функция устарела. Начиная с версии 6.0 она не используется!

Примечание: Данная функция устарела и не рекомендуется к использованию.


wspSETINITSTEAMDENSITY

Устанавливает и возвращает начальное приближение плотности пара в области 3 [кг/м3] как функция величин: плотность r [кг/м3]:

wspSETINITSTEAMDENSITY(r)

где:

  • r – плотность [кг/м3], тип: double;
  • Возвращаемый результат – устанавливает и возвращает начальное приближение плотности пара в области 3 [кг/м3], тип: double.

Функция устарела. Начиная с версии 6.0 она не используется!

Примечание: Данная функция устарела и не рекомендуется к использованию.


wspSETINITWATERDENSITY

Устанавливает и возвращает начальное приближение плотности воды в области 3 [кг/м3] как функция величин: плотность r [кг/м3]:

wspSETINITWATERDENSITY(r)

где:

  • r – плотность [кг/м3], тип: double;
  • Возвращаемый результат – устанавливает и возвращает начальное приближение плотности воды в области 3 [кг/м3], тип: double.

Функция устарела. Начиная с версии 6.0 она не используется!

Примечание: Данная функция устарела и не рекомендуется к использованию.


wspSETLASTERROR

Устанавливает и возвращает код последней ошибки как функция величин: код ошибки ErrCode:

wspSETLASTERROR(ErrCode)

где:

  • ErrCode – код ошибки, тип: long;
  • Возвращаемый результат – устанавливает и возвращает код последней ошибки, тип: long.

Данная функция может быть использована для подсчета количества ошибок: все коды ошибок пакета WaterSteamPro начинаются с нуля (ноль - это ошибка отсутствует) и последовательно увеличиваются с шагом 1. В случае если параметр данной функции больше максимального, то функция возвращает ноль, а иначе код установленной ошибки.


wspSETMAXITERATION

Устанавливает и возвращает максимальное число итераций в методе Ньютона как функция величин: максимальное число итераций maxiteration:

wspSETMAXITERATION(maxiteration)

где:

  • maxiteration – максимальное число итераций, тип: long;
  • Возвращаемый результат – устанавливает и возвращает максимальное число итераций в методе Ньютона, тип: long.

Это число используется в функциях, где используется метод Ньютона. Если число итераций больше, чем данное значение, то генерируется ошибка с кодом WSP_CANT_FIND_ROOT (3).


wspSETTOLERANCE

Устанавливает и возвращает относительную точность функций WaterSteamPro [-] как функция величин: точность tolerance [-]:

wspSETTOLERANCE(tolerance)

где:

  • tolerance – точность [-], тип: double;
  • Возвращаемый результат – устанавливает и возвращает относительную точность функций WaterSteamPro [-], тип: double.

Используется в функциях, требующих понятия точности вычисления.


wspSETTOLERANCEMODE

Устанавливает и возвращает режим ведения уточнения результатов функций как функция величин: mode mode:

wspSETTOLERANCEMODE(mode)

где:

  • mode – mode, тип: long;
  • Возвращаемый результат – устанавливает и возвращает режим ведения уточнения результатов функций, тип: long.

Используется в функциях, где может вестить уточнение результата (например, функции с аргументами (p, h) и (p, s)). Если аргумент данной функции равен нулю, то уточнение запрещается и скорость вычислений увеличивается, в то время как точность уменьшается.


wspSEXPANSIONPTPEFF

Удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspSEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspSEXPANSIONPTXPEFF

Удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspSEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная энтропия в конце процесса расширения/сжатия [Дж/(кг·К)], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspSMSPT

Удельная энтропия в метастабильной области [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspSMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия в метастабильной области [Дж/(кг·К)], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspSPH

Удельная энтропия [Дж/(кг·К)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspSPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspSPTX.


wspSPT

Удельная энтропия [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K]:

wspSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspSxPT).


wspSPTX

Удельная энтропия [Дж/(кг·К)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspSPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная энтропия [Дж/(кг·К)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspSxPT или wspSSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspSSST

Удельная энтропия пара на линии насыщения [Дж/(кг·К)] как функция величин: температура t [K]:

wspSSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия пара на линии насыщения [Дж/(кг·К)], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspSSTX

Удельная энтропия в двухфазной области [Дж/(кг·К)] как функция величин: температура t [K], степень сухости x [-]:

wspSSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная энтропия в двухфазной области [Дж/(кг·К)], тип: double.

Данная функция использует функции wspSSST и wspSSWT, которые возвращают удельные энтропии пара и воды на линии насыщения. При вычислениях используется следующая формула: Sx = (1 - X)·Sw + X·Ss, где Ss = wspSSST, Sw = wspSSWT и X - степень сухости.


wspSSWT

Удельная энтропия воды на линии насыщения [Дж/(кг·К)] как функция величин: температура t [K]:

wspSSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная энтропия воды на линии насыщения [Дж/(кг·К)], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspSURFTENT

Коэффициент поверхностного натяжения [Н/м] как функция величин: температура t [K]:

wspSURFTENT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент поверхностного натяжения [Н/м], тип: double.

Функция основана на "Release on The Surface Tension of Ordinary Water Substance 1995" от Международной Ассоциации по Свойствам Воды и Водяного Пара. Область определения функции от тройной точки (273.16K или 0.01°C) до 647.096 K.


wspT1HS

Температура в области 1 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspT1HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 1 [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT1PH

Температура в области 1 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspT1PH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура в области 1 [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT1PS

Температура в области 1 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspT1PS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 1 [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT2APH

Температура в области 2a [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspT2APH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура в области 2a [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT2APS

Температура в области 2a [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspT2APS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 2a [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT2BPH

Температура в области 2b [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspT2BPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура в области 2b [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT2BPS

Температура в области 2b [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspT2BPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 2b [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT2CPH

Температура в области 2c [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspT2CPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура в области 2c [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT2CPS

Температура в области 2c [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspT2CPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 2c [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT2HS

Температура в области 2 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspT2HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 2 [K], тип: double.

Функция основана на Дополнительных уравнениях для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspT2PH

Температура в области 2 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspT2PH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура в области 2 [K], тип: double.

Функция для расчета использует функции wspT2APH, wspT2BPH и wspT2CPH.


wspT2PS

Температура в области 2 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspT2PS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 2 [K], тип: double.

Функция для расчета использует функции wspT2APS, wspT2BPS и wspT2CPS.


wspT3HS

Температура в области 3 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspT3HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 3 [K], тип: double.

Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).


wspT3PH

Температура в области 3 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspT3PH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура в области 3 [K], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.


wspT3PS

Температура в области 3 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspT3PS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 3 [K], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.


wspT3RH

Температура в области 3 [K] как функция величин: плотность r [кг/м3], удельная энтальпия h [Дж/кг]:

wspT3RH(r, h)

где:

  • r – плотность [кг/м3], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура в области 3 [K], тип: double.

Функция использует основные уравнения Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара для определения температуры по заданным плотности и удельной энтальпии. Для определения корня функции используется метод Ньютона.


wspT5HS

Температура в области 5 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspT5HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 5 [K], тип: double.

Функция основана на использовании термодинамических соотношений для поиска температуры в области 5 методом Ньютона.


wspT5PH

Температура в области 5 [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspT5PH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура в области 5 [K], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.


wspT5PS

Температура в области 5 [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspT5PS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура в области 5 [K], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.


wspT23P

Температура на линии между областями 2 и 3 [K] как функция величин: давление p [Па]:

wspT23P(p)

где:

  • p – давление [Па], тип: double;
  • Возвращаемый результат – температура на линии между областями 2 и 3 [K], тип: double.

Функция основана на Формуляции 1997 для теплофизических свойств воды и водяного пара. Используется в функции wspWATERSTATEAREA при определении области параметров.


wspTB23HS

Температура на линии между областями 2 и 3 [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspTB23HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура на линии между областями 2 и 3 [K], тип: double.

Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).


wspTEXPANSIONPTPEFF

Температура в конце процесса расширения/сжатия [K] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspTEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – температура в конце процесса расширения/сжатия [K], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspTEXPANSIONPTXPEFF

Температура в конце процесса расширения/сжатия [K] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspTEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – температура в конце процесса расширения/сжатия [K], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspTHERMCONDEXPANSIONPTPEFF

Коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspTHERMCONDEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspTHERMCONDEXPANSIONPTXPEFF

Коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspTHERMCONDEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности в конце процесса расширения/сжатия [Вт/(м·K)], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspTHERMCONDHS

Коэффициент теплопроводности [Вт/(м·K)] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspTHERMCONDHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspTHERMCONDMSPT

Коэффициент теплопроводности в метастабильной области [Вт/(м·K)] как функция величин: давление p [Па], температура t [K]:

wspTHERMCONDMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности в метастабильной области [Вт/(м·K)], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspTHERMCONDPH

Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspTHERMCONDPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspTHERMCONDPTX.


wspTHERMCONDPS

Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspTHERMCONDPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspTHERMCONDPTX.


wspTHERMCONDPT

Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], температура t [K]:

wspTHERMCONDPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97 и формуляцией для вычисления теплопроводности. Для вычисления используется функция wspTHERMCONDRT с аргументом-плотностью, вычисляемому по обобщенной функции wspVPT.


wspTHERMCONDPTX

Коэффициент теплопроводности [Вт/(м·K)] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspTHERMCONDPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

Функция определена на всей области параметров, описываемой соответствующими формуляциями. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspTHERMCONDPT или wspTHERMCONDSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspTHERMCONDRT

Коэффициент теплопроводности [Вт/(м·K)] как функция величин: плотность r [кг/м3], температура t [K]:

wspTHERMCONDRT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности [Вт/(м·K)], тип: double.

Основана на "the IAPWS Formulation 1985 for thermal Conductivity" с коррекцией для Международной Температурной Шкалы 1990.


wspTHERMCONDSST

Коэффициент теплопроводности пара на линии насыщения [Вт/(м·K)] как функция величин: температура t [K]:

wspTHERMCONDSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности пара на линии насыщения [Вт/(м·K)], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspTHERMCONDSTX

Коэффициент теплопроводности в двухфазной области [Вт/(м·K)] как функция величин: температура t [K], степень сухости x [-]:

wspTHERMCONDSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности в двухфазной области [Вт/(м·K)], тип: double.

Данная функция использует функции wspTHERMCONDSST и wspTHERMCONDSWT, которые возвращают коэффициент теплопроводности пара и воды на линии насыщения. При вычислениях используется следующая формула: THERMCONDx = (1 - X)·THERMCONDw + X·THERMCONDs, где THERMCONDs = wspTHERMCONDSST, THERMCONDw = wspTHERMCONDSWT и X - степень сухости.


wspTHERMCONDSWT

Коэффициент теплопроводности воды на линии насыщения [Вт/(м·K)] как функция величин: температура t [K]:

wspTHERMCONDSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – коэффициент теплопроводности воды на линии насыщения [Вт/(м·K)], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspTHS

Температура [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspTHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура [K], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspTPH

Температура [K] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspTPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – температура [K], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH).


wspTPS

Температура [K] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspTPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура [K], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS).


wspTSHS

Температура на линии насыщения [K] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspTSHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – температура на линии насыщения [K], тип: double.

Функция вычисляет на основе термодинамических соотношений температуру на линии насыщения для заданных h и s. При поиске используется метод Ньютона.


wspTSP

Температура на линии насыщения [K] как функция величин: давление p [Па]:

wspTSP(p)

где:

  • p – давление [Па], тип: double;
  • Возвращаемый результат – температура на линии насыщения [K], тип: double.

Функция основана на "Supplementary Release on Saturation Properties of Ordinary Water Substance" от Международной Ассоциации по Свойствам Воды и Водяного Пара. Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspTXSHS

Параметры в двухфазной области как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspTXSHS(h, s, *t, *x)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • t – температура насыщения [K], тип: double. Внимание! Это выходной параметр;
  • x – степень сухости [-], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – параметры в двухфазной области, тип: double.

Функция вычисляет на основе термодинамических соотношений температуру на линии насыщения и степень сухости для заданных h и s. При поиске используется метод Ньютона.

Примечание: В пакете Mathcad функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (h, s) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspU1PT

Удельная внутренняя энергия в области 1 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspU1PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия в области 1 [Дж/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspU2PT

Удельная внутренняя энергия в области 2 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspU2PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия в области 2 [Дж/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspU3PT

Удельная внутренняя энергия в области 3 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspU3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия в области 3 [Дж/кг], тип: double.

Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.


wspU3RT

Удельная внутренняя энергия в области 3 [Дж/кг] как функция величин: плотность r [кг/м3], температура t [K]:

wspU3RT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия в области 3 [Дж/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspU5PT

Удельная внутренняя энергия в области 5 [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspU5PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия в области 5 [Дж/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspUEXPANSIONPTPEFF

Удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspUEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspUEXPANSIONPTXPEFF

Удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspUEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия в конце процесса расширения/сжатия [Дж/кг], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspUHS

Удельная внутренняя энергия [Дж/кг] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspUHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspUMSPT

Удельная внутренняя энергия в метастабильной области [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspUMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия в метастабильной области [Дж/кг], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspUPH

Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspUPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspUPTX.


wspUPS

Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspUPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspUPTX.


wspUPT

Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], температура t [K]:

wspUPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspUxPT).


wspUPTX

Удельная внутренняя энергия [Дж/кг] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspUPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия [Дж/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspUxPT или wspUSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspUSST

Удельная внутренняя энергия пара на линии насыщения [Дж/кг] как функция величин: температура t [K]:

wspUSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия пара на линии насыщения [Дж/кг], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspUSTX

Удельная внутренняя энергия в двухфазной области [Дж/кг] как функция величин: температура t [K], степень сухости x [-]:

wspUSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия в двухфазной области [Дж/кг], тип: double.

Данная функция использует функции wspUSST и wspUSWT, которые возвращают удельные внутренние энергии пара и воды на линии насыщения. При вычислениях используется следующая формула: Ux = (1 - X)·Uw + X·Us, где Us = wspUSST, Uw = wspUSWT и X - степень сухости.


wspUSWT

Удельная внутренняя энергия воды на линии насыщения [Дж/кг] как функция величин: температура t [K]:

wspUSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельная внутренняя энергия воды на линии насыщения [Дж/кг], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspV1PT

Удельный объем в области 1 [м3/кг] как функция величин: давление p [Па], температура t [K]:

wspV1PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем в области 1 [м3/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspV2PT

Удельный объем в области 2 [м3/кг] как функция величин: давление p [Па], температура t [K]:

wspV2PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем в области 2 [м3/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspV3HS

Удельный объем в области 3 [м3/kg] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspV3HS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельный объем в области 3 [м3/kg], тип: double.

Функция основана на "Supplementary Release on Backward Equations for p(h, s) for Region 3, Equations as a Function of h and s for the Region Boundaries, and a Equation Tsat(h, s) for Wet Steam of the IAPWS Industrial Formulation 1997 for the Thermodynamic Properties of Water and Steam" (Сентябрь 2004).


wspV3PH

Удельный объем в области 3 [м3/кг] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspV3PH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – удельный объем в области 3 [м3/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.


wspV3PS

Удельный объем в области 3 [м3/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspV3PS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельный объем в области 3 [м3/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Для определения корней функции от двух аргументов используется метод Ньютона.


wspV3PT

Удельный объем в области 3 [м3/кг] как функция величин: давление p [Па], температура t [K]:

wspV3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем в области 3 [м3/кг], тип: double.

Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.


wspV5PT

Удельный объем в области 5 [м3/кг] как функция величин: давление p [Па], температура t [K]:

wspV5PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем в области 5 [м3/кг], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspVEXPANSIONPTPEFF

Удельный объем в конце процесса расширения/сжатия [м3/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspVEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельный объем в конце процесса расширения/сжатия [м3/кг], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspVEXPANSIONPTXPEFF

Удельный объем в конце процесса расширения/сжатия [м3/кг] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspVEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – удельный объем в конце процесса расширения/сжатия [м3/кг], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspVHS

Удельный объем [м3/кг] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspVHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельный объем [м3/кг], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspVMSPT

Удельный объем в метастабильной области [м3/кг] как функция величин: давление p [Па], температура t [K]:

wspVMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем в метастабильной области [м3/кг], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspVPH

Удельный объем [м3/кг] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspVPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – удельный объем [м3/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspVPTX.


wspVPS

Удельный объем [м3/кг] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspVPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – удельный объем [м3/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspVPTX.


wspVPT

Удельный объем [м3/кг] как функция величин: давление p [Па], температура t [K]:

wspVPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем [м3/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspVxPT).


wspVPTX

Удельный объем [м3/кг] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspVPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельный объем [м3/кг], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspVxPT или wspVSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspVSST

Удельный объем пара на линии насыщения [м3/кг] как функция величин: температура t [K]:

wspVSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем пара на линии насыщения [м3/кг], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspVSTX

Удельный объем в двухфазной области [м3/кг] как функция величин: температура t [K], степень сухости x [-]:

wspVSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – удельный объем в двухфазной области [м3/кг], тип: double.

Данная функция использует функции wspVSST и wspVSWT, которые возвращают удельные объемы пара и воды на линии насыщения. При вычислениях используется следующая формула: Vx = (1 - X)·Vw + X·Vs, где Vs = wspVSST, Vw = wspVSWT и X - степень сухости.


wspVSWT

Удельный объем воды на линии насыщения [м3/кг] как функция величин: температура t [K]:

wspVSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – удельный объем воды на линии насыщения [м3/кг], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspVUSHCVWDERPT1PT

Результат вычисления свойств в области 1 как функция величин: давление p [Па], температура t [K]:

wspVUSHCVWDERPT1PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
  • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
  • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
  • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
  • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств в области 1, тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspVUSHCVWDERPT2PT

Результат вычисления свойств в области 2 как функция величин: давление p [Па], температура t [K]:

wspVUSHCVWDERPT2PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
  • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
  • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
  • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
  • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств в области 2, тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspVUSHCVWDERPT3PT

Результат вычисления свойств в области 3 как функция величин: давление p [Па], температура t [K]:

wspVUSHCVWDERPT3PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
  • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
  • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
  • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
  • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств в области 3, тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspVUSHCVWDERPT3RT

Результат вычисления свойств в области 3 как функция величин: плотность r [кг/м3], температура t [K]:

wspVUSHCVWDERPT3RT(r, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
  • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
  • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
  • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
  • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств в области 3, тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

Примечание: В пакете Mathcad функция имеет только аргументы (r, t) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (r, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspVUSHCVWDERPT5PT

Результат вычисления свойств в области 5 как функция величин: давление p [Па], температура t [K]:

wspVUSHCVWDERPT5PT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
  • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
  • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
  • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
  • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств в области 5, тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspVUSHCVWDERPTMSPT

Результат вычисления свойств переохлажденного пара (метастабильная область) как функция величин: давление p [Па], температура t [K]:

wspVUSHCVWDERPTMSPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
  • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
  • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
  • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
  • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств переохлажденного пара (метастабильная область), тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.

Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspVUSHCVWDERPTPT

Результат вычисления свойств как функция величин: давление p [Па], температура t [K]:

wspVUSHCVWDERPTPT(p, t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
  • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
  • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
  • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
  • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств, тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspVUSHDERPTxPT) в зависимости от области. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

Примечание: В пакете Mathcad функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (p, t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspVUSHCVWDERPTSST

Результат вычисления свойств для пара на линии насыщения как функция величин: температура насыщения t [K]:

wspVUSHCVWDERPTSST(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

где:

  • t – температура насыщения [K], тип: double;
  • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
  • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
  • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
  • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
  • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств для пара на линии насыщения, тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

Примечание: В пакете Mathcad функция имеет только аргументы (t) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspVUSHCVWDERPTSWT

Результат вычисления свойств для воды на линии насыщения как функция величин: температура насыщения t [K]:

wspVUSHCVWDERPTSWT(t, *v, *u, *s, *h, *Cv, *w, *DVDPt, *DUDPt, *DSDPt, *DHDPt, *DVDTp, *DUDTp, *DSDTp, *DHDTp)

где:

  • t – температура насыщения [K], тип: double;
  • v – удельный объем [м3/кг], тип: double. Внимание! Это выходной параметр;
  • u – удельная внутренняя энергия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • s – удельная энтропия [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • h – удельная энтальпия [Дж/кг], тип: double. Внимание! Это выходной параметр;
  • Cv – удельная изохорная теплоемкость [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • w – скорость звука [м/с], тип: double. Внимание! Это выходной параметр;
  • DVDPt – производная удельного объема по давлению при постоянной температуре [м3/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DUDPt – производная удельной внутренней энергии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DSDPt – производная удельной энтропии по давлению при постоянной температуре [Дж/(кг·К·Па)], тип: double. Внимание! Это выходной параметр;
  • DHDPt – производная удельной энтальпии по давлению при постоянной температуре [Дж/(кг·Па)], тип: double. Внимание! Это выходной параметр;
  • DVDTp – производная удельного объема по температуре при постоянном давлении [м3/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DUDTp – производная удельной внутренней энергии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • DSDTp – производная удельной энтропии по температуре при постоянном давлении [Дж/(кг·К·К)], тип: double. Внимание! Это выходной параметр;
  • DHDTp – производная удельной энтальпии по температуре при постоянном давлении [Дж/(кг·К)], тип: double. Внимание! Это выходной параметр;
  • Возвращаемый результат – результат вычисления свойств для воды на линии насыщения, тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Данная функция возвращает набор свойств, что значительно ускоряет вычисления при вычислении несколько свойств в одной точке.

Примечание: В пакете Mathcad функция имеет только аргументы (t) и возвращает массив, содержащий выходные параметры в системе СИ.

Примечание: В пакете Excel функция имеет только аргументы (t) и возвращает массив, содержащий выходные параметры в системе СИ. По умолчанию будет выводиться значение только первого элемента массива (первый возвращаемый параметр). Для получения всех значений необходимо: 1) Введите формулу, вызывающую данную функцию в одну из ячеек (например B2). 2) Выделите ячейки: первая ячейка с введенной формулой и несколько ячеек справа (например, с B2 по C2). 3) Нажмите клавишу F2. 4) Нажмите комбинацию клавиш Ctrl+Shift+Enter. После этого в выделенных ячейках появятся соответствующие значения. Если необходимо заполнять ячейки по вертикали (т.е. с B2 по B3) используйте встроенную функцию Excel "ТРАНСП".


wspW1PT

Скорость звука в области 1 [м/с] как функция величин: давление p [Па], температура t [K]:

wspW1PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – скорость звука в области 1 [м/с], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspW2PT

Скорость звука в области 2 [м/с] как функция величин: давление p [Па], температура t [K]:

wspW2PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – скорость звука в области 2 [м/с], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspW3PT

Скорость звука в области 3 [м/с] как функция величин: давление p [Па], температура t [K]:

wspW3PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – скорость звука в области 3 [м/с], тип: double.

Функция использует функцию wspR3PT для расчета плотности по давлению и температуре.


wspW3RT

Скорость звука в области 3 [м/с] как функция величин: плотность r [кг/м3], температура t [K]:

wspW3RT(r, t)

где:

  • r – плотность [кг/м3], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – скорость звука в области 3 [м/с], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspW5PT

Скорость звука в области 5 [м/с] как функция величин: давление p [Па], температура t [K]:

wspW5PT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – скорость звука в области 5 [м/с], тип: double.

Функция основана на Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара.


wspWATERSTATEAREA

Область параметров Формуляции IF-97 как функция величин: давление p [Па], температура t [K]:

wspWATERSTATEAREA(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – область параметров Формуляции IF-97, тип: long.

Функция основана на распределении областей в Формуляции 1997 для теплофизических свойств воды и водяного пара. Используется в обобщенных функциях.


wspWATERSTATEAREA2

Область параметров Формуляции IF-97 (версия 2) как функция величин: давление p [Па], температура t [K]:

wspWATERSTATEAREA2(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – область параметров Формуляции IF-97 (версия 2), тип: long.

Функция основана на распределении областей в Формуляции 1997 для теплофизических свойств воды и водяного пара. Второй вариант - без двухфазной области - при параметрах на линии насыщения возвращается вторая область. Используется в обобщенных функциях.


wspWATERSTATEAREAHS

Область параметров Формуляции IF-97 как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspWATERSTATEAREAHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – область параметров Формуляции IF-97, тип: long.

Функция основана на распределении областей Дополнительных уравнений для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Используется в обобщенных функциях.


wspWATERSTATEAREAPH

Область параметров Формуляции IF-97 как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspWATERSTATEAREAPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – область параметров Формуляции IF-97, тип: long.

Функция основана на распределении областей Дополнительных уравнений для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Используется в обобщенных функциях.


wspWATERSTATEAREAPS

Область параметров Формуляции IF-97 как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspWATERSTATEAREAPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – область параметров Формуляции IF-97, тип: long.

Функция основана на распределении областей Дополнительных уравнений для Формуляции 1997 теплофизических свойств воды для промышленных расчетов Международной Ассоциации по Свойствам Воды и Водяного Пара. Используется в обобщенных функциях.


wspWEXPANSIONPTPEFF

Скорость звука в конце процесса расширения/сжатия [м/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspWEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – скорость звука в конце процесса расширения/сжатия [м/с], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspWEXPANSIONPTXPEFF

Скорость звука в конце процесса расширения/сжатия [м/с] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspWEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – скорость звука в конце процесса расширения/сжатия [м/с], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspWHS

Скорость звука [м/с] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspWHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – скорость звука [м/с], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Далее определяются исходные переменные для уравнений области в этой точке (функции wspPTxHS и wspRT3HS). И в итоге вызывается функция для определения искомой величины по найденным значениям. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspWMSPT

Скорость звука в метастабильной области [м/с] как функция величин: давление p [Па], температура t [K]:

wspWMSPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – скорость звука в метастабильной области [м/с], тип: double.

Функция вычисляет свойства переохлажденного пара (в метастабильной области). Область параметров лежит при давлениях до 10 МПа и степени сухости выше 95%. Для вычислений используется специальная формуляция для метастабильной области, которая основана на Формуляции IF-97 от IAPWS.


wspWPH

Скорость звука [м/с] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspWPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – скорость звука [м/с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPH используется для определения области. Далее вызывается необходимая функция (wspTxPH). И в итоге вызывается функция wspWPTX.


wspWPS

Скорость звука [м/с] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspWPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – скорость звука [м/с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREAPS используется для определения области. Далее вызывается необходимая функция (wspTxPS). И в итоге вызывается функция wspWPTX.


wspWPT

Скорость звука [м/с] как функция величин: давление p [Па], температура t [K]:

wspWPT(p, t)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • Возвращаемый результат – скорость звука [м/с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе для определения области используется функция wspWATERSTATEAREA2(p, t). Далее вызывается необходимая функция (wspWxPT).


wspWPTX

Скорость звука [м/с] как функция величин: давление p [Па], температура t [K], степень сухости x [-]:

wspWPTX(p, t, x)

где:

  • p – давление [Па], тип: double;
  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – скорость звука [м/с], тип: double.

Функция определена на всей области параметров, описываемой формуляцией IF-97. При работе функция wspWATERSTATEAREA используется для определения области. Далее вызывается необходимая функция (wspWxPT или wspWSTX). Если точка лежит не в двухфазной области, то степень сухости игнорируется.


wspWSST

Скорость звука в паре на линии насыщения со стороны однофазной области [м/с] как функция величин: температура t [K]:

wspWSST(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – скорость звука в паре на линии насыщения со стороны однофазной области [м/с], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspWSTX

Скорость звука в двухфазной области [м/с] как функция величин: температура t [K], степень сухости x [-]:

wspWSTX(t, x)

где:

  • t – температура [K], тип: double;
  • x – степень сухости [-], тип: double;
  • Возвращаемый результат – скорость звука в двухфазной области [м/с], тип: double.

Данная функция использует функцию wspKSTX для вычисления скорости звука, с точки зрения термодинамики. Функция не учитывает структуру потока и поэтому не может использоваться без ее учета. До версии 5.6 данная функция использовала функции wspWSST и wspWSWT, которые возвращают скорости звука пара и воды на линии насыщения, что было неправильно с точки зрения термодинамики (при вычислениях использовалась следующая формула: Wx = (1 - X)·Ww + X·Ws, где Ws = wspWSST, Ww = wspWSWT и X - степень сухости).


wspWSWT

Скорость звука в воде на линии насыщения со стороны однофазной области [м/с] как функция величин: температура t [K]:

wspWSWT(t)

где:

  • t – температура [K], тип: double;
  • Возвращаемый результат – скорость звука в воде на линии насыщения со стороны однофазной области [м/с], тип: double.

Область определения функции от тройной точки воды (0.01°C) до критической точки (647.096K или 373.946°C).


wspXEXPANSIONPTPEFF

Степень сухости в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspXEXPANSIONPTPEFF(p0, t0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – степень сухости в конце процесса расширения/сжатия [-], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspXEXPANSIONPTXPEFF

Степень сухости в конце процесса расширения/сжатия [-] как функция величин: давление в начальной точке p0 [Па], температура в начальной точке t0 [K], степень сухости в начальной точке x0 [-], давление в конечной точке p1 [Па], внутренний относительный КПД процесса eff [-]:

wspXEXPANSIONPTXPEFF(p0, t0, x0, p1, eff)

где:

  • p0 – давление в начальной точке [Па], тип: double;
  • t0 – температура в начальной точке [K], тип: double;
  • x0 – степень сухости в начальной точке [-], тип: double;
  • p1 – давление в конечной точке [Па], тип: double;
  • eff – внутренний относительный КПД процесса [-], тип: double;
  • Возвращаемый результат – степень сухости в конце процесса расширения/сжатия [-], тип: double.

Функция возвращает искомый параметр в конце процесса расширения от параметров p0, t0, x0 до давления p1 с внутренним относительным КПД eff. Процесс рассчитывается по формуле: h1 = h0 - eff * (h0 - h1ад), где h0 - энтальпия в начальной точке, h1 - энтальпия в конечной точке, eff - КПД, h1ад - энтальпия в конечной точке при изоэнтропном (s = Const) равновесном расширении. Для расчета процессов сжатия необходимо использовать вместо КПД обратную величину (т.е. 1/eff).


wspXHS

Степень сухости [-] как функция величин: удельная энтальпия h [Дж/кг], удельная энтропия s [Дж/(кг·К)]:

wspXHS(h, s)

где:

  • h – удельная энтальпия [Дж/кг], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Алгоритм работы функции следующий: по заданным h и s определяется область состояния (по функции wspWATERSTATEAREAHS). Если эта область двухфазная, то вызывается функция для определения искомой величины. Для ускорения работы функций можно или отключать режим уточнения результата (функции wspGETTOLERANCEMODE и wspSETTOLERANCEMODE), или увеличивать/уменьшать относительную точность при поиске корня (функции wspGETTOLERANCE и wspSETTOLERANCE).


wspXPH

Степень сухости [-] как функция величин: давление p [Па], удельная энтальпия h [Дж/кг]:

wspXPH(p, h)

где:

  • p – давление [Па], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Алгоритм работы функции следующий: по заданным p и h определяется область состояния (по функции wspWATERSTATEAREAPH). Если эта область двухфазная, то вызывается функция для определения искомой величины.


wspXPS

Степень сухости [-] как функция величин: давление p [Па], удельная энтропия s [Дж/(кг·К)]:

wspXPS(p, s)

где:

  • p – давление [Па], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Алгоритм работы функции следующий: по заданным p и s определяется область состояния (по функции wspWATERSTATEAREAPS). Если эта область двухфазная, то вызывается функция для определения искомой величины.


wspXSTCP

Степень сухости [-] как функция величин: температура t [K], удельная изобарная теплоемкость (Cp) Cp [Дж/(кг·К)]:

wspXSTCP(t, Cp)

где:

  • t – температура [K], тип: double;
  • Cp – удельная изобарная теплоемкость (Cp) [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (CP - CPw)/(CPs - CPw), где CPw = wspCPSWT, CPs = wspCPSST.


wspXSTCV

Степень сухости [-] как функция величин: температура t [K], удельная изохорная теплоемкость (Cv) Cv [Дж/(кг·К)]:

wspXSTCV(t, Cv)

где:

  • t – температура [K], тип: double;
  • Cv – удельная изохорная теплоемкость (Cv) [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Начиная с версии 5.6 функция использует следующую формулу: X = (CV - CVDPw)/(CVDPs - CVDPw), где CVDPw = wspCVDPSWT, CVDPs = wspCVDPSST. До версии 5.6 функция использовала формулу без учета скачка значений изохорной теплоемкости на линии насыщения.


wspXSTD

Степень сухости [-] как функция величин: температура t [K], плотность r [кг/м3]:

wspXSTD(t, r)

где:

  • t – температура [K], тип: double;
  • r – плотность [кг/м3], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = rs * (rw - r) / (r * (rw - rs)), где rw = wspDSWT, rs = wspDSST.


wspXSTDYNVIS

Степень сухости [-] как функция величин: температура t [K], динамическая вязкость dv [Па·с]:

wspXSTDYNVIS(t, dv)

где:

  • t – температура [K], тип: double;
  • dv – динамическая вязкость [Па·с], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (DV - DVw)/(DVs - DVw), где DVw = wspDYNVISSWT, DVs = wspDYNVISSST.


wspXSTH

Степень сухости [-] как функция величин: температура t [K], удельная энтальпия h [Дж/кг]:

wspXSTH(t, h)

где:

  • t – температура [K], тип: double;
  • h – удельная энтальпия [Дж/кг], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (H - Hw)/(Hs - Hw), где Hw = wspHSWT, Hs = wspHSST.


wspXSTJOULETHOMPSON

Степень сухости [-] как функция величин: температура t [K], коэффициент Джоуля-Томсона jt [K/Па]:

wspXSTJOULETHOMPSON(t, jt)

где:

  • t – температура [K], тип: double;
  • jt – коэффициент Джоуля-Томсона [K/Па], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Начиная с версии 5.6 эта функция возвращает значение, правильное с точки зрения термодинамики. Согласно последнему, значение коэффициента Джоуля-Томсона в двухфазной области постоянно. Поэтому, эта функция производит проверку на соответствие параметра jt и вычисленного для температуры t. При их рассогласовании выдается ошибка с кодом 2. Иначе функция возвращает значение 0. До версии 5.6 функция использовала формулу: X = (JT - JTW)/(JTS - JTW), где JTW = wspJOULETHOMPSONSWT, Ws = wspJOULETHOMPSONSST.


wspXSTK

Степень сухости [-] как функция величин: температура t [K], коэффициент изоэнтропы k [-]:

wspXSTK(t, k)

где:

  • t – температура [K], тип: double;
  • k – коэффициент изоэнтропы [-], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (K - Kw)/(Ks - Kw), где Kw = wspKSWT, Ks = wspKSST. Функция возвращает правильное, с точки зрения термодинамики, значение, начиная с версии 5.6.


wspXSTKINVIS

Степень сухости [-] как функция величин: температура t [K], кинематическая вязкость kv [м2/с]:

wspXSTKINVIS(t, kv)

где:

  • t – температура [K], тип: double;
  • kv – кинематическая вязкость [м2/с], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (KV - KVw)/(KVs - KVw), где KVw = wspKINVISSWT, KVs = wspKINVISSST.


wspXSTPRANDTLE

Степень сухости [-] как функция величин: температура t [K], число Прандтля pr [-]:

wspXSTPRANDTLE(t, pr)

где:

  • t – температура [K], тип: double;
  • pr – число Прандтля [-], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (PR - PRw)/(PRs - PRw), где PRw = wspPRANDTLESWT, PRs = wspPRANDTLESST.


wspXSTS

Степень сухости [-] как функция величин: температура t [K], удельная энтропия s [Дж/(кг·К)]:

wspXSTS(t, s)

где:

  • t – температура [K], тип: double;
  • s – удельная энтропия [Дж/(кг·К)], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (S - Sw)/(Ss - Sw), где Sw = wspSSWT, Ss = wspSSST.


wspXSTTHERMCOND

Степень сухости [-] как функция величин: температура t [K], коэффициент теплопроводности tc [Вт/(м·K)]:

wspXSTTHERMCOND(t, tc)

где:

  • t – температура [K], тип: double;
  • tc – коэффициент теплопроводности [Вт/(м·K)], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (TC - TCw)/(TCs - TCw), где TCw = wspTHERMCONDSWT, TCs = wspTHERMCONDSST.


wspXSTU

Степень сухости [-] как функция величин: температура t [K], удельная внутренняя энергия u [Дж/кг]:

wspXSTU(t, u)

где:

  • t – температура [K], тип: double;
  • u – удельная внутренняя энергия [Дж/кг], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (U - Uw)/(Us - Uw), где Uw = wspUSWT, Us = wspUSST.


wspXSTV

Степень сухости [-] как функция величин: температура t [K], удельный объем v [м3/кг]:

wspXSTV(t, v)

где:

  • t – температура [K], тип: double;
  • v – удельный объем [м3/кг], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Данная функция использует следующую формулу: X = (V - Vw)/(Vs - Vw), где Vw = wspVSWT, Vs = wspVSST.


wspXSTW

Степень сухости [-] как функция величин: температура t [K], скорость звука w [m/с]:

wspXSTW(t, w)

где:

  • t – температура [K], тип: double;
  • w – скорость звука [m/с], тип: double;
  • Возвращаемый результат – степень сухости [-], тип: double.

Начиная с версии 5.6 данная функция вычисляет значение через коэффициент изоэнтропы, что правильно с точки зрения термодинамики. До версии 5.6 функция использовала формулу: X = (W - Ww)/(Ws - Ww), где Ww = wspWSWT, Ws = wspWSST.